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ABOUT THE COURSE MATERIALS 

Your Student Guide contains the following document: 

Student Workbook with 5 sections: 

a. Getting Started

b. Customization and Data Management

c. ERP Part 1

d. ERP Part 2

e. CRM and Next Steps.

Use the Bookmarks feature in your PDF to navigate between the documents. 

Click on the Bookmark icon to open the Bookmarks window. Scroll up and down to see all content. Expand 

and contract sections as needed. 

If desired for ease of use, open the PDF on two screens and use the bookmarks to have one window open to 

the Course Guide and the other to the Presentation Slides. 
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Course Materials 

Course Workbooks 

 

The NetSuite Essentials course provides you with five (5), daily workbooks that are 

organized by topics: 

• Getting Started 

• Customization and Data Management 

• ERP Part 1 

• ERP Part 2 

• CRM and Next Steps 
 

Feel free to annotate in the workbooks: 

• If using a printed copy, then write in the book 

• If using a PDF document, you can add electronic “Sticky Notes” 
o Use the Adobe tools for commenting 
o Add the tool bar if necessary 

 

Hands-on Exercises Overview 

 
Each of the independent study modules contains hands-on exercises for you to 

complete. The courseware follows a recommended methodology when implementing 

the NetSuite application. These exercises correspond with the Essentials sections and 

related modules.  

• Foundation 

• Enterprise Resource Planning 

• User Interface Customization 

• Data Migration 

• Set Up Accounts Receivable and General Ledger 

• Customer Relationship Management 

• Set Up Customer Support 

• Next Steps 
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The course exercises simulate tasks that you, as the Administrator, need to perform for 

your NetSuite implementation. Considerations and best practices, discussed in the 

presentations, are applied and seen in action during the hands-on exercises.  Tasks 

include: 

• Setting up company preferences 

• Customizing NetSuite to better support the Chatham Company’s business 
processes and requirements 

• Migrating data 

• Defining user access to data 

• Setting up and enabling preferences for key functional areas of CRM and ERP 
 

NetSuite Test Account 

 

As a student in the NetSuite Essentials course, you are provisioned with a test account.  

Tasks are performed in the OneWorld type of NetSuite test account. 

• This test account is available to you and may or may not have the same 
functionality of your production account. 

• Occasionally the presented material is different from the data that is in the test 
account during the class and that will be in the exercises 

• Working with a test account, you see “in person” and immediately how each 
decision you make builds to influence the next set of decisions to be made. 

 
Important: 
The exercises in the course are incremental, meaning the build upon one another. 

Therefore, it is critical you complete all the required exercises and DO NOT skip them. 

• For example, let’s say, you did not complete exercise ‘5’. When you try to 
complete exercise ‘12’, the exercise will fail, because there were steps in 
exercise ‘5’ that were necessary to complete exercise ‘12’. 
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Before You Begin 

 

The NetSuite Essentials course walkthroughs and exercises were validated against 

current functionality in a current-release account, to ensure that they were not “broken”.  

Your Student Workbooks have been updated accordingly.  

❖ Getting Started (Modules 01 through 08) 

❖ Customization and Data Management (Modules 09 through 14) 

❖ ERP Part 1 (Module 15 through 21) 

❖ ERP Part 2 (Modules 22 through 28) 

❖ CRM (Customer Relationship Management) and Next Steps (Modules 29 through 35) 

 

 IMPORTANT INFORMATION FOR SELF-STUDY STUDENTS 

If you are taking the self-study version of the NetSuite: Essentials course, 
please familiarize yourself with the information in this section. It outlines the 
possible differences between the self-study recordings and your Student 
Workbooks. 
Your Student Workbooks have been updated for the current release, but self-
study recordings may not reflect all the changes.   

 

Highlighted new features and functionality: 

❖ Administrators No Longer Required to Provide Initial Passwords to New users 

❖ Changed to the Role Record 
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Administrators No Longer Required to Provide Initial Passwords for New Users 

This may not be in the self-study recording for the Roles module. 

 Administrators no longer must provide an initial password to new users, because standard 

NetSuite user access email templates now contain a synthetic field that triggers the 

generation of a temporary URL with a verification code that is included in the email sent to 

new users for accessing NetSuite.  

o New users can click the URL in the notification email and create their own NetSuite 

passwords.  

 There is also a new company setting on the General Preferences page. Go to Setup > 

Company > General Preferences. The setting is User Registration Link Expiration In Hours.  

o You can set the length of time that the URL generated by the synthetic field remains 

valid. By default, the expiration in hours value is set to 24 hours, which is hard-coded in 

the standard user access email templates.  

o Valid values range from one hour to 72 hours.  

o If you change the default value for the setting, you must also update the value in the 

email templates.  

 

Changes to Role Record 

This may not be in the self-study recording for the Roles Overview module. 

 Restrictions Subtab in Role Record - The Restrictions subtab is used to set department, class 

and location restrictions; this was previously above all the subtabs. 

 Advanced Employee Restrictions functionality gives administrators more flexibility and 

control over what employee information certain roles can access in NetSuite 

 Authentication Section in Custom and New Role may be used for additional role definition 

and access security measures. 

 

Personalize Dashboard 

When you click the Personalize link, on a dashboard, the following panel displays and 

includes SuiteApps.  Please refer to Help for more information. 

This may not be in the self-study recording Navigate the Application 
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Small Changes to NetSuite Pages 

Other small changes have been made to various NetSuite webpages, which may 

include: 

• Additional checkboxes 

• Dropdown fields 
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Course Introduction 

 

Meet Your Instructor 
 

 

Feel free to make note of the following: 

• Instructor’s Name: 
 

• Instructor’s Profile: 
 

About This Course 
 

You might be wondering how this will: 

• Prepare you for your upcoming implementation project 

• Ready you for your configuration sessions with your implementation consultant 

• Facilitate the successful implementation of NetSuite at your company 
 

The instructor will be your guide to NetSuite Essentials using presentations and hands-

on exercises focused on: 

• Configuration of the NetSuite application 

• Best Practices in key areas 

• Specific end-user tasks 
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Course Audience 
 

You are responsible for the NetSuite application: 

• The Set Up of the NetSuite Account 
 

• The initial and ongoing account Configuration  
 

• Ongoing Maintenance of the account 
 

Activity: Class Introductions 
 

This is your chance to meet your classmates.  Feel free to do some networking outside 

of class, by asking for and noting their contact information 

 
Course Goals 

 

The intent of this course is to answer some common questions during implementation: 

• At a high level, what does the NetSuite application deliver? 

• Can I tailor NetSuite to better meet our needs without having technical expertise? 

• What are the customization options in NetSuite? 

• Are there administrator tools to facilitate data migration into NetSuite, from an 
external source? 

• How is NetSuite set up to handle our accounting? 

• Are there tools that help us extract business intelligence? 

• Can we use sales force automation and other CRM (Customer Relationship 
Management) features? 

• As we get closer to “Go-Live” what are some next steps  
  



 

9 

 

 

Course Objectives 
 

 

 

Course Flow 
 

This course starts with the basics, foundational knowledge, and then moves through 

configuration and end-user tasks.  
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Course Agenda 
 
 Day 1: Getting Started 
 

• NetSuite Fits Your Business 
Introduction to NetSuite and use of Relational Database Management Structure 

• OneWorld Overview 
Take a high-level overview of the OneWorld capabilities for customers needing 
consolidation of multiple, legal entities in one NetSuite account 

• Implementation Project 
Learn some of the basics of an implementation project and NetSuite’s approach 
to implementation methodology 

• Navigation 
Take your first steps in using the NetSuite navigation and learn some of the basic 
NetSuite lingo 

• Company Preferences 
Start setting up your company in NetSuite with company information, features 
and preferences 

• NetSuite Data Model 
Be presented with the NetSuite data model and its use of standard record types, 
which classify data in NetSuite and impact reporting 

• Roles, Permissions and Users 
Learn that using roles and associated permissions controls your data security 
and defines how your users use NetSuite 

 

Customization and Data Management 
 

• Custom Subtabs, Lists and Fields 
Start investigating the customization of the user interface, to better meet your 
business requirements, with some basic custom elements 

• Custom Forms 
See how to develop a specific view to enter and view data in NetSuite with forms 
you customize 

• Custom Records 
Grow your customization expertise and see the benefits of creating custom 
records for tracking, reporting and searching on a data object not handled by a 
standard NetSuite record type 

• Data Migration 
Learn how the NetSuite Import Assistant helps you to bring in data from various 
sources, external to NetSuite, into your NetSuite account so that you can run 
your business in NetSuite 

• Data Integrity 
See the importance of using multiple, NetSuite tools to maintain the integrity of 
your NetSuite data and providing your users with the correct and current data 
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ERP Part 1 
 

• Accounting Management 
Get an introduction to setting up basic accounting functionality in your NetSuite 
account 

• Multiple Currencies 
Consider the benefits and how to use multiple currencies for transactions with 
your customers and vendors 

• NetSuite Tax Information 
Take a high-level overview of the NetSuite functionality for the handling of taxes 

• Items 
Walk through a sample of setting up different item types in NetSuite for your 
purchasing and selling activities 

• Pricing 
See how you might fit your pricing strategy into NetSuite’s diverse and flexible 
pricing features 

• Order Management 
Walk through an introduction of the order-to-cash process in NetSuite 
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ERP Part 2 
 

• Accounts Receivable 
Consider setting up account receivable and the order-to-payment process 

• Purchasing 
Look at setting up purchasing in NetSuite and the options available to you 

• Accounts Payable 
Continue to understand how to transact with and pay your vendors with the 
NetSuite features 

• Banking and GL 
See how NetSuite accommodates basic banking and GL management 

• Reports and Searches 
Take your first steps into extracting business data into reports and searches for 
analysis and action 

• Dashboards for Users 
See the importance of relevant dashboards, for your users, and how best to set 
up those dashboards 

 

CRM and Next Steps 
 

• Sales Force Automation 
Consider setting up automation for your sales force and take advantage of 
automated lead assignment 

• Lead-to-Customer Management 
Nurture leads through to customers with quote-to-order NetSuite capabilities 

• Customer Support and Case Management 
Look at how you can build your customer support model in NetSuite by enabling 
and using key features for case routing and resolution 

• Marketing and Ecommerce Overview 
Look at a high-level overview of Marketing and Ecommerce capabilities within 
your NetSuite account 

• NetSuite on the Go 
Look at the available options for mobile access to your NetSuite Account and the 
related help resources 

• Go Live and Maintain NetSuite 
Understand key go-live tasks and your on-going responsibilities as the NetSuite 
administrator 

• Conclusion 
We remind you of all the objectives and topics presented in the course and 
provide you with resources for your future reference 
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Activity: What is Your Primary Objective? 

 
You and your classmates share what is most important for you to get out of this class. 

 
How to Use Your Student Workbook 

 

Download the materials from your Welcome email:  

• Save the downloaded file to your desktop or a desired file location  

• Open the file in Adobe Acrobat 

• File will be secured 
 

Annotate in the Workbook:  

• Utilize the Annotation tools from the Comment section 
o Sticky Notes 
o Highlight Text 
o Add Text 

 

Complete the hand-on exercises, which provide: 

• Practice on account configuration and customization 

• The experience to prepare you to use various end-to-end workflows and 
processes  

 

Class Set Up and Tips for Success 

 

Class Interactivity and Participation:  

• Ask questions: use parking lot and chat  

• Stay attentive: avoid distractions of email, cell phones and colleagues 

• Be on time; return promptly from breaks  
 
Course Materials: 

• Student Workbooks:  

• Getting Started 

• Customization and Data Management 
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• ERP Part 1 

• ERP Part 2 

• CRM and Next Steps  
 
Training Account 
  



 

15 

 

NetSuite is an Integrated Business System 
 

NetSuite enables running all facets of your business within one database: 

• After you log in, and continue through tasks throughout the course, you will see 
the breadth of the application 
 

 
 

Walkthrough: Initial Login and Training Account Review 

 
 
Use Case / Scenario: How to log into the training account for this class and look at the 

account profile  

• Log into www.netsuite.com  
 
The 30-day training account has the following attributes: 

• OneWorld account that supports multiple subsidiaries or legal entities  

• A profile that may be different from your production account 

• Provides both ERP and CRM functionality 
 
Class Login 
In this class, you are being provided with specific log in credentials.  Your login 

credentials will be valid for approximately 30 days. 

  

http://www.netsuite.com/
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Complete the following exercises: 

• Login into NetSuite (01-01) 
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Independent Study Exercises 
 

Exercise 01: Log in to NetSuite 
Time: 5 minutes 

Scenario: Let’s ensure that you have access to your training account and review the Add-On Modules: 

 Login to the application 

 Answer three security questions so you can verify your identity if you forget your NetSuite 

password 

 Mark the Administrator as the Default Role 

 Open your browser and type www.netsuite.com in the address field. 

 Find the Log In link, top-right and click it. 

a. Enter the Email Address as provided by the instructor. 

b. Enter the Password as provided by the instructor. 

i. Please make note of this password, for use throughout the course.  You can use 

the electronic sticky note in the PDF file. 

ii. DO NOT CHANGE THE PASSWORD; continue using the password provided. 

c. Select the Remember my email address check box and then click the Login button.  

 The Set Up Security Questions pop-up window displays: 

 

a. Select three security questions of your choice 

b. Uncheck Hide Answers 

c. As your Answer, enter the last word of each question; for example: 

i. Question: What was your childhood nickname 

http://www.netsuite.com/
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ii. Answer: nickname 

 

 Click Save and click Close in the Security Questions Complete pop-up window. 

 Check any checkboxes, and click Continue, for any additional pages to get to the NetSuite 

Application. 

 You should be on the NetSuite Essentials page. 

 Confirm your success with the instructor. 

 End. 
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Objectives and Course Flow 
 

The course logistics, objectives and course flow have been presented.  Please let the 

instructor know if you have any questions 

 

As a reminder: In the log in exercise you were given your login credentials.  Please 

make note of these credentials.  You may write here or add a PDF sticky note. 

 

We are done with Introductions, next up… Getting Started 
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How NetSuite Fits Your Business  

 

About this Module 
 

In this module, we consider information needed for the NetSuite implementation and 

introduce additional functionality:  

How is NetSuite going to manage our business rules and processes? 

Examine Data Organization and Structure 

Review NetSuite’s Environment 
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Integrated Business System 
 

• Single source of data, connecting the businesses’ functional units together, 
delivering a single point of business knowledge 

• Complex database with customizable business process and internal control 
capabilities 

 
 

Common Reasons for Choosing NetSuite 
 

NetSuite is a Software as a Services (SaaS) Model: 

o Application hosted over the internet (log in from anywhere) 
o Configurable and customizable 

 

NetSuite uses a relational database management structure (RDMS) 

o Uses data common to multiple tables to link them together 
o Predominant choice in storing financial records, manufacturing and 

logistical information, personnel data 
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Relational Database in NetSuite 
 

Benefits of a relational database: 

• Incorporates many unique tables 

• Defines tables with rows or unique lines of information 

• Relates tables together to form another table, for example a transaction 

• Displaces 4 pieces of information for 1 

• Provides a richer and more efficient use of data storage resources 

• Results in a more functional and significantly richer dataset for information 
delivery 

 

 
 

NetSuite Example 
 
New Sales Order table (or record) pulls information upon data entry from: 

• Customer, Partner, Sales Rep, and Item tables (records) 
o Item table pulls information from vendor table 
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Working with Forms 
 
A form is the interface used to create, view and modify a record: 

 

• Customizable to suit your business needs and processes 
o You can reorganize subtabs 
o Rename fields to better match your business processes 
o Control access to information in accordance with your business rules 

 

Business Rules and Business Processes 
 
Business Rules define or constrain aspects of the business systems 

• Example: Before fulfilling an order, the Sales Manager must approve it 

• Documenting business rules is essential for good system design 
 

Business Processes define how a business organizes its activities to complete the 

work and is a collection of the business rules: 

• Sales Rep enters an Order, then a sales manager approves the order, allowing 
the warehouse to then fulfill the order 

 

Well architected business processes can: 

• Provide internal control, ensure compliance and data integrity 

• Without defined business rule constraints to manage users’ interaction within the 
database, it is just a repository of information 

• With constraints, well defined, the database can be used to administrate a 
process and to provide control 
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Activity: Match Game 

 

See if you can match the terms on the left, with the task/description on the right. 
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OneWorld Overview 

  

About this Module 
 
The big picture! OneWorld is NetSuite’s solution to support a company that manages 
separate operating legal entities.  

▪ What is NetSuite OneWorld? 
▪ Are there specific features and preferences? 
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OneWorld Overview 
 
Run your parent company in a single NetSuite Account, with subsidiary identification 
and consolidation: 

• Parent company is the top level and owns each ‘Subsidiary’ (legal entity) 

• Subsidiaries are separate, distinct, legal entities for purposes of taxation and 
regulation but require consolidated reporting 

o Licensing dictates the number of subsidiaries that are allowed 

• Allows using subsidiary-specific configuration for: 
o Multiple currencies  
o Fiscal Calendar per subsidiary 
o Tax Calendar per subsidiary 
o Taxation rules (Nexus) 
o Reporting needs 

• Consolidated reporting allows for the currency translation from each 
subsidiary’s base currency to the currency of the parent entity 

o Consolidated reporting allows for aggregated financial statements and 
other reports  

o They provide meaningful consolidated reporting on transactions. Balances 
of subsidiaries are translated to the base currency of the consolidated 
report using Consolidated Exchange Rate 

 

Subsidiary Ownership: Subsidiaries may represent partially owned companies.  

Please be aware that NetSuite always considers the subsidiary to be 100% owned and 

you should do non-controlling interest accounting in the usual manner. 

 

Multiple Currencies 
 
The Standard NetSuite account supports local and foreign currencies for transactions 

with foreign companies. 

• OneWorld also supports transactions between subsidiaries: 

• Base Currency, or functional currency, is the currency in which the subsidiary 
manages its accounting books 

o Local Currency is “usually” the base currency in which the subsidiary does 
business. 

• Currency Exchange Rates are used to convert foreign currency to base currency: 
o Determine the value for a transaction where the entity currency is different 

than that of the subsidiary  

• The consolidated exchange rates are used to convert transactions and balances 
between subsidiaries and the base currency 

• Currency defaults from the parent entity record and does not default based on 
the subsidiary’s address  
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Fiscal Calendars by Subsidiary 
 
Enable different Fiscal Year start / end dates on a per-subsidiary basis: 

• This respects the quarterly and yearly reporting needs based on the subsidiary 
requirements 

• Your administrator needs to enable the Multiple Calendars feature, under Setup 
> Company > Enable Features > Accounting subtab 

 
Example: a subsidiary hierarchy with 3 fiscal calendars: 

• US Parent: Standard Fiscal Calendar - January 01 through December 31 
o India Subsidiary: India Fiscal Calendar - April 01 through March 31 

▪ China Subsidiary (Reports to India): Standard Fiscal Calendar 
▪ Pakistan Subsidiary (Reports to India): India Fiscal Calendar 

 

Editions and International Subsidiaries 
 
NetSuite Editions handle country-specific taxes, both sales and purchases: 

• The NetSuite edition is defined on the subsidiary record; drives tax fields on 
Transactions associated with the Subsidiary 

• Each edition handles the appropriate, local tax structure- handling of sales tax 

• Bundles are available for tax configuration in the international edition 
 
NetSuite United States (US): 

• Pre-coded tax, State tax imports required 

• No separate tax reporting periods, No Foreign trade settling 
NetSuite Canada (CA): 

• Pre-coded tax, GST/PST 

• No separate tax reporting periods, No foreign trade settling 
NetSuite United Kingdom (UK): 

• Pre-coded tax, VAT 

• Separate tax reporting periods, Provides full EU reporting 

• Foreign trade settling 
NetSuite Japan (JP): 

• Pre-coded tax, Consumption Tax 

• Separate tax reporting periods, Foreign trade settling 
NetSuite Australia (AU): 

• Pre-coded tax, GST 

• Separate tax reporting periods, Foreign trade settling 
NetSuite International (XX): 

• No pre-coded tax – install bundle to configure 

• Separate tax reporting periods 

• Foreign trade settling 
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Subsidiary Structure 
The below example is organized as a tree with ONE root company and its associated 

roots. A root company may have many parent and child subsidiaries: 

 

 
 

• Parent is the root company 
o If you are implementing NetSuite for the first time, you need to decide 

which organization becomes the “parent/root” subsidiary 
o If you are migrating up to OneWorld, the default is your parent root 

subsidiary 

• One subsidiary is created for each separate reporting legal entity within your 
organization 

• You can have multiple parents with many children 
o However, a child can only have one parent  

• Each subsidiary can operate in a different NetSuite Edition, which is set by their 
country of operation 

• Each subsidiary can function in its own base currency 

• You can create up to 124 subsidiary records in addition to the root subsidiary, for 
a total of 125 

o Any subsidiary marked as inactive is not part of the count 
 

Subsidiary Types 
 
Subsidiaries can be international or domestic. Different types of subsidiaries include: 

• Standard = legal entity 

• Elimination = normally one for each parent 
o This subsidiary type help facilitate unrealized profits or losses within 

intercompany transactions which must be eliminated 
o Only journal entries post to elimination subsidiaries 
o License fees for subsidiaries do not include charges for elimination 

subsidiaries, and elimination subsidiaries do not count toward the 
maximum of 125 subsidiaries. 
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Defining the Subsidiary Record 
 

The Country on Subsidiary record determines the following: 

• NetSuite Edition, and this cannot be edited once saved 

• A tax Nexus, the jurisdiction you pay collected taxes to, is automatically created 
or assigned based on address: 

o For U.S., state is required; for Canada, province is required  
o Can be edited once saved 
o You can define more than one nexus  
o Subsidiaries can share nexus and related tax items 

• Note: The Country cannot be changed at the root (Parent) level) 

• When you create a subsidiary, set the base currency: 
o Is the currency correct? Cannot change after saving the subsidiary. 
o Is the country correct? Cannot change after saving the subsidiary. 
o Each subsidiary’s base currency may be different from the parent 

 
If you have entered in the wrong information and saved the subsidiary, some 

fields will be locked for editing.  If necessary, mark the incorrect subsidiary as 

inactive and create a new subsidiary with the correct information 

 

Consolidated Reporting 
 
Consolidated Income Statement Example: Subsidiary Footer: filters contents, sets 

context (Subsidiary), and determines report layout  

• Filter: The report is filtered to show only data from the subsidiary you select, or in 
the case of consolidated subsidiaries, the data is shown for all child subsidiaries 
of the consolidated parent subsidiary 

• Currency Translation: The currency amounts are displayed in the base 
currency of the selected subsidiary. Consolidated rates are used if the 
subsidiaries shown on the report have different base currencies 

• Layout: If you are viewing a financial statement, selecting a subsidiary applies 
the appropriate financial statement layout on the report 

Note: The report displays in the currency of the user’s role. If using OneWorld and 
subsidiaries, you may need to create a role to view reports in UK currency (if the 
parent is USA) and to view the financial report of a UK subsidiary in UK pounds. 
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Subsidiary Context 
 
Reports are presented by user-selected Subsidiary Context or nodes: 

• Virtual consolidated reporting node are available for each subsidiary that is a 
parent (example, UK Consolidated) 

o Reports display data from the parent node selected, consolidated with its 
children 

o There are three iterations of subsidiary reporting: 1) Report on each 
parent, 2) Report on child and 3) Report on entire family (parent and child) 

 

Activity: Provide a Definition 
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Key Terms Reviewed 

 

Terminology Description 

Subsidiary 
Legal entity within an organization requires its own 
base currency. 

NetSuite Edition 
Edition drives tax fields on transactions associated 
with the Subsidiary. 

Nexus 
Set up for the tax preferences for each area in 
which you collect and pay taxes. 

Base Currency 
The currency in which a subsidiary manages its 
accounting books. 

Currency Exchange Rate 
Used to convert a foreign currency to the base 
currency. 

Consolidated Exchange Rate 
Used to translate transactions and balances 
between subsidiaries and the base currency 

 
Additional Resources 

 

NetSuite Help Center: 

• Account Setup: Getting Started with OneWorld 
 
SuiteAnswers Learning Center:  

• New Feature Training 

• Accounting Setup  

• NetSuite OneWorld 
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Introduction to Implementation Project 

 

About this Module 
 

NetSuite implementations can often follow a prescribed formula, with variables to meet 

your business needs. You may be wondering:  

• What might an implementation involve? 

• Who are the different players, people involved, in the implementation?  
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Walkthrough: NetSuite One Methodology 
 

 

Use Case / Scenario: Investigate NetSuite One 

• Get an understanding of and set expectations for the implementation project  
 

Introduction to NetSuite One 
 

NetSuite leverages a proven methodology based on lessons learned and best practices 

captured over years of implementing our customers 

•  View the Web Page, outside of your NetSuite account, at: 
http://www.netsuite.com/portal/services/consulting/methodology.shtml  

 

 

  

http://www.netsuite.com/portal/services/consulting/methodology.shtml
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NetSuite One Methodology Phases 
 

When you start working with your NetSuite Implementation consultant and Project 

manager they may review with you the phases and associated tasks, highlighting the 

following: 

•  Best Practices (if applicable) 

•  NetSuite documentation 

 

 

Members of Your implementation Project Team 
 
Define the project team early and include the appropriate stakeholders. 
 
Depending on your company’s requirements, seek out these resources: 

• Project Champion – Executive Sponsor 

• Project Manager – may be the primary NetSuite administrator 

• Backup Administrator 

• NetSuite Professional Services 

• Extended Project Team: 
o Business process owner(s) 

• End User(s)Technical Analyst 

• Training Coordinator 

• User Adoption Team 
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Role of the Administrator: Overview 
 
The NetSuite Administrator has key implementation and administration responsibilities 

for your NetSuite account: 

• The Administrator should have a thorough understanding of the overall goals of 
the implementation and be able to make and/or act upon most implementation 
decisions, in cooperation with the appropriate business unit representatives 
(Business Analysts).   

• This role will be responsible for all configuration tasks when implementation is 
complete. 

• The administrator should have varied business and technical skills, 
complimented by appropriate experience and education 

 

Role of the Administrator: Implementation 
 

During implementation of NetSuite, the Administrator is responsible for: 

• Implementation of the NetSuite application, working as a key liaison between the 
NetSuite Professional Services team and the business unit representatives 

• Ownership of understanding and identifying customer requirements and 
development of systems that support NetSuite productivity improvements and 
enforce corporate policies and procedures. 

• Management of the system configuration, including design and data migration 
decisions 

• Management of User Acceptance testing tasks  

• Customization of Forms, Fields, Online forms, and Custom Records 
 
Role of the Administrator: On-going Administration 
After completion of the NetSuite implementation, the Administrator will be responsible 

for: 

• Maintenance and daily management of the NetSuite application. 

• Technical and system administration, including data integration with multiple 
systems: e-mail marketing solution, member data mart, Web site and inventory 
management system. 

• Functional and technical requirements, system configuration, data integrity and 
all system-related policies and procedures. Define and write functional 
requirements based on staff business needs. 

• Providing front line support with regards to all aspects of NetSuite and data 
maintenance. 

• Primary point of contact to NetSuite Support. 

• Planning, reviewing and customizing NetSuite as needed to meet needs of staff. 
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• System adoption and satisfaction, including training users on the NetSuite 
application relevant to their jobs; provide support to users and maintain proper 
system access; and support end user technical requests. 

• Monitoring end-user usage of systems, tracking performance, performing daily 
administrative and support tasks and maintaining and dating system 
documentation. 

• Development and implementation of policies, procedures and guidelines to 
ensure the quality of data and perform regular data audits; resolve of data 
integrity issues. 

• Development, functional testing and rollout of customizations, custom objects, 
new enhancements, application releases and system integration based on 
user/business needs. 

• Developing, documenting and following formal policies, procedures and protocols 
for changes, customization, standards, usage, etc. 

• Development and maintenance of custom application extensions using system 
API and third-party tools. 

 

Implementation Project Best Practices 
 
Follow three basic practices to increase the chances for a successful implementation: 

• Facilitate change management and communication: Create a strategy to 
communicate with all project team members and your user community the up 
and coming changes 

o NetSuite offers a “User Adoption Toolkit” with practical change 
management activities. The toolkit can be found in Suite Answers 

• Develop and follow a project plan: Plan all the phases and tasks of the project. 
Assign task owners and report on the progress towards completion of each task 

• Use a test or sandbox account: This account becomes the official testing 
ground prior to migrating your configuration and customizations to production 
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Best Practices  
 
Access a list of assets, developed by subject matter experts, in SuiteAnswers: 

• Enter Best Practices in search field 

• Review the resulting list, which includes: 
o Support Articles 
o Training Videos 
o Help Topics 
o SuiteWorld Presentations 
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• Answer the following questions: 
o What are some of the tactical responsibilities of the Administrator? 

 
o What is the structure of the Chart of Accounts format? 

 
o How does this company track its reporting requirements? 

 
o How does this company plan to bring in GL balances? 

 
o Does this company have specific information that it wants to capture on 

customer records? 

• Allow 10 – 15 minutes 

 

Case Study Introduction 
 
The Chatham Company has just purchased NetSuite. Your role is to lead the 

implementation project for the Chatham Company. Before you begin, you are enrolled in 

the NetSuite Essentials course: 

• Gain a baseline understanding of how the product is designed 

• Review its standard features, functions 

• Prepare for the business process mapping activity scheduled next week in which 
you identify which standard NetSuite features can support the Chatham 
Company’s business requirements and which gaps need to be addressed.  

 

Enabling Features and Setting Up Company Preferences 
As you enable features, you make your “best educated guess” about what is needed to 

support the Chatham Company’s business practices. As you enable features, you 

enable standard functionality and configure these features relevant to your business 

needs.  The features are a "playbook" or a set of rules for you to build your processes 

• Most features can be enabled or disabled if you decide that you need or do not 
need them. (In effect, these early decisions can be reversed if necessary.) 

• Accounts Receivable, Order Management, Accounts Payable, Sales, Marketing, 
Customer Service and so forth 
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Defining User Access to Data 
Roles and Permissions are the foundation of your data security!  

• Plan for your users to have a positive adoption of the new product by giving 
users access to the data they need to do their job 

• Set up and organize the Roles and Permissions per the needs and tasks of the 
users. 

• Then test, test and test again the users’ Roles and Permissions.  
 
Customizing NetSuite for Your Business and Business Intelligence 
NetSuite provides SuiteBuilder, and other SuiteCloud tools, for customization of 

NetSuite. 

• Make detailed notes about what you would like to modify on entry forms or where 
you might need a custom field.  

• Extracting information from NetSuite comes in multiple forms, you can export 
information, run searches (like a database query), or use our extensive library of 
standard reports that you can customize for your individual company needs. 

 
Migrating Data and Data Integrity 
Using the Import assistant to move your data into NetSuite can be the single most time-

consuming task. To facilitate this process, it is critical to “scrub” or cleanse your data 

before import. 

• What data do you plan to migrate? 

• What is your strategy for moving your data from your current system to the 
NetSuite Account? 

• How much history do you intend to move to NetSuite? 

• How will you maintain data integrity? 
o Take the time upfront to clean your data 
o Stay on top of this activity so your reports and searches are more 

meaningful and accurate 
o Every time you complete a data import, be sure to run the Duplicate 

Detection functions! 
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Setting Enterprise Resource Planning (ERP) 
As we progress through this course we take detailed looks at what decisions should be 

made and how you make these decisions – the following areas are discussed: 

• Accounting Management 

• Multiple Currencies 

• Taxes 

• Item Types 

• Pricing 

• Order Management 

• Accounts Receivable 

• Purchasing 

• Accounts Payable 

• Banking and General Ledger 

• Reporting and Searching 

• Dashboards for Users 
 
Setting up Sales Force Automation and Customer Support 
Examine automatic lead and case assignment, quote-to-order, and case management 

Conclusion 
Upon completion of this course, as the NetSuite Administrator, you are ready to work 

with your implementation team to begin the project. You know the areas that need your 

attention; you know the questions that need to be asked and the considerations that 

need to be taken. 
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Hands-on Exercise: Introduction to the Implementation Project 
 

Suggested Time to Complete Exercises: 15 minutes 

Independent Study Exercise 

Exercise 01: Review the Business Requirements Document 

 

Time: 10-15 minutes 

Introduction: You will first read through the Business Requirements Document and 

then answer the following questions: 

 What are some of the tactical responsibilities of the Administrator? 

 What is the structure of the Chart of Accounts format? 

 How does this company track its reporting requirements? 

 How does this company plan to bring in GL balances? 

Scenario: You are the project lead of the Chatham Company implementation project. You and your 
team have read the Business Requirement Document (BRD) project team introduction and have 
worked to complete other sections. 

 Locate the Business Requirements Document, starting on the next page. 

 Review the Case Study for the unique requirements identified for the implementation.  

 What are some of the tactical responsibilities of the Administrator? 

a. Answer: 

 What is the structure of the Chart of Accounts format 

a. Answer: 

 How does this company track its reporting requirements? 

a. Answer: 

 How does this company plan to bring in its General Ledger balances? 

a. Answer: 

 Does the Chatham Company have any unique requirements that it wants to capture on its 

customer records? 

a. Answer: 
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The Chatham Company Business Requirements Document 
(Abbreviated Sample) 

 

Project Team Introduction: 

Who is the Administrator? 

 The NetSuite Administrator is the Customer Implementation Project Lead: 

 Oversees and manages the project and works with the NetSuite Professional Services Team 

on scheduling and planning guidance  

 Understands the overall goals of the implementation 

 Can make and or act upon most implementation decisions  

 Is responsible for all configuration tasks when implementation is completed 

 After implementation, the NetSuite Administrator is the subject matter expert (SME), of the 

NetSuite application, for their company 

What are the Administrator's tactical responsibilities? 

 Attend all meetings 

 Act as point of contact for all day-to-day project operations 

 Coordinate subject matter experts and their project team 

 Manage decision making resources 

 Serve as gatekeeper for project status 

 Manage their system requirements 

 Learn configuration specific to their business 

 Manage configuration decisions 

 Manage user acceptance testing 

Who are the Implementation Team Members? 

 Define the project team early and include appropriate stakeholders. 

 Depending on your company’s requirements, seek out these resources: 

 Administrator and backup administrator 

 Business process owner (s) 

 End User (s) 

 Executive Sponsor 

 Project manager 

 Technical Analyst 

 Training Coordinator 
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Chatham Company: OneWorld Account: The Chatham Company is a worldwide 

provider of computer hardware and services to support the hardware they provide and 

has headquarters in San Mateo, California. 

 Two subsidiaries also need to be set up: 

 Germany, which is a sales and service organization for most of EMEA. 

 Italy, which is reports into the Germany subsidiary 

 Chatham is currently negotiating with a Russian and Japanese company and; these 

organizations may become legal entities within the Chatham Company.  

Chart of Accounts Structure: The Chart of Accounts for the Chatham Company will 

be reviewed for the implementation of NetSuite.  

 Both account name and account numbers will be used, traditional format 

 The account number is four digits in length. For example: 

 6000 is an expense account 

 6300 is an expense account for utilities 

 6310 is an expense sub account for water 

 A parent/child hierarchy may be used to group similar expenses.  

 Final determination will be made during configuration sessions. 

 No restrictions will be imposed on the parent account to prevent posting 

 The Chart of Accounts will include accounts for all subsidiaries so that manual entries can be 

made.  

Segmentation (Departments/Classes/Locations): Chatham reporting requirements 

include tracking data using segmentation or classifications: 

 Divisions can be tied to transactions 

 Warehouses for each subsidiary to distribute its products 

 Sales to be tracked through Sales Channels 

Multiple Currencies: Chatham requires multiple currencies for transactions and 

reporting. 

 Consolidated reporting will be done in US dollars, the base currency of the parent. 

 Local currencies of the subsidiaries will be used for reporting within the subsidiary. 

 Use the multi-currency customer feature for sales transactions 

Sales Tax and Tax Reporting: 

 Sales tax is charged by Chatham Company for sales within the USA. 

 Appropriate VAT taxes are collected for the EMEA subsidiaries.  

 Tax Codes or Tax Groups will be setup and utilized. 
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Chatham Company has the following product/service offering requirements: 

 Inventory items will be created for all hardware products  

 Service items will be created for all services provided in support of the hardware products 

 Office supplies will use the non-inventory item type.  

Pricing: 

 Price levels will be assigned to items. 

 Quantity breaks will be established. 

 In some situations, prices/price lists are established on the customer level also. 

 Prices are defined in the currency of the subsidiary where the transaction occurs. 

 With approvals, Sales Reps can change the customer price. 

Relationships: Chatham Company will use standard NetSuite functionality for 

customer records: 

 Considering the use of numbers or the customer full name as the entity record ID. Final 

determination will be made during configuration sessions. 

 Track the progression and development of potential customer from a Lead, Prospect and 

eventually to a Customer. 

 Chatham Company may utilize customer statuses to track their movement through the sales 

cycle. Initially the following statuses will be set up for each stage of a customer: 

 Chatham company will enable the Multi-Subsidiary Customer features to create customer 

records across multiple subsidiaries.  

▪ Stage ▪ Status ▪ Probability 

▪ Lead ▪ Unqualified ▪ 0 

▪ Lead ▪ Closed - Lost/Duplicate ▪ 0 

▪ Prospect ▪ Qualified ▪ 10 

▪ Prospect ▪ In Discussion ▪ 20 

▪ Prospect ▪ Identified Decision Makers  ▪ 30 

▪ Prospect ▪ Proposal ▪ 50 

▪ Prospect ▪ Reviewing Proposal ▪ 65 

▪ Prospect ▪ In Negotiation  ▪ 75 

▪ Prospect ▪ Purchasing ▪ 90 

▪ Prospect ▪ Closed – Lost/Duplicate ▪ 0 
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▪ Stage ▪ Status ▪ Probability 

▪ Customer ▪ Won ▪ 100 

▪ Customer ▪ Renewal ▪ 100 

▪ Customer ▪ Closed - Lost ▪ 0 

Contacts: Chatham Company Requirements: 

 Contacts are people associated with vendors, partners, and customers 

 Contact numbers may be used for referencing contacts in the system. Final determination 

will be made during configuration sessions. 

 Chatham Company will evaluate the standard Contact fields and forms to determine if the 

out-of-the-box fields and forms meet their requirements.  

Employees: Chatham Company Requirements 

 Employee numbers will not be used for referencing employees in the system. 

 Their full name will be utilized. 

 Not all employees will require access to NetSuite. 

 An employee hierarchy will be set up, to accommodate approval routing 

Groups: The Chatham Company will use groups to segment its customer and lead 

base for marketing and sales campaigns.  

Role Configuration: Chatham Company Requirements 

 No restrictions have been defined for the user roles. 

 Sales Reps will not have employee restrictions set and will be allowed to have access to 

other sales reps’ transactions and entities. 

 Sales Managers approve all Sales Orders, and need to see all Purchase Orders. They do not 

have access to any financial statements.   

Role Restrictions: Chatham Company Requirements 

 The Chatham Company Support Manager will work across multiple subsidiaries.  
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Customization: Additional Customer Information: The Chatham Company would 

like to maintain information about the customer’s organization, to be collected on the 

Customer record. This may require customization. 

 Type of industry 

 Annual revenue 

 Year Established 

List Data Migration Summary: The following list data will be imported as part of the 

implementation: 

 

Data Component # of Records Method Responsibility 

Chart of Accounts 300 CSV Chatham 
Co/NetSuite 

Vendors 1500 CSV Chatham 
Co/NetSuite 

Contacts 5000 CSV Chatham 
Co/NetSuite 

Customers 500 CSV Chatham 
Co/NetSuite 

Items 1000 CSV Chatham 
Co/NetSuite 

Sales Tax Items 25 Manual Chatham Co 

Employees 50 Manual Chatham Co 

 

Chatham Company Requirements: 

 The above records will be part of the data migration.  

 Sales Tax Items and Employee records will be manually entered in NetSuite. 

 The remaining data will be imported into NetSuite using the CSV Import tool. 

 A Data Migration Consultant has been assigned and will guide the data migration process 

with Chatham Company. 
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Transaction Data Migration Summary: The following transaction data will be imported 

as part of the implementation: 

Data Component # of Lines Method Responsibility 

General Ledger Balances TBD Manual Chatham Co 

Open Sales Orders 25 Manual Chatham Co 

Open Accounts Receivable 25 Manual Chatham Co 

Open Accounts Payable 300 CSV Chatham Co/NetSuite 

Sales Orders History From beginning of 
current year 

5000 CSV Chatham Co/NetSuite 

Closed Cash Sales  1000 CSV Chatham Co/NetSuite 

Closed Customer Payments 10000 CSV Chatham Co/NetSuite 

Closed Customer Credit Memos 2500 CSV Chatham Co/NetSuite 

Journal Entries 1500 CSV Chatham Co/NetSuite 

 

Chatham Company Requirements 

 General Ledger Balances imported as transactional detail records for the current year. 

 Open Accounts Receivable will be brought in as All Open Invoices per Customer with line 

details. 

 Open Accounts Payable brought in as All Open Bills per Vendor with line details. 

 Sales History will be imported as full transactional detail for the current year and will allow 

for full customer, product/service and sales rep based reporting. 

 Purchase History will be brought in as bills plus checks. (Note: Checks can only be brought 

into NetSuite via Web Services.) 

Data Strategy: The overall strategy that will be used to import data will be finalized 

during configuration. 

 The final imports are to take place approx. 1 week before go-live. Please note that Imports 

supported by our Data Migration Consultant do not usually occur during weekend. 

 Three imports per data component will be conducted as part of the migration process:  

 Test Import: 10-15 Records will be imported into the Production account as a test. 

 Main Batch: all static transactions, all list data available is imported into the Production 

account. 

 Catch up Batch: all data that has been added between the ‘Main Batch’ cutoff date and the 

‘Go Live Data” cutoff date is imported into the Production account. 

  



 

51 

 

Data Management and Integrity: 

 Duplicate Detection will be utilized comparing Customer Name based on the Name/ID or 

email (domain only), the contact name based on the email address, and so forth. 

 CSV Imports and ensure that custom fields created prior to doing data imports. 

 Mass Updates: Chatham Company has not identified any unique requirements in this area. 

Accounting Management: Chatham Company has the following implementation 

considerations: 

 Multiple currencies 

 Financial Year 

 Journal entries and approvals 

 Opening Balances 

 Roles and Responsibilities 

 OneWorld: 

 All non – US subsidiaries track taxes at transaction line level   

 If you enable Accept Payments through Top Level Customer, then cannot use parent-child 

relationships that span subsidiaries and currencies 

 What currency rates will you use to prepare consolidated financial statements? 

 Utilize multi-subsidiary vendors and customers  

Accounting Periods 

 Use ‘Calendar Based’ monthly periods 

 No yearend adjustment period is being used 

Inventory Management: Chatham Company will enable the following feature: 

 Multi-Location Inventory to associate each item and transaction with a location.  

o Chatham Company has the requirement to track items by geographical location  
o Track the purchase, sale, stock level and value of items in your locations, as well as 

transferring inventory between locations. 

Inventory Counts: Chatham Requirements: Inventory is counted annually. 
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Order Management: Sales Process: Order to Cash: Chatham Company has the 

following Implementation Considerations 

 Quote-to-cash process 

 Sales order management and order types 

 Approval routing prior to fulfillment 

 Fulfillment management and invoicing 

 Return material authorization 

 Returns 

 Accounts receivable process 

 Credit card processing and Electronic Funds Transfer (EFT) 

 Invoicing, payments and collections 

 OneWorld: 

 When creating a special order, or drop ship sales orders, the vendor must share the 

customer subsidiary 

 When fulfilling an order, the location must be in the same subsidiary as the customer 

(Locations are tied to a single subsidiary) 

 Are my receivables segregated by countries? 

 How is the intercompany accounting tracked? 

Sales Orders: 

 Orders are received via telephone, fax, and email. 

 Approvals are required for certain pricing situations. 

 Items should be committed at the time of Sales Order entry. 

 A sales order acknowledgement will be Emailed to single or multiple recipients. Distribution 

will be based on the contact information stored on the customer record.  

Fulfillment: 

 All items on one Sales Order will be shipped to the same address. 

 The fulfillment process is as follows: 

 Sales Order and dispatch document are completed by the Sales Representative. 

 A copy is scanned and emailed to Shipping and Receiving. 

 The Shipping Clerk selects material from inventory. 

 The tallies are delivered to the main office. 

 The Sales Representative totals the material and adds the delivery costs. 

 Information is forwarded to A/R 

 Invoice is created. 

 A fulfillment Email will be utilized. Distribution will be based on the contact information 

stored on the customer record. 
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Shipping Integration: Chatham Company does not require shipping integration at this 

point. 

Billing Schedules: The Chatham Company will not be using billing schedules at this 

time. 

Invoices and Cash Sales: Chatham Company Requirements: 

 Multiple Bill-To addresses will be utilized. 

 The finance department will be responsible for producing invoices 

 Printed invoices will be provided to customers by both direct mail and Email, based on the 

customer’s preference. 

 Credit card transactions will be used by Chatham Company for this implementation. 

Customer Payments 

 Payments are received via cash, check, or credit card. 

 Chatham Company will contact one of NetSuite’s integrated credit card processors for 

processing credit card payments. 

Return Authorizations 

 The return authorization process will be utilized for the following situations: 

 Return back into inventory in which a credit may or may not be given. 

 Return back for repairs and refurbishment 

 Approvals will be required. 

Credits: Chatham has not identified any unique requirements in this area. 

Purchase Process: Purchase to Payment: A formal purchase policy will be developed 

by Chatham Company as part of this implementation to outline which classifications of 

purchases require purchase orders. 

 Purchase Orders will be created through the purchase request process or manually. 

 All departments will use purchase requisitions. 

 Purchase requisitions will be entered by employees if they have access to NetSuite or at a 

manager level in departments that do not have access. 

 Requests will be set up to automatically Email managers, requesting approval. 

 Purchases will be approved by the senior managers based upon dollar limits. 

 The purchase order document will primarily be faxed or Emailed to vendors. 
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Purchase Receipts: When a shipment arrives or a service is performed, these 

activities can be matched against open purchase orders by processing a purchase 

receipt.  

Purchase Bills: Bills created from a purchase order will have the invoice number 

entered and then be reviewed to confirm details including the amount, date and 

payment terms 

Payments: In NetSuite, payments for bills, expenses and commissions can be 

processed as part of a check run or individually. 

 These can be processed for payment through physical printed checks or electronically 

through ACH payments.  

 Checks printed from NetSuite are designed to print on check stock available from NetSuite’s 

exclusive supplier of imprinted forms, NetSuite Checks & Forms  

Chatham Company Requirements: 

 Some vendors require a down payment against the Purchase Order prior to shipment and 

receipt, utilizing Standard NetSuite functionality “Bill advance of receipt”. 

 Open bills will be reviewed as part of the regular check run to confirm which bills should be 

paid 

 Direct deposit for payment of employee expense reports will not be set up as part of this 

implementation 

Vendor Returns: 

 Know the status of each return and you can track accurate information about each return 

you process 

 The vendor return workflow includes obtaining Return Materials Authorization (RMA) from 

the vendor, then processing the return in NetSuite to track information about each return. 

Credits 

Chatham Company will utilize standard NetSuite functionality for Vendor Credits. 

 In NetSuite, purchase credits can be applied against open accounts payable transactions.  

Journal Entries:  

 All journal entries are entered by the Company Accountant. 

 For this implementation, no approvals will be built into the process 

 Allocations will not be used.  

Intercompany Journal Entries: Chatham Company has not identified any unique 

requirements in this area. 
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Year End Close: Chatham Company has not identified any unique requirements in this 

area. 

General Ledger Reporting: Chatham Company has not identified any unique 

requirements in this area. 

Bank Management: Chatham Company requirements: 

 Bank Accounts: Chatham Company has a separate account for each subsidiary. 

 Deposits: Electronic deposits are done daily and an Undeposited Funds account is being 

considered 

 Bank reconciliations will remain manual with the understanding that if the electronic bank 

statements can be imported, utilizing one of the proper formats, then Chatham Company 

may choose to utilize the online process 

Financial Reporting 

 Financial statements available at any point in time with real-time information 

 Basic statements (without comparisons) display in a column format, based on segment or 

time period 

 All statements can be filtered to display segment information 

 The Chatham Company will need to run financial statements by subsidiary as well as 

consolidated reports at the parent level.  

Sales Force Automation: Chatham Company may have the following implementation 

considerations 

 Lead generation 

 Lead routing and assignment 

 Opportunity management 

 Forecasting 

 Up-selling and cross-selling 

 Incentive management 

 Partner management 

 Reporting 

Sales Organization: The Sale Organization at Chatham Company, has Inside and 

Outside Sales Reps, and Customer Service Reps. The sales channels consist of phone, 

fax, and Email. 

Routing and Assignment 

 Leads typically generated from business publications, trade shows, and referrals from 

existing customers. 

 Currently, leads are assigned to Sales Reps based on geographic location.  
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 Chatham Company will want to utilize standard NetSuite functionality to track the 

development of a Lead, Prospect, and eventually a Customer. 

 Sales reps will have access to other sales reps’ transactions. 

Opportunity and Estimate Management 

 Currently, Chatham Company is considering using Opportunities to manage potential sales  

 Estimates/Quotes will be included for the implementation project. Expiration dates on 

Estimates/Quotes will be utilized. 

 Estimates will be created from Opportunity records. Once an Estimate is accepted, it will be 

converted to a Sales Order.  

Customer Support and Case Management: Implementation Considerations: 

 Customer support cases and roles 

 Support channels 

 Support teams and case assignments 

 OneWorld 

 How do you handle support procedures across subsidiaries? 

 How do you communicate with your customers? Are there differences depending upon 

the subsidiary such as using logos or the wordings and policies among the different 

subsidiaries?  

Support Organization: Chatham Company has not identified any unique requirements 

in this area. 

Case Origin: Chatham Company has not identified any unique requirements in this 

area. 

Routing & Assignment: Chatham Company has not identified any unique 

requirements in this area. 

Case Processing & Resolution: Chatham Company has not identified any unique 

requirements in this area. 

Escalation: Chatham Company has not identified any unique requirements in this area. 

Marketing and Ecommerce: Chatham Company has not identified any unique 

requirements and intends to investigate the related capabilities in the future. 
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Solution for Exercise 01: Review the Business Requirements Document 

 

What are some of the tactical responsibilities of the Administrator? 

Answer: 

 Attend all meetings 

 Act as point of contact for all day-to-day project operations 

 Coordinate subject matter experts and their project team 

 Manage decision making resources 

 Serve as gatekeeper for project status 

 Manage their system requirements 

 Learn configuration specific to their business 

 Manage configuration decisions 

 Manage user acceptance testing 

What is the structure of the Chart of Accounts format? 

 Answer: The Chart of Accounts is based on a traditional format. Trailing segments will be 

created in the Chart of Accounts to designate and represent the sub accounts. 

How does this company track its reporting requirements? 

 Answer: The company tracks its reporting requirements through divisions. There are 

warehouses with each subsidiary to distribute its products. Additionally, they need sales 

channels. 

How does this company plan to bring in its General Ledger balances? 

• Answer: The company intends to bring in its General Ledger Balances as transactional detail 

records for the current year. 

Does the Chatham Company have any unique requirements that it wants to capture on its customer 

records? 

 Answer: The Chatham Company would like to maintain information about the customer’s 

organization. This data will be collected on the Customer record. Information to be collected 

includes company’s primary line of business (type of industry), annual revenue and year 

established (This is part of the requirement regarding Relationships) 
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Additional Resources 
 
NetSuite Help Center: 

• Account Setup 
 
Podcasts  

• Welcome to NetSuite 

• Implementation of a Global Company 

• NetSuite One Methodology 
 
SuiteAnswers Learning Center:  

• New Feature Training 

• Administration/Data 

• Customization/Integration 

• User Adoption 

• Various Best Practices 
 

 
 

https://system.netsuite.com/core/media/media.nl?id=8515360&c=NLCORP&h=dc6d75a23f01cebf84fb&_xt=.mp3
https://system.netsuite.com/core/media/media.nl?id=8515349&c=NLCORP&h=5e42bc02fe94df9d81aa&_xt=.mp3
https://system.netsuite.com/core/media/media.nl?id=8515227&c=NLCORP&h=855a8b779b7fc929c6c0&_xt=.mp3
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NetSuite Navigation 

 

About this Module 
 

Learning navigation will facilitate your implementation project and is your first step on 

your path to using NetSuite’s native features: 

▪ NetSuite offers multiple, effective navigation paths 

▪ NetSuite uses basic browser functionality 
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Walkthrough: Login and Security 
 

 

Use Case/Scenario: Introduce logging in and security measures that are applied 

 

Review Customer Login 
 
Click the Customer Login link, available from the Visitor Center website: 

 
 

• In the Customer Login enter in the E-mail address and password 
 
Caution: User 30-minute lockout occurs after six (6) failed attempts.  After 30 

minutes, has passed, Re-enter your email and password. 
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Administrator Password Management 

 

Administrators responsible for defining password management: 

• Administrator go to Setup > Company > General Preferences 

• Password Policy: enforces specific requirements 
o Strong: minimum length of 10 characters, at least 3 of these four 

character types —uppercase letters, lowercase letters, numbers, non-
alphanumeric characters – this is the default setting 

o Medium: minimum length of 8 characters, at least 2 of these four 
character types: uppercase letters, lowercase letters, numbers, non-
alphanumeric characters 

o Weak (Not Recommended): minimum length of 6 characters 
o All three password policies continue to enforce validation against these 

basic criteria: significant difference from previous password, use of only 
legal characters. 

• Maximum Password Length:  dictated by the password policy defined 
o The default value for this field is determined by the selected password 

policy. 
o You can, if desired, make the minimum password length value longer than 

the minimum required by the policy. You cannot make this value shorter. 
o Passwords for new users logging in with the Customer Center role, and for 

web site shoppers, require a minimum of six (6) characters. Passwords for 
Customer Center users and web site shoppers who existed before that 
release were not affected by this change. 

• Password Expiration: number of days a login password can be used before a 
user is prompted to change it 

o Days are calculated from the date that each user last changed their 
password, not from the date that the company preference is changed. 

o It is strongly recommended that administrators set this value to a minimum 
of 180 days. 

▪ The maximum number of days will take a very large number, which 
should accommodate most companies. 

o To comply with Payment Card Industry (PCI) standards, employees with 
access to view unencrypted credit card numbers are automatically 
required to reset passwords every 90 days, unless the limit set here is 
shorter. 
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Your NetSuite Account Security 
 
NetSuite takes your account security seriously: 

• Upon first login, users may be prompted to set up security questions 
o Select from a predefined list of questions and provide the answer 
o Security questions are required and help NetSuite protect your account 
o You will be asked to provide an answer to one of your questions upon 

switching browsers or computers 
 
Security Question Confirmation and Reset 
NetSuite provides a confirmation of your security questions being set: 

• NetSuite sends a system-generated email to the user 

• Users may reset their security questions in the Settings portlet 
o Go to Home > Settings Portlet 

 
• Users are required to verify security questions upon changing browsers 

 

Walkthrough: NetSuite Center and Web Page Elements 
 

 
 
Use Case/Scenario: Look at the starting point for navigation by investigating a NetSuite 
Center and page elements 
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NetSuite Center 
 
The center is a role-specific set of tabbed pages; providing the pages and links users 

need to perform their job. 

• The administrator, by default, works in the Classic Center 

• Each Center has a default Dashboard 
o The New Release portlet is often provided and is your best resource for 

information regarding an upcoming release 
 

 
(Please note that with his release, the tabs across the top have been reordered; 

Customization has been moved to the right of Setup) 
 

Dashboards 
 
Each tabbed page has an overview or dashboard: 

• Provides a visual workspace, which may be personalized  

• Displays portlets containing relevant information to your job 
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Portlets and Release Information 
Each tabbed page has a dashboard, a visual workspace, which may be personalized 

through publishing dashboards to groups of users or allowing individual users to 

personalize their own dashboard: 

• Display Portlets containing relevant information to your job, which are dynamic-
data display windows, for example: 

o Provides hyperlinks (Reminders) to other areas within NetSuite 
o Presents metrics (Key Performance Indicators) or a list of information 
o Displays a list of information (Customers) 

 

 

• Review the Release Information at the bottom of the home dashboard 
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Change Password  
 
At any time, users may choose to change their password: 

• Go to Home > Settings, select Change Password  

• Enter in Current Password and New Password to be evaluated by the Password 
Criteria 

• The passwords are evaluated for strength based on the Password Policy as 
defined by the administrator 

 

 

 

Update Security Questions 
 
Update Security Questions – Home > Settings portlet, select Update Security 
Questions: 

 
Security questions are available, which can be set at any time.  

• Choose from pre-define lists of questions and then provide your answers 

• These questions are used to validate user’s authenticity; in case they forget their 
password or get timed out. 

• Best Practice: complete the security questions the very first time you are 
prompted by the system 
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Set Preferences 

 
 
User-level preferences may be set by each user: 

• Home > Set Preferences 

• Define some preferences for each of your roles 

• Note: Administrators can define company-wide preferences, such as formatting 

• Review each subtab and subsequent sections to set your personal preferences: 
o General:  

▪ User profile 
▪ Localization 
▪ Formatting 

o Appearance:  
▪ Color Theme 
▪ Centers & Dashboards 
▪ Chart themes 

o Analytics: 
▪ Search 

o Activities:  
▪ Enable your NetSuite Calendar preferences 

 
Note: Utilize the ‘field level help definitions’ to learn more about the settings. Click the 
field name link to view the definition. 
 

Activity: Match Game 
 

See if you can match the terms on the left, with the task/description on the right. 
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Walkthrough: Personalize the Home Dashboard 

 
 
Use Case/Scenario: Optimize usage of the Home dashboard through some 
personalization and definition 
 

Personalize Create New Dropdown List 
 
The Create New bar provides hyperlinks to pages in NetSuite: 

• Available hyperlinks are determined by roles and permissions 

• It is available for most records on most dashboards 

• Click the down arrow to display the list 

• Click Personalize 

• Add, move, remove links 

• Available hyperlinks are determined by roles and permissions 

• Is available for most records on most dashboards 

• Choose to Include or not the task in the ‘Create New’ toolbar 

• Organize the list by Move To Top, Move To Bottom, or drag and drop 

• Save your changes 
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Add Content to Dashboard 
 
Personalize the dashboard to add portlets 

• Click the Personalize link, top-right of the dashboard 

 

• Add Standard Content, Report Snapshots, Trend Graphs 

• Add SuiteApps, if already installed in your account, to add additional automation 
of functionality.  Please refer to help for more information. 

• Consider portlets that support managing the user’s workload and decision 
making 

o Key Performance Indicators (KPIs): Display personal or company’s 
performance in sales, support or other key areas of your business. You 
can highlight or compare them based on a selected date/period range. 

o KPI Meters: View the KPIs graphically. You may have up to three KPI 
meters on your dashboard. These can be easily swapped between the 
KPIs you have set. 

o KPI Scorecards: Display a portlet based on the results of a KPI. This 
portlet is not available unless the KPI Scorecards feature has been 
enabled, in the account. Also, check with your account administrator to 
ensure you have the KPI Scorecards permission. 

o My Login Audit: Display on your dashboard to track your last successful 
login, your last failed login, the IP address associated with your login 
activity, the date when your password will expire, and other login 
information. 

o RSS/Atom Portlet: Displays news feeds from popular web sites which 
support RSS format. You can use any RSS feed available; in the setup 
link, select Custom and paste in the URL. 

o Report Snapshots and Trend Graphs: Quick looks at business results 
each time you view your dashboard 

• Review Currently Used portlets 

• Close when done 

• The NetSuite Help Center has a related topic: Portlet Types Table 
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My Login Portlet 
 

Helps ensure the security of your NetSuite account; audit your own login activity 

• Track your last successful login and failed login 

• Monitor the IP address associated with your login activity 

• View the Password expiration date; the administrator defines a setting which 
impacts the expiration date 

o Listed dates and times are driven by user-level preferences and the time 
zone selected, as part of localization 

 
 

Define Dashboard Layout 
Go to the Layout link, top-right of the dashboard and select your desired layout: 

• 2 columns: Narrow, wide 

• 2 columns: Wide, narrow 

• 3 columns, Narrow, wide, narrow 
 

 
 
Selecting a two-column layout setting is probably the most optimal for viewing 
NetSuite on a tablet or phone 
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Manage Portlets 
Portlets may be configured to better suit the user’s needs: 

• Hover over a portlet’s title bar to access the Set Up  

 

• Click Set Up and define the portlet’s display 

• Portlets may be moved to new locations on the dashboard using drag and drop: 
o Click the portlet title bar, hold the mouse down to move the portlet 
o Release the mouse to drop into the new location 

 

Introduction: NetSuite Terminology 

 
 

Lists and Transactions - Classic Interface (Center) 
 
Administrators access NetSuite in the Classic Interface (Center), with menu paths for 
Transactions and Lists: 

• Transactions involve movement of money or value, for example: 
o Transactions > Bank  

▪ > Write Checks 
▪ > Make Deposit 
▪ > Transfer Funds 

• Lists include people, places and things for example: 
o Lists > Relationships 

▪ > Customer 
▪ > Vendors 

o Lists > Accounting 
▪ > Items 
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Forms and Records 
 
Forms: 

• Enter, view, and modify data in NetSuite. For example: 
 
Records: 

• Store the data as a specific record type; for example: 
o Customer 
o Item 
o Account 
o Subsidiary 

 

Customization, to be introduced later in the course, allows you to work with forms and 

records: 

• Forms may be customized to meet your business requirements 

• Custom records may be created to meet your business needs 
 

Walkthrough: Basic Search Options 
 

 

Use Case/Scenario: Introduce different ways to search for information/records in the 
NetSuite Account 
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Global Search 
 
Global search is a common way to quickly search for records by entering in criteria: 

• Displays at the top-center of your NetSuite page 

• Use up to three key words per search 

• Autosuggest can drive results 

• Use letters, numbers, dashes, and the “OR” separator  

• Leverage wild cards:  “%” or “_”  

• Use prefixes such as “cus:” to restrict results to customer records 

• Use the “Page” prefix to find a report 

• Click the Name to view the record or click Edit to edit the record 
 
Enter criteria and click Go; auto suggestion can drive the results: 

 

• Click Edit to open the record in edit mode 

• Click on the name to open the record in view mode 
 
Tip: You can right-click on the mouse, to edit or open the record, to either open in 

a new tab or a new window 

 

Quick Search Portlet 
 

 
 
The Quick Search portlet may be added to the dashboard (personalize): 

• Click the Set Up link 

• Define the behavior, for example: 
o Search Type can be either General or Transaction 
o Save 

• In the portlet, now enter your criteria and Search 
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Walkthrough: Using Help Resources 
 

 

Use Case/Scenario: As a new user, it is important to know where and how to find 
online resources 
 

NetSuite Help Center 
 
The NetSuite Help Center is a complete repository of online help resources: 

• Access the Help Center, clicking on Help at the top-right of your NetSuite page: 

• Access complete repository of online help resources 
o Help Topics, User Guides, training materials, links to other resources 
o Search the Help Center 

• Type in help: followed by keyword(s) and click Go to the Global Search field 
 

Tip:  Use Global Search to go to a list of topics by typing in Help: followed by a 

word or phrase.  For example, help: invoice 

The NetSuite Help Center opens in a new window: 

• Navigate through the Table of Contents 

• Navigate to SuiteTraining to view course offerings  

• View User Guides in PDF  

• Use the Help Center Search to look for a specific topic 

• Utilize other hyperlinks for SuiteAnswers, What’s New, FAQs, etcetera 
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NetSuite Glossary 
 

 
 
NetSuite Glossary: Search the NetSuite Help Center for the glossary 

• Type “Glossary” into search box 

• View the list of available PDFs in translated versions 

• Select the version choice to view the PDF and then save a copy to your desktop 
 

Field Help 
 
Field Help provides users with field-specific information: 

• Available on most field in view, edit or add mode 
o Note: If you add a custom field, then you write the field help 

• Hover over the field name and click on What’s This? 

 
o Example: Company Name 

• A pop-up window opens and displays the Field Help, which provides details 
about the selected field 

o Example: Company name is the legal name of the customer 
Other fields, such as column field, do not have Field Help 

• For example, columns on line items such as Quantity 
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Page Help: 
 

NetSuite “knows” where you are in the system 

• Click the help link at the top, right-hand side of the page 

• View information relevant to the page you are viewing 
 

 

 

SuiteAnswers 
 
An online repository - a wealth of knowledge: 

• Access from the Support tab, inside your NetSuite Account, and click on Visit 
the SuiteAnswers Site 

• In SuiteAnswers, click on the Learning Center tab 
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SuiteSupport 
 

You have the various support options; complemented by an extensive library of detailed 

online help and other resources such as: 

• FAQs, online user guides, sneak peeks at upcoming releases, and tips that will 
help you get the most from your NetSuite application  

• View more information at: SuiteSupport or 
http://www.netsuite.com/portal/services/support.shtml  

 

 
 

Activity: Match Game 
 
See if you can match the terms on the left, with the task/description on the right. 

 

  

http://www.netsuite.com/portal/services/support.shtml
http://www.netsuite.com/portal/services/support.shtml
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Walkthrough: Browser Functionality and NetSuite 
 

 
Use Case/Scenario: Learn tips for using NetSuite in the browser and assessing its 
performance 
 

Open New NetSuite Tabs or Windows 
 

NetSuite utilizes standard browser function to view links in a new tab or a new window: 

• Hover a link and right or left mouse click 

• Select Open in New Tab 

• Select Open in New Window 

 

 

Review Recent Records 
 

Access recent records from the  icon, located to the left of the home icon, rather 

than the back arrow in the browser: 

• Select to view or edit the record 

• Select All Recent Records to display a date-driven list 

• Note: Avoid using the browser Back Button to retrace your steps. 
o Data entered may be lost if you navigate with this back button 
o Also, pages presented may not be refreshed 
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Investigate Processing Time 
 

Double click the NetSuite logo, top-left of the page, to view processing time: 

 

• Server = How long it took NS to find the data 

• Server SuiteScript, Server Workflow = If you are using these for automation, it 
shows stats.  Please refer to help for more information on SuiteScript and 
WorkFlow. 

• Network = How long it took to transmit the data from NS to you 

• Client = How long it took your machine to display the information 

• Identifies the Page, your Email for login, and Date 

If you are experiencing a slowdown: 

• Navigate to a different website to gauge load speed 
o If the other site loads quickly, then the problem is between your ISP and 

the NetSuite servers 

• Clear browsing history or cache 

• If necessary, close NetSuite and reopen 
 

Now It’s Your Turn 
 

 
 
Use Case/Scenario: 

• Start setting up your view of NetSuite 

• Investigate search and help  

• Allow 10 – 15 minutes 
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Independent Study Exercises 

Exercise 01: Set Your Preferences 
Time: 2-5 minutes 

Scenario: How do you want your NetSuite pages to look and how do you want to interact with areas of 

the account?  

Use these exercises to: 

 Set your preferences for the application “look and feel” and for viewing information.  

 Set preferences for the Searches and the Calendar 

Note: The Home dashboard is represented by the icon [ ]. All menu paths will reference  

Set Preferences 

 In the Administrator role, navigate to Home > Set Preferences. The General subtab displays 

automatically. 

 In the User Profile section, review the available fields 

a. In the Signature text box. If you like you may enter your name, a Department Name, 

Company Name and address. 

 Click the box to Add Signature to Messages from NetSuite. 

 In the Localization section, select your Local Time Zone. Also, review the following and change if 

necessary: 

a. Search Sorting set to English (U.S.) or your preferred language. 

b. Time Zone set to your preferred time zone. 

 In the Formatting section, select your preferred formats for Time,  

a. Review the available fields. 

b. Administrators can set company-wide preferences, for data entry consistency; any 

company-wide preference, the corresponding field would be grayed out.  

 Click the Appearance subtab: 

a. Select the Color Theme you want for the Administrator role; color themes can be set 

differently for each of your roles. 
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 Click the Analytics subtab, in the Search section check mark the following boxes, if not already 

checked: 

a. Show List When Only One Result  

b. Quick Search Uses Keywords 

c. Popup Auto Suggest 

d. Global Search Auto Suggest 

e. Under Export – change the export option to your home operating system: UTF-8 (if it is 

already set to UTF leave it alone). 

 Click the Activities subtab and select how you want calendar, task and phone call information to 

display.  Check mark the following boxes: 

a. Edit Activities from Calendar 

b. For Send Invitation Emails, click To all Invitees button. 

c. Default Event Access Setting for New Events Public 

d. Check Default New Tasks Public 

e. Check Default New Phone Calls Public 

 Click Save when you are done with setting your preferences. 

 End. 
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Exercise 02: Set Up Your Dashboard 
Time: 2-5 minutes 

Scenario: Consider how you would like your workspace to look.  Your account may have some 

dashboards preconfigured, but you might still want to further personalize. 

In this exercise, you: 

 Define Dashboard Layout 

 Choose the portlets you want to display 

 Define portlet display placement 

Define Dashboard Layout for the Administrator Role 

 Click the Layout link, located in the upper-right corner of the Home page. 

 Using the images, click on one of the following: 

a. 2 columns: narrow, wide 

b. 2 columns: wide, narrow 

c. 3 columns: narrow, wide, narrow 

Add portlets to the Home Dashboard 

 Click the Personalize link, located in the upper-right corner of the Home page. The Personalize 

Dashboard pane opens at the top of the page. 

 Click on Currently Used and review which portlets are on the dashboard; the following portlets 

may be included: 

a. Account Reconciliation Summary: Lists your bank and credit card accounts and displays 

the key data for matching and reconciliation activities. 

b. Key Performance Indicators: Shows key business metrics. These metrics are summary 

data from reports or saved searches for selected date ranges, with options to show 

comparisons between date ranges and to highlight results not meeting defined 

thresholds. 

c. New Release: Shows a summary of new features from the latest release of NetSuite, 

with links to more detailed descriptions. 

d. Quick Search: Shows a form where you can quickly search for records of a selected type, 

using one selected filter field and entered keywords. 

e. Settings: Shows links to user-level setup tasks. 

f. Shortcuts: Shows links to selected pages, so you can navigate quickly to frequently used 

pages. 
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g. Please refer to the Help Topic: Portlet Types Table for more information. 

 Add Content: We can use drag and drop functionality to add Standard Content to the Home 

dashboard. if necessary, add the following portlets: Calendar, Custom Search, List, My Login 

Audi Portlet, Quick Search, Reminders, Tasks, and Shortcuts. You may also add the Quick Add 

portlet; sales reps like this portlet. Click on Currently Used again; review the portlets that are 

now on the dashboard 

 Click on SuiteApps and note that we do not have anything available.  Please refer to Help for 

more information regarding SuiteApps 

 Close the Personalize Dashboard pane by clicking the X in the top-right corner. 

Organize the Home Dashboard portlets 

 Hover title bar of Calendar: My Calendar portlet and click on Set Up.   

a. Review the available display options and then click Cancel. 

 In the Calendar portlet, find the dropdown list and change Day (or other time reference) to 

Agenda.  This can help you manage your time and activities 

 

 Note: If visible, hide the New Release portlet that NetSuite pushes out to users.  Hover over the 

top right-hand side of the title bar and click Remove. This portlet is pushed out by NetSuite 

when a New Release is coming 

 Drag and drop the My Login Audit portlet to a narrow column, if it has defaulted to a wide 

column. 

 Hover over the title bar of the Reminders portlet and click Set Up. 

 

 Ensure that the Event Invitations to respond to reminder is displayed in the list and move it to 

the top. 

a. Click or Drag to Add a reminder to the list. 
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b. Click the Save button when you are done. 

 End 
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Exercise 03: Use Global Search 
Time: 2-5 minutes 

Scenario: Global Search is the best way to search for information in the application. 

In this exercise: 

 Practice using (Global) Search. 

 Enter employee in the Global Search field. NetSuite will either start displaying possible results 

or click Enter on your keyboard to see all results.  

 What types of records are returned?  Why do you think these records returned?  

 Click Home. 

 End. 
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Exercise 04: Use NetSuite Help 
Time: 2-5 minutes 

Scenario: NetSuite Help topics are a great resource to assist you with learning how to use the NetSuite 

application. 

In this exercise: 

 Conduct research within the NetSuite Help center. 

 Start on the Home Dashboard 

 Click the Help link in the top-right corner of the page.  

a. What displays in the main Help page?  

b. Answer: Since you are on the Home Dashboard, Help displays the basic Welcome page. 

 Enter CRM in the Help Center Search field, click Enter on your keyboard, and then scroll through 

the list and click the link for Creating CRM Task Records.  

a. Find the first topic discussed in this section and review. 

i. Scroll through help topic and look at the list of Related Topics 

 Click User Guides in the Help task bar. 

a. What file formats are these documents?  

 Scroll down to the Sales, Marketing, and General CRM Guides.  Click the Sales Automation 

Guide. 

a. The guide displays 

b. Review the Table of Contents 

c. If you like, download a copy to your desktop. 

 Go back to Home – NetSuite browser tab.  

 Go to the Create New dropdown   , click Personalize 

a. Select Task 

b. Move to the top 

c. Save 

 Go to the Create New dropdown   , click Task to create a new task record.  

a. Click on the word Assigned To*.  
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b. Review the field help 

c. Close the Field Help pop-up. 

d. Now click on Priority* field and review the field help; close the pop-up window when 

done. 

e. Click Cancel. 

 Go to the Global search field and type in Help: Sneak Peeks and click search icon  

a. The Help Center opens 

b. Find and click on the link “Finding Out What’s New in NetSuite” in the list of results. 

c. Review the information about Sneak Peeks. 

 Close all open Help browser tabs. 

 End. 
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Solution for Exercise 03: Use Global Search 
 

Use (Global) Search (Search by Key Word) 

Enter employee in the Global Search field and click Go. 

What types of records are returned? Why are these records returned? 

• Answer: The results show no employee records; all records are pages with the word employee 
in them. 
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Solution for 04: Use NetSuite Help 
 

Click the Help link in the top-right corner of the page.  

What displays in the main Help panel?  Why does this content display? 

• Answer: Welcome to NetSuite Help Center. 

• Answer: When on the Home page, and we click Help, it takes us to a page introducing the Help 
Center 

 

Enter CRM in the Search field and click Enter on your keyboard. Scroll down the page and click the link 

for Working with CRM Tasks  

What is the first topic discussed in this section? 

• Answer: Working with CRM Tasks providing an overview. 
 

Click the User Guides button in the Help task bar.  

What happens? And what file formats are these documents? 

• Answer: A list of all the User Guides display in PDF format. 
 

Click the Sales Automation Guide. What displays?  

• Answer: The Sales Force Automation Guide.  
 

Go back to Home – NetSuite (Essentials) browser tab.  

In the Create New dropdown, click New Task to create a new task record. Click on the word Title*.  

What does the field level help text tell you about the Title field?  

• Answer: This name is the subject line of the email sent to the assignee if you check the Send 
email box. 

This title also displays to others if the Private Task box is not checked. The title shows on the Tasks list. 

 

What does the field level help tell you about the Start Date* field? 

• Answer: This is the date the task should be started. If you are entering or editing the task, type 
or pick the start date of the task. This date is included in the email to the assignee. 
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Activity: Match Game 
 

See if you can match the terms on the left, with the task/description on the right. 

 
 

Additional Resources 
 

NetSuite Help Center: 

• NetSuite Basics 
 
SuiteCloud Infrastructure Web Page: 

• http://www.netsuite.com/portal/platform/infrastructure/main.shtml 

• Read more about NetSuite’s enterprise-class treatment of: 
o Application Security 
o Data Management 
o Operational Security 
o Availability  

 
SuiteAnswers Learning Center:  

• New Feature Training 

• Getting Started 
 

  

http://www.netsuite.com/portal/platform/infrastructure/main.shtml
http://www.netsuite.com/portal/platform/infrastructure/main.shtml
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Set Up Company Preferences 

  

About this Module 
 

NetSuite is the single source for your data and can be tailored or configured to meet 

your business needs: 

• Features are enabled and preferences defined to satisfy your company’s 
requirements 

• The Administrator is often responsible for the configuration 

• At the beginning of the implementation project, it is okay to not know all your 
company’s preferences  
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Introducing the Setup Manager 

 

The Setup Manager links to setup pages to configure NetSuite: 

• Go to Setup > Setup Manager 

• Provides logical navigation for configuration of the account 

• Presents Overviews for Company, CRM, ERP and Web Site Setup 

 
Walkthrough: Initial Set up Tasks 

 

 
 
Use Case/Scenario: The administrator begins tailoring NetSuite to the company’s 
requirements. 
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Define Company Information  
 

 
 
Go to Setup > Company > Company Information 
At the top of the page you may enter your company information, such as: 

• Company Name: Can be printed on forms 

• Company Logo: Can be set for web pages and printed forms 

• Display Logo Internally: Check to display your company logo 

• Return Email Address: used when emailing forms and reports from NetSuite.  

• Define your company’s Currency Locale and review the subsequent Format 
Sample 

• Setting your First Fiscal Month 

• Identifying your corporate Time Zone 
o The corporate headquarters’ time zone, may differ from each user’s time 

zone 

• You may click the Edit link to enter in an Address, you may enter in your 
corporate address: 

 
Scroll down on the page to enter: 

• Address (to display on all forms, except checks) 

• Return Address for receiving returned orders 

• Shipping Address for shipments 
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Enable Features 
 
Go to Setup > Company > Enable Features and Elect to turn on or off NetSuite 
features and functionality: 

• Available features are determined by your subscription 

• SuiteApps and Beta Features may be accessed through various subtabs 

• Functional groupings on the following subtabs 

 
 
Note: Record the Reason for Deleting a Transaction is available on the Company 
subtab, ERP section – select the Use Deletion Reason feature: 
 

• In some countries, providing the reason why a transaction was deleted is a legal 
requirement. 

• The Use Deletion Reason feature satisfies this requirement by making it 
mandatory for users to record the reason for deleting a transaction. 

• All transactions listed at Setup > Company > Auto-Generated Numbers on the 
Transactions subtab are impacted by the Use Deletion Reason feature. When 
this feature is enabled, users must provide a reason for deleting a transaction 
record. The Transaction Numbering Audit Log provides a list of the deleted 
transactions, their transaction number, and the date on which the transaction was 
deleted and by whom. It also provides 

 

Tips: Enable Features 
 
Standard NetSuite Account: 

• You do not need to enable/disable features all at once 

• Return to Enable Features as needed 

• Once enabled some features cannot be disabled 

• Multi-Location Inventory cannot be disabled 
o Important: Do not enable the Multiple Locations Inventory until after you 

have loaded all your inventory items. If you enable Multiple Locations 
Inventory before loading inventory items, then you must map to the 
locations, making it more difficult for data migration. 

• Multi-Language: for use by your users and customers viewing your Website 

• Multiple Currencies cannot be disabled 
o Choose to have NetSuite run updates at 12:30 PST or by your set base 

time zone. Then those will run at 6AM for the local time you select. 
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OneWorld – Additional Considerations 

• Multi Subsidiary Customer may be enabled to allow creation of customer records 
across subsidiaries. But, please refer to the Help Topic: Multi-Subsidiary 
Customer Feature Limitations 

• The Advanced taxes feature is enabled by default 
o Allows you to use tax schedules to track taxes for each nexus in which 

your company is required to pay taxes 

• Accounting periods enabled by default 
o Use this feature to segment your fiscal year 

• Currency Exchange Rate Integration is useful:  
o The list of currency exchange rates can be automatically updated using 

the Currency Exchange Rate Integration feature.  This will be reviewed 
later in the course, but we offer both Xignite and Thomson Reuters.  

o Not all companies will use this feature or you may prefer to manually set 
the exchange rates.  

o If you are NOT using multiple currencies the "currency exchange rate 
integration" runs at 12:30PST.  

 

Implementation Considerations 
 
Standard NetSuite Account may have some of the following considerations: 

• What is the Currency Locale and Format (base currency) of your company? 

• How do you plan to update and maintain currency exchange rates? 

• How do you want to track and number your transactions? 
 
OneWorld NetSuite Account may have additional considerations: 

• How many separate legal entities need to be consolidated? 

• What are the base currencies of each of your subsidiaries? 

• How do you plan to update and maintain consolidated exchange rates? 

 
Walkthrough: Additional Set up Tasks 

 

 
Use Case/Scenario: The administrator continues with tasks that are specific to their 
company’s requirements. 
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Rename Records/Transactions 
 

 
 
Go to Setup > Company > Rename Records/Transactions 

• At the top of the page you can change the default record names, in NetSuite, to 
familiar terminology: 

• On the Transaction Name subtab, you may rename the various transactions 

• On the Account Type Names subtab, you may rename the account and reorder 
how they display in a list of values for example move Expense to the top of the 
Account Type Names list 

o Use Case: When setting up a new account for the GL, the Type field will 
display Expense as the first value in the dropdown list of available values 

 

Best Practices: Renaming 
Records: 

• Enter new names as singular  

• Do not rename a record the same as an existing record 
o (e.g. do not rename Customers as Partners) 

• Do not use the same word to rename more than one record 
o (e.g. do not rename Vendors and Employees both as Resources) 

• You can reorder the listing of accounts 
 
Transactions: 

• Do not change the abbreviations 

• These abbreviations are referenced in NetSuite source material and renaming 
them can cause confusion 

• Help Text is also referenced by the NetSuite name 
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Auto-Generated Numbers 
 

 
 
Go to Setup > Company > Auto-Generated Numbers 
Define the numbering schemes for your different records: 

• Use numbers, rather than names for Entity and CRM records 

• Use prefixes and suffixes with records, and define a numbering scheme 

• Determine if you want to Allow Override or Update 
 

Tips: Auto-Generated Number 
 

Standard NetSuite Account may have some of the following considerations: 

• Transactions are automatically assigned numbers, but you can define a 
numbering scheme 

• Use prefixes for entities 
o For example, C for customer and V for vendor 

• Use auto-generated numbers, with Entity names, so that the Entity name is a 
combination of ID and name 

 
OneWorld NetSuite Account may have additional considerations: 

• Specify subsidiary prefix on subsidiary records 

• Enable auto-generated numbers  

• Check Use Subsidiary box for subsidiary specific sequences to be used 

• Must have transaction prefix on subsidiary to generate numbering scheme 
(Example: USA or AUS 01) 
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Transaction Numbering Audit Log 
 
Go to Transactions > Management > Transaction Numbering Audit Log 

• Provides a complete list of every transaction number, including numbers 
assigned to deleted or failed transactions 

• Example: Cash sale failure due to credit card processing problem 

• Requires the List type permission – Access to transaction numbering log 

• Includes transaction type, number, date and time of the transaction number 
assignment, creator of the transaction 

• Additionally, subsidiary and location may also be available 

• If a transaction is deleted, then the report shows the date and time stamp and the 
user who deleted the transaction 

• If a transaction failed to be created, a reason displays in the message column 
 

Configure Administrative Notifications 
 

 
Go to Setup > Company \> Administrative Notifications 

• Provides the ability to define separate configuration settings for each of the 
following notification types: 

o Administrative Notifications: feature availability in your account and 
login failures 

o Billing and Renewal Notices: payment requirements when you purchase 
new features and notify you when it is time to renew your contract with 
NetSuite. 

o Legal Notifications: changes that require administrator acceptance, such 
as a modification to the Terms of Service (TOS). 

o Scheduled Maintenance: date and time for scheduled maintenance 
o Service Release Notifications: information about access to the Release 

Preview environment, and the time-frame when your account will be 
upgraded. 

• Requires Setup Company permissions 
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You can define configuration settings separately for each of the notification types listed: 

• Administrative Notifications - Announce upcoming changes to feature 
availability in your account. 

• Billing and Renewal Notices - Alert you to payment requirements when you 
purchase new features and notify you when it is time to renew your contract with 
NetSuite. 

• Legal Notifications - Notify you of changes that require administrator 
acceptance, such as a modification to the Terms of Service (TOS). 

• Scheduled Maintenance - Provide the date and time when scheduled 
maintenance tasks may affect access to your account. 

• Service Release Notifications - Occur prior to the release of a new version of 
NetSuite. These notifications provide information about access to the Release 
Preview environment, and the time-frame when your account will be upgraded.  

 

Walkthrough: Define Preferences 

 
Use Case/Scenario: The administrator can set company-wide preferences and 
settings.  If using a sandbox, review the related information. 
 

General Preferences 

 
Go to Setup > Company > General Preferences 
Company preferences supersede individual user preferences: 

• On the top of the page you define how information is entered and formatted, and 
set default values 

• On the Overriding Preferences subtab, you may disallow the user’s ability to 
override settings  

• Note that the Centers subtab is related to Web sites; connect your company web 
site's look and feel with the NetSuite application by specifying a landing page 
when employees, customers or partners log out. 

• Note: New accounts will have a default of 180 days in the Password Expiration 
in Days field.  Please refer to related topics in SuiteAnswers. 
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Tips: General Preferences 
 
Standard NetSuite Account common tips: 

• Set company-wide formatting for consistency of data entry 

• If using NetSuite payroll, do not “Allow free form states in addresses” 

• If your business addresses individuals as Customers, Vendors or Partners, you 
may want to enable “Show Individuals as Contacts” 

o Displays individual customers also as Contacts in your account 

• Consider setting these settings for all users: 
o Show List When Only One Result  

 

Printing, Fax & Email Preferences 
 
Set company-wide Preferences: 

▪ Go to Setup > Company > Printing & Fax  

 
▪ Set printing defaults for Transactions, Check Printing, and PDFs 
▪ Define fax defaults and fax service 

 

▪ Go to Setup > Company > Email Preferences 

 
▪ Determine email defaults for Transactions, Templates, and other 

functionality 
– Have your administrator review Domain Key Identified Mail 

definitions to increase your delivery rates; this is important for email 
marketers 
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Tips: Printing & Fax Preferences  
Printing: 

• Place disclaimers on individual forms rather than globally. This enables using 
different disclaimers for different locations and purposes 

• PDF definitions may improve the look of printed forms: 
o Add Extra Space Between Items 
o Line Spacing 
o Extend columns to bottom of page 

 
FAX: 

• Set up a separate email account, for registration with your fax provider, to receive 
bounced efaxes 

• Remember faxes are not always sent immediately; when you click FAX, NetSuite 
creates a PDF and sends it to the Fax service 

 

Tips: Email Preferences  
General and Transactions Options: 

• From Address for Emailed Forms: enter an email address  

• If you do not set this preference, the sender of each saved search’s emails 
defaults to be the search owner 

• Review the “Send to all Administrators” setting 

• Use Popup for Main Transaction Email Button to edit email 
 
Release Sandbox and Release Preview Options: 

• Define email Sandbox Options that are separate from your email Release 
Preview Options 

o Sandbox accounts have configuration, data, and customization identical 
to your production account 

▪ Multiple sandbox accounts can be provisioned for each production 
account 

▪ Actions in sandbox accounts (transaction entries, record deletions, 
and form customization) have no effect on your NetSuite production 
account 

o A Release Preview account is part of the phased new release process 
and is an environment in which to test data and workflows; note that it 
runs separately from your production account 

• Specify where to send emails, from the respective accounts, or suspend emails 
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Additional Sandbox Information 
 

Sandbox accounts provide ideal environments for: 

• Testing customization elements before deployment 

• Fixing issues with existing customizations 

• Trying out third-party integration features like Payroll or Credit Card Processing 

• Training employees in existing and new business practices in an environment 
identical to your production account 

 
Sandbox accounts can be refreshed from production upon request: 

• Copies all configuration, data, user passwords, and customizations from your 
production account into the sandbox account 

• Any changes you have made to the sandbox account are overwritten 

• Go to Setup > Company > Sandbox accounts to track refreshes: system notes 
are not included in the data that is refreshed – Contact support if you get an error 
message.  

 

Sandbox Expiration Notification 
 

Renewing your sandbox account before it expires is very important: 

• The status of a sandbox account is automatically set to “Inactive” the day it 
expires 

• You cannot log in to an inactive sandbox, and data from expired sandbox 
accounts is automatically purged 30 days after attaining an inactive status 

 
Receive email notification before a sandbox account expires; renew the account without 

an interruption of availability or potential data loss  

• The notification process is completely automated, no action on your part is 
required 

• If you are the administrator of the sandbox, you will be notified by email several 
times before the expiration date, giving you time to renew your sandbox account  
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Introducing OneWorld Classifications 
 

 
 
Use Case/Scenario: Companies that are running multiple legal entities, in a single 
NetSuite account, are going to use OneWorld classifications or records  
 

OneWorld; Subsidiaries 
 

New Subsidiaries – Go to Setup > Company > Subsidiaries > New 

 
NetSuite OneWorld allows data management for a hierarchical structure of separate 

legal entities, or subsidiaries, structured as a tree rolling up to the root, or top-level 

parent, subsidiary. NetSuite supports 124 subsidiaries and 1 root (parent): 

• Setup base currencies before setting up a subsidiary 

• Select the country. This determines the NetSuite Edition and sets tax nexus 

• A transaction posts to one subsidiary, except an intercompany transaction 
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Best Practices: OneWorld Subsidiaries 
 
Plan and document, in visual form, your subsidiary hierarchy, Design the hierarchy 

around accounting and reporting requirements; consider working with NetSuite 

Professional Services to assist with setting up your hierarchy 

• Use top-down setup, parent with children 

• Once defined in NetSuite it is difficult to change 
o If in the production account, with data, customer must buy a sand box 

before changing  

• Create up to 124 subsidiaries in addition to the root (parent). 
o An inactive subsidiary does not count towards the total number 

• If subsidiaries share multiple nexuses, set up in the proper order: 
o Subsidiary 
o Tax Agency 
o Nexus 
o Tax Code 

• Select languages to translate Web site information and to print on transactions. 
NOTE: Multiple languages features must first be enabled. 

• Different types of Subsidiaries: 
o Standard  
o Elimination  
o Reporting  
o Statutory to GAAP 

 

Overview of OneWorld Elimination Subsidiaries 
Set up an elimination subsidiary as child of each parent entity, with the same base 

currency: 

 

• License fees for subsidiaries do not include charges for elimination subsidiaries, 
and elimination subsidiaries do not count toward the maximum of 125 
subsidiaries. 

• Elimination subsidiaries are only associated with journal entries 

• Base currency should be same currency as parent 
o Select the currency for the Elimination subsidiary, and then check the 

Elimination checkbox 
 
Another User Case Example:  A company in India may keep their accounts in the local 
books/currency. Create a subsidiary of that company to hold adjustments between the 
local practices and the accounting principles that are used for consolidating in total. 
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OneWorld: Elimination Subsidiaries Set Up 
Create elimination subsidiary for each parent subsidiary to eliminate revenue or 

expense at the consolidated level, only journal entries post to elimination subsidiaries: 

Go to Setup > Company > Subsidiaries > New 

 

• Enter subsidiary information 

• Consider using the word “Elimination” in the name of the subsidiary 

• Set the Currency for the subsidiary 

• Check the Elimination checkbox 
 

Walkthrough: Other Setup  

 
Use Case/Scenario: Administrators are the only users that should investigate the ability 

to delete all account data.  Billing information provides the administrator with visibility 

into the provisioned NetSuite account modules and components. 
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Delete All Data 
 
 
Navigate to Setup > Company > Delete All Data: 
 

 
 

▪ Requires contacting technical support 
▪ Can be used for removing all test data, but resets the account to a “blank 

shell” 
 

View Billing Information 
 
Go to Setup > Company > View Billing Information 

 
Review your product subscription: 

• View the Product you are using, such as: NetSuite, NetSuite CRM+ 

• View the Anniversary Date, either the date of when your service began or the 
most recent renewal date 

• Review your product subscription: 
o Billable Components 
o Add-On Modules 
o Provisioning History 
o Component Usage 

  



 

107 

 

Now It’s Your Turn 

 

Use Case/Scenario: 

• As the administrator, begin to configure the NetSuite application for your 
company’s needs  

• Allow 20 - 35 minutes 
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Hands-on Exercises 
Set Your Company Preferences 

Suggested Time to Complete Exercises: 1 hour 

Independent Study Exercises 

Exercise 01: Set Company Information 
Time: 2-5 minutes 

Scenario: The Chatham Company’s requirements are defined in the BRD. Now you begin to enter data 

into your NetSuite account to satisfy these requirements.  In this exercise: 

 Enter the company information in the blank account 

 Navigate to Setup > Company > Company Information. 

 At the top of the page enter the Company Name: Chatham Company 

 Select California in the County/State/Province dropdown list, if not already populated in our 

training account.  We need to do this since we were issued a US Edition account. 

 Confirm the Currency Locale as United States (English) or Currency as USA; selecting a country 

determines the currency for your account.  

 Select January as the First Fiscal Month  

 Select the local time zone, from the Time Zone dropdown list, to represent the time zone of the 

company’s headquarters.  

 Scroll down to the Address field, click the Edit link. 

 In the pop-up window, enter / confirm the following information. 

a. Country: United States 

b. Addressee: Chatham Company 

c. Address1: 1500 3rd St 

d. Address2: Suite 100 

e. Zip: 94403 and click the tab key 

f. City (San Mateo) and State (CA) fill in automatically 

g. Click OK 

 Click Save when you are done. When you click Save, the system redirects you to Setup Manager. 

 End. 
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Exercise 02: Enable Features 
Time: 2-5 minutes 

Scenario: The administrator is responsible for enabling features per your company’s requirements. At 

this stage, you may not know all the features that you will be using.  Other features will be enabled in 

later modules.  In this exercise: 

 Enable key features per discussions and the BRD 

 Enable Multi-Language for language translation 

 Enable Multiple currencies to conduct and manage books in different currencies 

 Navigate to Setup > Company > Enable Features. 

 Under the Company subtab, check the following features: If the features are already checked, 

leave them checked and do nothing. Do not UNCHECK anything without direction. 

a. Classifications: 

i. Departments 

ii. Locations 

iii. Classes 

b. Projects: Uncheck any features that are enabled.  Projects are not part of this class.  

Click through any pop-up windows. 

c. ERP General 

i. Uncheck Multiple Units of Measure, if checked. 

ii. Review the field level help for Use Deletion Reason 

iii. Select Multi Subsidiary Customer; Chatham did specify this in their BRD as 

being useful.  

d. Resource Management: Uncheck Resource Allocations, if checked. 

e. International: 

i. Multi-Language confirm or mark as checked 

ii. Multiple Currencies - Check this box to conduct business with customers and 

vendors that use currencies other than the currency in which your company 

manages its financials. 

1. Click OK in the redirect pop-up window 

iii. Currency Exchange Rate Integration and click I Agree. 

f. Data Management: 
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i. Inline Editing 

ii. File Cabinet 

iii. Duplicate Detection & Merge: Click OK in the redirect pop-up window 

iv. Review field help for Antivirus Scanning on File Cabinet Files (BETA), but do not 

select. 

g. Do nothing in Access, Social or Mobile sections, if displayed.  

h. Go to the Analytics subtab, Dashboards section and select KPI Scorecards, if not already 

checked. 

i. Click Save.  Note: A Message from webpage popup displays.  Review the information, 

click OK, and continue to the Set Up Manager. 

 

  Go to Home> Set Preferences, General subtab. 

a. In the Localization section select your preferred language for each of the following: 

i. Language from the dropdown list of values. 

ii. Search Sorting from the dropdown list of values. 

iii. Language of the Help Center from the dropdown list of values. 

b. Click Save. 

 End. 
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Exercise 03: Rename Records and Transactions 
Time: 2-5 minutes 

Scenario: NetSuite records and transactions may be renamed to fit your company’s terminology. In this 

exercise: 

 Available records are dependent upon the enabled features 

 Rename NetSuite standard classifications (department, location and class) per the BRD  

 Rename a transaction record and reorder the account list 

Modify Records and Transactions 

 Navigate to Setup > Company > Rename Records/Transactions. 

 Rename or confirm the following records as shown: 

a. Name for Department: Division 

b. Name for Location: Warehouse 

c. Name for Class: Sales Channel 

d. Name for Other Name: Donor (to attach a charity or a donor to a transaction without 

making the donor a customer) 

 Go to the Transaction Names subtab and confirm the following: 

a. Estimate: Quote 

 Click on the Account Type Names subtab. 

a. Move the Expense field to the top of the list. 

b. Hint: Select the Expense field row and click the Move To Top button or drag and drop 

the row to the appropriate position. 

 Click Save when you have finished. 

 End. 
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Exercise 04: Turn Off Auto-Generated Numbers 
Time: 2-5 minutes 

Scenario: The Chatham Company will identify its customers by name. In this exercise: 

 Turn off the auto-generated numbers feature. 

 Navigate to Setup > Company > Auto-Generated Numbers. 

a. Under the Entities subtab remove any existing checkmarks in the Enable column. 

i. Note: Subpartners, under Within Parent Group column, is checked. No action is 

required.  

b. Review the Document Numbers subtab and review any checkmarks under Allow 

Override.  

 Click Save. 

 End. 
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Exercise 05: Set General Preferences 
Time: 2-5 minutes 

Scenario: Setting preferences at the company level applies these preferences for all users.  In this 

exercise: 

 Verify and set preferences for all users and disallow users' ability to change specific 

preferences 

 Do not uncheck any options, unless instructed. 

 

 Navigate to Setup > Company > General Preferences.  Set the following values: 

a. Date Format: MM/DD/YYYY 

b. Long Date Format: Month DD, YYYY 

c. Time Format: hh:mm AM/PM 

d. Number Format: Your choice, consider your currency 

e. Negative Number Format: Your choice 

f. Phone Number Format: Your choice – Interesting note, by defining a phone number 

format, this will carry over to any external forms that you create for your account. We 

will see this in a later module, when we create an Online Marketing Form. 

g. First Day of Week: Sunday 

 Check or confirm that the following choices are checked: 

a. Pre-Populate contact Address to have the contact’s address fields pre-populated from 

the Customer Address fields. 

b. Show Employees as Contacts box to create a contact record for each employee record. 

c. Show Display Name with Item Codes box. When you turn on this preference, both the 

item name and its item code display in the drop-down lists. 

 Continue down and define the following: 

a. Password Policy: leave as Weak. This is not recommended, but we are doing it for our 

training environment. 

b. Minimum Password Length leave as eight (8).  Be sure to review the field help for 

additional information. 

c. Password Expiration in Days: review field help, but do not enter in any value. 

i. Best Practice on Passwords NOT in a training account, but in your production 

account, use the following settings: Password Policy should be set at strong. Set 
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a Minimum Password Length: 10 characters, at least 3 of these four-character 

types — uppercase letters, lowercase letters, numbers, non-alphanumeric ASCII 

characters 

d. Review Field Help for User Registration Link Expiration in Hours and Idle Session 

Timeout in Minutes, but do not change default values. 

 Scroll down and review field help for the Horizontal Labels checkbox.  You do not have to check 

it. 

 On the right-hand side review current settings and field help for the following: 

a. Log System Notes on Update Only 

b. Show List When Only One Result to provide users with a consistent view of search 

results.  Please select this. 

c. Default Customer Type – leave as Company 

d. Default Vendor Type – leave as Company 

e. Default Partner Type– leave as Company 

f. Maintenance Complete Email Notification 

 On the lower half of the page are several preferences that you can check or uncheck to allow or 

prevent users from overriding. 

 Uncheck the following settings: 

a. Customer Credit Limit Handling 

b. Date Format 

c. Phone Number Format 

d. Vendor Credit Limit Warnings 

 Click Save when you are done. 

 End. 
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Exercise 06: Set Printing, Fax & Email Preferences 

 

Time: 2-5 minutes 

Scenario: The company’s preferences can be set for Printing, Fax, and Email. In this exercise: 

 Set check printing preference, review FAX information 

 Enable Email button 

 Navigate to Setup > Company > Printing & Fax. 

 The Printing subtab displays. 

 In the Check Printing section, select Voucher for the Default Check Type. 

a. Standard option prints three checks to an 8.5-by-11-inch sheet without any 

voucher/stubs. 

b. Voucher option prints a single check per page with voucher information at the bottom. 

 Go to the Fax subtab and review the information. 

 Click Save 

 Navigate to Setup > Company > Email Preferences 

 On the Transactions subtab, In the Transactions section, check Use Popup For Main Transaction 

Email Button. 

a. Note: If you do not see this, the associated feature may have been turned off. Go to 

Setup > Company > Enable Features, then the CRM subtab, and on the right-hand side 

select the Mail Merge feature 

 Go to the Sandbox and Release Preview subtab, Sandbox Options and Release Preview 

Options sections.  Please review field help and the Help Center for more information.   

 Click Save when you are done. 

 End. 
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Exercise 07: Create New Subsidiaries OneWorld  
Time: 2-5 minutes 

Scenario: Per the BRD, the Chatham Company currently has two subsidiaries and these subsidiaries will 

process transactions in their local currency.  In this exercise: 

 Create two subsidiaries. 

 IMPORTANT: If you create and save the subsidiary with incorrect information, you may not 

be able to edit that information.  If necessary, mark the incorrect subsidiary inactive and 

enter in a new subsidiary with correct information. 

 Navigate to Setup > Company > Subsidiaries > New. 

 Enter the following details for the new subsidiary record: 

a. Name: Germany 

b. Subsubsidiary of: Parent Company 

c. Uncheck Subsidiary is Inactive, if checked 

d. Document Number Prefix: DE (as in Deutschland) 

e. Currency: Euro (If the currency field is not visible, you may not have enabled all the 

features in Exercise 02 

f. Country: Germany  

g. Note: The Edition field defaults to XX upon choosing the Country. 

 If the Accounting Advanced Feature for Multiple Calendars was enabled, two additional fields 

are visible: Fiscal Calendar and Tax Fiscal Calendar.  If these fields are displayed, you may review 

field help for Fiscal Calendar and Tax Fiscal Calendar, but no changes are required.  At this time, 

Chatham is only maintaining a single, Standard Fiscal Calendar. 

 Click Save when you have finished.  (If you are returned to the Subsidiaries page, then click the 

View link next to the Germany subsidiary.) 

 Select the Nexuses subtab and see that a Nexus has been created for the Germany subsidiary. 

 Go to Actions and select New. 

 Repeat these steps to create a subsidiary for Italy using the following details for the new record: 

a. Name: Italy 

b. Subsubsidiary of: Parent Company: Germany 

c. Uncheck Subsidiary is Inactive, if checked 

d. Document Number Prefix: IT 
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e. Currency: Euro 

f. Country: Italy 

g. Note: After we study how to create a new currency, we will create two more 

subsidiaries (including another Subsubsidiary of Germany). 

 Click Save when you have finished. 

 End. 
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Exercise 08: Create Elimination Subsidiaries OneWorld 
Time: 2-5 minutes 

Scenario: Use elimination subsidiaries to eliminate transactions when doing business between 

subsidiaries.  In this exercise: 

 Create elimination subsidiaries for each parent subsidiary. 

 IMPORTANT: If you create and save the subsidiary with incorrect information, you may not 

be able to edit that information.  If necessary, mark the incorrect subsidiary inactive and 

enter in a new subsidiary with correct information 

 Navigate to Setup > Company > Subsidiaries > New. 

 Enter the following details for the new elimination subsidiary record: 

a. Name: *Elimination – Parent Company 

b. Subsubsidiary of: Parent Company 

c. Uncheck Subsidiary is Inactive, if checked 

d. Select California from the State/Province dropdown list 

e. Country: United States 

i. Note: The Edition field defaults to US when you choose the Country. 

f. Currency: US Dollar or USA (Set the currency BEFORE checking Elimination) 

g. Elimination box: Checked 

 Click Save & New when you have finished. 

 Repeat these steps to create an elimination subsidiary for Germany: 

a. Name: *Elimination – Germany 

b. Subsubsidiary of: Parent Company: Germany 

c. Uncheck Subsidiary is Inactive, if checked 

d. Currency: Euro (Set the currency BEFORE checking Elimination) 

e. Elimination box: Checked 

f. Country: Germany (Edition defaults to XX) 

 Click Save when you have finished. 
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 Navigate to Setup > Company > Subsidiaries and confirm that your company structure looks like 

this: 

 

 If you structure does not look like the above, then edit. 

 Click Edit next to the subsidiary you want to correct 

a. In the subsidiary record and mark Inactive. 

 Now enter the subsidiary correctly. 

 End. 
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Activity: True or False 
 

 

 

Additional Resources 
 
NetSuite Help Center: 

• Account Setup  
 

SuiteAnswers Learning Center: Training Videos 

• New Feature Training 

• NetSuite OneWorld 

• Administration/Data 
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NetSuite Data Model 

  

About this Module 
 

NetSuite is your single, data source for the data your company collects: 

• How is data classified, sorted and recorded? 

• What determines who can access the data? 
 

 

  



 

122 

 

NetSuite Data Tables 
 

Utilize one of the following standard tables, which support records, or create a custom 

record that results in a new table being created: 

• Entity: people and organizations that you do business with 
o For example: leads, prospects, customers, contacts, employees … 

• Transaction: represent a financial exchange or value adjustment 
o For example: Sales orders, bank deposits, inventory adjustments … 

• CRM: activities with customers 

• Item:  goods and services you buy and sell; line items on sales and purchase 
order forms 

• Custom: addresses unique needs of your business 
o Use Case:  NetSuite Training Services uses a custom record for our 

course evaluations 
 

Entity Table Types 
 
Entities can be people or companies: 

• Customers buy from you, may be a company or an individual 

• Vendors sell to you (those who you pay), may be a company or an individual 

• Partners are Marketing or Sales Partners, may be a company or an individual 

• Employees work for you 

• Contacts are people who work for companies and may be associated with 
multiple companies! 

o Important!  Employees and contacts are always individuals, not 
companies  

• Parent: Child relationships can be set up for customer, partners, and vendors 
 

Transaction Table Types 
 
Transactions involve the movement of money or adjustment of values: 

• Bank: tasks conducted with your bank and recorded in NetSuite 
o For example: Make Deposits, Transfer Funds 

• Purchases / Vendors: Purchasing from vendors, recording bills from vendors 

• Sales: transactions with your customers 
o Includes such activities as Opportunities, Orders, and Accepting 

Payments 

• Employees: includes expense reporting, time tracking, and payroll activities 

• Inventory: includes inventory management and adjustments 
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Customer Relationship Management Table Types 
 
Used to help us better how we conduct Customer Relationship Management (CRM): 

• Activities: using tasks, phone calls, and events to communicate 

• Project Tasks: part of Advanced Projects and include defining tasks, resources, 
and gannt charts 

• Cases: working with support and IT (Help Desk cases) 

• Solutions: part of issue management 

• Campaigns: marketing 
 

Item Table Types 
 
What we reflect on sales and purchase order forms: 

• Discounts 

• Other Charges 

• Inventory items 
o Impact the balance sheet 

• Non-inventory items 
o Do not have a balance sheet impact 

• Service items 
 

Activity: Complete the Table 
 
Can you think of examples for each type of record? 
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Customization 
 
Use customization to capture what you need: 

• Modify standard NetSuite records or create new custom records 

• Go to the Customization menu, review your options 

• Use Case 1: Capture specific information on a customer record by adding new 
entity fields 

o Customization > Lists, Records, & Field > Entity Fields > New 

• Use Case 2: Create new record type to capture course evaluations 
o Customization > Lists, Records, & Field > Record Types > New 

 

Access Records with Forms 
 
Consider the creation of different form versions for different user roles. Each form can 

be assigned to a specific role: 

• Sales Role can see some subtabs on a customer record: 
o General, Qualification, Sales, Marketing, Address information 

• Operations can see additional subtabs on a customer record 
o All the above subtabs 
o Can also view Financial, Access, Workflow 
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Database Relationships 
 
Within a database, four core methods for relating data together exists.   

 

  
One : Many 

• Send One marketing 
newsletter to many customers 

• Create One invoice with 
Many items 

 

 

  
Many : One 

• Many people are attending 
One event 

• Many students fill out 
evaluations for One course 
 

 

  
One : One 

• One item has One serial 
number 

 

  
Many : Many 

• Many contacts can be 
associated with Many 
companies 
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Relationships between Records 
 
Transactions and CRM records are associated to Entities: 

• Transactions roll up to a related entity record. 
o E.g. sales orders and campaigns are associated with a customer 

 
Associate Items to Entities and Transactions 

• Tie item records to entities to track purchase history of a customer, then you can 
offer promotions based upon their purchases 

• Associate an item with a sales order 
 

 
 
Note: It is important for you to understand how records are related so that you can 

organize data to fit within the NetSuite database. Likewise understanding the record’s 

relationships is critical for retrieving customer data when generating reports and 

searches. 
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One-to-one (1:1) and One-to-Many (1:M) relationships can exist between records 

• Each sales order references a single Customer therefore (1:1) 

• Each Sales Order may have many items thus (1:M) 

• Each customer may have many sales orders (1:M) 
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Subsidiary Relationships with Entities and Items 
 
One World allows tying subsidiaries to entities and items: 

• An Entity can be associated with multiple subsidiaries 

• Enable Multi Subsidiary Customer feature 

• Turn off Non-compatible other features 
o Accounting subtab, Advanced Features: Consolidated payments and 

Intercompany Time & Expenses 
o Transactions subtab, Billing section:  Bill Costs To Customers, 

Advanced Billing, Charge-Based Billing, and Billing Operations. 
 

 
 

• An Item can be associated with multiple subsidiaries 
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OneWorld: Subsidiary Relationship with Transaction and Item 
 

Transactions and Items are associated with an Entity. Data displayed, on the 

Transaction and Items records, is restricted by the Subsidiary associated with the Entity 

record. 

• Transactions inherit their subsidiary from the selected entity (customer or vendor) 

• Only items associated with the transaction’s subsidiary will be available on that 
transaction 

• Other records (items, departments, locations) referenced on transaction are 
limited by values associated with that subsidiary 
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OneWorld: Subsidiary Association 
 

Entities from one subsidiary may be linked to an entity associated with a different 

subsidiary: 

• Contacts associated with one subsidiary can be linked to customer, partner or 
vendor records associated with another subsidiary 

o Contacts may be associated with more than one subsidiary, because 
transactions are never entered against the contact 

o Subsidiary is a mandatory field on the Contact Record 
▪ Contacts are not restricted to the subsidiary; rather the contact is 

associated with the subsidiary. When you associate a contact with 
an entity, it does not inherit the characteristics of the entity 

• Sub-Customers associated with one subsidiary can be linked to parent 
customers associated with another subsidiary, only if “Accept Payments at Top 
Level” is disabled  

Sub-Customers and customers can have different base currencies when 
“Accept Payments at Top Level” is disabled 
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Data Segmentation  
 

Organize data to extract and view Business intelligence through alternative lenses, 

different perspectives and insight: 

• Data segmentation groups information in different ways: 
o Entities (Customer, Vendor, Employee, Contacts and Partners) 

▪ Type 
▪ Statuses 
▪ Categories 
▪ Classifications (can act to restrict Employee access) 
▪ Demographic Elements (City, DoB, Size) 

o Transaction 
▪ Statuses 
▪ Classifications: 

• Departments, Classes, & Locations 
 

Classifications 

Measure your business with classifications to track records such as: financial, 

transactions and employees 

• Departments: Designate transactions’ owner and resources as part of internal 
team 

• Locations: Are interrelated with Classes and Departments, and are best applied 
to places of the business whether virtual or real. 

• Classes: For wider categorization within your business (Business Unit) 

• For example: A cleaning company may want to track income and expenses 
separately for household and a commercial customer.  

• Setup classes for each of these account types providing the ability to track the 
financial performance over any given period.  

• The same cleaning company may want to track income and expenses for 
different departments including; operations, sales & administration.   

 

Use Classifications to restrict access to system information 

• The impact of classifications (departments and classes) on permissions/role and 
users’ ability to see/do is dependent upon the restrictions set within their roles. 

 
OneWorld Impact 

• Departments, Classes and Locations can be restricted to a subsidiary 

• Departments and Classes can go across subsidiaries, but locations are a 1:1 
relationship and can only be associated with one subsidiary 
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Walkthrough: Creating a Record 
 

 

Use Case/Scenario: The administrator is going to enter in a test customer record to 
examine how information is entered in the NetSuite account. 
 

Create a Customer 
 

Go to Lists > Relationships > Customers > New: 

• Complete required and optional fields in the different field groupings, such as: 
o Primary Information 
o Email | Phone | Address 
o Classification 

• Continue entering information on subtabs such as: Subsidiaries, Relationships, 
Communication, Address … 

• If you want to record contacts for the customer: 
o Save the customer record first and then add the contact 

▪ Populates the contact record with email, phone, address and other 
information and can be edited 

• If you need to update the saved contact’s role, go to the customer record and 
relationship subtab: 

o Click Update Primary Contact button, then Edit in the pop-up window 
o Change the contact’s role and click Save  

 

Now It’s Your Turn 

 

Use Case/Scenario: Become familiar with record entry 

▪ Enter new entity records, Customer and Vendor 

▪ Add a new employee  

▪ Allow 30 - 40 minutes 
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Independent Study Exercises 

Exercise 01: Create Customer Record and Enter Contact 
 

Time: 5 minutes 

Scenario: The Chatham Company will import most of its existing customers using the Import Assistant. 

We can also enter data for new entity records manually. In this exercise: 

 Enable or Confirm the Multi-Subsidiary Customer feature and disable incompatible features 

 Create a new customer record with related contacts 

 Enter US phone numbers; allow formatting to be applied 

 Go to Setup > Company > Enable Features 

a. Company subtab, ERP section:  Confirm or select Multi Subsidiary Customer per the 

BRD Chatham company wants to use this to create customers across subsidiaries.  

o Disable any incompatible features 

▪ Accounting subtab, Advanced Features: Consolidated payments and 

Intercompany Time & Expenses 

▪ Transactions subtab, Billing section:  Bill Costs To Customers, Advanced Billing, 

Charge-Based Billing, and Billing Operations. 

o Save. 

 Navigate to Lists > Relationships > Customers > New.  The Customer Form should be displayed. 

 Enter the following details for the new customer record: 

a. Company Name: TEST ABC 

b. Email: abc@TEST ABC.com  

c. Phone: 6506271000 

d. Fax: 6506271001 

e. Primary Subsidiary: Parent Company 

f. Note: The Status defaults to CUSTOMER–Closed Won. Leave this default value.  

 On the Subsidiaries subtab, in the subsidiary column field, review the available subsidiaries 

a. Select Germany 

b. Click Add. 

 Click the Address subtab, go to the far-right column, find the Edit pencil; click to open a pop-up 

window. 

mailto:abc@mytestcompany.com
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 Enter /Confirm the following information, in the pop-up window: 

a. Country: United States 

b. Address 1: 2955 Campus Drive 

c. Address 2: Suite 100 

d. Zip: 94403  

e. Click the tab key, on your keyboard, to see City (San Mateo) and State (California) 

populate. 

f. Click OK to close the pop-up window. 

g. Click the Add button, to record the address entered. 

 Go to the Financial subtab; in the Account Information section confirm that the Primary 

Currency has defaulted to US Dollar.  If necessary, select it from the dropdown list. 

 Go to the Currencies sublist, Currency column field, and select Euro (this is for the Germany 

subsidiary). 

 Click Save and note the “Confirmation: Customer successfully Saved” message at the top of the 

page. 

 

 On the TEST ABC customer page, scroll down and click the Relationships subtab 

 On the Contacts sublist, click the New Contact button to open a pop-up Contact window. 

 Enter the following information to add the contact with the same address and phone number as 

the customer record. 

a. Contact: this field will populate with information entered in to the Name fields 

b. Role: Decision Maker 

c. Name: Amy Andrews 

d. Job Title: CEO 

e. Email: amy@testabc.com 

 Click Save to save the contact information.  

 On the Relationship subtab, Contacts sublist, go to the line for Amy Andrews and see that she is 

listed as the Decision Maker. 

mailto:amy@testabc.com
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 Click on the name to open the contact pop-up window. Notice that the contact is attached to 

the customer record. Close the pop up window by clicking on the X.  

 End. 
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Exercise 02: Create Customer Record and Enter Contact OneWorld  
Time: 5 minutes 

Scenario: In this exercise, for OneWorld accounts: 

 Create new customer records with related contacts in a subsidiary. 

 TIP: Go to NetSuite and refer to the Best Practice “OneWorld Intercompany Order 

Processing” for more information on setting up customers in a OneWorld Account. 

 Navigate to Lists > Relationships > Customers > New.  The Standard Customer Form should be 

displayed. 

 Enter the following details for the new customer record: 

a. Company Name: TEST German Customer 

b. Email: 123@TestGermanCust.com 

c. Phone: 49-69-696-0 (This is an international number; our defined phone number 

formatting will not work for international numbers) 

d. Primary Subsidiary: Germany 

e. Note: The Status defaults to CUSTOMER–Closed Won. Leave this default value.  

 On the Subsidiaries subtab, in the subsidiary column field, review the available subsidiaries 

a. On a new line, select Italy 

b. Click Add. 

 Click the Address subtab, go to the Edit pencil and click to open a pop-up window 

 Enter the following information, in the pop-up window: 

a. Address 1: Bergen Strasse 123 

b. City: Frankfurt 

c. Zip: D-65046  

 Click OK to close the pop-up window. 

 Click the Add button. 

 Click Save and note the “Confirmation: Customer successfully Saved” message. 

 Scroll down and click the Relationships subtab. 

 On the Contacts sublist, click the New Contact button to open a pop-up Contact window. 
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 Enter the following information to add the contact with the same address and phone number as 

the customer record. 

a. Contact: this field will populate with information entered the Name fields 

b. Role Decision Maker 

c. Name: Dieter Hoch 

d. Job Title: CEO 

e. Email: hoch@TestGermanCust.com 

 Click Save to save the contact information. 

 Notice on the under Relationships subtab, Contacts sublist, Deiter Hoch is listed as the Decision 

Maker with his other information. 

 End. 
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Exercise 03: Create a Vendor Record and Enter Contact 
Time: 5 minutes 

Scenario: In this exercise: 

 Create a new vendor record with a related contact.  This is the vendor that Chatham will be 

buying goods and services from and the primary subsidiary will be the Parent Company. 

 Navigate to Lists > Relationships > Vendors > New.  

 Enter the vendor’s information: 

a. Company Name: TEST Widget Works 

b. Email: info@testwidgetworks.com 

c. Phone: 6503065555 

d. Primary Subsidiary: Parent company 

i. Note: NetSuite allows a vendor to be associated with more than one 

subsidiary.  We will look at this in a later module. 

 Click the Address subtab, go to the Edit pencil and click to open a pop-up window 

 Enter the following information, in the pop-up window: 

a. Address 1: 20 Kelly Avenue 

b. Zip: 94019 

c. Click the tab key on your keyboard; City (Half Moon Bay) and State/Province (California) 

fields are automatically populated when the Zip Code is entered; for USA only  

 Click OK to close the pop-up window. 

 Click the Add button. 

 Click Save and note the “Confirmation: Vendor successfully Saved” message. 

 Scroll down and click the Relationships subtab. 

 On the Contacts sublist, click the New Contact button to open a pop-up Contact window. 

 Enter the following information to add the contact with the same address and phone number as 

the customer record: 

a. Contact: this field will populate with information entered in the Name fields 

b. Role: Primary Contact 

c. Name: John Brown TEST 

mailto:info@testwidgetworks.com
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d. Job Title: Account Manager 

e. Change the email from info@testwidgetworks.com  to jbrown@testwidgetworks.com  

 Click Save to save the contact information. 

 Notice on the Relationships subtab, Contacts sublist, John Brown TEST is listed as the Primary 

Contact with his other information. 

 Click Home. 

 End. 

 

  

mailto:info@testwidgetworks.com
mailto:jbrown@testwidgetworks.com
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Exercise 04: Create a Vendor and Enter Contact OneWorld 
Time: 5 minutes 

Scenario: In this exercise, for your OneWorld account 

 Create a German Vendor that Chatham can purchase from when doing business in their 

German subsidiary. 

 If still viewing TEST Widget Works, Select New from the Actions dropdown list.  Or, navigate to 

Lists > Relationships > Vendors > New.  

 Enter the Vendor’s information: 

a. Company Name: Test German Vendor 

b. Primary Subsidiary: Germany 

c. Note: NetSuite allows a vendor to be associated with more than one subsidiary.  We will 

look at this in a later module. 

 Click the Address subtab, go to the Edit pencil and click to open a pop-up window 

 Enter the following information, in the pop-up window: 

a. Address 1: Heidermanstrasse 164 

b. City: Munchen 

c. Zip: D-80939 

 Click OK to close the pop-up window. 

 Click the Add button. 

 Click Save and note the “Confirmation: Vendor successfully Saved” message. 

 Scroll down and click the Relationships subtab. 

 On the Contacts sublist, click the New Contact button to open a pop-up Contact window. 

 Enter the following information to add the contact with the same address and phone number as 

the customer record. 

a. Contact: this field will populate with information entered the Name fields 

b. Role Primary Contact 

c. Name: Mark Schwarz TEST 

d. Job Title: Account Manager 

 Click Save to save the contact information. 
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 Notice on the under Relationships subtab, Contacts sublist, Mark Schwarz TEST is listed as the 

Primary Contact with his other information. 

 End. 
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Exercise 05: Enter New Employees 
Time: 5 minutes 

Scenario: To better understand how records are stored, you are going to investigate the employee 

record. 

In this exercise: 

 Enter two (2) new employees, Amy and Bob 

 They will be early testers of the NetSuite Account during the implementation project 

 Navigate to Lists > Employees > Employees > New.  

 Enter the employee Name: Amy Nguyen. 

 Enter Support & Sales Rep as the Job Title. 

 In the Classification section choose Parent Company under Subsidiary. 

 Go to the Human Resources subtab. In the Job Information section, click the Sales Rep 

checkbox. 

 (In a later module, Customer Support and Service feature will be enabled, allowing the display 

of a Support Rep field is available on the Human Resources subtab) 

 Click the Save and New button to save the employee record and add a second employee. 

 Repeat steps 2 to 4 and add Bob Smith as an employee. Make him a Sales Rep. Enter Sales Rep 

as the Job Title. Choose Parent Company under Subsidiary. 

 On the Human Resources subtab, click the Sales Rep checkbox.  

 Click Save. 

 Navigate to Lists > Employees > Employees. 

 Confirm that both Amy Nguyen and Bob Smith are in listed.  If not, enter in the missing 

employee. 

 Note: Cathy Cadigan was set up at the time the account was provisioned.  If the display of her 

name as Cathy Cadigan Cathy Cadigan, this is due to the original naming configuration when the 

account was set up. 

 End. 
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NetSuite Help Center: 

• Account Setup: Using Departments, Classes, and Locations 

• NetSuite Basics: Working with Records 
 

SuiteAnswers Learning Center:  

• New Feature Training 

• Items/Fulfillment/Billing 
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NetSuite Roles and Permissions 

 

About this Module 
 

Roles are the foundation for data security in your NetSuite account: 

• Roles are defined by permissions and restrictions 

• Permissions define a user’s access to data and govern the user’s authority to 
work with that data 

• Understanding the function of Roles and Permissions is important as you set up 
users in the account  
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Roles Overview 
 
A set of Standard Roles is provisioned in your NetSuite account: 

• Note: NetSuite recommends creating and assigning custom roles, which we will 
cover in a later module 

 

A User is anybody with access to your NetSuite Account: employee, customer, partner, 
or vendor 
A role is a configured access that is assigned to users, and defined by: 

• A set of permissions 

• A level that is set for each granted permission 

• Restrictions that modify permissions  
 

Implementation Considerations 
 

The following are some questions that you may need to consider: 

• What Roles are needed in your company? 

• How many users per Role? 

• Who will manage these Roles? 

• What are the high-level functions/Permissions the Roles will need? 

• What are sensitive areas of information that need to have limited access? 

• What do I NOT want these Roles to see/access? 

• Are there issues with Sales Reps seeing or having access to other Reps’ 
customers? 

• What standard NetSuite Role can I start from? 
 

Defining Permission Levels for the User 
 
A set of permissions is provided in your NetSuite Account: 

• Governs and defines a user’s access and view of your account data 

 
 

Each granted permission is assigned an access level 

A permission can be removed to disallow access 
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Security Layers on a Role 
 

T Security layers are applied to a role and govern interaction with data, for example:  

Sales person / rep type of role and that role will work with sales orders  

 

• Permission to Edit Sales Order = Edit sales orders (from anyone) 

 
• Restrict to only edit OWN order - this modifies the permission 

o Edit own sales orders, or those belonging to my department, location 

 
• Open fields for assignment/ viewing, e.g. assign any rep to an order 

• Assign a Custom form to control the view; assign to the role 
 

Centers Overview 

 

Role–specific centers determine the set of tabbed pages that displays, to optimize 

navigation for the role: 

• A list of the standard Centers is available in Help. 

• Administrator defaults to Classic Interface: 
o Includes Transactions and Lists between Activities and Reports 

• The following centers are examples of different menus displayed between 
Activities and Reports 

o Accounting Center for accounting and finance staff: Customers, 
Vendors, Payroll and HR, Financial 

o Shipping Center for warehouse staff:  Shipping, Receiving, Inventory 
o Sales Center for sales staff:  Leads, Opportunities, Customers, Forecast 

• Roles, other than the Administrator, can switch to the Classic Interface: 
o Home > Set Preferences > Appearance > Use Classic Interface 
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Center | Role Relationship | Navigation 
 

The Navigation paths control access to data and relates to tasks for a role; this is a 

portion of a list, in Help, of NetSuite standard centers and their supported roles.  

 

• Administrator role navigation for customer or inventory tasks: 
o For example: Transactions > Sales > Enter Sales Orders 
o For example: Transaction > Inventory > Adjust Inventory 

• Sales Role has tasks associated with working with customers: 
o For example:  Customers > Transactions > Sales Orders > New 
o Warehouse Role has tasks associated with shipping and inventory: For 

example: Inventory > Inventory > Adjust Inventory 
 
Here are pages common to all centers: 

 
▪ Home  
▪ Activities  
▪ Documents  
▪ Setup 

 

Switching Between Multiple Roles 
 

Employees can use different roles to do their work: 

• Hover over your login profile, top-right side of the page, to view assigned roles 

• If necessary, click on View All Roles 

• Click the role to select from the assigned roles list 
 

Set a different color scheme for each of your assigned roles under 
Home > Set Preferences > Appearance 
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Standard and Specialty Roles 
 
Standard Roles are typical company positions with predefined Permissions: 

• Accountant 

• Warehouse Manager 

• Sales Rep, and so on 

• Review the Standard Roles Permission Table in Help 
 

NetSuite recommends that Standard roles should 
always be customized to meet your company’s specific needs. 

Again, review the Standard Roles Permission Table in Help. 
 
Other types of roles are available, review Help for more information: 

• Specialty Roles: Customer Center, Vendor Center, Partner Center 

• Discounted Roles: Employee Center, Advanced Partner Center 
 

Activity: True or False 

 
 

Walkthrough: Review Standard Roles and Compare 

 
 
Use Case/Scenario:  Prepare to work with roles: 

• Look at the standard list of roles, and associated centers, provided in the 
NetSuite account 

• Discuss the Administrator Role 

• Identify difference between roles  
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Access Standard Roles 

 
• Go to Setup > Users/Roles > Manage Roles 

• List may be sorted, for example sort on Name or Center Type 

• This is the starting point for creating custom roles 
 

Administrator Role 
 

Your NetSuite account is provisioned with an Administrator Role: 

• The Administrator role is a global role that applies to the entire NetSuite account 
and cannot be customized 

o  This may designate the primary administrator for your company 

• This is a Full Access Role; the role has ALL permissions at ALL levels 

• Administrators, and users with Full Access roles, must use two-factor 
authentication in newly-provisioned accounts 

• The Administrator role does not show up in access reports, list of roles for 
reporting, nor a list of roles and permission assignments 

• The role cannot be customized: 
o Navigate to Setup > Users/Roles > Manage Roles and note that 

Administrator/Full access role is not listed 
o As an alternate solution, you can customize the System Administrator role; 

the access levels per permission are all set to Full, Edit or View 

• Assign a backup administrator with the Administrator role: 
o If your administrator leaves and you do not have a backup, you must 

contact support  

• Administrator versus System Administrator, what is the difference? 
o The administrator has complete control over the account, including being 

able to delete all data and close account 
o The System Administrator has fewer permissions than the Administrator 

and cannot use delete 
 

  



 

151 

 

Show Role Differences: 
 
Go to Setup > Users/Roles > Show Role Differences 
Ability to view and compare differences in Permissions between Roles: 

• Define the Base and Compare to roles, and check Only Show Differences 

 
• The Role Permission Differences page displays; permissions are listed by 

category (Lists, Reports, Transactions, Setup) 
o Review assigned permissions and level of permissions 
o This list may be exported out of NetSuite 

 

Walkthrough: Create Custom Role 
 

 
 
Use Case/Scenario:  Sales management has asked that a custom sales role be 
created:  

• Create a custom sales person role, based on a standard role in NetSuite, paring 
down some permissions 

• Define the Customer form for Sales, custom form, as the preferred form for this 
role 

• This custom role can be assigned to new and existing sales people 
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Select a Standard Role: 
 
Go to Setup > Users/Roles > Manage Roles 

 

NetSuite recommends not using Standard Roles for your users: 

• May require frequent changes for your user 

• Does NOT meet the best practice of granting the least number of permissions, 
for any given user to do their job, and could jeopardize account security 

 

Select the role that will be the basis for your custom role: 

• Go to Setup > Users/Roles > Manage Roles 

• The Manage Roles page displays and may be sorted on any of the columns, e.g. 
the Name column 

• Click the Customize link for the Standard Role you are interested in using, e.g. 
Sales Person  

  



 

153 

 

Customize a Role 
 

Select the appropriate standard role and customize the Custom Role page displays:  

• Rename the role using your company prefix, e.g. ABC: Sales Person 
 

 
 

• Review General and Authentication sections 
o Review Employee Restrictions and define 
o Open fields for viewing and assigning 
o Review optional Authentication fields and Field Help 

• Assign Permissions (Layer 1) 
o Which records can the role see and with what level of access (None – 

remove the element, View, Create, Edit, Full) 

 

• Review Employee Restrictions (Layer 2) 
o These controls are applied over level 1 
o Includes departments, class, location and subsidiaries. 
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o Set it to either “none - default to own”, “own, subordinate, and unassigned” 
or “own and subordinates only” and then you can check the box the “Allow 
Viewing” box. 

• Permission Open Field check boxes:  
o These determine restrictions, such as do not restrict record viewing and 

do not restrict list of values. 

• Forms: assign various forms to the role 
o Tailor the level of access you want to give to users 
o Control the entry and transaction forms they use to enter data. 

• Restrictions: Set department, class and location restrictions; new record name 
will display, e.g. Warehouse if renamed. 

• Administrator can also set preferences by role. The preferences set for a role 
serve as the defaults for any users who log in with that role. 

• Support of translation of custom role names, in accounts where the Multi-
Language feature is enabled, is available. 
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Customize Role: Other Subtabs 
 
Spend some time getting familiar with the other subtabs on a role: 

• Searches: set default searches to be used by users with this role 

• Preferences:  Administrators can set preferences to the needs of a role; 
preferences are also available under User Preferences 

o The following chart compares the different preference levels 
(This is available in Help) 

 

• Dashboard: select a published dashboard to assign to all users with this role 

• Translation: works with the multi-language feature; translate custom role names 

 

Walkthrough: Assign a Role and Global Permissions 
 

 
Use Case/Scenario:  NetSuite recommends using custom roles, which are created by 
selecting a standard role and then customize it.  
 

Assign a Role to an Employee 
 
Edit the Employee Records: 

• Navigate to Lists > Employees > Employees and select Edit for the employee  

• Go to the Access subtab, Roles sublist 

• Select each Role and Add 
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Global Permissions Overview 
 
Administrator assigns employees’ permissions that apply to all their assigned roles: 

• User must have one or more roles assigned – Access subtab, Roles sublist 

• These can be useful for temporary or unique permissions, but use with caution. 
 
Useful to handle exceptions; e.g., cover daily responsibilities when person is on leave. 

• They are employee specific permissions and override the role permissions.  
o E.g.: An AP clerk role can print checks. You hire a temporary AP 

assistant, but you want the assistant only to be able to view checks. This 
is when you use global permissions to assign temporary permissions. 

o OneWorld: An AP clerk works in different subsidiaries; a different role for 
each subsidiary. Due to some nuance in the roles or the subsidiary, you 
would use global permissions to execute those differences.  

 

Enable Global Permissions 
 
Setup > Company > Enable Features > Employees subtab, Permissions section: 

• Select Global Permissions 

 

• Review field help for Advanced Employee Permissions and refer to the Help 
Topic: Advanced Employee Permissions: 

o This gives administrators more flexibility and control over what employee 
information certain roles can access in NetSuite 

Define Global Permissions on an Employee Record 
 
Edit an Employee record; go to the Access subtab, Global Permissions sublist: 

▪ Go to the Access subtab, Global Permissions sublist 
▪ Add Permissions and define the Level 

▪ Overrides role permission levels 
▪ There are no defined Layer 2, 3, 4 control levels 
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Walkthrough: Additional Administrator Tasks 

 
Use Case/Scenario: Administrators need to complete additional tasks after working 
with roles: 

• Test any custom role 

• Use some tips and tricks  
 

Test Custom Role 
Sign on as the Administrator: 

• Go to the function and copy the URL from the function 
o For Example: Transactions > Sales > Enter Sales Order 

 
Change Role to the custom role that is being tested: 

• Paste the same URL in your browser; review the error message 
 

 
 

Administrator Tips 
 
Administrators can better serve their users: 

• Assign each role, being used, to yourself: 
o Test the role 
o View NetSuite in the user’s view 

• When assisting a user, direct them to the classic interface: 
o This is a familiar view to the administrator 
o User navigates to Home > Set Preferences > Appearance 

• Ensure that any role that needs to see Customer or Vendor transactional 
information has the following Permission enabled: 

o Edit the role 
o Go to the Permissions subtab and the Lists sublist 
o Add the Financial History permission to view; allows viewing transactions 

related to the entity 
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Walkthrough: Add an Employee 
 

 
Use Case/Scenario:  All employees need to be entered in the NetSuite account and 
their access must be controlled and defined.  
 

Enter a New Employee 
 
Navigate to a form to enter in a new employee record: 

• Go to Lists > Employees > Employees > New 

 
• Complete required and optional fields in the different field groupings, such as: 

o Primary Information 
o Email | Phone | Address 
o Classification  
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Define Access 
Navigate to the Access subtab: 

 

• Click Give Access when you are ready to have this user login 

• Either select Send Notification Email or select Manually Assign or Change 
Password 
 

• Provide the Password and Confirm Password; review the Password Criteria 

• Select Password Change on Nest Login 

• Add each required Role 
o An employee may have multiple roles; this does not affect your license 

count 
 

OneWorld: Employees, Roles and Subsidiaries 
 
All employees/ users have roles: 

• By default, standard roles have no subsidiaries attached to them 
o Defining the subsidiary (subsidiaries) is optional and if used then the users 

can only see data in subsidiaries associated with the role 
 
Assigning an employee to a subsidiary does the following: 

• Determines the currency of their direct transactions (i.e. Commissions, expense 
reports, salary)  

• Restricts the Employee to accessing data only associated with this subsidiary 

• If the assigned role (s) do not have subsidiary restrictions, NetSuite reverts to 
employee record to determine their subsidiary restrictions 
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OneWorld: Employee Access to Multiple Subsidiaries 
 

All employees/ users have roles.  By default, standard roles have no subsidiaries 

attached to them.  Defining the subsidiary (subsidiaries) is optional and if used then the 

users can only see data in subsidiaries associated with the role 

Assigning an employee to a subsidiary does the following: 

• Determines the currency of their direct transactions (i.e. Commissions, expense 
reports, salary)  

• Restricts the Employee to accessing data only associated with this subsidiary 

• If the assigned role (s) do not have subsidiary restrictions, NetSuite reverts to 
employee record to determine their subsidiary restrictions 

 
To give an employee access to multiple subsidiaries: 

• Configure a role and associate it to multiple subsidiaries 

• Grant this role to the employee (gives the employee access to the multiple 
subsidiaries) 

• Level of access is restricted by Permissions and level of access associated with 
that Role 
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Walkthrough: Login Audits 
 

 
Use Case/Scenario:  The administrator can audit all user activity in the account.  
Individual users can audit their login activity.  
 

Login Audit Trail 
 
View Login Audit Trail provides a specialized search tracking user activity in the 
account; information is pulled from system notes: 

• Go to Setup > Users/Roles > View Login Audit Trail and define search criteria 

 
• View the Login Audit Trail Search: Results  

o Drill into results 
o Export results 
o Note: If you receive no results, this indicates that the user was logged into 

NetSuite, but did not “create” nor “edit” any records 

• Results: view the success of each login attempt and Security Challenge column 
 

Security Challenge 
 

 
The Login Audit Trail Search: Results displays a column for Security Challenge: 

Security Challenge: an instance when a user is prompted to answer a security 
question in order to login and is triggered by any of the following: 

• User attempts to use a new browser or computer 

• User forgets their NetSuite password 

• Or, if it has been more than 90 days since the user’s last login 

• If this column does not display either Success or Failure for a row, it means no 
security challenge occurred for that login  

• Assists administrators in detecting hacking attempts, which can be evidenced by 
a high number of failures in a short period 

• Possible outcomes: Correct login = Success; 6 consecutive wrong logins = 
Failure 
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My Login Audit Portlet  
 
Personalize the Home Dashboard; add My Login Audit portlet to monitor the usage and 

security of your login: 

 

• Setup the portlet to meet your needs; review each subtab 
and associated settings: 
o Last Login 
o Successful Logins 
o Login Failures 
o Password Updates 
o Mobile Devices 
o Web Services 

 
Best Practices: 

 

• Do not assign Standard Roles to users; they almost never meet the “least 
privileges” standard, for a given function 

• Use NetSuite Roles as templates to copy; rename Custom Roles with your 
company’s prefix  

• Always weigh and evaluate reasons for assigning a user multiple roles or 
providing a single custom role: 

o It may be easier for the user to only have one role 

• Design and test new and custom roles before assigning to users: 
o Verify the user/role has all Permissions and access to necessary data 

from beginning-to-end of a process 

• Assign new and custom roles before a new user starts accessing the account: 
o Do not rename a former employee to a new employee;  
o The new employee would inherit all records of former employee 

• When an employee leaves immediately remove their access to NetSuite: 
o Mark them inactive, also you can remove roles and global permissions 
o Why is this so important? 

 

Now It’s Your Turn 
 

 

Use Case/Scenario: 
• Learn to work with custom roles 

• Add a user 

• Audit activity  

• Allow 30 – 45 minutes 
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Independent Study Exercises 

Exercise 01: Rename Roles with Your Company’s Prefix 
Time: 3-5 minutes 

Scenario: As a best practice, rename all the standard roles with your company’s prefix.  Use these 

renamed roles to provide the roles you need for your organization, protecting the standard template 

roles provided by NetSuite. 

In this exercise: 

 Rename roles with the CC prefix  

 Navigate to Setup > Users/Roles > Manage Roles. 

 Click Customize next to the Employee Center role. 

 In the Name Field enter CC: Employee Center. 

 Click Save. 

 Click Customize next to the Sales Manager role.  

 In the Name Field enter CC: Sales Manager 

 Click Save 

 On the list of roles, sort on role names; your custom roles should be grouped together 

 If you are not on the list of roles, then navigate to Setup > Users/Roles > Manage Roles. 

 How are these roles identified on the list of roles? 

a. Answer: 

 Do the original, NetSuite Standard roles still exist? 

a. Answer: 

 How can you identify a NetSuite Standard role? 

a. Answer: 

 End. 
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Exercise 02: Customize the Sales Manager Role 
Time: 5-10 minutes 

Scenario: Your Company has some specific requirements for your Sales Manager.  

In this exercise: 

 Edit the CC: Sales Manager role to meet the Company’s requirements. 

 Add and assign this role to yourself – Cathy Cadigan (Administrator) 

 Sign in with this role and test that the modified (CC: Sales Manager) role has the correct 

permissions associated with it.  

Examine the default values associated with the CC: Sales Manager Role 

• We start from the standard sales manager role and pare it down to meet your company’s 

requirements.  

• As we are looking at the few examples that follow please use this thought process to apply to 

all areas of the roles’ responsibilities. 

 Navigate to Setup > Users/Roles > Manage Roles. 

 Click the Edit link next to the CC: Sales Manager role.  

 Do you want your Sales Manager to just see his, his subordinates and unassigned transactions?  

a. If so, choose “own, subordinate and unassigned” on the dropdown list next to Employee 

Restrictions. 

 Do you want to allow other users to view records assigned to others but not edit them?  

a. If so, check the box next to “Allow Viewing.” 

 Navigate to the Permissions subtab and then the Transactions sublist; some of the questions 

you need to ask for this role: 

 Does your Sales Manager need to approve Sales Orders, but not delete sales orders? If so, under 

the Permissions subtab, Transactions sublist, click on the Sales Order Approval record, select 

Edit from the Level dropdown list. 

  Click OK. 

 Does your Sales Manager need to see Purchase Orders? If yes, under Permissions subtab, 

Transactions sublist; from the Permissions dropdown list select Purchase Order and set the 

Level to View. 

 Click Add. 
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 Does your Sales Manager need to access Customer Payments? If so, what level? Permissions 

subtab, Transactions sublist, from the Permissions dropdown list select Customer Payment and 

set the Level to View. 

 Click Add. 

 Does your Sales Manager need to access Credit Memos? If yes, Permissions subtab, 

Transactions sublist, add the Credit Memo Permission and set the Level to View. 

 Click Add. 

 Does your Sales Manager need to be able to export lists from NetSuite (i.e. customer list)? If not, 

Permissions subtab, Lists sublist, select the Export Lists record, and then click Remove button. 

 Click OK. (Note: this list is in alphabetical order, the “export lists” permission is midway in the 

list.) 

 Does the Sales Manager need to see the Financial Reports? If not, Permissions subtab, Reports 

sublist and make sure that Financial Statements is not there, if it is remove it! 

 Does the Sales Manager need to see the Financial History? If yes, Permissions subtab, Lists 

sublist and add Financial History permission with View level. 

 Click Add. 

 Click Save. 

Test the Role 

 Add this role to your Login or whichever login name is at top-right of page; go to Lists > 

Employees > Employees 

 Pick the person you are logged in as, named at the top-right of the page (e.g. Cathy Cadigan, Ed 

Baumann) 

a. Click Edit and navigate to the Access subtab. 

b. Go a blank line and from the Roles dropdown list select CC: Sales Manager Role from 

the list. 

c. Click on Add. You should have both the Administrator and CC: Sales Manager Role. 

 Click Save 

Change Roles 

 Go to top-right hand side of your page and switch roles to the CC: Sales Manager. 

a. *Note: If Change Role does not display in the upper-right hand corner of your page, 

please log out of NetSuite and log back in. 
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b. Select Administrator as the Default Role, on the View All Roles page and then click on 

CC: Sales Manager role to enter as the CC: Sales Manager. 

 

 If prompted, use the Set Up Security Questions pop-up window displays: 

a. Select three security questions of your choice 

b. Uncheck Hide Answers 

c. As your Answer, enter the last word of each question; for example: 

i. Question: What was your childhood nickname 

ii. Answer: nickname 

 Click Save and click Close in the Security Questions Complete pop-up window 

 Test that you can see all items you gave permissions for and test that you can’t see financial 

reports. 

 Is there a Setup tab? What are some of the menu listings under this role’s setup tab? 

a. Answer:  

b. Why? 

 End. 
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Exercise 03: Show Role Differences 
Time: 3-5 minutes 

Scenario: To familiarize yourself with roles, compare permissions between two roles: 1) Sales Manager 

and 2) Sales Rep 

 Change back to Administrator role, if necessary. 

 Navigate to Setup > Users/Roles > Show Role Differences 

 Ensure that the Only Show Differences box is checked, top right-hand side of the page.  

 Click in the Base Role field.  

 From the Base Role dropdown list, select the Sales Manager role. 

 In the Compare To field, from the Compare To dropdown list, select any other Sales role in the 

account. 

 Click the Show button. 

 What are the differences between these roles? Just make note of some of the differences in 

Lists, Reports, Transactions, and Setup 

 End. 
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Exercise 04: Customize a Sales Administrator Role OneWorld 
Time: 3-5 minutes 

Scenario: The Chatham Company’s Sales Administrator will work in multiple subsidiaries.  In this 

exercise: 

 Create and work with a customized Sales Administrator role to assign to employees in 

different subsidiaries 

 Navigate to Setup > Users/Roles > Manage Roles. 

 Click Customize next to the Sales Administrator role. 

 In the Name field enter CC: Sales Administrator. 

 Click Save. 

a. Note: We did not choose a subsidiary when we customized this role. 

Assign employee record to a subsidiary 

 Now Add the role to your Login (or whichever login name is at the top-right of page) and assign 

your employee record to the Germany subsidiary. 

 Lists > Employees > Employees 

 Pick the person you are logged in as, named at the top-right of the page (e.g. Cathy Cadigan, Ed 

Baumann). 

a. Click the Edit link 

b. Subsidiary = Germany 

c. Go to the Access subtab 

d. Add the role for CC: Sales Administrator 

 Click Save. 

 Navigate to Change Role in the upper-right hand corner of your page. 

a. If Change Role does not display in the upper-right hand corner of your page, please log 

out of NetSuite and log back in. 

 Enter NetSuite as the CC: Sales Administrator. 

 If prompted Set Up Security Questions: Select three security questions of your choice and 

uncheck Hide Answers.  As your Answer, enter the last word of each question; for example: 

a. Question: What was your childhood nickname 

b. Answer: nickname 
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 Click Save and click Close in the Security Questions Complete pop-up window. 

 Navigate to Home > Set Preferences > Restrict View tab. 

 Which subsidiaries are listed in the Subsidiary pick list? (Subsidiary is under the Restrict View 

tab.) 

a. Answer:  

Modify the role to restrict to specific subsidiaries 

 Modify the CC: Sales Administrator role so that only German and Italian employees can use this 

role. 

a. Navigate to Change Role in the upper-right hand corner of the page. 

b. Enter NetSuite as the Chatham Company-Administrator. 

 Navigate to Setup > Users/Roles > Manage Roles. 

 Click the Edit link next to the CC: Sales Administrator role. 

 Hold down the Ctrl key and select Parent Company: Germany and Parent Company: Germany: 

Italy in the Subsidiary field. 

 Click Save. 

a. Note: We are NOT modifying the employee record: the employee is still assigned to the 

Germany subsidiary. 

 Navigate back to Change Role and switch to CC: Sales Administrator. If you do not see it, you 

may need to log out and back in. 

 Navigate to Home > Set Preferences > Restrict View tab. 

 Which subsidiaries are listed in the Subsidiary pick list? 

a. Answer: 

 Navigate to Change Role in the upper-right hand corner of your page. 

a. Enter NetSuite as the Administrator. 

 If prompted Set Up Security Questions: Select three security questions of your choice and 

uncheck Hide Answers.  As your Answer, enter the last word of each question; for example: 

a. Question: What was your childhood nickname 

b. Answer: nickname 

 Navigate to Lists > Employees > Employees. 
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 Select your employee record (Cathy Cadigan). Click Edit. 

 In the Classification section, change the value in the Subsidiary field back to Parent Company. 

 Click Save. 

 End. 
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Exercise 05: Add a NetSuite User 
Time: 2-5 minutes 

Scenario: Administrators are responsible for entering new users and assigning roles.  In this exercise: 

• Enter a NetSuite User 

• Assign a role 

 Confirm that you are in the Administrator role. 

 Navigate to Lists > Employees > Employees > New. 

 Confirm that you are using the Employee form. 

 Enter the required information: 

a. Enter employee’s name in the Name fields. The employee’s name is Joe S TEST. 

b. In the Job Title field, enter Sales Manager 

c. Review field help for the Email field, but do not enter an email now. 

d. Subsidiary is Parent Company 

Assign Roles 

 Click the Access subtab. 

a. Review the Give Access box, but do not check yet. When this employee starts work, you 

can check the box. 

b. Select the Manually Assign or Change Password checkbox 

c. In the Password field, enter My_old_dog34 as the password and reconfirm the 

password to test the password strength. 

d. Review the Password Strength.  

 From the Role dropdown list, select the CC: Sales Manager 

 Click the Add button. 

 Click the Save button. 

 Review the Confirmation message   

 End. 
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Exercise 06: View the Login Audit Trail 
Time: 2-5 minutes 

Scenario: NetSuite tracks when each user logs in, as well as transactions entered during that time. For 

example, an employee tells you that several of his records were changed on a day that he did not log in 

to NetSuite. 

In this exercise: 

 Practice viewing the user’s login trail to see when this employee has logged in. 

 Navigate to Setup > Users/Roles > View Login Audit Trail. 

 If necessary, uncheck the Use Advanced Search box. 

 Leave any of as the User filter, select – Mine - from the dropdown list. (There maybe 

transaction changes available. If you select an employee that you have just entered, there are 

probably not any transactions to view.) 

 From the Date dropdown, select within. 

 Click in the next field to see your options; set the Quick Filters to Month. 

a. Now scroll down and select this month. 

 Click the Submit button. 

 The Login Audit Trail Search Results lists all the dates and times when the user logged in.  

 Review the Status and Security Challenge columns. 

 Click any Date/Time links to view a user activity.  

a. Note: if there are no results, it means the user was logged in but did not edit or create 

records. 

 When you are done, click the Home tab. 

 

 End. 
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Solution for Exercise 01: Rename Custom Roles with Your Company’s Prefix 
 

How are these roles identified on the list of roles? 

• Answer: They have the prefix CC 
 

Do the original, NetSuite Standard roles still exist? 

• Answer: Yes 
 

How can you identify a NetSuite Standard role? 

• Answer: Standard Roles have a Customize link. 
 

 

 
Solution for Exercise 02: Customize the CC: Sales Manager Role 
 

Is there a Setup tab? What are some of the menu listings under this role’s setup tab? 

• Answer: Sales & Marketing Automation, Customization, Other Setup 

• Why? Different permissions. 

 
 
Solution for Exercise 04: Customize a Sales Administrator Role for OneWorld 
 

Which subsidiaries are listed in the Subsidiary pick list? (Subsidiary is under the Restrict View tab.) 

• Answer: Only Germany, since the Employee record is tied to Germany. 
 

Which subsidiaries are listed in the Subsidiary pick list? 

Answer: since these subsidiaries were identified on the role record.  The role governs subsidiary 

access; we defined the role to be in Germany and Italy. 
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Activity: Match Game 
 
Match the terms on the left to the task/description on the right 

 

Need More Information 
 
NetSuite Help Center: 

• Account Setup: Managing Roles & Permissions 
 

SuiteAnswers Learning Center: Training Videos 

• New Feature Training 

• Training Webinars 
 
View the following video, access from the demo account, NetSuite Essentials tab: 

• Getting Started Video: Day 1 - Getting Started: Data Security 
 

Getting Started is done, next is Customization and Data Management 

 
 

This is the end of this book 
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Getting Started: Recap and Review 

 
About this Module 

 

Review Day 1: Getting Started:  

• NetSuite Fits Your Business 

• OneWorld Overview 

• Implementation Project 

• Navigation 

• Company Preferences 

• NetSuite Data Model 

• Roles, Permissions and Users 
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Relational Database within NetSuite 
 

Benefits of a relational database: 

• Incorporates many unique tables 

• Defines tables with rows or unique lines of information 

• Relates tables together to form another table, for example a transaction 

• Displaces 4 pieces of information for 1 

• Provides a richer and more efficient use of data storage resources 

• Results in a more functional and significantly richer dataset for information 
delivery 

 

 
OneWorld Overview 

 
 
OneWorld allows domestic and international companies to manage multiple legal 

entities in a single NetSuite Account.   

The legal entities are organized as a tree with one root company at its root: 

• One subsidiary created for each separate reporting legal entity 
o NetSuite supports 124 subsidiaries and 1 root (parent) 

• Subsidiary configuration includes: multiple currencies, taxation rules, and 
reporting needs 

o Country, chosen on the subsidiary record, determines NetSuite edition 

• Offers consolidated reporting with foreign currency translation 
 
Elimination Subsidiary: Create for each parent subsidiary to eliminate revenue or 

expense at the consolidated level: 

• Only journal entries post to elimination subsidiaries 

• Not included in Subsidiary license fees 

• Not counted in the maximum of 125 subsidiaries 
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Navigation 
 
The first step is signing in to NetSuite and then you: 

• Authenticate your credentials using security questions 

• Access the center associated with your role 

• Work with transactions and lists 

• Use forms to create or access records; the data is stored in specific record types 

• Take advantage of various search options 

• Use online help resources 
 

Set Up Company: Information & Features 
 
As the Administrator, you use the Setup Manager for the following items: 

• Company Information and enter your company name and other relevant 
information – Setup > Company > Company Information 

• Enable feature to start tailoring NetSuite to your business requirements -  
Setup > Company > Enable Features and review the various subtabs 

o Available features are determined by your NetSuite subscription 
o Access Related SuiteApps from various subtabs, refer to help topics 
o Functional groupings live on the subtabs 

 

  



 

 

4 
 

Naming and Numbering 
 

NetSuite allows changing out-of-the-box terminology and numbering to be changed to 

meet your needs: 

▪ Go to Setup > Company > Rename Records/Transactions 
▪ Change the default names, in NetSuite, to familiar terminology, for 

example: 
▪ Go to Setup > Company – Auto Generated Numbers to define the numbering 

schemes for your different records 
 

 

Set Company Preferences 
 

The administrator can define company-wide preferences: 

• Preferences at Setup > Company > General Preferences can supersede 
individual user preferences 

• Set company-wide printing / and fax service at Setup > Company > Printing & 
Fax  

• Set company-wide email preferences at Setup > Company > Email 
Preferences  
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NetSuite Data Model 
 

The following tables support the four (4) standard record types: 

• Entity: people and organizations that you do business with 
o For example: leads, prospects, customers, contacts, employees … 

• Transaction: represent a financial exchange or value adjustment 
o For example: Sales orders, bank deposits, inventory adjustments … 

• CRM: activities with customers 

• Item:  goods and services you buy and sell; line items on sales and purchase 
order forms 

• Custom: addresses unique needs of your business 
o Use Case:  NetSuite Training Services uses a custom record for our 

course evaluations 
 

NetSuite Classifications 
 
NetSuite Classifications can help you track various financial, transactional, and 

employee records and therefore useful for reporting: 

• Departments: Designate transactions’ owner and resources as part of internal 
team 

• Classes: For wider categorization within your business (Business Unit) 

• Locations: Recognize physical or virtual places 
 
Use classifications can also be used to restrict a user’s access to system information. 

 
Roles and Permissions 

 
A User has one or more roles; each role defines access to data: 

 

• A user is anybody with access to your NetSuite account: employee, customer, 
partner, or vendor 

• The role is defined by: 
o Set of Permissions  
o Levels of each permission 
o Role Restrictions 
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Review Questions  
 

See if you can answer the following questions; fill in the bank or use true/false values: 

1. True or False: NetSuite’s data structure incorporates many unique tables 
 

 
2. NetSuite OneWorld allows you to set up multiple ________   ________, in one 

NetSuite account, using subsidiaries 
 

 
3. A __________ is used to enter or view existing data 

 
 
4. The ___________ is how data is stored in NetSuite 

 
 
5. The __________ Manager provides links to configure NetSuite 

 
 
6. True or False: Company-wide preferences may be set, such as “Email, Printing & 

Fax Preferences” 
 

 
7. Name the 4 standard NetSuite data (record) types: 

_____________           ___________          ____________           ____________ 
 

 
8. True or False: Classifications can be useful for segmenting data (reporting) 

 
 
9. A __________ is anybody with access to your NetSuite account 

 
 
10. A role is a set of ________________ governing a user’s access to data 

 

11.  
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Customization: Create Subtabs, Lists, and Fields 

 
About this Module 

 

Chatham Company has specific requirements for a customer profile:  

• What do I do if this requirement cannot be met by standard NetSuite? 

• What are the customization options in NetSuite? 

• Which tools can I use to help me meet this requirement? 
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NetSuite Customization Options 
 
The SuiteCloud features provide us with ways to add customized elements and 

functionality to our NetSuite Account: 

• We will focus on SuiteBuilder in this class 
o Add fields and lists to pages, while customizing the look of those pages 

• We offer technical courses in: 
o SuiteScript: Automate and create web pages, run batch updates to your 

data, and work with SuiteFlow 
o SuiteBundler: Package and deploy customizations, work with SuiteApps 

or Bundles 
o SuiteTalk: Communicate with NetSuite via Web Services 

 

Beyond basic customization and not part of this class - SuiteScript: 

▪ SuiteScript is a JavaScript-based API that gives developers the ability to 

extend NetSuite beyond the capabilities provided through SuiteBuilder 

point-and-click customization.  

▪ Many NetSuite forms, records, customization objects and their 

event/trigger points are accessible through SuiteScript. What you decide 

to do with SuiteScript depends on which part of NetSuite you are trying to 

extend, search, or process. 

 

Here is a chart with additional information: 

 

Tool Function Description 

SuiteBuilder 
User Interface 
Customization 

A set of point-and-click tools that allows users 
to easily customize NetSuite by adding custom 
fields, custom lists, custom record types, and 
custom forms. 

SuiteScript Scripting 

An extension of the JavaScript APIs that gives 
developers the ability to extend NetSuite to 
automate business processes or to build 
applications on top of NetSuite. 

SuiteBundler 
Vertical 
Solution 
Deployment 

Allows vertical solutions to be quickly and easily 
deployed to multiple NetSuite accounts. 

SuiteTalk 
Web Services 
Integration 

Exposes NetSuite as a web service to simplify 
integration with legacy systems and third party 
vertical applications. SuiteTalk relies on industry 
standards, such as SOAP and XML, for data 
communication with external hosts. 
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SuiteBuilder Overview 
 

 
Point-and-click tool: 
Easily tailor the look of NetSuite to meet your business needs: 

• Point and Click functionality 

• Custom Fields: on Entity, CRM, Item and Transaction records 

• Custom Lists: Set up predefined choices (list of values) in custom fields 

• Subtabs: Assign custom fields to custom sub tabs 

• Custom Forms: Entry, Transaction, PDF Layout, HTML Layout 
o Create custom forms: 

▪ Create the layout for printed and emailed forms 
▪ Define preferred entry form for a user role 

 
User Interface Elements 

 
Use Case:  
Chatham Company, per their BRD, wants to capture company profile information for 

their customers, organize the information and NetSuite does not have the necessary 

fields: 

 

• Create a new Subtab “Company Profile” 

• Create Custom Lists of values to be available for a user to select from 
o “Industry” 
o “Annual Revenue” 

• Create the Custom Fields for our custom lists to live in. e.g. Industry Type 

• Customize the Standard Customer Form to manage the final display of fields 
and subtabs 
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Order of creation is dictated by where the information lives: 
 

 
 

Customization Menu 
 

 
 
Most of the tools reside in the Customization menu: 

• Navigate to Setup > Customization 
o > Lists, Records, and Fields: 

▪ Specific fields 
▪ Other Custom Fields, such as Subsidiary record customization 

o > Forms 
▪ Subtabs, forms, layouts 

o > Centers and Tabs – please refer to help topics 
o > SuiteBundler – please refer to help topics 

• Many of the customization records, once viewed, are then available in recent 
records menu  
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Customization Considerations 
 

Plan and design before you act: 

• What is unique to my business and is not native in NetSuite? 

• How does the customization fit into business processes? 

• How will customization impact reporting? 

• How does the data need to be organized? 

• What are the relationships between the data?  

• Who needs access to this data and do I need to restrict access? 

• Have we discussed with stakeholders, to reach a consensus? 

• Not everyone should have customization permissions! 
 

Field Types 
 
Here are some of the commonly-used custom fields; refer to Help and SuiteAnswers for 
all custom fields types: 

• Check Box: True/False, Yes/No, or On/Off statements 

• Date: Display as a date and display the calendar icon 

• Decimal Number: Enter number with a decimal point 

• Free-Form Text: Enter short text (up to 300 characters) 

• Hyperlink: Link to a Web page 

• List/Record: Reference a list of values or point to a record 

• Percent: Display a numeric value as a percent 
 
Custom fields can be placed in the header (main) part of a form or a line level. 
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Other Record Fields 
 
Other Record Fields are used for records that do not have custom forms associated 
with them and can be added, to gather information specific to your business needs, to 
various record types: 
 

• Go to Customization > Lists, Records, & Fields > Other Record Fields 

 

Please refer to SuiteAnswers for a complete list of the record types. 

 

Walkthrough: Create a Subtab for an Entity 

 
Use Case/Scenario:  

• I need to add geographic information to a customer record, on its own subtab 
 

Create a Subtab for an Entity 
 
Use Case: Display a Geography subtab on a customer record: 

• Subtabs can be added to any record in NetSuite and are used to organize 
custom fields on your transaction, entity, CRM and item records 

• Create custom subtabs first and then assign any custom fields to the custom 
subtabs. 

• Create custom child-subtabs by defining an existing subtab as the parent subtab. 
o Allows defining an additional layer of information for your subtab 

categories. 

• Custom subtabs display on the record after a field is assigned to the subtab  
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• Go to Customization > Forms > Subtabs 

 
• Select the correct record type such as: 

• Transaction: Used for cash refund, cash sale, credit memo, estimate, 
invoice, opportunity, purchase order, return authorization and sales order 
transaction records.  

• Entity: Used for customer, project, vendor, employee, other name, contact, 
partner and group records.   

• Item: Used for inventory, non-inventory, group, other charge, assembly/bill of 
materials, kit/package and service item records   

• CRM: Used for task, phone call, event, case, campaign and solution records   
 

Create a Custom List and List/Record Field 

 

Use Case/Scenario: Track a customer headquarters’ location to a global region: 

• I want users to select a single region from a list 

• Create a new custom field that uses my custom list 

• View a customer record to ensure that my subtab, list and field are all visible  
 

Create a Custom List 
 

Use Case: Give users a list of Global regions to select one value for the location of the 

customer’s headquarters: 

• Go to Customization > Lists, Records, & Fields > Lists > New 

 
• Enter a Name for the list, e.g. Global Regions 

• Define Show Options in, select one of the following 
o the order entered 
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o alphabetical order 
 

Create an Entity List/Record Field 
 

Use Case: Provide users a field where they select a single value from a list of Global 

regions: 

• Go to Customization > Lists, Records, & Fields > Entity Fields > New  
 

 

In the top of the form, enter the field name in the Label field 

• NetSuite assigns an Internal ID to the custom field and which will be visible 
when viewing a list of custom fields. (Note: Go to Home > Set Preference and on 
the General subtab, in Defaults choose “Show Internal IDs) 

• Enter the field ID to easily identify the location and purpose of the custom field; 
can be used by java scripting: 

o This must begin with an underscore ‘_’ , e.g. ID: _global_regions 

• Select the Type of field you are creating; the value you select determines the 
other options you can set  

o If you select List/Record or Multiple Select, you must then select the list or 
record in the List/Record field that contains the items for the list field.   

• Review the field definitions for the following and select per your business needs: 
o Store Value:  

▪ If the field displays the result of a formula, do NOT store the value 
▪ Tip! Select Store Value if you want to use this field for duplicate 

detection criteria 
o Show In List 
o Global Search 
o Record is Parent 
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Go to the Applies To subtab, select the entity record(s) that will use the custom field(s) 

Navigate to the Display subtab and select the placement of this field on transactions in 

relation to other custom fields and write help text: 

• Select the subtab for the field to display 

• Select the type of display you want this field to have: 
o Normal: This field can be edited. Use with custom code calculations, 

defaulting and sourcing information 
o Disabled: Useful for custom code, users can not enter information 
o Inline Text: information cannot be entered, the field is for informational 

purposes only 
o Hidden: Does not display on the record, but can be searched on. The 

information in the field is a result of a calculation or maybe a custom code 

• Enter the Help text definition. What you enter will display when users click on the 
field name ‘help’ hyperlink. 

 

Tips: Correcting a Custom Field 
 

If you entered information incorrectly, and saved the field, here are some actions 

you can take: 

• Use the Actions menu items to Check Delete Dependencies or Check inactive 
Dependences 

o After checking dependencies, you can choose Delete or, 

 
o Mark Inactive 

 
o If you entered the ID incorrectly, you can select the Change ID and enter 

a new ID 
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View a Customer Record 
 

Once a field has been assigned to the custom subtab, the subtab is visible for viewing.  

Go to Lists > Relationships > Customers  

 

• Click the View link for an existing customer 

• The new Subtab, e.g. Geography, is now available on a customer record: 

• The new Custom Field, e.g. “Global Regions”, is available 

• The new Custom List provides our dropdown list of values, for example: 
o APAC 
o EMEA 
o No Amer 
o So Amer 
o Other 

• Note that we see “-New-” in our role, which has customization permissions  
 

Activity: Entity Customization Review 
 

Can you answer the following questions? 

• Which field type provides a yes or no, true or false value? 
 

• What must be created first, to organize my data on a form? 
 

• What can provide a defined choice of values and cut down on data entry errors? 
 

• True or False: Help should be written for the new custom field  
 

Now It’s Your Turn 
 

 
Use Case/Scenario: 

• Your company wants to capture customer information around the customer’s 
type of industry and annual revenue 

• You need to organize this data, provide a list of values and create the new fields  

• Allow 8-15 minutes 
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Independent Study Exercises 

Exercise 01: Create Subtabs and Lists 
Time: 3-5 minutes 

Scenario: You Company wants to capture information about each customer's profile; to be stored on the 

Customer Record. 

As the administrator, in this exercise: 

 Create a custom subtab, to organize the custom fields to be created 

 Create two (2) custom lists to identify: Type of Industry and Annual Revenue 

Create Subtab 

 Go to Customization > Forms > Subtabs. 

 Click the Entity subtab. 

 Enter Company Profile in the Title field. 

 Click Add. 

 Click Save when you are done. 

Create Custom Lists for Industry and Annual Revenue 

 Go to Customization > Lists, Records, & Fields > Lists > New. 

a. Name: Industry 

b. Owner: (leave as is) 

c. Description: You can leave this blank. But, the recommended best practice is to enter a 

description, such as why this field is needed and who requested it  

d. Show options in: alphabetical order 

e. Inactive: (leave blank) 

 Enter and add the following in the Value column (click Add after each item). 

It is important that values are entered exactly as noted here (no spaces 

around the hyphens!): 

a. Financial Services 

b. Retail 

c. Education 

d. Government 

e. Computer Software 
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f. Computer Hardware 

g. Advertising Media 

 Click Save & New when you are done. 

 Enter the following information (click Add after each item): 

a. Name: Annual Revenue 

b. Owner: (leave as is) 

c. Description: You can leave this blank. But, the recommended best practice is to enter a 

description, such as why this field is needed and who requested it. 

d. Show options in: the order entered 

e. Inactive: (leave blank) 

 Enter the following in the Value column (click Add after each item): 

a. Less than $6M 

b. $6-$100M 

c. More than $100M 

 Hover over Save & New and click Save when you are done. 

 The Custom Lists page displays. You should see the two (2) lists you created: 

 

a. Annual Revenue 

b. Industry 

 End. 
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Exercise 02: Create and Apply Fields 

 
Time: 7-10 minutes 

Scenario: Custom lists (Industry and annual revenue) were created for the Company Profile subtab. 

In this exercise: 

 Update your User Preferences to Show Internal IDs 

 Create custom entity fields that use those custom lists 

 Additionally, create a field for Year Established 

Update User Preferences 

 Go to Home > Set Preferences 

 On the General subtab, go to the Defaults section and select Show Internal IDs 

 Click Save 

Create Custom Entity Field - Industry 

 Go to Lists > Relationships > Customers > New. 

 You should be viewing a Standard Customer Form. 

 Go to the top-right hand side, from the Customize dropdown menu, select New Field.  

 You should be on the Custom Entity Field page. 

 Enter the following information: 

a. Label: Industry 

b. ID: _industrytype 

c. Owner: (leave as is) 

d. Description: You can leave this blank. But, the recommended best practice is to enter a 

description, such as why this field is needed and who requested it. 

e. Type: List/Record 

f. List/Record: Industry 

g. Store Value: check 

h. Show in List: check 

 (The system defaults to Customer.) Verify that Customer is checked in the Applies To subtab 

(and other records where you want to see this field). 
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 Click the Display subtab and enter the following information: 

a. Insert before: (leave blank) 

b. Subtab: Company Profile 

c. Display Type: Normal 

d. Help: Type in the following text into the Help field. “Select the value that most clearly 

identifies the customer.” 

e. Tip: Copy the above sentence in NetSuite, and then you can paste it into the other help 

areas for the additional custom fields in NetSuite 

 Do not do anything on the Validation & Defaulting, Sourcing & Filtering, Access, or Translation 

subtabs. 

 Hover over Save & New and click Save & New when you are done.  You should be on the Custom 

Entity field page. 

Create Custom Entity Field – Annual Revenue 

 Enter the following information:  

a. Label: Annual Revenue 

b. ID: _annualrevenue 

c. Owner: (leave as is) 

d. Description: (leave blank) 

e. Type: List/Record 

f. List/Record: Annual Revenue 

g. Store Value: check 

h. Show in List: check 

 Check Customer in the Applies To subtab (and other records where you want to see this field). 

 Click the Display subtab and enter the following information: 

a. Insert before: (leave blank) 

b. Subtab: Company Profile 

c. Display Type: Normal 

d. Help: Type or paste in the following text into the Help field.  “Select the value that most 

clearly identifies the customer.” 
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 Do not do anything on the Validation & Defaulting, Sourcing & Filtering, Access, or Translation 

subtabs. 

 Click Save & New when you are done. 

Create Custom Entity Field – Year Established 

 Enter the following information: 

a. Label: Year Established 

b. ID: _yearestablished 

c. Owner: (leave as is) 

d. Description: (leave blank) 

e. Type: Integer Number 

f. List/Record: (grayed out) 

g. Store Value: check 

h. Show in List: check 

 Check Customer in the Applies To subtab (and other records to see this field). 

 Click the Display subtab and enter the following information: 

a. Insert before: (leave blank) 

b. Subtab: Company Profile 

c. Display Type: Normal 

d. Apply Formatting: Uncheck the box if it is checked. We do not want number formatting 

applied to the year. 

e. Help: Type in the following text into the Help field.  “Enter the year this company 

began doing business.” 

 Do not do anything on the Validation & Defaulting, Sourcing & Filtering, Access, or Translation 

subtabs 

 Hover over Save & New and click Save when you are done. 

 The Custom Entity Fields page displays. 

  Review the Internal ID, type, list and tab.  You should see the three (3) custom fields that you 

created: 
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a. Industry 

b. Annual Revenue 

c. Year Established 

 . End. 
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Walkthrough: Review a Transaction Record and Add New Body Field 
 

 
Use Case/Scenario:  

• My company needs to show if accounting has approved a sales order 

• We just want a simple check box 

• The field should be placed at the top of the form 

• It should be available in reports and searches  
 

Review a Transaction Record and Select Customize 
 

For example, go to Transactions > Sales > Enter Sales Orders and choose from the 

Customize dropdown list: 

• New Body Field: top of the form 

• New Column Field: line-level information 

• New Option Field: line-level information 
 
Recommended: Start from the transaction record, such as a new sales order, and use the 
Customize dropdown list. 
 
Use Case:  display check box for Accounting Approval on sales transactions. 

• Use the Customize dropdown list and select New Body Field: 
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New Body Field: Check Box for Accounting Approval 
 

Create and define a Check Box field: 

 

• Name: Accounting approval 

• Optional: Enter the field Label, ID (must begin with an underscore ‘_’), etc. 

• Type: Check Box 

• Check Store Value and Show in List to facilitate searches and list displays 

• Applies to: select which transactions that you want the field (s) applied, e.g. 
Sales Order 

• Display: define the following: 
o Subtab: Main, so it is not on a subtab or line 
o Display Type: Normal – the user interacts with the field 
o Help: “Check if approved by accounting” 

 
Note: Use these same steps to create a New Column field or New Item Option field 
for transactions. 
 

Available in Reports and Searches 
 

The new custom field is immediately available: 

• Sales by Customer reports 

 
• Transaction saved search  
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Consider Additional Field Features 
 

Navigate to the Validation & Defaulting subtab: 

 

• Be aware that it may be wiser to apply constraints on a custom form and not at 
the field level: 

• Example: Make a field mandatory on a custom form, not on the field itself  
 
Defaults are values you specify for your custom fields: 

• Enter a Default Value; If the field is not locked, the value may be changed 

• Build formulas by clicking on the icon and using the pop-up window 
o If you are using a formula, never store the value of the custom field 

• Select a search with summary results, to be used to calculate a value for this 
custom field. 

 

Navigate to the Sourcing & Filtering subtab: 

• Auto-populate a custom field by sourcing information from another record and a 
field on that record  

• Ensure that you have the most current information 

 

• Reduce data entry errors 

• For example: Display the Customer Contact and their Phone Number at the top 
of a transaction 

o A custom field to link to customer record and display contact name 
o A custom field to populate the phone number from the contact information 

 
Now It’s Your Turn 

 
Use Case/Scenario: 

• Display a deposit percentage and deposit due on a sales order 

• Populate a sales order with the customer contact’s name and phone number 

• Populate a purchase order with the weight of an item  

• Allow 10 - 20 minutes 
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Exercise 03: Custom Transaction Fields – Validation and Defaulting 

 
Time: 5-10 minutes 

Scenario: Chatham Company has a requirement for Sales Order transactions: 

 Automatic calculation of percent deposit required from the customer based on the total 

amount of the transaction multiplied by a percentage 

In this exercise: 

 Create a field to enter in the % Deposit Required 

 Create a field to calculate the Deposit Due 

 

Create a Transaction Body Field for Percent Deposit Required 

 Go to Transactions > Sales > Enter Sales Orders.  You should be viewing a Standard Sales Order 

form. 

 Go to the top-right hand side of the form and select New Body Field from the Customize 

dropdown. 

  You should be on the Transaction Body Field page. 

 Enter the following information: 

a. Label: Deposit Percent 

b. ID: _dep_percent 

c. Owner: (leave as is) 

d. Description: You can leave this blank. But, the recommended best practice is to enter a 

description, such as why this field is needed and who requested it. 

e. Type: Percent – Think about how the information should be displayed. 

f. List/Record: (greyed out) 

g. Store Value: check 

h. Show in List: (leave blank) 

 Check Sale in the Applies To subtab (and other transactions as required) 

 Click the Display subtab and enter the following information: 

a. Insert before: (leave blank) 

b. Subtab: Main 
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c. Display Type: Normal 

d. Help: Type in the following text into the Help field.  “Enter the required deposit 

percentage.” 

 Do not do anything on the Validation & Defaulting, Sourcing & Filtering, Access, or Translation 

subtabs. 

 Hover over Save and click Save & New when you are done. Note the message. Confirmation 

Transaction Body field successfully Saved 

Create a Transaction Body Field to Calculate the Deposit Due 

 You should be on the Transaction Body Field page. 

 Enter the following information: 

a. Label: Deposit Due 

b. ID: _dep_formula 

c. Owner: (leave as is) 

d. Description: You can leave this blank. But, the recommended best practice is to enter a 

description, such as why this field is needed and who requested it. 

e. Type: Currency.  We choose currency, because the result of the formula calculation 

needs to be displayed in currency format 

f. List/Record: (greyed out) 

g. Store Value: (leave blank) - When creating a formula field, calculations are dynamic so 

we do NOT want to store the value – will create an error. 

h. Show in List: (leave blank) 

 Check Sale in the Applies To subtab (and other transactions where you want to see this field). 

 Click the Display subtab and enter in the following information: 

a. Insert before: (leave blank) 

b. Subtab: Main 

c. Display Type: Inline Text - The system will populate this field, so we do not want the 

user interacting with the field. 

d. Help: Type in the following text into the Help field.  “Displays the calculated deposit 

amount.” 

 Click the Validation & Defaulting subtab. 
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 Click in the Default Value field, click the Set Formula icon 

 In the pop-up window, to the following: 

a. Click the Field dropdown and select Deposit Percent  

b. In the Formula Field, the following value should display: {custbody_dep_percent} 

 In the Formula field, now add the multiplication operator “ * “ {custbody_dep_percent}* 

 Go back to the Field dropdown and select Total. The following formula should display as 

{custbody_dep_percent}*{total} 

 Click Set to close the pop-up window. 

 Review the formula in the Default Value field. 

 

 Do not do anything on the Sourcing & Filtering, Access or Translation subtabs. 

 Hover over Save & New and click Save when you are done.  You should see the list of the two 

new Transaction Body fields and can review their Internal IDs and Type: 

 

a. Deposit Percent 

b. Deposit Due 

Let’s validate your work!  Create a Sales Order transaction 

 Go to Transactions > Sales > Enter Sales Orders. 

 Select the customer: TEST ABC and Warehouse: MidWest 

 In Deposit Percent, enter 10.  Deposit Due remains blank. 

 On the Items subtab select Printer Cables, from the dropdown list, and a Quantity of 10.  Click 

through any pop-up window, it is okay if we do not have any inventory. 

 Click Add to add the printer cables to the order. 
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 Click Save when you are done. 

 The Deposit Due field should display calculated amount. 

 

 End. 
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Exercise 04: Custom Transaction Fields – Sourcing & Filtering 
Time: 5-10 minutes 

Scenario: Chatham Company has the following requirement for the Sales Order transaction: 

 Identify the primary contact and their phone number 

In this exercise: 

 Create Sales Order transaction fields: Contact Name, Contact Phone Number, Shipping 

Preference 

 Source information from the Customer record to auto populates the Contact Name and 

Contact Phone Number on the Sales Order transaction. 

Create a Transaction Body Field for Contact Name 

 Go to Transactions > Sales > Enter Sales Orders.  You should be viewing a Standard Sales Order 

form. 

 Go to the top-right hand side; click the New Body Field, from the Customization choices. 

 You should be on the Transaction Body Field page. Enter the following information: 

a. Label: Contact Name 

b. ID: _contactontrans 

c. Owner: (leave as is) 

d. Description: You can leave this blank. But, the recommended best practice is to enter a 

description, such as why this field is needed and who requested it. 

e. Type: List/Record 

f. List/Record: Contact 

g. Store Value: check 

h. Show in List: (leave blank) 

 Check Sale in the Applies To subtab (and other transactions to view this field). 

 Click the Display subtab and enter the following information: 

a. Insert before: (leave blank) 

b. Subtab: Main 

c. Display Type: Normal 

d. Help: enter the following: “Select the contact for this customer.” 
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 Click the Sourcing & Filtering subtab. Enter the following information to pull contact data from 

the customer record 

a. Source List: Entity 

b. Source From: (leave blank) 

c. Source Filter By: Parent 

 Do not do anything on the Validation & Defaulting, Access or Translation subtab. 

 Hover over Save and click Save & New when you are done. 

Create a Transaction Body Field for Contact Phone Number 

 You should be on the Transaction Body Field page.  Enter the following information: 

a. Label: Contact Phone Number 

b. ID: _contactphonenumber 

c. Owner: (leave as is) 

d. Description: You can leave this blank. But, the recommended best practice is to enter a 

description, such as why this field is needed and who requested it. 

e. Type: Phone Number 

f. List/Record: (greyed out) 

g. Store Value: check 

h. Show in List: (leave blank) 

 Check Sale in the Applies To subtab (and other transactions where you want to see this field). 

 Click the Display subtab and enter the following information: 

a. Insert before: (leave blank) 

b. Subtab: Main 

c. Display Type: Inline text. 

d. Help: enter the following text: “This is the contact's phone number.” 

 Click the Sourcing & Filtering subtab. Enter the following information, to pull in or source in data 

from the contact record: 

a. Source List: Contact Name 

b. Source From: Phone 
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 Do not do anything on the Validation & Defaulting, Access or Translation subtabs. 

 Hover over Save & New and click Save you are done.  Note that these two new files are now 

included in the list of Transaction Body Fields. You now have a total of four (4) Transaction Body 

Fields: 

 

a. Deposit Percent 

b. Deposit Due 

c. Contact Name 

d. Contact Phone Number 

Validate your work! Enter a new sales order but do NOT save 

 Navigate to Transactions > Sales > Enter Sales Orders 

 Customer - Select TEST ABC.  This is the parent entity. 

 In the Classification section, select TEST ABC: Amy Andrews as the Contact Name 

 Contact Phone Number populates.  Note that because we defined the field as inline text, that 

the number is displayed and cannot be edited. 

 Click Cancel, you do not need to save the order. 

 End. 
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Exercise 05: Custom Transaction Fields – Sourcing & Filtering 
Time: 5-10 minutes 

Scenario: Chatham Company wants to display each item’s weight placed on a Purchase Order, which can 

be shared with the vendor.  This information can be used for any shipping charges that they are incurred 

for purchasing these items.  

In this exercise: 

 Create a custom field and source in data 

Create a Transaction Column Field for Item Weight 

 Go to Transactions > Purchases > Enter Purchase Orders  

 Select New Column Field from the Customize dropdown, top-right hand side. 

 You should be on the Transaction Column Field page.  Enter the following information: 

a. Label: Weight 

b. ID: _itemweight 

c. Owner: (leave as is) 

d. Description: You can leave this blank. But, the recommended best practice is to enter a 

description, such as why this field is needed and who requested it. 

e. Type: Decimal Number 

f. List/Record: (greyed out) 

g. Store Value: check 

 Check Purchase Item in the Applies To subtab (and other transactions where you want to see 

this field). 

 Click the Display subtab. Enter the following information: 

a. Insert before: (leave blank) 

b. Display Type: Disabled 

c. Help: enter information the following text: “This is the weight of the item, pulled from 

the item record.” 

 Click the Sourcing & Filtering subtab.  We want to pull information from the item record by 

identifying the following: 

a. Source List: Item 

b. Source From: Weight 
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 No action on the Validation & Defaulting, Access or Translation subtabs. 

 Click Save when you are done.  Review the Transaction Column Fields page; you should have the 

one field. 

 

 Go to Transactions > Purchases > Enter Purchase Orders 

 Select the vendor: TEST Widget Works. 

 Click the Items subtab. 

 Select the Printer Cables from the Items dropdown list in the Items column. 

  Validate that Weight is displayed as a column, the weight of the item is displayed, and you 

should not be able to edit this value.  You may need to use the horizontal scroll bar, to see the 

column. 

 Click Cancel. 

 End. 
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Custom Elements: Best Practices 
 

• Identify what is unique to your business and what is needed to support business 
practices 

• Assess whether the required functionality exists in NetSuite 

• Plan and design before you act; limit who can add custom elements 

• Work with stakeholders  

• Consider how elements relate to each other 

• Provide ease of data entry and prevention of data entry errors by choosing the 
best field type  

• Enable SuiteCloud > SuiteScript feature and User Preferences > General 
subtab > Show Internal IDs to see the field names when field help is accessed 

• ID Field naming convention: _ abbreviation_description 

• Use the Description field to provide business reasons, who asked for it, notes 
for the backup Administrator  

 

Recent Custom Fields Enhancements 
 

• Enhanced Delete Behavior for Records Referenced by Custom Fields impacts 
the behavior of list/record and multiple select custom fields: 

o Problem: The list of values is populated by records of the list/record type 
set in the custom field definition. Because list/record and multiple select 
custom fields are dependent on these referenced records, deletion of 
these records can be problematic. 

o Example: A custom field called “Color” is dependent on the custom list 
“color”.  Purple is deleted from the list; this impacts every record with a 
custom field value of “purple” 

o Previous handling: NetSuite handled the deletion of records referenced by 
list/record and multiple/select custom fields according to the type of the 
record to be deleted. This behavior could not be customized 

o Solution:  Many enhancements have been made to better define the 
resulting deletion behavior.  
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• Ability to Make Custom Fields Inactive 
o Before this release, it was possible to remove a custom field from a 

specific record type, or to delete the field completely.  
o This version supports the ability to make a custom field inactive instead of 

deleting it. 
o  A new Inactive check box now appears on each custom field record. 
o Also as part of this feature, a new “Show Inactives” option is available on 

all custom field list pages, including the list of custom fields on each 
custom record type’s Fields subtab.  

o By default, the “Show Inactives” option is disabled so that inactive custom 
fields are filtered out of lists. 

o When this option is enabled, the list displays both inactive and active 
custom fields, and each custom field in the list has an Inactive check box 
next to it.  

o You can check this box to make a custom field inactive, and clear this box 
to reactivate an inactive custom field. 

o When a custom field is made inactive, it no longer appears on any forms 
or reports and it is not returned by global search, just like a deleted field. 

 

Please refer to SuiteAnswers for more information 

 
Additional Resources 

 
NetSuite Help Center: User Guides 

• SuiteBuilder Guide 

• Encrypting Custom Field Stored Values 

• Customizing Delete Behavior for Records Referenced by Custom Fields 

• SuiteCloud (Customization, Scripting, and Web Services)  
 

• SuiteAnswers Learning Center: Training Videos 

• New Feature Training: SuiteCloud  

• Customization/Integration 

• SuiteScript  
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Create Custom Forms 

 
About this Module 

 

I have been reviewing the NetSuite standard forms and they are not exactly what my 

company needs: 

• Can I modify existing forms to collect, organize, and store this data? 

• Is it possible to change the printed look of a form, such as a sales order?  

• Will a custom form help me to define who can see and use certain data? 

• Will NetSuite let me link a custom transaction form to another transaction 
creating some sort of workflow?  
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Forms: Types and Layouts 
 

• Custom Entry Forms is used to enter information in the creation of entity 
records  

• Custom Transaction Forms is used to enter and print transactions  

• Transaction Form Layouts are custom layouts that allow you to customize the 
look and feel of the transaction forms that you may want to print of email to those 
you do business with: 

o These are also referred to as basic layouts, which we will work with in this 
course  

• Advanced PDF/HTML Templates provide an alternate method, to basic layouts, 
for customizing printed and emailed records; support the production of either 
PDF or HTML output: 

o Require enabling additional features 
o For more details refer to Advanced PDF/HTML Templates in Help  

 
Forms: Functionality 

 
Forms control user access to viewing and entering information: 

• Forms can be customized (define different versions) 

• Forms can be chained together to create a workflow 

• Forms can be assigned to roles: 
o This provides that last level of control on a role: Control view a user’s 

view with an assigned, custom form for their role  

• Forms can attach script for additional functionality 
 

Customize Entry Forms: Overview 
 

The entry form may be customized in the following, general ways: 

• Subtabs: display, rename, change display order 

• Field Groups: change display order, rename, remove, add  

• Fields (standard and custom): can be re-used on multiple forms 

• Actions: rename, hide or change the display 

• Sublists: control sublists on the subtabs in a form 

• Quickview: add, remove, or rearrange the fields in a QuickView  

• Roles: make preferred for any standard or custom role 
 

Review each of the form subtabs and their associated sublists 
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Walkthrough: Customize an Entry Form 

 

Use Case/Scenario:  

• We want sales reps to only see some of the subtabs on a customer form 

• We will “hide” subtabs  
 

Customize the Entry Form 
Use Case: Hide the Marketing, Financial and Preferences subtabs from a sales rep  

• Go to Customization > Forms > Entry Forms and click Customize for the 
Standard Customer Form  

 

• Go to Subtabs, uncheck Show to hide desired subtabs 
 

 

  



 

 

40 
 

• Save and compare the standard and custom form 
 

 

 
 

Now It’s Your Turn 

 
Use Case/Scenario: 

• Your company wants the Industry Type field marked as a mandatory field and 
show the subtabs in a different order. 

• You want Resource or Project Managers to see some of the information from an 
employee record, hiding other information.  

• Allow 10- 15 minutes 
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Exercise 01: Customize Entry Forms 

 

Time: 5-8 minutes 

Scenario: Chatham Company needs the Customer Form modified to better meet their needs. This will be 

the preferred form for a sales manager to use. We want to define field and subtab behavior. 

In this exercise create a custom form and: 

 Mark Industry Type as a mandatory field  

 Position Company Profile subtab just under the Info tab 

 Test at the end of the exercise 

Customize the Entry Form 

 Go to Lists > Relationships > Customers > New. 

 Select the Standard Customer Form in the Custom Form field. 

 Click Customize Form from the Customize dropdown, top-right hand side. 

 You should be on the Custom Entry Form page 

 Enter the following information: 

a. Name: CC: Customer Form for Sales 

b. Inactive: (leave blank) 

c. Enable Field Editing on Lists: check 

d. Store Form with Record: check (99% of the time check this box) 

e. Form is Preferred: leave blank, uncheck if necessary 

f. Use for Pop-ups: (leave blank) 

g. Pop-up Only: (leave blank) 

 Go to the Subtabs subtab.  

a. Click the Company Profile row to highlight it.  Drag and drop just under the System 

Information row. 

 Click the Fields subtab. 

a. Click the Company Profile sublist. 

b. Find Industry and check Mandatory checkbox. 

c. Click Annual Revenue to highlight the row and click Move to Bottom button. 
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 Leave the other subtabs untouched. 

 Go to the Roles subtab and check this as Preferred for the CC: Sales manager. 

 Click Save when you are done. 

Test the Custom Form 

 Switch roles from Administrator to CC: Sales Manager 

 Go to Customers > Relationships > Customers > New. 

 Select CC: Customer Form for Sales 

 You should see the Company Profile subtab after the System Information subtab. 

 Click the Company Profile subtab. 

a. Ensure that the Industry Type field has an asterisk, indicative of a mandatory 

(required) field, and the other fields are in the right locations. 

 Enter one (1) new customer. Ensure that all the fields on the Company Profile subtab are 

completed. 

 Under the Relationships subtab, Contacts sublist; enter one (1) contact person with phone 

number for this customer. 

 Click Save when you are done creating the customer record and make note of the Customer that 

you created. 

Return to Administrator Role 

 Switch roles back to Administrator. 

 Click Home. 

 End. 
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Exercise 02: Create an Internal Custom Form 
Time: 5-8 minutes 

Scenario: The Chatham Company would like to have a custom Employee Record form to be by viewed 

by the Project Managers that displays limited information. 

In this exercise: 

 Customize the Entry form for an employee record 

 Restricting visible fields and subtabs 

Create Custom Employee Form 

 Go to Lists > Employees > Employees > New; ensure that the Standard Employee Form is 

displayed. 

 Select Customize Form from the Customize dropdown list, top-right hand side; you should be 

on the Custom Entry Form page. 

 Enter the following information: 

a. Name: CC: Employee Form for PM  

b. Inactive: (leave blank) 

c. Enable Field Editing on Lists: (leave blank) 

d. Store Form with Record: check 

e. Form is Preferred: (leave blank), uncheck if necessary 

f. Use for Pop-ups: (leave blank) 

g. Pop-up Only: (leave blank) 

 On the Subtabs subtab, only the following should be checked under the Show column: 

a. Human Resources 

b. Access 

c. System Information 

 Click the Fields subtab. 

 On the Main sublist.  Uncheck the following items under the Show column: 

a. Template 

b. Address 

 Rename the following fields: 
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a. Phone field to Primary Phone in the Label column. 

b. Supervisor field, Display Type = Disabled 

 On the Human Resources sublist: 

a. Uncheck the Show column for all items, except the following.  These are the only fields 

to have view access by PMs. 

i. Type 

ii. Employee Status 

iii. Job Description 

iv. Sales Rep 

v. Support Rep 

b. Choose Disabled on the following items under the Display Type column: 

i. Type 

ii. Employee Status 

iii. Job Description 

iv. Sales Rep 

v. Support Rep 

 On the Time Tracking sublist, choose Disabled for Time Approver under the Display Type 

column. 

 On the System Information sublist uncheck the following item under the Show column: 

a. Inactive 

 Do not do anything on the other fields and tabs. 

 Click Save when you are done.  

Test the Custom Employee Form 

 Go to Lists > Employees > Employees > New 

 Review the available subtabs in the Standard Employee form. 

 Now select CC: Employee Form for PM in the Custom Form field. 

 You should only see the subtabs that you have selected, edit the fields that you have selected, 

also other fields are inline/disabled. 
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a. Note: The System Information subtab does not display on a new record, until that 

record is saved. 

 Click Cancel. 

 End. 
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Entry Form: Best Practices 
 

Consider the following best practices, when creating custom forms: 

• Create a naming convention for custom forms 
o Standard form remains in NetSuite as a template 

• Create different form versions for different roles 
o Define as preferred 
o Use form for pop-ups if it is preferred 

• Define a custom field as mandatory on your custom form: 
o Do not define it as mandatory at the field level 
o Enable using that custom form on other forms if needed 

• Rename standard fields to match your business process 
 

Customize Transaction Forms: Overview 
 
The transaction form can be customized, like an entry form, but with additional 

capability: 

• Subtabs: display, rename, change display order 

• Field Groups: change display order, rename, remove, add 

• Screen Fields: change display order and type, rename, make mandatory  

• Actions: rename, hide or change the display 

• Sublists: control sublists on the subtabs in a form 

• Printing Fields: control fields to be printed in defined sections of a printed 
transaction  

• Quickview: add, remove, or rearrange the fields in a QuickView  

• Roles: make preferred for any standard or custom role 

• Linked Forms: control which transaction form is used when you convert one 
transaction into another; create a chain of transaction forms that mirror your 
business workflow.  

Review each of the form subtabs and their associated sublists 

 
Walkthrough: Transaction Form PDF Layout 

 

 
Use Case/Scenario:  My company wants a specific look and feel to the printed 
transaction form: 

• Review a Standard Sales Order transaction form PDF Layout, revise it and save 
it to use later. 

• Review a Standard Sales Order transaction form HTML Layout, but at this point 
take no action 
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Transaction Forms: PDF Layout 
 

By default, most transactions use the same PDF layout, which governs the printed look 

of the form: 

• Go to Customization > Forms > Transaction Form PDF Layouts 

 
• The Custom PDF Layouts page displays, select the form to Customize - e.g. 

Standard Transaction Layout 

• The Custom PDF Layout page open 
o Enter a Name for your layout; follow a naming convention 
o Select Page Size, verify Width, Height, enter Top Margin and select your 

Colors 
o Use drag-and-drop functionality to edit the custom PDF layout 

▪ You can create custom PDF layouts for every type of transaction 
and link it to the custom transaction form 

o Define the Primary Information and Colors 
o Scroll down to start using the Editor and Elements; the right-side panel is 

the WYSIWYG (what you see is what you get) with drag and drop, and 
click on an element to edit the properties. 

o New elements can be added by using the Add Custom Element button.  
▪ Once an element is placed, other features can be controlled using 

the controls in the left-side panel. 
▪ If your logo contains your company name you can: 

• Customize the transaction form and direct the printing fields 
to not print the company name 

• Or, minimize the company name element, in the pdf layout 
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Transaction Forms: HTML Layout 
 
By default, most transactions use the same HTML layout, which governs the emailed 
look of the form: 

• Go to Customization > Forms > Transaction Form HTML Layouts 

 
• The Custom HTML Layouts page displays, select the form to Customize - e.g. 

Standard HTML Transaction Layout 

• The Custom HTML Layout page open 
o Enter a Name for your layout; follow a naming convention 
o The editing tool is not drag-and-drop functionality 
o Work with the Templates and Elements 

• Can create custom HTML layouts for every type of transaction and link it to the 
custom transaction form 

 
This course does not focus on HTML.  Feel free to explore this on your own time. 
 

Walkthrough: Customize Transaction Form – Layout and Form Elements 

 

Use Case/Scenario:  Now customize a sales order form: 

• Associate my PDF layout, with the new text color, to a specific transaction 

• Review form elements 
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Associate Layout 
 
Associate a Layout to a specific transaction form. Use a standard form as the basis for 

your custom form: 

• Go to Customization > Forms > Transaction Forms and select the form to 
customize 

 

 
The Custom Transaction Form page displays and you can fill in the information at the 

top of the page: 

• Name: Enter the name of the form users will select, avoid using the word 
“custom” 

• Printing Type: Choose a printing type to define the formatting for printed and 
emailed transactions that use this custom form 

• PDF Layout: Select the form that determines how the form is printed 

• HTML Layout: Select the form that determines how the form is emailed 

• Disclaimer: Enter a message to appear at the bottom on the form 

• Address: You can enter a different company address to appear on this form  

• Allow Add Multiple: Turn off the Add Multiple button on any forms that rely on 
custom code line item validation scripts. 

 
Save versus Save & Move Elements 

• Save will save your changes 
Save & Move Elements allows further customization, such as moving fields from 

one subtab to another 
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Review Form Elements 
 

Review all the elements and subtabs: 

• Tabs 

• Field Groups  

• Screen 
Fields 

• Actions 

• Sublists  

• Printing 
Fields 

• Quickview  

• Roles 

• Linked 
Forms  

 

 

 

Walkthrough: Customize Transaction Form – Actions, Roles & Linked Forms 

 

Use Case/Scenario:  Continue with customizing a sales order form: 

• Consider changing the display of actions; change from a button to an item under 
the Actions or change an item under the Actions menu to a button 

• Link the sales order to a standard product invoice 
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Consider Actions 
 
The Actions subtab on the form provides access to customize standard and custom 
actions: 

• Standard actions: rename, hide, or change from an inline button display to a 
menu item 

• Custom actions: rename and change from inline buttons to being listed as a 
menu item 

 

Important! The Save, Cancel, Reset, Edit and Back buttons are not customizable.  

These are used for basic, core processing. 

 
Look at Roles and Linked Forms 

 

Go to the Roles subtab: 

 

• Roles controls the ability to make the form preferred for everyone (in main area) 
or for a specific role 

• Sort the list by role name 

• Make this the preferred form for any standard or custom role 
o Select Preferred for any given role (s) 
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Go to the Linked Forms subtab 
 

 

Link Forms together creating a preferred workflow to guide users: 

• Guide users from one form to another, systematically 

• Define the default transaction forms involved when you convert one 
transaction into another; thus, creating a chain of transaction forms that mirror 
your business workflow. 
o  For example, when a sales order is used to print a picking ticket, the 

custom picking ticket form selected on the sales order form is used by 
default. 

o  Another example: A company has three custom sales order forms, each 
form used for a certain set of items they sell.  

▪ When one of these sales orders is used to create a picking ticket, 
the specific picking ticket form created for each type of sales order 
is used. 

▪ The employee creating the picking ticket does not have to search 
for the custom form dropdown to find the proper picking ticket form. 

• To set up this form workflow, the administrator edits the custom sales order form, 
and selects the picking ticket form on the Linked Forms subtab. 

 

Now It’s Your Turn 
 

 
 
Use Case/Scenario: 

• Customize the PDF layout for the look and feel 

• Assign it to a customized sales order and test the new form 

• Allow 10 – 15 minutes 
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Exercise 03: Custom Transaction Forms - PDF Layouts 
Scenario: Chatham Company wants a custom, printed version of the Sales Order form to capture some 

of their custom fields. 

In this exercise: 

 Customize the Sales Order print layout for Page Size, Preferred form, and some color 

considerations. 

Customize the Transaction Form PDF Layout 

 Go to Customization > Forms > Transaction Form PDF Layouts. 

 Click Customize next to the Standard Transaction Layout. 

 On the Custom PDF Layout page, enter the following information: 

a. Name: Chatham Order Layout 

b. Page Size: Letter 

c. Layout is Preferred: (leave blank, uncheck) 

 Change Label Fill Color to Black (#000000). 

 Change Border Color to Black (#000000). 

 Scroll down and find the Add Custom Element button and click it. 

a. In the pop-up window change the Element Name to Deposit Percent.  

b. Choose Element Deposit Percent and select Show Label. 

 

c. Click OK  

 Drag and drop the field to a new location.  
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 Click the Add Custom Element button. 

a. In the pop-up window change the Element Name to Deposit Due.  

b. Choose Element Deposit Due and select Show Label. 

c. Click OK 

 Drag and drop the field to a new location. 

 Click Preview, and make the necessary changes back in the Custom PDF Layout page. 

 Close the Preview tab. 

 Click Save when you are done. 

Customize the Sales Order Form 

 Go to Transactions > Sales > Enter Sales Orders. 

 Select Customize Form from the Customize dropdown list. 

 On the Custom Transaction Form page, enter the following information: 

a. Name: Chatham Sales Order 

b. ID: leave blank, but this can be used with scripting 

c. Printing Type: Basic 

d. PDF Layout: Chatham Order Layout 

e. HTML Layout: (leave as is) 

f. Disclaimer: (leave blank) 

g. Address: (leave blank) 

h. Logo: (leave blank) 

i. Allow Add Multiple: Check 

j. Inactive: (leave blank) 

k. Form is Preferred: (leave blank), uncheck if necessary 

 Click the Screen Fields subtab, Main sublist. 

a. Click the Contact Name and select Primary Information for the Field Grouping; the field 

will move up on the page. 

b. Check Show and select Normal under the Display Type column. 
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c. Click Contact Phone Number and select Primary Information for the Field Grouping; the 

field will move up on the page. 

d. Scroll up to find Contact Phone number; check Show and select Inline Text under the 

Display Type column. 

e. Scroll up and now click the Printing Fields subtab >Body sublist. 

f. Check Contact Name, Contact Phone Number and Deposit Due in the Print/Email 

column. 

 Click Save when you are done. 

Create a Sales Order Transaction 

 Go to Transactions > Sales > Enter Sales Orders. 

 Select Chatham Sales Order, if not already selected, in the Custom Form field 

 Create the Sales Order as you would normally do, start with selecting a Customer, e.g. Test ABC. 

 Make sure to select a Contact Name, e.g. Amy Andrews. 

a. The Contact Phone Number should auto-populate. 

 Select MidWest for the Location (Warehouse). 

 Enter the Percent Deposit Required, e.g. 10. 

 Enter/add one item of your choice. 

 Click Save & Print.  Hint: Click the drop-down arrow to the right of the Save button. 

 You may get a pop-up blocker message.  Please take the appropriate action. 

 

 You should see a PDF layout for the Sales Order that has the Contact Name and Contact Phone 

Number, as well as the Deposit Due amount at the top of the right-hand side of the form. 

 It may require some refining, such as removing some print fields, but you can do that at your 

convenience. 

 Close that browser tab, with the print view of the sales order. 

 Click Home. 
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Transaction Forms Best Practices 
 

Consider these best practices when working with transaction forms: 

• Create a naming convention for custom forms 
o Standard form remains in NetSuite as a template 

• Create different form versions for different Roles 
o Define as preferred and use form for pop-ups if it is Preferred 

• Define a custom field as mandatory on your custom form 
o Do not define it as mandatory at the field level 
o Enables using that custom form on other forms if needed 

• Rename standard fields to match your business process 

• Edit PDF layout for printed version 

• Edit HTML layout for emailed version 

• Use Printing Fields to determine what to Print/Email 
 

 
Activity: Customizing Forms 

 

Can you answer the following questions? 

• True or False: Develop a naming convention for your custom forms and layouts, 
as a best practice 
 

• Which layout controls the printed look of transaction forms? 
 

• How do you create a transaction workflow? 
 

• True or False: Editing the PDF layout uses point and click functionality.  
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Consider Advanced PDF/HTML Templates  
 

Investigate the Advanced PDF/HTML Templates (Beta) feature, which provides 

expanded transaction form customization capabilities: 

• Go to Setup > Company > Enable Features > SuiteCloud subtab, 
SuiteBuilder section and select Advanced PDF/HTML Templates 

• These templates introduce a template-based model for print customization, and 
to allow you to try it out on a selected set of transactions. 

• Transactions currently supported include: cash refund, cash sale, credit memo, 
customer deposit, invoice, packing slip, payment voucher, picking ticket, 
purchase order, quote (estimate), return authorization, and sales order 
templates. 

• Please refer to SuiteAnswers for more information 
 

Additional Resources 
 

NetSuite Help Center: 
▪ SuiteBuilder Guide 
▪ Encrypting Custom Field Stored Values 
▪ Customizing Delete Behavior for Records Referenced by Custom Fields  

 
SuiteAnswers Learning Center:  

• New Feature Training 

• Customization/Integration 
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Create Custom Records 

 
About this Module 

 

Custom subtabs, lists and fields will serve some of our needs. However, we are unsure 

about how to capture employee and customer information that will support us over time: 

▪ What is the best way to track events or activities against an employee or 

customer? 

▪ If adding custom fields becomes too tedious, are there other options? 

▪ How could we create a new type of form, that is not an entity or 

transaction form? 

▪ What if we need to track information, which is not supported by a standard 

record type? 

▪ Can I create two custom fields; the choice made in the first field 

determines the available options in the next field? 
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Activity: Is this a good way to track employee training events? 
 

We want to track courses that our employees take; we have created a custom subtab, a 

few lists, and custom fields. Will this be scalable and work for us over time regarding: 

• Display? 

• Functionality? 

• Practicality?  

 

Custom Record Overview 
 

 
A custom record will meet the needs of tracking unique records: 

• A standard record of Entity, Item, Transaction, or CRM does not meet your 
requirements  

• Too many custom fields are required, making maintenance and usability difficult 

• A One-to-Many Relationship (1:M) is required or unique Parent: Child 
relationships:  

o NetSuite uses a custom record to capture course evaluations 
o The parent record is a course and the child records are all the evaluations 

for the course 

• An online entry form needed (not Lead, not Case) 
o NetSuite created a form for the evaluation completion and submission 

• Provides a new form, e.g. Employee Courses 

• Presents a list of the records, e.g. Employee Courses List and connects to the 
parent record, employee 
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Walkthrough: Create a Custom Record Type 
 

 
 
Use Case/Scenario: We need to track courses that our employees complete: 

• We need to enable the feature and then start defining the record 

• We want both a list of these courses and see information on the employee 
record. 

 
Enable the Feature 

 

To use custom records, the Setup > Company > Enable Features > SuiteCloud 

subtab > SuiteBuilder section and select Custom Records: 

• If you have not already done so, you may be prompted to view SuiteCloud Terms of 

Service 

 
 

Once the feature has been enabled, creating a custom record follows a sequence of 

actions: 

• Define record attributes and behavior 

• Create necessary subtabs and save to create the record in the database 

• Create custom fields and define other elements of the custom record 
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Define Record Attributes, Behavior and Subtabs 
 
Use Case: 
Track courses that our employees complete 
 
Define some basic attributes and behavior as the first step: 

• Go to Customization > Lists, Records, & Fields > Record Types > New 

• The Custom Record Type page opens 

 
 

• At the top of the page, define some basics: 
o Enter the Name for the record type, e.g. Employee Courses 
o Set display options and available actions: 

▪ Access Type: choose one of the three options to meet your needs. 
The default is to require the custom record permission 

▪ Records are Ordered: Edit the order of the records on the parent 
record, otherwise, it will be alphabetical 

▪ Enable Optimistic Locking: enable to protect custom record data 
integrity. Optimistic locking assumes that multiple concurrent 
transactions can usually complete without affecting each other, so 
data resources do not have to be locked while transactions are in 
process. Instead, a check for conflicts occurs before each 
transaction is committed. 

▪ Enable Inline Editing: custom record data to be is editable on lists 
▪ Show Creation Date: On Record or On List.  Check On List if: 

• Creation Date needs to be displayed in a List view 

• Creation Date needs to be viewed as a sublist from a Parent 
record 

  



 

 

63 
 

▪ Show Last Modified: On Record or On List.  Check On List if: 

• Last Modified needs to be displayed in a List view 

• Last Modified needs to be viewed as a sublist from a Parent 
record 

▪ Show Owner: On Record or On List.  Check On List if: 

• Show Owner needs to be displayed in a List view 

• Show Owner needs to be viewed as a sublist from a Parent 
record 

▪ Show Owner: Allow Change: allows users to be selected from a 
list when the record is entered, instead of using the current user. 

• Review field help for other check boxes; consider your business requirements 
Scroll down on the page to Subtabs: 

• Define Subtabs, for example in the use case  
o Courses 
o Evaluation (this might have instructor’s evaluation of the student) 

• Save the record so that it is created in the database, and then proceed to create 
Fields and other customizations 

o After saving the Custom Record, additional field and subtabs appear: 
 

Walkthrough: Add Fields and Assign Links for the Custom Record 
 

 
 
Use Case/Scenario:  

• Add fields: available courses, start and end dates for each course, difficulty level 
of each course, and instructor comments 

• Assign the fields to the appropriate subtab 

• Review other subtabs on custom record 

• Assign links for user navigation 

• Test the form 
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Add Fields 
 

Once the custom record has been created, a Fields subtab displays.  Create fields and 
add to the appropriate subtab; consider which custom field type best serves your 
purpose. 

• Go to Fields subtab 

• Click New Field button, for example in the use case  
o List/Record for a list of courses, assign to Courses subtab 
o Date field for the start date of the course, assign to Courses subtab 
o Date field for the end date of the course, assign to Courses subtab 
o List/Record for a list of difficulty levels, assign to Evaluation subtab 
o List/Record for a list of student ratings, assign to Evaluation subtab 
o Long Text for instructor comments about the student 

• Enter in the information 
o This is the same as creating other custom fields 
o On the Display subtab, you will choose one of your custom records 

Subtab 
o Set any other field definitions 
o Save 

• To edit any field, click on the field name 

 
 

  



 

 

65 
 

Assign Links for User Navigation 
Define the location for users to access the custom records: 

• Go the Links subtab to map out navigation:  
o Define the Centers for the custom record, e.g. Classic 
o Define the Section for each Center, e.g. Lists 
o Enter in a label to identify the menu item for the custom record 

▪ In the example use case - Lists > Custom > Courses 
Note: Numbering (Numbering subtab) can be enabled at this point, however the 
recommendation is to do this later after records have been in use for a while.  Once a 
record is numbered, it cannot be un-numbered 
 

 
 

Review Permissions 
 

Review the Permissions subtab:  

 

• Human Resources will enter, view, and edit the record 

• Employees can view the records 
 

Go the record header: 

 

• Set the Access field to Use Permissions 

• Note: The Best practice is to not set the field until the form is ready to use 
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Test the Form 
Open the form and evaluate the look and functionality 

• Follow the navigation as defined in the Links, e.g. Lists > Custom > Employee 
Courses 

• View the form and make note of changes you might want to make; for our use 
case: 

o Rearrange the subtabs 
o Remove the Name field; we would rather have the user select from a list 

of employees 
 

 
 

Walkthrough: Edit the Custom Record and Form 
 

 
Use Case/Scenario: After the assessment of the form, we want to: 

• Rearrange the subtabs and remove the Include Name Field 

• Link the course record to the employee record; populate employee job title 

• Confirm that we can see a list of courses taken by employees 

• Add a new course from an employee record  
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Edit the Custom Record 
 
Use Case: Rearrange the subtabs and remove the Include Name Field. Have the 

course record linked to the employee record and populate the employee job title 

Go to Customization > Lists, Records, & Fields, click the record name: 

 

• Uncheck Include Name Field 

• Go to the Forms subtab: 
o Click Customize for the Standard Employee Course Form 
o Enter a Name, use a naming convention 
o Select Form is Preferred  

• Change the order of the Subtabs, for example: 
o Courses 
o Evaluations 
o Notes File Cabinet 
o Workflow  
o Custom 

• Click Save to save the new form 
 

Add Parent-Child Field 
 
Click New Field to add a List/Record type of field and point to the parent record: 

 
• Enter a Label, e.g. Employee Student  

• In the new field select Type – List/Record 

• In the List/Record field chose the record to point to, e.g. Employee 

• Select Record is Parent; establishes the 1:M relationship (Parent: child) 
o Like creating a foreign key in relational database world 

• On the Display subtab: 
o Leave Subtab blank 
o Select Human Resources for Parent Subtab 

• Save & New 
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Source Information from another Record 
 

The employee’s job title needs to be captured:  

 

• Add another field to display the job title; the display type should be inline text 

• Pull the job title from the employee record 

• Enter a Label, e.g. Job Title 

• Choose the correct field Type, e.g.  Free-Form Text 

• Go to Sourcing & Filtering to define from where the information is coming 
o Source List = Employee Student  
o Source From = Job Title 

• Save 
 

Test the Form  
 

Open the form and evaluate the look and functionality. 

Use Case: Review the functionality to confirm 1) that we can see a list of courses taken 
by employees and 2) we can add a new course from an employee record 

• Follow the navigation as defined in the Links, e.g. Lists > Custom > Employee 
Courses > New 

 
• Validate the following: 

o Can you select the Student Employee? 
o Does the Job Title populate? 
o Which subtabs are available and in what order? 
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View the Custom Record in Different Locations 
 

Once the form is completed for a student and saved, it is available: 

• In a list of Courses Taken by Employees 

 
• On the employee record Human Resources subtab, TDSS Employee Courses 

sublist 

 
 

Create or Modify from the Parent Record 
 

Go to an Employee record, Human Resources subtab, Employee Courses sublist: 

▪ Click Edit to modify existing record 

▪ Click New to create new records 

 

Now It’s Your Turn 
 

 
Use Case/Scenario: On each customer record, we want to track the following: 

• Credit checked: yes or no 

• Risk/Rating value 

• Rating explanation 

• Allow 10-15 minutes 
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Exercise 01: Create Custom Records 
Time: 15-20 minutes 

Scenario: Chatham Company tracks the credit risk/rating of each customer. On each customer record, 

we need to track the following: 

 Credit Checked (yes or no) 

 Risk/Rating (dropdown list of two values) 

 Reference 

In this exercise: 

 Enable custom records 

 Create custom List 

 Create a custom record 

 Create custom fields 

Enable Feature 

 Go to Setup > Company > Enable Features. 

 Click the SuiteCloud subtab.  

 Under SuiteBuilder, check Custom Records. If Item Options are already checked, then do not 

change. 

a. If unchecked, check the box and agree to the terms. 

 Click Save. 

Create Custom List 

 Go to Customization > Lists, Records, & Fields > Lists > New. 

 Add a new Custom List named Credit Rating. 

 Show options in: the order entered.  

 Enter and Add each of the following items under the Value column: 

a. Risky 

b. Worthy 

 Click Save.  

  



 

 

71 
 

Create the New Record Type 

 Go to Customization > Lists, Records, & Fields > Record Types > New. 

 Make the following field modifications: 

a. Name: Credit Risk/Rating 

b. Include Name Field: uncheck, because we will be creating a parent: child relationship via 

a custom field 

c. Show Creation Date on List: check 

d. Show Last Modified on Record: check 

e. Show Owner on Record and Allow Change 

f. Access Type: Leave as - Require Custom Record Entries Permission 

 Go to Subtabs subtab and enter under Title: Rating, click Add. 

 Click Save. 

 On the Record Types page, click Credit Risk/Rating 

Create New Field for Customer (Parent) and Credit Rating 

 Click the New Field button on the Fields subtab. 

 Make the following field modifications: 

a. Label: Customer 

b. ID: _credit_cus 

c. Type: List/Record 

d. List/Record: Customer 

e. Store Value: Check 

f. Show in List: check 

g. Record is Parent: check 

 Enter the following information in the Display subtab: 

a. Subtab: leave blank 

b. Display Type: Normal 

c. Parent Subtab: Financial 

 Click Save & New, to save and add another field. 
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 Make the following field modifications: 

h. Label: Credit Reviewed 

i. ID: _credit_reviewed 

j. Type: Check Box 

k. Store Value: check 

l. Show in List: check 

 Enter the following information in the Display subtab: 

a. Subtab: Rating 

b. Display Type: Normal 

c. Normally you would also enter useful Help for this custom field 

 Click Save & New, to save and add another field for a list of value for Risk Rating 

 Make the following field modifications: 

m. Label: Risk Rating 

n. ID: _risk_rating 

o. Type: List/Record 

p. List/Record: Credit Rating  

q. Store Value: check 

r. Show in List: check 

 Enter the following information in the Display subtab: 

a. Subtab: Rating 

b. Display Type: Normal 
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 Click Save. 

 Review the Fields subtab and the list of fields. 

 

You should now be back on the Custom Record Type page 

 Click Links subtab. 

 Enter the following on the first line: 

s. Center: Classic Center 

t. Section: Lists 

u. Category: Custom 

v. Link: Credit Risk/Rating 

w. Label: Customer Credit Risk/Rating 

 Click Add.  

 Click Save when you are done. 

 Note: You may see the following Notice: Items you have requested in the record have been 

deleted since you retrieved the form 

Test the custom record 

 Go to Lists > Custom > Customer Credit Risk/Rating 

 Click the New Credit Risk/Rating button. 

 Enter the Customer as TEST ABC. 

 Navigate to the Rating subtab and enter the following: 

a. Credit Reviewed = Check 

b. Risk Rating = Select Worthy 
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 Click Save. 

 Enter TEST ABC in to (Global) Search. 

a. View the record. 

b. Click the Financial subtab. 

b. Click Credit Risk/Rating sublist and confirm that your credit rating information is there. 

 End. 
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Dependent Dropdowns Overview 
 
Use Case: Allow a support rep to use a customized case form to 1) select operating 

system being used by the employee and 2) select the supported browser being used by 

the employee 

In a “dynamic” list; selecting a value in first field provides a set of related choices in the 

second field: 

• Can be multiple levels deep 

• Association between lists is achieved by adding a filter that relates one list to 
another  

 
Introduction to Optional Exercise 

 
Use Case/Scenario: Allow a support rep to use a customized case form to: 

• Select the operating system being used by the employee and 

• Select the supported browser being used by the employee 
 

Custom List: Operating Systems 
 
Create a custom list of operating systems used by employees: 

• Go to Customization > Lists, Records & Fields > Lists > New  
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Custom Compatible Browsers with Field for Operating System 

 

Create a new record for compatible browsers: 

•  Go to Customization > Lists, Records & Fields > Records > New - “Compatible 
Browsers” and Save 

•  Add a new Multiple Select field for Operating System, points to our Operating 
Systems list  

 
Create Combination of Operating Systems and Browsers 

 
Now we want to define the combinations:  

• Go to Customization > Lists, Records & Fields > Records and click List for 
Compatible Browsers 

 
• In the Compatible Browser List, click the New Compatible Browser button 

start entering your combinations and save each combination e.g. Internet 
Explorer and Google Chrome 

 
 
  



 

 

77 
 

Create a Custom Case Form 
 
Enable the CRM – Customer Support Feature 

Create a custom case form that will allow a support rep to enter a case and choose: 

•  Operating System 

•  Browser 

•  Windows XP works with Google Chrome 

 
 

Now It’s Your Turn – Optional Exercise 
 
Go the Appendix in this book 

 

Use Case/Scenario: Use Dependent Dropdowns to allow Support Reps to: 

• Open a support case 

• User custom fields on the case record to select user’s operating system and one 
of the supported browsers 

• Allow 20 - 30 minutes 
 

Troubleshooting Custom Records 
 
It is important to test incrementally as you work with custom records and elements: 

• If the custom element doesn’t display or doesn’t accept changes made: 
o Log out and in again 
o Clear the cache on your browser 
o Try using a different browser 

 

• When all fails, call NetSuite Support 
o Walk through creation steps 
o If possible, compare live account to functioning test account 
o Log a case first; continue working on the issue 

 

• Use other Help resources (Online Help, User Group, NetSuite Support Center)  
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Custom Records Best Practices 
 
Consider the following best practices for custom records: 

• Create custom records when 1:M (1: Many) is required 

• Save your custom record first, then add fields  

• Include a List/Record field and define Record is Parent; establish the Parent: 
Child (1:M) relationship 

• On Custom Records, use Show in List for the record’s custom fields 

• Use Permissions only when the custom record is ready to be used 

• If you choose to, you can create a subtab on the Parent record to receive the 
custom record 

• Create dependent dropdowns by creating custom lists and records, and applying 
filters to limit the results 

 
Activity: Custom Records 

 

• What are some factors in considering a custom record? 
 

• What kind of field do you need to add to create the Parent: child relationship? 
 

• True or False: NetSuite creates a form for your custom record 
 

• True or False: Dependent dropdowns can be multiple levels deep? 
 

Additional Resources 
 

NetSuite Help Center: 

• SuiteBuilder Guide User Guide 

• Custom Records 

• Multiple Dependent Dropdowns 
 

SuiteAnswers Learning Center: Training Videos 

• New Feature Training  

• Customization/Integration 
 
Access video from NetSuite Essential tab, in this demo account: 

• Day 2 - Customization: SuiteBuilder Custom Records 
 
If you are interested in an optional exercise, Create Dependent Drop Downs, then 
go to the Appendix of this workbook 
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Migrate Your Data 

 

About this Module 
My company will occasionally need to bring in new data or even update data and I am 

wondering: 

• Is data migration complex and time consuming? 

• Can I update data through some sort of import? 

• What are the related tasks that an administrator should complete? 

• Are there any data migration tips? 
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Data Migration Overview 
 

Data migration may be a key to adding new data into your NetSuite Account, such as a 

purchased list of leads.  

Successful migration has the following, key phases: 

• Identify the data objects that need to be migrated  

• Determine an import strategy for data migration  

• Prepare the data for import 

• Use the Import Assistant 
 

Data Migration Considerations 
 
The following are some questions and considerations for data migration: 

• How much CRM or transaction history needs to be migrated to the new system? 

• How will you enter in opening balances? 

• How do you know what is available in NetSuite and what to add? 
o Will you need to do any customization in NetSuite first? 

• How will you handle entities with multiple addresses and doing business with 
your various legal entities? 

o Will you be using a OneWorld account; defining subsidiary/entity 
relationships? 

• Do you need to use NetSuite Professional Services or do it yourself? 
 

Activity: Your Data Migration Needs 
 
Will you be bringing in any of the following record types? Comments? 
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Data Migration: Overview of Tasks 
 

Let’s start looking at some of the possible tasks  

 
OneWorld: Set Up Subsidiaries 

 
If you have a OneWorld account then subsidiary data must be in place, for example: 

• Tax nexus 

• Currency 

• Go to Setup > Company > Subsidiaries > New 
 

Follow a Suggested Sequence 
 
You are setting up a shell into which the data is imported; a logical sequence, for 

imports, should be followed due to the relationship between the data: 

 

• Classifications, if enabled: Department, location, class 
o Departments: Are usually groupings per management responsibilities 
o Locations: Are usually groupings per geography 
o 1:1 relationships with subsidiaries 
o Classes: Are used for more general groupings 

• Chart of Accounts:  
o Turn on auto-generated numbers if necessary 
o Remember that NetSuite also provides a standard list of accounts 

• Employees:  
o Sales reps and support reps may need to be available for assignment to 

imported records 
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Best Practices: Classifications and Chart of Accounts 
 

• If needed, set up classifications (D/L/C) prior to import 

• Use the provided Chart of Accounts: 
o Rename accounts to your company’s naming convention; use the 

renamed accounts in NetSuite, not your pre-existing accounts 
o If importing accounts with account numbers, define the preference at 

Setup > Accounting > Accounting Preferences 
 

Consider Auto-Generated Numbers Feature 
 

Review the setting for Auto-Generated numbers of entity records.  This is an important 

consideration/decision to be made before importing existing data.  Once you enable 

auto generate numbers, you cannot switch back. 

 

• Go to Setup > Company > Auto-Generated Numbers 
o Enable auto-generated numbers to have NetSuite generate IDs for your 

Entities: 
o This option is beneficial when you have multiple customers with the same 

name. Using auto-numbers ensures all your customer records are unique.  
o The concept of using numbers along with names or a prefix (C = 

customer, V = vendor) is a consideration.  

• Check Allow Override to import your legacy entity IDs 
o NetSuite concatenates the auto-generated number with the company 

name. As a result, you can search for the Customer in NetSuite using 
Global Search by name or number 

• Update: Is used to auto-number records that have not been previously 
numbered. 

o The Update box cannot be checked if you have checked the Locations 
box or the Subsidiaries box. 

o Review Help for other behavior of the Update function 

• Use External IDs when importing entities; External IDs make it easier to import 
transactions and CRM records by avoiding use of Entity IDs: 

o Entities with parent/child relationships 
o Entities using auto-generated numbers 
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In the Import Assistant define the Import Type and Record Type: 

 

• Import Type: Employees 
o Available Record Types: Employees, Expense Report, Track Time 

• Import Type: Relationships and select from available Record Types: 
o Contacts Only 
o Customers and Contacts Together 
o Customers Only 
o Leads and Contacts Together 
o Leads Only 
o Partners 
o Prospects and Contacts Together 
o Prospects Only 
o Vendors 

 
Considering the following best practices for customer and contacts: 

• Import Customer records first 

• Import Contact records second  

• Consider values associated with Global Subscription Status field 
o A marketing automation consideration 

• Designate one address as the primary address when importing multiple 
addresses 

 
CRM and Other Records 

 

Activities and Communications support importing in some CRM Data: 

• Tasks, Messages, Notes 
 
Please review Release Notes and Help topics in SuiteAnswers for newly support 
records for import: 

• Each release, NetSuite adds to the list of supported record types 
 
Use Web Services/SuiteTalk to import unsupported record types 

• Please refer to the CSV Imports Overview in the NetSuite Help Center 
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Import ERP Data 
 
ERP and transaction records are associated with entity or relationship records: 

• Items - if you have enabled the corresponding features: 
o Inventory items, serial and lot numbered, matrix items, assemblies, kits 
o Non-inventory items (sale, resale, purchase) 
o Service items (sale, resale, purchase) 

• Transactions can be Posting or Non-posting:  
o Account Receivables such as: Opportunities, Estimates 
o Accounts Payables such as: Purchase Orders, Bills, Vendor Payments 
o Journal Entries 

 
Best Practices: Items 

 

• Enter a beginning inventory cost  

• Use the Adjust Inventory Worksheet to enter starting inventory quantity (just 
before going live!) 

o Must do some setup for matrix items (other lists) 
 

The following items may be imported, if you have enabled their corresponding features: 

• Can import inventory items, matrix items 

• Can import serial inventory numbers  

• Can import lots, assemblies, kits 

• Can import non-inventory items (sale, resale, purchase) 

• Can import service items (sale, resale, purchase) 
 

Best Practices: Transactions 
 

• Do not import large numbers of historical transactions – storage will cost you 
o The storage space allowed is listed on your sales order 

• Use ‘entity account names’ and numbers when importing transactions, not the 
Chart of Accounts number 

• Keep in mind that imported transactions will behave just as if they were created 
in the User interface: 

o For example: If you import an Invoice or a Vendor Bill with Inventory 
Items, then that transaction WILL affect inventory 
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Activity: True or False 

 

Data Import Preparation 
 
Preparation for Data Import is crucial to have a successful import: 

• Review existing data and scrub the data 

• Determine import options 

• Determine how to map from existing application into NetSuite 

• Create a .csv template 

• Run test imports 

• Resolve errors 

• Plan for the data migration 

• Execute the data import 

• Resolve any errors 

• Review data validity, have a sign off 

• Importing Employees Example 
 

Walkthrough: Import Employees 
 

 

Use Case: Our Company will be acquiring another company, and the employees, and 
we need a way to quickly bring in new employee records. 
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Review and Determine Options 

Review how NetSuite stores a record, for example an employee record: 

 

• Go to Lists > Employees > Employees > New to review a New Employee form 

• What are the available fields? 

• How does NetSuite handle the data? 
o We notice that Employee ID is Copied From Name 

 
Create a.csv Template 

 
View any list of records in NetSuite, to export out a .csv file: 

• We want to go to Lists > Employees > Employees 
o Select the View that displays the most appropriate columns, e.g. Basic 

• Select the Export – CSV icon  at the top of the list 
o Open the new file 
o Enter new values into your template and save as .csv 

 

 

You can use an empty list of record, just review the columns and set the View 
to show the columns that you want 

 
Template-Based Imports: Here are some imports that can be performed using the 
template-based approach: 

•  Journal Import 

•  Bulk Fulfill Orders Using a CSV Import 

•  Importing a Vendor Price List 

•  Importing Keyword Campaigns 

•  Importing Employee Commission Data 

•  Importing Budgets  
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Import the Revised .csv File 
 
Go to Setup > Import/Export > Import CSV Records and complete the following 
steps: 

• Scan & Upload CSV File 

• Define Data Handling 

• Correctly define Field Mapping 

o For example: Map Name to Employee ID 

 

 
Save and Run 

 
Save and Run the import; saves the mapping for future use: 

• View confirmation message 

 
• View Import Job Status: goal is to have Complete at 100% and all records 

imported successfully 

 
• View List of Employees, to see our additions 

 
 

Walkthrough: Import Assistant – Your Exercise 

 

Use Case: Import in customers – This is a preview of one of your exercises  
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Scan & Upload CSV File 
 
Go to Setup > Import/Export > Import CSV Records and Scan & Upload CSV File: 

 

• Select Import Type, e.g. Relationships 

• Select the Record Type, e.g. Customers Only 

• Define Character Encoding 
o Use Character Encoding UTF – 8 if you have special characters to import 

(umlauts, accents or characters such as Chinese) 

• Select File, review the file name and click Next 
 

Import Options 
 
Select one of the Data Handling options based on whether you are importing new data 

or updating existing data and consider Advanced Options: 

 

• Add 

• Update 

• Add or Update: If using Add or Update, turn off Auto Generated Numbers 
 
Advanced Options: 

• Review each option and select as required by your business needs 

• Use “Overwrite Missing Fields” and “Add or Update” if you need to remove data 
from a record.   

o Include Name/ID and field you want to empty, data on existing records will 
be deleted 

• Note that you can also Validate Mandatory Custom Fields 

• Select Prevent Duplicate Records; this works in tandem with the feature 
“Duplicate Detection” 

o Uses the criteria defined in Setup > Company > Duplicate Detection 

• Click Next 
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Field Mapping 
 

 

The most critical step is mapping Your Fields to NetSuite Fields: 

• The CSV file was scanned and NetSuite has done a preliminary mapping 

• Left-hand column represents Your Fields (columns) in your file 

• Right-hand column represents NetSuite Fields (columns) 

• Center column shows the preliminary mapping, now you need to complete the 
mapping 

o Edit the field to set a default value, by clicking the pencil icon  
o Find a blank line and add Your Fields to the corresponding NetSuite 

Fields by clicking on the field names in the left or right-hand columns; 
alternately you can drag and drop fields into the center column 

• Click Next when you are done mapping 
 

Save Mapping & Start Import 

 
Saving the import map enables you to create your own template for future imports with 

same data structure: 

• Import Map Name: provide a unique name to save your mapping and use for 
future imports 

• Description: provide an optional description 

• Script ID: provide a unique ID to identify this mapping to pull into SuiteScripts 
 
When you are ready, do one of the following: 

• Save: saves your mapping and allows you to run the import later 

• Save & Run: saves the mapping and executes the import 

• Run: executes the import but does NOT save your mapping 
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View CSV Import Jobs  
 
If Run or Save and Run selected, a confirmation message displays with a link to View 

the import jobs queue 

 

Or navigate to Setup > Import/Export > View CSV Import Status:  

• Date driven 

• Status 

• Percent Complete 

• Message:  

• CSV Response  

• Click Refresh until jobs show 100% complete 
 

Data Import Best Practices 
 
Use the following best practices to facilitate successful imports: 

• Scrub your data before importing it 

• Save data from other applications into separate CSV files: 
o Exception import Customer/Prospect/Lead with contacts  

• Apply CSV file formatting guidelines: 
o Adjust data to conform to NetSuite file conventions and record types 

• Perform test imports with a sample set of data; use only 2 or 3 records to start 

• Perform import tasks during off-peak hours: 
o Break large jobs into smaller chunks to improve performance 
o The limit is 25,000 records per imported file 

• Identify where the imports will happen, e.g. production or sandbox 
 

OneWorld Best Practices 
 
Additionally, consider these OneWorld account best practices: 

• Setup subsidiary records prior to importing any data 

• CSV file values for subsidiaries should be hierarchical names in the grandparent 
format: Parent: child   

• OneWorld accounts must map NetSuite subsidiary field to a field in the .CSV file 
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Next Steps 

 
 
Use Case/Scenario: Your company needs to be able to import in entity records: 

• Review the setting for auto-generated numbers 

• Import in a list of new customers 

• Update existing customer records with annual revenue 

• Create a template to use for future imports of vendor records 

• Allow 30-40 minutes 
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Exercise 01: Review Auto-Generated Number Settings 
Time: 1-2 minutes 

Scenario: Your Company is not assigning numbers to entities; in this exercise: 

 Validate that you have turned off the Auto-Generated Numbers feature from an earlier 

exercise. 

 Navigate to Setup > Company > Auto-Generated Numbers. 

 Under the Entities subtab, there should be no checkmarks!  

 If there are: Uncheck Subcustomer and Job; then uncheck Customers. 

a. Subpartner may be checked, but grayed out.  This is okay. 

 Click Save. 

 End. 
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Exercise 02: Import Customers 
Time: 10-15 minutes 

Scenario: Chatham Company has completed their NetSuite customization, facilitating capture of the 

additional customer information. They are ready for data migration of a list of their customers. They will 

import using the NetSuite Import Assistant. 

In this exercise: 

 Use a csv file we provide 

 Use the Import Assistant to import the csv file. 

Get CSV file 

 Download OneWorld Customers Industry_dups.csv file from https://tinyurl.com/NSOWcustdup 

place it on your desktop. 

Confirm or Enable features 

 Go to Setup > Enable Features > SuiteCloud subtab: 

 In the SuiteScript section confirm or select the following features: 

a. Client SuiteScript and agree to terms popup, if necessary. 

b. Server SuiteScript and agree to terms popup, if necessary. 

 Save 

Get to Import Assistant 

 Navigate to Setup > Import/Export > Import CSV Records. 

 Review the message in the Welcome to the Import Assistant window, and then click the Get 

Started! button. 

Step 1: Scan and Upload CSV File 

 From the Import Type dropdown list, select Relationships. 

 From the Record Type dropdown list, select Customers Only.  

 Leave the default values for Character Encoding, CSV Column Delimiter, and CSV File(s) (one file 

to upload). 

 Click the Select… button and browse to your desktop to locate the file OneWorld Customers 

Industry_dups.csv. Select this file and click Open.  

 Click the Next button to go to Step 2 of the Import Assistant. 

Step 2: Import Options 

https://tinyurl.com/NSOWcustdup
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 On the Data Handling Step > In the Import Options section, select Add 

a. In the Advanced Options review the options, but do NOT select any.  

b. Prevent Duplicate Records can be useful; however, for purposes of another exercise, 

we do NOT want to prevent duplicates. 

 Click Next. 

 Step 3 is skipped, since we are only importing in a single file 

Step 4: Field Mapping 

 There are three columns to work with on the Mapping page: 

a. Left column: Your fields, from the .csv import file 

b. Central column: 

i. Displays the results of the mapping between your fields and NetSuite fields 

ii. Displays a pencil icon define a field value or default. 

c. Right column: NetSuite fields available  

i. Some NetSuite fields are found in sub folders which need to be expanded 

 In the Central column, map the remaining fields.  

a. Click the pencil icon on any line or blank lines, on the left side of the column, to define 

the value for that entry. 

b. Click Done after each selection. 

CSV Import Fields: Left side NetSuite Fields: Right Side 

Blank, Select Default = No. Individual (Req) 

Select Provide Default Value radio button 

and choose US Dollar or USA 

Currency 

Select Provide Default Value radio button 
and choose Parent Company 

Subsidiary (Req)y 

Select Provide Default Value radio button 
and Alternate Price 1 

Price Level 

Select Provide Default Value radio button 

and Amy Nguyen 

Sales Rep 

 Go to the right column, NetSuite Fields, close the Customer Folder. 

a. Open the Customer Address folder and then open the Customer Address 1 sub folder to 

view the fields available for mapping.  
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 In the Center column, select a blank row, don’t overwrite existing values. 

a. Select values from the NetSuite Fields (right column) first if a value needs to be defined 

for the CSV Import Fields (left column). 

CSV Import Fields: Left side NetSuite Fields: Right Side 

Blank, Default Billing = Yes Address 1: Default Billing 
In the pop-up window, click OK.  NetSuite 

Adds the following field automatically 

Billing Country Customer Address 1: Country (Req) is added 
for us. – (Note: Country field is required, it 
determines the custom form to be used for 

each address) 

 Manually add the following: 

Billing Address 1 Address 1: Label 

Billing Address 1 Address 1: Address 1 

Billing Address 2 Address 1: Address 2 

Billing City Address 1: City 

Billing State/Province Address 1: State 

Billing Zip Address 1: Zip 

 When finished, click Next to go to Step 5 of the Import Assistant. 

Step 5: Save Mapping and Start Import 

 Enter a name in the Import Map Name field, to save and reuse the defined field mapping. For 

example, enter Standard Customer Lists. 

 In the Description field, enter a longer description: e.g. “New Customers”. 

 Click Save & Run.  

 Check the import status at: Setup > Import/Export > View CSV Import Status. 

 Click the Refresh button. The goal is to have the Status Complete, Percent Complete 100%, and 

Message: “12 of 12 records imported successfully”.  

 

  



 

 

96 
 

 Note (Correcting errors):  

a. Click the CSV Response link and open the results.csv file.  

b. First column displays the errors. Note the errors, close the results.csv file. Open csv file 

previously downloaded, correct the errors and try again:  

c. Use the previously saved CSV Import to re-import your customers:  

d. Navigate to Setup > Import/Export > Saved CSV Imports. 

e. Click on your saved CSV Import List link. 

f. Upload the corrected “OneWorld Customers Industry_dups.csv” file. 

g. Repeat Steps 7- 11. (Correct the field mapping if needed). 

h. Click Save and Run (select OK to override the existing saved import). 

i. Navigate to Setup > Import/Export > View CSV Import Status to view the status of your 

new import. 

j. Click the Refresh button until the status is Complete. 

 End. 

 For reference, this is what the mapping should look like 
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Exercise 03: Update Customers Using an Import 
Time: 10-15 minutes 

Scenario: You have completed a customer import. Now you would like to add in Annual Revenue 

information. 

In this exercise: 

 Use the CSV file we provide 

 Use the CSV Import Update feature to correct this problem. 

 Please note that this exercise has an intentional error built in.  At the end, see if you can 

figure out why. You do NOT have to fix it.  

Review the list of customers 

 Navigate to Lists > Relationships > Customers.  

 Confirm that the View filter is set to All at the top of the screen. 

 Scroll all the way to the right; note that there is no information in the Annual Revenue field. 

Access Import Assistant  

 Download to desktop OneWorld Customers Annual Revenue Add.csv file from 

https://tinyurl.com/nsowcustAdd and place on your desktop. 

 Navigate to Setup > Import/Export > Import CSV Records. 

 If displayed, review the message in the Welcome to the Import Assistant window and then click 

the Get Started! button. 

Scan & Upload CSV file 

 From the Import Type dropdown list, select Relationships. 

 From the Record Type dropdown list, select Customers Only.  

 Leave the default values for Character Encoding, CSV Column Delimiter, and CSV File(s) (one file 

to upload). 

 For the CSV File(s) and select One File to Upload. 

 Then go click the Select button for and browse to your desktop to locate the file 

OneWorld_Customers_AnnualRevenue_Add.csv. Select this file and click Open.  

 Click the Next button. 

Import Options 

 In the Import Options section, select Update. Do not select any Advanced Options. 

https://tinyurl.com/nsowcustAdd
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 Click Next. 

a. Note: File Mapping automatically skipped because you are importing only one .csv file. 

Field Mapping – Central column 

 In the Central column, map the remaining fields.  You will notice there are noticeably less fields 

than our last import. We only need to import the fields that we are updating 

CSV Import Fields: Left side NetSuite Fields: Right Side 

Company Name Customer: Company Name 

Annual Revenue  Customer: Annual Revenue 

Inactive Customer: Inactive 

ON A BLANK LINE 
Name (pull from left-hand column) 

ON A BLANK LINE 
Customer: Customer ID (pull from right-
hand column) 

 Tip: If Customer: Annual Revenue is not available you may have set up the custom list 

incorrectly.  

 Hover over Customization > Lists, Records & Fields > Entity Fields and open in a new tab 

 Click on the Annual Revenue field and ensure that Show in List is selected 

 Click Next. 

 Enter a name in the Import Map Name field, Customer Update, so that the field mapping you 

just defined can be saved and re-used later.  

 Click Save & Run. The update will begin. 

 Go to Setup > Import/Export > View CSV Import Status. 

 Click the Refresh button until you see the final results. The goal is to have the Status as 

Complete, the percent complete 100%, but you may not have 11 of 11 records imported or 

another number. 

 For your reference, this is what the mapping should look like. 
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Identifying errors 

 See if you can identify the errors and how you might fix them and write here. 

a. What is the Error? 

b. What is a possible resolution? 

 End. 
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Exercise 04: Create Vendor Import Template (optional) 
Time: 3-5 minutes 

Scenario: You have a list of your vendors available from your existing software application. After 

working with the list, you are now ready to import this list into the NetSuite application. You need to 

build a template. 

In this exercise: 

 Create a template to use to bring in your list 

 Use the Import Assistant provided by NetSuite 

 Test your .csv file with just a few records (only three or four) ensuring the file is set up 

correctly. 

Create an Import Template for Vendors 

 Navigate to Lists > Relationships > Vendors. 

 In the top of the page make sure that View is set to Address 

 Once the list* displays, click the Export-CSV icon in the top portion of the page. 

 

*There may not be any names in the list. This is acceptable. 

 Save to your desktop or a folder you have created. 

 Optional: You could repeat the process to make a template for partners or any other type of 

relationship record.  

 Use this newly-created template to import in a test batch of vendors, maybe 1 or 2.  Fill in the 

information for the following columns. 

a. If displayed, do not enter anything in Internal ID 

b. Fill in a Name 

c. Enter a street address for Billing Address 1 

d. Optional, enter a suite number in Billing Address 2 

e. Enter the city for Billing City 

f. The state or province in Billing State/Province 

g. Enter the Zip Code  
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h. Enter the Billing Country 

i. Do not enter anything under the Billing Address 

j. Do not worry about Date Created and Last Modified 

 Access the Import Assistant, navigate to Setup > Import/Export > Import CSV Records. 

a. Import Type: Relationships 

b. Record Type: Vendors 

c. Leave the defaults for Character Encoding and CSV Column Delimiter 

 CSV File(s) 

a. Leave One File to Upload selected 

b. Go down and click the Select button 

c. Find your CSV saved template and click Open. 

 Click Next. 

 For Import Options, click Add. 

 Click Next. 

 You are now on the Field Mapping.  In the Central column, map the remaining fields.  You will 

notice there are noticeably less fields than our last import. Use the pencil icon to provide default 

values. 

CSV Import Fields: Left side NetSuite Fields: Right Side 

Blank, Select Default = No. Vendor: Individual (Req) 

Blank, Select Default Value = Parent 
Company 

Vendor: Primary Subsidiary (Req) 

 Go to a blank line and add the following: 

CSV Import Fields: Left side NetSuite Fields: Right Side 

Name Company Name 

 Go to the right column, NetSuite Fields, close the Vendor Folder. 

a. Open the Vendor Address folder and then open the Vendor Address 1 sub folder to 

view the fields available for mapping.  
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 In the Center column, select a blank row, don’t overwrite existing values. 

a. Select values from the NetSuite Fields (right column) first if a value needs to be defined 

for the CSV Import Fields (left column). 

CSV Import Fields: Left side NetSuite Fields: Right Side 

Blank, Default Billing = Yes Address 1: Default Billing 
In the pop-up window, click OK.  NetSuite 

Adds the following field automatically 

Billing Country Vendor: Address 1: Country (Req) is added 
for us. – (Note: Country field is required, it 
determines the custom form to be used for 

each address) 

Billing Address 1 Address 1: Label 

Billing Address 1 Address 1: Address 1 

Billing Address 2 Address 1: Address 2 

Billing City Address 1: City 

Billing State/Province Address 1: State 

Billing Zip Address 1: Zip 

 Click Next. 

 Enter a name in the Import Map Name field, e.g. Vendor, so that the field mapping you just 

defined can be saved and re-used later.  

 Click Save & Run. 

 Go to Setup > Import/Export > View CSV Import Status. 

 Click the Refresh button until you see the final results. The goal is to have the Status as 

Complete; the percent complete 100 and the number of successful imported records. 
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 If you need to troubleshoot, you may want to look at your mapping. Here is the correct 

mapping: 

a. Setup > Import/Export > Saved CSV Imports 

b. Click the View link for your vendor import to view the mapping.  Please note that you 

may or may not see an additional field that reads Default Work Calendar and you may 

ignore it. 

 

 End. 
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Solution: Exercise 03: Update Customers Using an Import 

 

Click the Refresh button until you see the results. The goal is to have the Status as Complete, the 

percent complete 100%, and the message may read: 10 of 11 records imported successfully”. 

See if you can identify the errors and how you might fix them and write here. 

What is the Error? Values in our CSV file do not match values in NetSuite, such as a company 

name or annual revenue. 

What is a possible resolution? Research and if necessary, correct the name in the CSV file 
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Activity: Data Migration 
 

Can you answer the following questions? 

• How can you create a .csv template to import records in? 
 

• True or False: Scrub your data before importing 
 

• True or False: You cannot import in contacts and customers together, in one file 
 

• True or False: Consider running imports during off-peak hours  
 

CSV Import Enhancements 
 
With each release, NetSuite provides updates to import capabilities: 

CSV Import Support for Timesheets and Time Entry Records: 

• Enables you and your employees to track hours in a CSV-capable editor and 
then import the data into NetSuite 

o The Timesheets feature is a hidden feature that Support can make visible 
and then enable the feature at Setup > Company > Enable Features > 
Employees subtab 

• In the import assistant, first select Employees as the Import type and then you 
can select the Record Type 

• Review the differences between importing with Time Tracking versus Timesheets 
– Please refer to SuiteAnswers and release notes 

 
CSV Import Enhancements to Support Multi-Book Accounting: 

• Journal Entry and Intercompany Journal Entry record imports are being 
enhanced to support the import to a specific book, necessary for the Multi-Book 
Accounting feature. 

 
CSV Import Impact of Address Enhancements – the enhancements have caused 

changes to entity, transaction, and location imports: 

• Country field is now required; it determines the custom form to be used for each 
address 

o Entity, transaction and location records now require values to be set for 
the Country field 

o If your CSV file does not include a column with values for the Country 
field, the Country field is mapped to a default value of US.  

o You can change this default on the Import Assistant Field Mapping page 
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Additional Resources 
 
NetSuite Help Center: 

• CSV Imports Guide  
 
SuiteAnswers Learning Center 

• New Feature Training  

• Newly Supported Record Types for CSV Import 

• Data Migration 

• Administration/Data 
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Data Integrity 

 

About this Module 
 

Daily, data is populating our account and you should be concerned with: 

• Reducing duplicate records 

• Providing the most current data to my users 

• Ensuring that the data is correct 
 

 

Duplicate Detection & Duplicate Resolution 
 
Define the Duplicate Detection criteria: 

• The defined search criteria are used to identify potential duplicates 

• NetSuite searches for duplicates of customers, contacts, partners, or vendors  
 
Use Entity Duplicate Resolution to choose how to handle duplicate search results: 

• Reviews Contacts, Customers, Vendors, and Partners 

• Define Merge Type 

• Merge information from duplicates into a single master record  
o If merged record and duplicate record have different data for the same 

field, the data in the master record is saved 
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Addressing False Duplicates 
 
Potential duplicate records occur with either matching or similar information; minimize 

false duplicates by reviewing duplicate detection criteria: 

• False duplicates occur when multiple contact records from one company use 
same domain name in their email addresses  

• Review the evaluation of the email field on a company versus contact record; 
this is domain versus full email evaluation 

o Customer: Flagged as a duplicate when domain name portion of the 
address matches, if the domain name is not listed  

o Contact: Flagged only as a duplicate if the entire email address matches 

• Use the NetSuite “Other Relationships” function: 
o Manage an entity that may have multiple roles such as partner who is also 

a vendor 
o Define this on the entity record 

 
Walkthrough: Inline Editing and Duplicate Detection 

 

 
Use Case: As the Administrator, I need to enable the tools and then start working with 
managing potential duplicates; I want to provide users with the most current and correct 
data.  
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Enable Features 
 
The administrator enables the following Data Management features: 

 
• Go to Setup > Company > Enable Features 

• On the Company subtab, Data Management section, ensure that the following 
features are selected: 

o Inline Editing: facilitates updating records while viewing a list of those 
records 

o Duplicate Detection & Merge: allows duplicate detection of various entity 
records and management of the duplicates 

• Click Save 
 
 

Define Duplicate Detection Criteria 
 

Go to Setup > Company > Duplicate Detection to set the evaluation criteria for 

detecting potential duplicates: 

 

• Detection subtab: choose which entities to review 
o Select standard and custom field to be evaluated 

▪ To make a custom entity field available as criteria in duplicate 
detection, check the Store Value check box 

o Define saved search parameters, using “and” logic 
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• Excluded Domains subtab 
o Enter or remove the domains you want to exclude from domain only 

duplicate detection matching 

• Other Preferences subtab: 
o Show Duplicate Warning Popup on Records 

▪ Check this box if you want to present a popup warning when a user 
clicks Save while the cursor is in a duplicate criteria field. 

o Resolve Duplicates with Conflicting Login Access 
▪ If two duplicate records each have login access, but the records 

have different email addresses, they are considered to have 
conflicting login access. 

▪ Choose how you would like to resolve duplicate records that have 
conflicting login access: 

• Manually - Duplicate records with conflicting login access are 
not merged. You must manually remove the login access of 
one of the records before they can be merged. 

• By deleting the duplicates' access - When merging records, 
the login access of duplicate records is deleted when it is 
merged into the master record. 

• Save the criteria; it now will always run in the background 
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Review Entity Duplicate Resolution 
 

Review the search results displaying the listing of potential duplicates: 

 

• Navigate to Lists > Mass Update > Entity Duplicate Resolution 

• Ensure that the View is set to Duplicates 

• Then use the Filters at the top of the page 
o Fields: choose either Basic or Match Fields 
o Entities: select the Entities to review, e.g. Contacts 
o Merge Type: define the action to be taken; more information following 

• Use the Mark All as Dup., Mark All as Not Dup. or Unmark All buttons as 
required when you review the potential duplicates 

 
Merge Type Options Overview 

 

This chart provides more information on the action performed with the different Merge 

Type options: 

• This chart comes from the Help topic on Entity Duplicate Resolution and is 
included in your workbook. 
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Manage Potential Duplicates 
 
Determine the action to take, to properly manage the records: 

 

• Select Master, Duplicate or Not a Dup checkbox for each record shown 
o You can also determine if you want to use the buttons Mark All as Dup. 

or Mark All as Not Duplicate 

• Choose the Merge Type filter for the appropriate action 
o Merge Options: 

▪ Merge duplicates into master record 
▪ Merge duplicates into record created earliest 
▪ Merge duplicates into record with most populated fields 
▪ Merge duplicates into record with most recent activity 

o Delete Options 
▪ Delete duplicates, keep master record 
▪ Delete duplicates, keep record created earliest 
▪ Delete duplicates, keep record with most populated fields 
▪ Delete duplicates, keep record with most recent activity 

o Convert duplicates into sub-records of the master record 

• Click Submit Selected – This action is irreversible 

 
 

Review Duplicate Resolution Status 
 

• NetSuite navigates to the Duplicate Resolution Status page that shows your 
results 
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Review System Notes 
 
NetSuite always tracks each time a record is created and/or changed: 

 
On the System Information subtab, the System Notes sublist, you can review the merge 
of the record: 

o Date and time stamped 
o User identified 
o Merge details provided 

 
Walkthrough: Mass Updates 

 

 
 
Use Case: We want to use mass updates to: 

• Assign a supervisor to multiple employees 

• Reassign a sales rep to different customers 

• Set rules to merge large number of records 

• Change a permission on a custom sales role, view only access of a Cash Sale 
 
The Mass Update feature is an alternative way to update records. You can also update 

records using the Import Assistant.  
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Perform a General Update 
 
Use Case: Assign supervisor to employee records without a supervisor; perform update 
immediately 
 
Navigate to List > Mass Update > Mass Update: 

• Expand General Updates and select the record, e.g. Employee 

• Enter in the Title of Action, e.g. Update Supervisor 

• Define the Criteria – Filter, e.g. any of Supervisor Unassigned 

• Go to Mass Update Fields subtab: 
o Check Supervisor 
o Select Value, e.g. Cathy Cadigan 

• Preview to check / uncheck Apply updates to records 

• Perform Update and view the confirmation 

• Click OK 

 

Perform a Specific Update 
 
Use Case: Reassign sales territories, but schedule for a future date. 

• Go to Lists > Mass Update > Mass Updates 

• Expand Sales Force Automation and select Change Territory Assignment 

• Enter in the Title of Action, e.g. Re-org Sales Territories 

• Select Change Territory To – Default Round-Robin 

• Define the Criteria – Filter: Territory  

• Go to Schedule subtab 

• Check Run According to Schedule, select Single Event, and set date 

• Preview to check / uncheck Apply updates to records 

• Save 
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Merging Large Numbers of Records  
Using the Mass Update functionality, Administrators can set rules to merge an unlimited 

number of records: 

• Go to Lists > Mass Update > Mass Updates and expand Duplicate Resolution 

• Select the Entity, e.g. Customers 

 

• In the Mass Update page: 

 
o Enter in Title of Action 
o Select the Operation 
o Select the Master Selection Mode 
o Select the Record Selection Mode 

• Continue defining the update per your requirements and user criteria to control 
the search results. 
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Mass Update to Permissions on a Custom Role 
 

A specialized mass update to add, remove, or change the level of a permission 

for multiple, custom roles at the same time, instead of editing each role 

individually: 

• This mass update can only be applied to custom roles; do this instead of editing 
each role individually 

• This mass update is not available to customized Customer Center, Employee 
Center, Partner Center, or Vendor Center roles. 

 
Navigate to List > Mass Update > Mass Update: 

• Expand Roles & Permissions and select Add/Edit Permission on Roles 

• Enter in the Title of Action  

• Select Permission and then Level, e.g. Cash Sale set to View 

• Define the criteria, e.g. Center Type = Sales Center  

• Continue defining the update per your requirements and user criteria to control 
the search results 

 

 

Walkthrough: Use Inline Editing 
 

 

Use Case: Quickly update a list of customers to add in year established  

  



 

 

117 
 

Inline Editing at List Level 
 
When viewing any list of records, utilize the Edit switch to use inline editing; for 

example, updating customer records with Year Established: 

 

• Go to Lists > Relationships > Customers, set the View, e.g. Address 

• Click the Edit icon to turn it on inline editing  

• Columns with the pencil icon are available for editing 

• Go to the column to edit, select the line to edit 
o You may use the ctrl key or shift key to select multiple lines or a range of 

lines 
o Make your changes and click out 

• When done, click the Edit icon to turn off inline editing  
 

Now It’s Your Turn 

 

Use Case/Scenario: Take some time to ensure data integrity: 

• Check for potential duplicates, since we have done some imports 

• Schedule an update to reassign customers to a new sales rep 

• Create a saved search for employee records and then use that with inline editing 

• Work with a mass update to perform a calculation - optional  

• Allow 20 - 30 minutes 
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Exercise 01: Identify and Merge Duplicate Records 
Time: 3-5 minutes 

Scenario: The Duplicate Detection tool facilitates data integrity as you in your NetSuite account. As a 

best practice, you should check for duplicate records on a regular basis to protect the integrity of your 

data. 

In this exercise: 

 Define Duplicate Detection Criteria 

 Go to potential duplicates and review page filters 

 Review potential duplicates. 

Define Duplicate Detection Criteria 

 Navigate to Setup > Company > Duplicate Detection. 

 The following settings should be confirmed and updated if required, on the Detection subtab. 

a. Detect Customer Duplicates: Check 

b. Customer Field to Match On: Email (domain only) 

c. Detect Vendor Duplicates: Check 

d. Vendor Field to Match On: Email (domain only) 

e. Detect Partner Duplicates: Check 

f. Partner Fields to Match On: Email (domain only) 

g. Detect Contact Duplicates: Check 

h. Contact Fields to Match On: Email (full) 

 Go to the Other Preferences subtab: 

a. Check Show Duplicate Warning Popup on Records to alert users that they may be 

entering a duplicate record. 

b. Review field help for Resolve Duplicates with Conflicting Login Access 

 Do not change any other settings.  

 Click Save. Read the warning in the pop-up window and click OK. 
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Review potential duplicates 

 Navigate to Lists > Mass Update > Entity Duplicate Resolution. 

 At the top of the page, open the Filters 

 Select Match Fields from the Fields dropdown list. 

 Then select Customers from the Entities dropdown list. The customers with potential duplicate 

fields, based on defined criteria, will display. 

Manage potential duplicates 

 Define that all records are Not Duplicates; in this case, we do NOT have any true duplicates. 

a. Click the Mark All As Not Dup button 

b. Confirm that the Merge Type filter is set to Mark all selected as not duplicates 

 Click Submit Selected.  

 The Duplicate Resolution Status page displays.  Click the Refresh: 

a. The Status shows a green checkmark 

b. # of Entities and # Resolved are the same 

c. # Failed is 0 

 End. 
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Exercise 02: Schedule a Mass Update 
Time: 3-5 minutes 

Scenario: Data integrity may also involve updating a field in many records. 

In this exercise: 

 Schedule a mass update to change the sales rep of existing customers to a new sales rep on 

a specific date. 

 Navigate to Lists > Mass Update > Mass Updates to display the Mass Update page. 

a. Open Sales Force Automation.  

b. Select Change Sales Rep Assignment. 

 Enter Title of Action as Sales Reorg  

 In the Change Sales Rep to field, select Bob Smith from the dropdown list. 

 Under the Criteria subtab, the Filter sublist and select Status 

a. A Mass Update popup window displays. Select any of Customer-Closed Won and Set 

 Click the Schedule subtab. 

a. Check the Run Update According To Schedule box. 

b. Choose Single Event. 

c. Series Start Date: Select December 31st of the current year. 

 Click Save. This mass update will now run on the designated date. 

 You can go to Lists > Mass Update > Saved Mass Updates to view your update. 

a. You could click on the name of the update to edit it. 

 

b. Click on the Preview link to note how many customers will be reassigned. 

c. Click Cancel 

 End. 
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Exercise 03: Create a Saved Search for a List View 
Time: 3-5 minutes 

Scenario: You would like to have a specific view of a list of employees. 

In this exercise, you: 

 Create a saved search that defines the columns when viewing a list of employees 

 You will use this view in the following exercise to use inline editing. 

Access a list of employees and start customizing the view 

 Navigate to Lists > Employees > Employees. 

 Go to the top of the page and set the View filter to All. 

 Click the Customize View button, top-left side of the page. 

 The Customize Employee Search Results: Custom Employee All View page displays.  

a. Enter a Search Title for the search – e.g. XXX: Employee List (XXX your initials) 

b. Click More Options to access all search features. 

c. Tip: To make your saved searches easier to find later, add your initials to the beginning 

or end of the name – e.g. ABC - Employees with new Job Titles  

 Be sure the Available as List View box is checked. 

 

Define criteria and results 

 Go to the Criteria subtab > Standard sublist, set the following Filter criteria: 

a. Select Subsidiary is any of Parent Company and click Set 

b. Select Login Access is NO (false) and click Set. It will then display the Description “is 

false”. 

 Click the Results subtab click Remove All 

 Click the Add Multiple 
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 Resize the pop-up window, to see the vertical scroll bar, and select the following by using the 

Ctrl key on your keyboard; click Add: 

a. Division 

b. Email 

c. Job Title 

d. Login Access 

e. Name 

f. Phone 

g. Subsidiary 

Preview the search 

 Click the Preview button to check the results. Your preview results should a list of names, with 

the columns you specified. 

 Click the Return to Criteria button to refine your search criteria or change the order of the 

columns for your results, if needed. 

 Click Save & Run when you are done to save the results. 

 Go to Lists > Employees > Employees and at the top of the page change the View filter to select 

the saved search that you just created. 

 End. 
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Exercise 04: Set Up and Use Inline Editing 
Time: 3-5 minutes 

Scenario: Chatham Company offices are moving. Some employees are getting new phone extensions. 

Inline editing can facilitate this. 

In this exercise: 

 Confirm that the Inline Editing feature is enables 

 Use inline editing do input phone numbers 

 Navigate to Setup > Company > Enable Features and confirm that you are on the Company 

subtab. 

 In the Data Management section, confirm that Inline Editing is enabled. 

 Click the Save button. 

 Use inline editing; navigate to Lists > Search > Saved Searches. 

 Find the Saved Search (employee search) that you created in the previous exercise. If necessary 

open the filters and be sure to set the filters ALL.  You should be able to find the Employee List 

Saved Search easily if you remembered to save it with your initials as part of the title. 

 Click the View link to view the search results. 

 In the List header, switch the Edit toggle to On.  The system may display a tutorial pop-up 

window.  If so, close it by clicking the “X” in the bottom-right. 

a. A pencil icon displays at the top of the columns to allow you to make changes directly to 

the column fields.  

 Go to the Phone column. Click on the first employee. Add or change their phone number to 

8885551212. Click outside of the phone number field to register the change. 

 When finished with the direct list editing, turn off Edit to disable inline editing. 

Use the system notes validate the changes made 

 Click the View link next to one of the employees whose information that you changed.  

 On the employee's record, click the System Information subtab. Under System Notes, look for 

the record that shows the employee's phone number was changed: Old Value and New Value 

both show. 

 Click Cancel. 

 End. 
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Exercise 05: Perform Mass Update with Calculation (optional) 
Time: 3-5 minutes 

Scenario: Updates may include updating fields with a formula.  

In this exercise: 

 Perform a mass update with a calculation 

 Navigate to Lists > Mass Update > Mass Updates to display the Mass Updates page and open 

General Updates. Select Inventory Item. 

 Under the Results subtab, add Purchase Price to the list to display and click Add. 

 Go to the Mass Update Fields subtab select the following. 

a. Scroll down on the page and find Purchase Price, select the Apply check box. 

b. Tab over to the far, right-hand side to the Formula column, click on the Set Formula 

icon.  

 

 In the pop-up window, do the following: 

a. Select Purchase Price from the Field dropdown; it will display as {cost} in the formula 

box. 

b. After {cost} type in *2. 

c. This calculation doubles the purchase price for your inventory items. 

d. Click Set. 

 Click Preview (Preview enables you to see if you have entered the formula correctly.) 

 You should see Printer Cables displayed with the Purchase Price and New Purchase Prices.  

 

 Click Cancel. 

 End. 
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Activity: Data Integrity 
 

Review these questions after doing the exercises: 

Can you answer the following questions? 

• True or False: Merges are reversible. 
 

• True or False: Inline Editing allows updating information in any column, when 
viewing a list of records 
 

• How should we evaluate email addresses on contact records to minimize false 
duplicates? 
 

• For discussion: How often do you think you will review the results of Entity 
Duplicate Resolution?  
 

 
Additional Resources 

 
NetSuite Help Center: 

• Making Mass Changes or Updates 

• Using Inline Editing 
 
SuiteAnswers Learning Center:  

• New Feature Training  

• Getting Started  

• Administration/Data 
 

Customization and Data Management is done, next ERP Part 1 
 

 

This is the end of the book, the appendix follows 

  



 
 

 
126 

 

 

  



 
 

 
127 

 

 

 

 

 

Workbook Appendices 

The following section is for your reference. 
You must first enable Customer Support to do this exercise:  

Setup > Company > Enable Features > CRM > Customer Support and Service 

Optional Exercise: Create Dependent Dropdowns 

 

Time: 20-30 minutes 

Scenario: Chatham Company supports users on various Operating Systems.  The Support Rep identifies 

which Operating system the user is using and then they follow with targeted questions about which 

operating system-specific Browser they are using. 

Since not all Browsers work with all Operating Systems, Dependent Dropdowns are used on the Support 

Case record to help the Support Rep with this identification task. 

Four custom objects are created in this exercise to support the scenario: 

 Create a custom list of Operating Systems. 

 Create a custom record type containing all the valid combinations of Operating Systems and 

Compatible Browsers. 

 Create a custom List/Record CRM field that points to the list of Operating Systems. 

 Create a custom List/Record CRM field that points to the custom record containing the 

combinations of Operating Systems and Browsers. This field becomes the dependent 

dropdown. The records returned are filtered based on the Operating System selection in the 

other List/Record CRM field. 

Dependent Dropdowns allows users to make the right choices in situations where some options might 

not make sense if selected together. 
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Create a Custom List for Operating Systems (acts as a master list) 

 Go to Customization > Lists, Records, & Fields > Lists > New. 

 Enter Operating Systems in the Name field. 

 Leave Show Options In: The Order Entered as the default. 

 Enter the following in the Values subtab: 

a. Windows 

b. Mac  

c. Linux 

 Click Save. 

Create Record Type containing the operating systems and compatible browsers 

 Go to Customization > Lists, Records, & Fields > Record Types> New. 

 Enter Compatible Browsers in the Name field. 

 Make sure Include Name Field remains checked. 

 Click Save. 

Add Operating System Field to the Compatible Browsers record type 

 You should be viewing the record type you just saved. On the Fields subtab click New Field to 

add a field for the operating system. 

 Enter the following information: 

a. Label: Operating System 

b. ID: _operating_system 

c. Type: Multiple Select 

d. List/Record: Operating Systems 

e. Store Value: check 

f. Show in List: check 

 Click Save. 

Create the combinations for operating systems and compatible browsers 

 Go to Customization > Lists, Records, & Fields > Record Types 
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 Click the List link for Compatible Browsers 

 

 You should be on the Compatible Browsers List page 

 

 Click New Compatible Browsers to begin adding combinations.  You will be using the following 

browsers while adding combinations:  

a. Internet Explorer 

b. Google Chrome 

c. Firefox 

 Enter the following information 

a. Enter a browser into the Name field, e.g. Firefox. 

b. Select operating system (s) from the Operating System, multi-select field.  See example 

below. 

 

c. Click Save & New  

d. Keep adding records for each operating system so that you have different combinations 

of browsers for each. 
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e. Click Save when done. 

Enable Support and then customize a case form 

 Note: We have not yet enabled Customer Support and Service, so first go to 

a. Setup > Company > Enable Features 

b. CRM subtab, Basic section 

c. Check Customer Support and Service 

 Click Save 

 Go to Lists > Support > Cases > New. 

 Select Customize Form from the Customize link, top-right hand side of page. 

 Go to Fields subtab. 

 Click New Field button. 

 Enter the following information: 

a. Label: User’s Operating System 

b. ID: _user_operating_system 

c. Type: List/Record 

d. List/Record: Operating Systems  

  Go to the Applies To subtab, check Case 

 Click Display subtab. 

 Enter the following information: 

a. Subtab: Main 

b. Display Type: Normal 

c. Enter Help text: Select user's operating system 

 Click Save & New. 
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Create Field on a Case form for dependent list of compatible browsers 

 Enter the following information: 

a. Label: User’s Browser 

b. ID: _user_browser 

c. Type: List/Record 

d. List/Record: Compatible Browsers 

 Go to the Applies To subtab, check Case  

 Click Display subtab. 

 Enter the following information: 

a. Subtab: Main 

b. Display Type: Normal 

c. Enter Help text: Select user's browser 

 Click Sourcing & Filtering subtab 

a. Add a filtering row on this subtab: 

b. Filter Using: Operating Systems 

i. This is a field on the Compatible Browsers record. 

c. Compare Type: equal 

d. Compare to Field: User’s Operating System 

ii. Compare to Field is a field on the Case form.  

e. Click Add.  See example below. 

 

 This filtering row connects the selected operating system on the case form with the operating 

system on the custom record. This filters the list of browsers to the selected operating system. 

 Click Save. 
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Create a New Case 

 Go to Lists > Support > Cases > New. 

 You should see the fields for User’s Operating System and User’s Browser on your Case Form.  

See example below. 

 

a. These are dependent dropdowns 

b. Once you choose a value in the first field User’s Operating System, you will then see a 

list of browsers that apply to the selected Operating System.  

 Once you have confirmed the fields, click Cancel. 

 End. 
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Customization and Data Management: Recap and Review 

 

Review Day 2: Customization and Data Management 
 

Let’s review and recap some key points from yesterday’s topics:  

• Custom Subtabs, Lists and Fields 

• Custom Forms 

• Custom Records 

• Data Migration 

• Data Integrity 

SuiteBuilder Overview 
 

Easily tailor the look of NetSuite to meet your business needs: 

• Point and Click functionality 

• Custom Fields: on Entity, CRM, Item and Transaction records 

• Custom Lists: Set up predefined choices (list of values) in custom fields 

• Subtabs: Assign custom fields to custom sub tabs 

• Custom Forms: Entry, Transaction, PDF Layout, HTML Layout 
o Create custom forms: 

▪ Create the layout for printed and emailed forms 
▪ Define preferred entry form for a user role 
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User Interface Elements  
 

 

Custom elements should be entered in a logical order, based on where information 

lives: 

• Create a new Subtab 

• Create Custom Lists of values to be available for a user to select from 

• Create the Custom Fields for our custom lists to live in 

• Customize the Standard Customer Form  to manage the final display of fields 
and subtabs 

 

Custom Fields 
 

Consider the different field features and how they enforce processes: 

• Select the appropriate field Type 
o For example, use List/Record to provide a list of values for the user 

• Define basic attributes and behavior 
o Select Store Value to have the field available for duplicate detection 

criteria 

• Consider advanced field attributes: 
o Validation & Defaulting 

▪ Validation options to place constraints on your custom fields 
▪ Defaults are values you specify for your custom fields 
▪ Use formulas to display results of a calculation 

o Sourcing & Filtering 
▪ Sourcing information from another record and a field on that record 
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Custom Forms 
 
Custom forms can be customized to provide specific ways to enter and view 

information: 

• Subtabs: Display, rename, change display order 

• Fields (standard and custom): can be re-used on multiple forms 

• Lists: control sublists on the subtabs in a form 

• Create different form versions for different Roles 
 

Custom Record 
Custom record use cases: 

 

• Capture information, not addressed by standard NetSuite functionality 

• Too many custom fields are required, maintenance/usability issue 

• One-to-Many Relationship (1:M) or required Parent: Child 

• An online entry form needed (not Lead, not Case) 
 
Steps to use custom records: 

• Enable the feature 

• Define record attributes and behavior 

• Create necessary subtabs and save to create the record in the database 

• Create custom fields and define other elements of the custom record 
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Data Imports (Migration) 
 
Data migration is another term for importing data into your account. 

Preparation for the Data Import is crucial to a successful import: 

• Review existing data and scrub the data 

• Determine import options – not all record types are available for import 

• Determine how to map from existing application into NetSuite 

• Create a .csv template – export a list view of the record type 

• Run test imports 

• Resolve errors 

• Plan for the data migration 

• Import data prior to the “go-live” event 

• Resolve any errors 

• Review data validity, have a sign off 
 

Using the Import Assistant 
The Import Assistant directs the user through the required steps for data import. 

Go to Setup > Import/Export > Import CSV Records  

• Scan & Upload CSV File: select import type, record, character encoding, and 
file (s) 

• Select one of the Data Handling options based on whether you are importing 
new data or updating existing data 

• Consider the use of Advanced Options 

• Complete the most critical step of mapping Your Fields to NetSuite Fields 

 
• Save mapping and run import 

 

Navigate Setup Import/Export > View CSV Import Status to review the status of any 

given import 
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Data Integrity 
 
Integrity of the data is fundamental; users must have the most current /correct 

information: 

• Evaluate records with Duplicate Detection by enabling the feature and defining 
the criteria for marking a record as a possible duplicate: 

o The administrator reviews the duplicate detection criteria, which uses 
saved search functionality and always runs in the background 

o Review email evaluation for contacts versus other entity records 

• Use Entity Duplicate Resolution to review/manage potential duplicates: 
o Set the list filters appropriately 

• Execute Mass Updates, using either general updates or specific updates 
o Remember that updates may be scheduled 

• Enable the Inline Editing feature and use to quickly update records from a list of 
records 
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Review Questions  
 
See if you can answer the following questions; fill in the bank or use true/false values: 

1. True or False: SuiteBuilder is a point and click tool for customization 
 

2. Use a _________  ________ to control how information is entered and viewed 
 

3. True or False: A custom record may be a better option than adding too many 
custom fields to an existing record 
 

4. True or false: Preparation for the Data Import is crucial to a successful import 
 

5. How can I create a CSV template to use for an import template? 
__________________________ 

6. True or False: All records may be imported via the import assistant 
 

7. What sort of criteria can you set by going to Setup > Company > Duplicate 
Detection? 

 
8. True or False: Whether a company or an individual, NetSuite should look at the 

email address in the exact same way 
 

9. How would you simultaneously edit/change multiple records at once? 
______________________________ 

 
10. Which features allow editing records directly from a list? ________   _________ 

 

Customization and Data Management is done, next ERP Part 1 
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Set Up Accounting Management 

 

About this Module 
 

Will you be doing your accounting in NetSuite? If so, you may be wondering:  

• Can I tailor the chart of accounts? 

• Is there flexibility within accounting functionality and the General Ledger? 

• Are there ways to define my fiscal year: 
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Enterprise Resource Planning (ERP) Overview 
 
Enterprise Resource Planning (ERP) unifies operations into a single data source; 

increase efficiencies and better manage the bottom line.  

 

• Set up accounting: enable Features and define Preferences 

• Work with the Chart of Accounts (CoA) 
o Industry accounting structures to classify transactions to accurately record 

information about your business 
o In NetSuite, you may choose to use the Chart of Accounts with or without 

account numbers; set the accounting preference 
o Displays account number, name, type and balance for each account 

▪ If you use multiple currencies, the currency and a foreign currency 
balance are also displayed 

• Use the General Ledger (GL) 
o CoA and GL differences: 

▪ GL information is transaction-based 
▪ GL entry is created after a transaction is saved  
▪ CoA is viewed anytime by the user with or without transactions 
▪ Shows transactions sorted and subtotaled by account 
▪ View the GL impact from any transaction 

• Consider Financial Segmentation (Classifications) 
o Classify transactions using the following attributes: Accounting Periods, 

Account Numbers, Departments, Locations and Classes 
o Departments, Locations and Classes are tracked on transactions and are 

available for reporting 

• Use and manage Accounting Periods 

• Supports general ledger management.  

• If not used, NetSuite transactions post in real time 

• OneWorld accounts use Accounting Periods by default 
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A Few Accounting Considerations 
 

Accounting set up questions: 

• How is your financial year defined? 

• Do you need to define separate fiscal calendars for each legal entity, within the 
OneWorld account? 

• Will you need to consider segmenting your financial data in reports? 
 

Opening balances: 

• What level of detail will be brought into NetSuite? 

• When and how are you bringing in opening balances? 
 

Roles and responsibilities: 

• What roles are responsible for this area and what are their responsibilities? 

 

Walkthrough: Chart of Accounts and General Ledger 
 

 

Use Case: As the Administrator, you are helping the CFO investigate NetSuite’s 
structure that supports accounting 
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Chart of Account (CoA) and Best Practices 
 
Access the Chart of Accounts: Go to Lists > Accounting > Accounts 
Lists all accounts tracked in the system: 

• Lists all accounts tracked in the system 

• Capture and review financial information to make well-informed decisions and 
manage the bottom line 

• Use account types to organize transactions in registers and reports 
o You may create a hierarchy of accounts within each account type, by 

defining subaccount relationships on account records 

• Create a hierarchy of accounts within each account type by defining subaccount 
relationships on account records 

o You can also create accounts record solely for reporting purposes, called 
summary accounts and are useful when you want to create a non-posting, 
inactive parent account that has active child accounts.  

▪ New summary accounts in a non-OneWorld environment cannot 
have an opening balance, but you can convert an existing account 
with a transaction balance into a summary account.  

▪ In this case, you cannot post additional transactions to the account. 
Summary accounts appear with their children in the chart of 
accounts list. You cannot merge a summary account into another 
account. 

 
Best Practices in setting up the Chart of accounts: 
 

• Enter zero opening balances and load in transactions; opening balances are 
normally entered through import of journals 

• Consider financial segmentation using NetSuite classifications 
o This may be an alternative to creating subaccount  

• Enable account numbers if you are importing CoA with account numbers. 
Account numbers are optional in NetSuite 

• OneWorld only: Use a common Chart of Accounts where possible 
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General Ledger (GL) 
 

The general ledger, with subledgers, is the core of your company’s financial records 

• Entries post to the subledgers and transact through the GL as debits and credits 

• View the GL impact from a transaction and drill into the register 
o View a transaction and More Actions > GL Impact 
o The GL impact displays with debit and credit amounts by account 
o Drill into the account register, by clicking on the account hyperlink 

▪ Non-Posting Accounts:  
o Lists transactions that do not directly affect the balance of what 

the company is worth. 
o Purchase orders, for example, are transactions that do not 

actually incur debt in the same manner as a bill. 
o Nevertheless, it's important to know how these transactions 

may affect the future balance of your accounts 
o NetSuite offers several registers and reports based on non-

posting accounts. These accounts display in the Chart of 
Accounts only if you have set the preferences to use the 
corresponding features. Non-posting accounts include: 
o Estimates Register  
o Payroll Adjustment Register  
o Purchase Order Register 
o Sales Order Register 
o Unapproved Expense Reports Register  
o Unapproved Payments Register  

• There are two main issues to understand when setting up the general ledger.  
o One is their linkage to your financial reports 
o The other is the establishment of opening balances.  Opening balances 

are the amounts in your General Ledger accounts when you start to use 
NetSuite.  Again, NetSuite recommends importing journals to establish 
opening balances 

 

Understanding General Ledger Impact of Transactions help 

• Search the Help Center for Understanding General Ledger Impact of 
Transactions and view the topics: 

• Click on a topic, e.g. Understanding Sales Transaction G/L Impact to view 
details 
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Accounting Management and Financial Reporting 
 
Consider the use of Classifications, as part of the setup of accounting management, to 
facilitate financial reporting. 
 
What do you need to report on and track? 

• Cost Centers? 

• Multiple warehouses? 

• Regional offices? 

• Product Lines? 
 

NetSuite Classifications 
 

Departments, Locations and Classes 
Classifications are optional. Establishment of classifications is driven by your accounting 

and reporting needs. They provide you with a means to govern access to data, are 

useful for tracking how your business is run and where income / expenses are 

generated. 

• Note: Account postings are independent of the classifications. Income/expenses 
will be posted correctly even according to account types and transactions 
processed. 

 
Measure and report on your business with classifications to track records such as 

financial, transactions and employees. Use any /or combination of Departments, 

Locations and Classes: 

• Departments: listed first on transactions, and can designate transactions and 
resources as part of an internal team 

• Locations: Recognize physical or virtual places 
o If you plan to use NetSuite’s auto-generated numbering with the locations 

feature, you can make your transaction number sequences independent 
per location, and prefix transactions with the location name 

o E.G. If you have several state branches, you can set up the forms to print 
the branch address from where the sale originated.  

• Classes: Useful for wider categories within your business 

• Use any /or combination of Departments, Locations and Classes 
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OneWorld: Subsidiaries and Other Classification 
 
A subsidiary is a classification unique to OneWorld and has more restrictive powers. 
Subsidiaries are integrated with the “standard” classifications. 
 
Associate Departments, Locations, and Classes as needed for one or more 
subsidiaries: 

• Example 1: Subsidiary 1 sells houses from Ohio and Maine 
o Department = Residential 
o Location = Ohio and Maine 
o Class = Sales 

• Example 2: Subsidiary 2 sells offices and shops in New York & California 
o Department = Commercial 
o Location = New York and California 
o Class = Sales 

• Example 3: Subsidiary 3 rents offices in New Jersey 
o Department = Commercial 
o Location = New Jersey 

 

Accounts and Subaccounts in the General Ledger 
 
The General Ledger can have accounts and subaccounts, but consider the most 

appropriate structure that applies to your organization. 

• In this example, you have setup three accounts that have four subaccounts for 
each location: 
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Activity: Could you use Classifications? 
 

Would you be able to see expenses by account or across classifications? 

• Which classification (Department, Location, or Class) might you use in the top of 
the table, below? 

• What might be the values for the column headings? 

 

 

Use Classifications with Accounts 
See expenses by account or across classifications: 

• Reduces account redundancy  

• Simplifies your chart of accounts  

• Preserves detailed account information when you need it 

 
Walkthrough: Enable Features 

 

 
 
Use Case: Now that you have direction from the CFO, you can start setting up NetSuite 
to accommodate your accounting needs  
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Company Classifications 
 

Use Classifications for a streamlined Chart of Accounts and improved financial 
reporting: 

• Go to Setup > Company > Enable Features > Company subtab 

• Review the Classifications section and associated features  
o Departments: Track activity by department, division or another category.  

Department can be renamed to suit your needs 
o Locations:  Track activity by location.  Location can be renamed to suit 

your needs 
o Classes: Track activity by categories.  Classes can be renamed to suit 

your needs 
 

 

Rename Classifications to meet your requirements: 

• Go to Setup > Company > Enable Features > Rename Records/Transactions 

• Enter new names, for records, using your terminology 
o Enter in the singular, NetSuite will pluralize  
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Accounting Features 
 

 

Select the Basic and Advanced Features: 

• Navigate to Setup > Company > Enable Features > Accounting subtab 

• Review Basic Features and Advanced Features 
o OneWorld accounts, by default, use Accounting Periods 

and Advanced Taxes 

• If you have OneWorld provisioned, the advanced taxes feature is automatically 
checked and cannot be unchecked; this is found on the Tax subtab  

• Review SuiteAnswers for additional information 
 

Walkthrough: Create Each of the Following Classifications 
 

 
Use Case:  The CFO has mapped details out and now the Administrator can enter the 
necessary classifications to facilitate your financial segmentation in tracking and 
reporting. 
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OneWorld: Create Subsidiaries 

 

Create a subsidiary for each legal entity, in a top-down fashion; go to Setup > 

Company > Subsidiaries > New  

• Set up the base currencies before setting up a subsidiary; the subsidiary record 
has a dropdown list of values of available currencies 

• Select the country; this determines NS Edition and sets tax nexus 

• Once saved, the Subsubsidiary of, Elimination, Currency, Edition, or Country 
fields cannot be changed 

• If necessary, mark the incorrect subsidiary as inactive; create a new subsidiary 
with the correct information  

 

View the saved subsidiary record and all associated subtabs, which further define the 

subsidiary record.  Please review the Help topic: Editing Subsidiary Records 

If you enter in the wrong information and save the subsidiary, some fields will be 

locked for editing.  If necessary, mark the incorrect subsidiary as inactive and 

create a new subsidiary with the correct information 

 

Create Departments 

 

Go to Setup > Company > Departments > New to create each unique department in 

your organization: 

• Track financial, transaction, and employee records against the department 

• Use in conjunction with classes 

• Departments are listed first on transactions and are useful to designate 
transactions and employees as part of an internal team. 

• Use in conjunction with classes 
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Create Locations 

 
 
Go to Setup > Company > Locations > New to create a location record for each of 

your company's locations: 

• Define location to one subsidiary; locations cannot be shared by subsidiary 

• Set up different locations for multi-location inventory 

• Enter the following information: 
o Name 
o Sublocation of – if this reports into another location (warehouse in our 

demo account) 
o Subsidiaries – If OneWorld Account 

▪ Locations cannot be shared by subsidiaries  

• Location Type - Select Store, Warehouse, or Undefined: 
▪ One of the criteria that the Automatic Location Assignment 

feature uses when determining the ideal fulfillment location.  
▪ You can set the location to Undefined to represent locations that 

are neither a store nor a warehouse.  

• Track employees and transactions by locations 

• Set up different locations for multi-location inventory 
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Create Classes 

 

Go to Setup > Company > Classes > New to use for a broader category, such as 

product lines: 

• Enter the following information: 
o Name 
o Subclass – to support a class (sales channel) hierarchy 
o Subsidiaries – If OneWorld Account 

▪ Departments can be shared by subsidiaries 
▪ Consider Include Children  

• Use in conjunction with departments 

• Note that Classes can be shared by subsidiaries 
 

Convert Classes 
 

 

After consideration, you may go back and convert Classes to either Departments or 

Locations 

• Setup > Company > Convert Classes to Departments or 
Setup > Company > Convert Classes to Locations  

• Overrides existing department or locations 

• Leaves your Classes empty 

• Is not reversible 
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Financial Segmentation Example 
This chart represents segmentation Best Practices by our professional services team - 

“Segmenting your Chart of Account for Detailed Financial Reporting”: 

 
 
Reminder: Financial Segments are completely optional to enable in NetSuite. 

• The requirement to use Financial Segments is determined based on: 
o How is your organization structured? 
o What type of reporting is required?  
o What level of visibility you need into these transactions? 

 

Activity: Review Questions 
 

• True or False: Enterprise Resource Planning (ERP) unifies operations into a 
single data source, to increase efficiencies and better manage the bottom line.  
 

• Which presents a list showing account type, the Chart of Accounts or the General 
Ledger? Leaves your Classes empty 

 

• True or False: Classifications are mandatory 
 

• True or False: Classifications can simplify my Chart of Accounts. 
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Walkthrough: Define General Ledger Preferences 
 

Use Case:  Continue working with the CFO and configure the appropriate settings, per 

their instructions  

 

General Ledger Preferences 
 
Setup > Accounting > Accounting Preferences > General subtab, General Ledger 

 

• Account Numbers: (optional) Enable to see both account numbers and names 
for GL accounts in dropdown lists, CoA and most financial reports 

• Use Legal Name in Account: Check this box to add the Legal Name 
field to the general ledger account record. This field is useful in countries where 
the legal name of an entity is required by law. 

• Show All Transaction Types In Reconciliation: Check this box to display all 
transactions in the reconciliation pages, including positive or negative amounts of 
certain transaction types. 

• Expand Account Lists: (Best Practice): Enable this feature on an "as needed" 
basis: 

o Check this box to enable additional choices in account lists. For example, 
you may need to select Cost of Goods Sold and balance sheet accounts 
for items, or asset accounts for vendors.  

o Uncheck this box to restrict lists to accounts most likely to be used. For 
example, income and expense accounts can be chosen on items to be 
resold, or expense accounts can be chosen on purchases.  

• Cash Basis Reporting: Check box to set standard reports to be on a cash basis 
rather than accrual basis, for all reports where this choice is relevant. 

o Please note that if you customize a report, you can override this with the 
Reports > More Options. 

  



22 

 

• Work with Journals:  
o Void Transactions Using Reversing Journals 

▪ Enabling this feature gives you slightly more control. 
▪ If set to “No”, on the transaction when you click Void the transaction 

values are set to zero 
▪ If set to Yes clicking the void button on the transaction opens a 

journal. This gives you the ability to change the date and the period 
of the reversing journal. The reversing journal could be in a different 
period from the source transaction. 

o Require Approvals on Journal Entries: check this box to review journals 
entries before posting to the general ledger 

• The following preferences are applicable if the Accounting Periods feature has 
been enabled: 

o Enable Accounting Period Window: Automatically maintain a minimum 
number of unlocked current and future accounting periods.  

o Minimum Period Window Size: Use the Minimum Period Window Size 
preference to set the number of unlocked periods.  

o Allow Transaction Date Outside of Posting Period: Set a preference 
for handling mismatched transaction entry. 

• If your user role is granted both the Set Up Accounting and Period Closing 
Management permissions and you want to use Quick Close: 

o You must select the Allow Quick Close of Accounting Periods preference 
at Setup > Accounting > Accounting Preferences.  

o On the General subtab under the General Ledger section, check the Allow 
Quick Close of Accounting Periods box and then save.  

o This preference does not appear in user roles that do not have the Period 
Closing Management permission. 

 
Note: The remaining accounting preferences may be discussed in later modules. 
Please refer to field help and SuiteAnswers for more information.  
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Walkthrough: Accounting Periods 

 
Use Case:  Since your company is managing the fiscal year by accounting periods, the 
periods need to be managed and set up.  
 
Overview: The Accounting Periods feature supports general ledger management.  

• If accounting periods are not used, NetSuite transactions post in real time.  

• When accounting periods are enabled, you can select a past or future posting 
period for each transaction, and accounting personnel can more effectively 
monitor and control the status of accounts  

• Accounting periods are used for Financial Reports and all reports if you have set 
up your preferences (under Home > Set Preferences).   

 
Note: We recommend not using an Adjustment period with OneWorld.  Accounting 
periods are required in OneWorld, not required in standard NetSuite.  
 

Set Up Full Year 
 

Go to Setup > Accounting > Manage Account Periods; click Set Up Full Year to set 
up all fiscal periods for an entire year; this is considered a best practice: 

 
• Define First Fiscal Month, Fiscal Year End, Period Format, Year in Period Name, 

One-Day Year-End Adjustment 

• Important Considerations: 
o Use for initial company set up 
o Set up all historical periods required for importing historical data and set 

up all future periods required for revenue recognition or expense 
amortization 
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New Year Only, New Quarter Only, Base Period 
 
Select one of the following to create fiscal periods one-by-one: 

• Go to Setup > Accounting > Manage Accounting Periods > click New Year 
Only, New Quarter Only or Base Period 

o Select New Year Only first, then set up sub-periods as required such as 
Quarter or Base Period 

 
• Define another format other than the NetSuite formats of:  

o Calendar Months, 4 Weeks, or 4-4-5 Weeks 

• Use for incremental additions 

• Define as many as you need, but they cannot overlap each other 
 
Important!  Setting up accounting periods individually can create incomplete or 
incorrect period rollups if you are not careful. 
 
Other reasons to use Create New Year, Quarter, or Base Period: 

• When you need to manually change from one fiscal year type to another 

• You are using Sun-Sun or Mon-Mon accounting periods; companies using 4-
week periods often go Monday to Monday.  

• You define accounting periods in 4-week or 4-4-5-week increments, 
o The first period of the year beginning on January 1; resulting with 

‘Tuesday to Tuesday’ all year, ending with one long period the end of the 
year ending on December 31. 

o The following year, when Jan 1 shifts to Wednesday, you will have a 
Wednesday to Wednesday accounting periods, which is not preferred 

 

Accounting Periods Page 

 

Lists all the Period Names that are set up in your account and includes: 

Go to Setup > Accounting > Manage Accounting Periods to view all set up periods 
in your account:  

• You can Expand All/Collapse All 

• Use the Checklist for period close activities 

• View the status of period, AP, AR, All G/L, and Allow Non G/L Changes  
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Accounting Period Batch Jobs Status 

 

Go to Setup > Accounting > Manage Accounting Periods > Status to view a date-

driven list of accounting period actions and status: 

• When accounting periods are added, edited, or deleted, a batch process runs in 
the background to align existing transactions with the appropriate accounting 
period: 

o Additional changes, to accounting periods, cannot be made until this 
process finishes 

• Displays actions such as inserting period, Set Up Full Year 

• Displays the status of batch processes: 
o Status can be Complete, Processing, Pending, Deferred, or Failed 

• Define the From and To date Filters 

• Click Refresh  
 

Walkthrough: GL Accounts and Opening Balances 
 

 
Use Case:  The Company has found a need to add general ledger accounts and need 

to consider how best to entering in opening balances. 
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Create New General Ledger Account 
 

 

 

Set up accounts as needed to support your reporting requirements: 

• Go to Lists > Accounting > Accounts > New 

• Enter in the following information 
o Number (if Account Number preference enabled) 
o Name 
o Subaccount of: consider hierarchy 
o Type: the account type you select here determines the default section for 

this account on your financial statement. 
o Specify other attributes as required 

▪ For example, create a Summary Account for reporting purposes 
by checking the Summary checkbox 

• This account record is solely for reporting purposes 

• Useful for non-posting, inactive parent account that has 
active child accounts 

• New summary accounts in a non-OneWorld environment 
cannot have an opening balance, but you can convert an 
existing account with a transaction balance into a summary 
account. In this case, you cannot post additional transactions 
to the account.  

• Summary accounts appear with their children in the chart of 
accounts list.  

• You cannot merge a summary account into another account. 
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Enter Opening Balances (Optional) 
 

Opening Balances can be entered for each general ledger account: 

• Go to Setup > Accounting > Enter Opening Balances 

 
 

• This is considered an optional task 

• NetSuite recommends importing journals to enter in opening balances 

• Please refer to Help and SuiteAnswers for more information 
 
Opening balances: other information and considerations 

• For accounts added later, enter opening balances after account records have 
been created in NetSuite in the Opening Balances page 

• If you use NetSuite OneWorld, you need to create and save accounts, then enter 
opening balances in the Opening Balances page 

• If you do not use NetSuite OneWorld; for the accounts included in your initial 
NetSuite chart of accounts, enter opening balances for your go-live date on each 
account record as you create the accounts 

• Tip: Obtain a trial balance report in debit/credit format, from your accountant or 
from your previous accounting management system, to use as a worksheet for 
entering opening balances in NetSuite. 

o More common; you may import a journal for your opening balances 
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Activity: True or False 

 

Standard Accounting Reports 
 
Navigate to Reports > Financial to view specific reports 

• View reports by specific dates or time periods 

• Income, expenses, and net income 

• Transactions sorted and subtotaled by account 

• Balance of each active account in debit and credit columns  
 
Please refer to Standard Reports topic in the Help Center or SuiteAnswers for more 
information 

 
 

Now It’s Your Turn 

 
Use Case/Scenario:  Prepare for accounting functions.  

• Configure features and preferences 

• Set up warehouse locations in US and Germany 

• Add new GL accounts 

• Set up accounting periods through to the current year 

• Allow 20 - 30 minutes 
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Independent Study Exercises 

Exercise 01: Enable Accounting Features and Define Preferences 
Scenario: Before using NetSuite for accounting transactions, ensure that all required features are 

enabled and accounting preferences defined. The BRD indicates the Chatham Company uses both 

Account Numbers and Names. Review Accounting preferences the General Ledger. 

In this exercise: 

 Confirm that Classifications are enabled 

 Enable Accounting Features 

 Define General Ledger Accounting Preferences 

 Note: The features in this exercise might be different from those in your purchased NetSuite 

account. 

 As the Administrator navigate to Setup > Company > Enable Features; the Company subtab 

displays. 

a. Confirm that Classifications features are checked for Chatham Company reporting 

requirements through classifications, which have been renamed: 

i. Departments, Locations and Classes 

 Click the Accounting subtab, check the following features. Note: The check box for Accounting 

Periods is checked and greyed out. 

a. Basic Features: 

i. Accounting 

ii. A/R 

iii. A/P 

iv. Accounting Periods 

v. Do not check GL Audit Numbering now.  You can review field help and related 

Help Topics 

b. Advanced features: uncheck the following features 

i. Expense Allocation 

ii. Revenue Recognition 

iii. Multiple Budgets 

iv. Do not check any other features 

v. Do not make any changes Multi-Book Accounting features. Refer to 

SuiteAnswers for more information, since we will not be covering these in class. 
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c. Some NetSuite features are dependent on each other; disabling one feature may disable 

associated features and a warning dialog box displays; click OK in the box. 

 Click the Employees subtab. 

a. Go to the Time & Expenses section and confirm that Approval Routing and Purchase 

Requests features are checked. 

b. You may leave any other checked features as is. 

 Click the Save button to commit your changes. 

Set Up Accounting Preferences   

 Navigate to Setup > Accounting > Accounting Preferences. The Accounting Preferences page 

opens. Notice it automatically opens on the General subtab. 

a. Under the General Ledger section: 

i. Ensure that the Use Account Numbers check box is checked. 

ii. Make sure that Expand Account Lists is NOT checked. 

b. Click Save. 

 End. 
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Exercise 02: Set Up Multiple Warehouses 
Scenario: The Chatham Company BRD indicates warehouses with each subsidiary. 

In this exercise: 

 Remember that Locations are called Warehouses in our account 

 Set up two US warehouse locations for Parent company 

 The German subsidiary also needs a warehouse 

 Go to Setup > Company > Warehouses > New 

 In the Warehouse page, complete the following fields: 

a. Name field, type East Coast. 

b. Subsidiary field, leave Parent Company as selected value. 

c. Review field help for Location Type and then select Warehouse. 

d. Select appropriate Time Zone. 

e. Click the Address, Edit Link to enter/confirm information 

i. Country: United States 

ii. State/Province = New York 

iii. Click OK 

 Click Save & New. 

 In the Location page, complete the following fields: 

a. Name field, West Coast 

b. Subsidiary: Parent Company 

c. Location Type: Review field help and then select Warehouse 

d. Select the Time Zone, select appropriate Time Zone 

e. Click the Address, Edit Link to enter/confirm information 

i. Country: United States 

ii. City: enter California 

iii. Click OK. 

 Click Save & New 

 In the Location (New Warehouse) page, complete the following fields: 
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a. Name field, type Berlin. 

b. Subsidiary field, select Parent Company: Germany. 

c. Review field help for Location Type and then select Warehouse. 

d. Select appropriate Time Zone. 

e. Click the Address, Edit Link to enter/confirm information 

f. Country field, select Germany. 

g. Click OK 

 Click Save. 

 Go to Setup > Company > Warehouses and ensure that you have four (4) warehouses: 

Berlin, East Coast, MidWest, and West Coast. 

 End.  
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Exercise 03: Create General Ledger (GL) Accounts 

Scenario: In this exercise: 

 Create two Utility GL Accounts for Parent company 

 As the Lists > Accounting > Accounts > New. 

 The New Account page opens; enter the following information: 

a. Number: 6310 – This is now mandatory, since we chose - to use Account Numbers in 

our Accounting Preferences 

b. Name: Water  

c. Subaccount of: 6300 Utilities 

d. Type: Expense 

e. Subsidiaries: Parent Company and select Include Children 

f. If visible, Restrict to Accounting Book: leave default 

 Click Save & New: 

a. Number: 6320 

b. Account Name: Electricity 

c. Subaccount of: 6300 Utilities 

d. Type: Expense 

e. Subsidiaries: Parent Company and select Include Children 

f. If visible, Restrict to Accounting Book: leave default 

 Click Save & New 

 Enter the following information: 

a. Number: 1010 

b. Name: Checking - Germany 

c. Subaccount of: 1000 Checking 

d. Type: Bank 

e. Currency: Euro – this is required since Type equals Bank 

f. Subsidiary – Parent Company: Germany 

g. If visible, Restrict to Accounting Book: leave default. 
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 Click Save. 

Confirm your accounts; go to Lists > Accounting > Accounts  

 Click Home and end.  
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Exercise 04: Set Up Accounting Periods 

Scenario: Chatham Companies need to break up the fiscal year into Accounting Periods: 

In this exercise: 

 Set up accounting periods for the current year and one year beyond As the Lists > 

Accounting > Accounts > New. 

 Navigate to Setup > Accounting > Manage Accounting Periods. Take note of which Fiscal Year 

already exists. 

 At the top, left-hand side of the page, click the Set Up Full Year button. Enter the following: 

a. First Fiscal Month: January 

b. Fiscal Year End: enter appropriate year 

c. Period Format: Calendar Months 

d. Year in Period Name: Ending Year of Period 

e. Do not check One-Day Year-End Adj. Period 

 Click Save. 

 Verify the period created is for the current year (or the next year) with four quarters. 

 If necessary, collapse the Fiscal Year and Fiscal Quarters being displayed 

 Continue steps 2 through 3, until you have all years including current year. 

 Confirm by reviewing Setup > Accounting > Manage Accounting Periods. 

 End. 
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Activity: Match Game 
 

Match the terms on the left to the task/description on the right. 
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Multi-Book Accounting 
 
General Information: 
This feature provides the ability to maintain multiple sets of financial records in parallel 

to support various accounting and reporting standards:  

• Please contact your sales or account representative  

• NetSuite Professional Services is required to implement this feature  

• Multi-book accounting now supports reporting in the following categories 
o Time & Billing 
o Sales Tax US 
o Sales Tax Canada 
o VAT/GST 

• GL audit numbering is available in the secondary books 

• Please refer to Help and Suite Answers for more information 
 
Overview from Help: Multi-Book Accounting Overview 
The Multi-Book Accounting feature provides the ability to maintain multiple sets of 

accounting records based on a single set of real-time financial transactions.  

• Supports different managerial and regulatory compliance needs, such as: 
o Deliver different financial reports to serve different purposes; companies 

can add accounting books to generate different versions of financial 
reports and statements that are mandated by local governments or 
industry regulations. 

o Provide detailed transaction-based reports for each accounting book 
▪ Satisfy managerial reporting requirements and provide detailed 

transaction level audit trail to book specific financial statements.  
o Display saved search and KPI results by accounting book. 
o Automate posting to multiple accounting books per pre-defined accounting 

rules 
o Create different revenue recognition and expense amortization rules for 

different accounting books. 
o Adjust financial results on a per-book basis 
o Manual journal entries, including intercompany journal entries, can be 

posted for individual accounting books. 
o Ensure data integrity across multiple accounting books, as follows: 
o The system automatically maintains data synchronization for parallel 

transactions in different accounting books  
o Enable customization to leverage the Multi-Book Accounting context 
o Implement SuiteApps and customization to yield book specific financial 

results. 

• The Multi-Book Accounting feature includes options for chart of account 
mapping, foreign currency management, and revenue and expense management 
to address these needs. 
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Statistical Accounts 
 
Overview 
A statistical account is a General Ledger account that displays in your chart of accounts, 

but does not impact your G/L 

• Track non-monetary data and then use that information on reports and income 
statements 

• Examine the non-monetary data to view its relationship with the financial activity 
of your organization 

• For example, you may create a statistical account that tracks the rent fee 
for the square feet of occupied office space for each location in your 
organization. 

• A statistical account is always debit positive, and is always excluded from foreign 
currency translation  

• Enable the feature at Setup > Company > Enable Features > Accounting 
subtab, Advanced Features section and select Statistical Accounts  

o Multiple Units of Measure feature will be enabled.  
 
Enable the feature at Setup > Company > Enable Features > Accounting subtab, 
Advanced Features section and select Statistical Accounts:  

• Statistical Accounts require using Multiple Units of Measure - Setup > 
Company > Enable Features > Company subtab, ERP General section and 
select Multiple Units of Measure 

 
Create statistical accounts the same way you create other accounts; go to Lists > 

Accounting > Accounts > New, specify Type of Statistical 

• Currency-specific fields do not display when you create a statistical account 
because they are irrelevant for non-monetary accounts. Instead, you assign a 
default unit of measure type, and a default unit within that type. 

o For example, you may define the Unit of Measure Type, AREA that 
includes the unit of measure, square feet (SQFT). 

 
Maintenance of statistical accounts may be done through: 

• Manual entry of statistical journal entries and auto-generate journal entries 
through a saved search run by a statistical schedule 

• New journal entries track the increase and decrease of a statistical balance 

• You can also update the absolute balance, rather than just track the difference  
 

Refer to SuiteAnswers for more information  

  



39 

 

Additional Resources 
 
NetSuite Help Center: 

• Accounting  
 
SuiteTraining: 

• SuiteAnalytics: Financial Reports and Searches 
 

SuiteAnswers Learning Center 

• New Feature Training 

• Financial Management 

• NetSuite OneWorld 

• Entering Opening Balances 

• Segmenting Your Chart of Accounts for Detailed Financial Reporting 
 
Key Terms Reviewed 
 

Terminology Description 

Subsidiary Create for each legal entity 

Opening Balance Balance for each general ledger account 

Classifications 
Facilitates financial segmenting using departments, 
classes, and locations 

Accounting Periods 
Ability to have transactions posted to a period, rather 
than just a date 
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Use Multiple Currencies 

 
About this Module 

 

Are you conducting business in a Business in a Global Marketplace? 

Do you need to transact business in different currencies to?  

• Sell to customers and purchase from vendors  

• Transact in currencies other than the base currency of your company 

• Assign multiple currencies to customer and vendor records 
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Walkthrough: Enable Features and Accounting Preferences 
 

 

Use Case:  Configure the features to accommodate working with international 

transactions  

 

Enable International Features 
 
Setup > Company > Enable Features > Company subtab, International section 

• Multiple Languages: Useful for translating web site, item names and 
descriptions, printed sales transactions and confirmation emails 

• Multiple Currencies Use foreign currencies for sales and purchase transactions 
and to account for the fluctuations in exchange rates 

o Note: Multiple currencies does not default as enabled “on”, however if you 
enable it and create a transaction using multiple currencies, it cannot be 
disabled.  Contact Customer Support 

• With Multiple Currencies enabled, customer and vendor records will have a 
sublist for defining all the currencies being used 

o The Currency field on the vendor or customer record is changed to 
Primary Currency 

• Currency Exchange Rate Integration: automatically update exchange rates 
o A Web services call contacts Thomson Reuters, specify which provider in 

Accounting Preferences (Please note in current account Xignite is no 
longer supported) 

o After enabling, check the Automatic Update box on a currency record 
o The currency exchange rates automatically update approximately at 

12:30am PST/PDT 

• Thomson Reuters offers a four, significant decimal exchange rate; the leading 
zero displays, but does not count as one of the four digits. E.g., both 0.1234 and 
0.0001234 represent four significant digits. 

• NetSuite offers three methods for obtaining currency exchange rates: 
o Triangulation calculation by NetSuite is useful when the two home 

currencies involved in the transaction are not available from the selected 
rate provider.  

o Direct currency exchange rates are those that are provided directly from 
your specified exchange rate provider. 

o Inverse rates are those exchange rates that are based on the direct rate 
used by another NetSuite account. 

Please refer to SuiteAnswers for More Information 
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Accounting Preferences: Exchange Rate Integration 
 
Setup > Accounting > Accounting Preferences > General subtab: 

• Scroll down the page to the Exchange Rate Integration section 

 
• In the Rate Provider field select Thomson Reuters (Xignite no longer supported 

in production accounts) 

• If Thomson Reuters is selected, then agree to the Terms for Currency Rate 
Feature (“Terms”) 

o If required, select Use Triangulation Calculation by NetSuite preference 
o Check this box to permit NetSuite to use cross currency triangulation to 

calculate the exchange rate for a transaction where the two home 
currencies are not available from the selected rate provider 

o Agree to the Notice for Currency Rate Feature with NetSuite 
Triangulation (“Notice”) and define the anchor currency fields 

 
▪ When you designate three anchor currencies, you are instructing 

NetSuite to make three separate attempts to find exchange rates 
for currency pairs.  

▪ For example, if the primary anchor currency is not available as a 
standard pair from the selected rate provider, NetSuite will make a 
second attempt to obtain exchange rates between the two home 
currencies and the secondary anchor currency. If there are no 
standard pairs using the second anchor currency, NetSuite will 
make a third attempt to obtain exchange rates using the tertiary 
anchor currency. 
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Walkthrough: Working with Currencies 
 

 
 
Use Case:  Now that multiple currencies, and other features, have been enabled the 
administrator can start working with currency records.  
 

Create New Currency Records 
Create all currency records to be used in transactions: 

 

• Go to Lists > Accounting > Currencies > New 

• Enter a Name and a Default Locale 

• The ISO Code populates based on the Default Locale 

• Define the Default Exchange Rate (to root subsidiary currency) 

• Define Automatic Update: whether currency exchange rates update daily 

• Determine if you want to Override Currency Format 
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Manage Base Currencies 
 
Base currency is either your company’s base currency or the currency assigned to any 

subsidiary in OneWorld accounts.  Properly manage base currencies to ensure the 

latest currency rate: 

• Navigate to Lists > Accounting > Currencies and click on the currency Name 
to Edit the currency record 

 

• Select the Update Time Zone for each base currency 
o At the update time in the selected time zone, a Web services contacts 

either Thomson Reuters or Xignite, which sources its data from 
Morningstar.  

o The Web services call provides the latest “bid and ask” exchange rates as 
well as the computed midpoint of these two quotes. 

o NetSuite uses this midpoint to populate the Currency Exchange Rates list. 
Morningstar obtains rates from several sources, as described  

• OneWorld Consideration: You can create currencies spontaneously from the 
subsidiary screen, by clicking the plus sign next to Currency field. 

 
Warning: If any user has saved a transaction that includes a currency amount, 

you cannot change the base currency unless you delete that transaction. 

 

Currency Exchange Rates Overview 
After creating your currency records in NetSuite, and defining a base currency, you can 

set up exchange rates between the base currency and foreign currencies: 

• Applied to Transactions 

• Set per “As of” effective date 

• Each rate translates between Base currencies and one foreign currency 

• Updated by manually adding new rows with new effective dated to Currency 
Exchange Rates list, or using Currency Exchange Rate Integration feature for 
automatic daily updates 

• If you use NetSuite OneWorld: 
o You may define a different base currency per subsidiary 
o Exchange rates for a base currency apply to all subsidiaries that use the 

same base currency 

• These rates are stored in a list at Lists > Accounting > Currency Exchange 
Rates 
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Viewing the Currency Exchange Rate List 
The Currency Exchange Rates List includes the exchange rates between each base 

currency and foreign currencies, for transactions: 

 

• Navigate to Lists > Accounting > Currency Exchange Rates 

• By default, rates as of the current date are displayed in the list 
o You can change the As of date to display past or future rates 

• The Rate Provider and Method are displayed 
 

Adding Rates to the Currency Exchange Rates List 
 
Go to Lists > Accounting > Currency Exchange Rates > New 

 

• You can specify an exchange rate between each base currency and each foreign 
currency: 

o Select the Base Currency and the Currency 
o Define the Exchange Rate and Effective Rate 

• These exchange rates are applied to transactions and provide default rates for 
transactions in currencies other than the base currency 

o Exchange rates are expressed in terms of base currency units per foreign 
currency units 

• Use spot rate to translate most balance sheet accounts, current rate at the end of 
the accounting period: 

o NetSuite allows selecting daily time for the currency rate to change 
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Update Rates in the Currency Exchange Rates List 
 
You have two choices for making updates to exchange rates displayed: 

• You can manually update a rate between two currencies by adding a new rate for 
the same two currencies, with a different effective date 

o Lists > Accounting > Currency Exchange Rates > New 
▪ Select Base Currency, Currency, Exchange Rate and enter 

Effective Date  

• Or, if the Currency Exchange Rate Integration feature is enabled, you define 
the Update Time Zone on the currency record; automatically update exchange 
rate with each base currency daily 

o Update rates daily at approximately 6 am in the time zone selected 
 

Introduction OneWorld Considerations 
 

 

Use Case: As the Administrator, continue with additional OneWorld set up and 

considerations  

 

OneWorld: Consolidated Exchange Rates Overview 
 

Consolidated Exchange Rate configuration provides consolidated management 

reporting and financial statements: 

• Applied to Consolidated reports 

• Set per Accounting periods 

• Each rate translates between Base currencies for one pair of related subsidiaries 

• Updated by manually editing, auto calculating rows or both in the Consolidated 
Exchange Rates Table 
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OneWorld: Consolidated Exchange Rate Types 
 
Three different rate types are maintained for each period-parent-subsidiary. They are 

current, average and historical: 

• Current – also referred to as “ending rate” and is based on the currency 
exchange rate that is effective at the end of the reported upon period 

o Used for most asset and liability accounts in the balance sheet 

• Average –calculated from a weighted average of the exchange rates for 
transactions applied during the period to accounts with a general rate type of 
Average.  

o Used to translate accounts in the income statement and to build retained 
earnings. 

• Historical –calculated from a weighted average of the exchange rates for 
transactions applied during the period to accounts with a general rate type of 
Historical 

o Used for equity accounts, or owner's investments, in the balance sheet. 
 

Note: The difference among these rates results in a balance in the ‘Cumulative 

Translation Adjustment’ (CTA) account. 

Following are the default rate types for accounts: 
General Rate Type: 

• Current - for all balance sheet accounts other than equity accounts 

• Average - for all income statement accounts 

• Historical - for all equity accounts 
Cash Flow Rate Type: Average - for all accounts 
  



49 

 

OneWorld: Consolidated Exchange Rates Editing 
Navigate to Lists > Accounting > Consolidated Exchange Rates to set configuration 

that facilitates reporting: 

 

• Select the appropriate View 

• Open the Filters and select Period, From Subsidiary and To Subsidiary 

• Enable Edit; some rates are editable for some periods 
o Direct rates, between child and parent subsidiaries are editable for 

periods that have not been closed (that have a value of No in the Closed 
column) 

o Indirect rates, also known as implied rates, between subsidiaries more 
than one hierarchical level removed from each other are never editable. 

For each accounting period, the Consolidated Exchange Rates list has an editable 

(displayed in black print) entry for every subsidiary-parent relationship, even if the base 

currencies of the subsidiary and its parent are the same.  

• Rates that are not editable remain grayed out. Edit the values under each type 
heading: 

 
Consolidated Exchange Rates vs. Currency Exchange Rates 
It is important to understand the difference between these two terms; this table 

summarizes those differences: 
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OneWorld: Multiple Currencies 
A OneWorld account utilizes multiple currencies as follows: 

• Each subsidiary has a base currency 

• Subsidiaries can manage and report their books in local currency 

• Currency list must include the base currency of each subsidiary and any other 
currency in which transactions will be recorded 

• Set up default exchange rates to handle processing between different currencies 

• Use consolidated exchange rates to translate transactions and balances between 
base currency and the currency that you are reporting in (one of the parent 
currencies). 

• Normally the base currency is the local currency, but reporting that subsidiary in 
the context of a different parent, then translate (using the consolidated rate) 
report in the parent’s currency  

 

Best Practices: OneWorld Currencies and Reporting 
 

Consider these best practices if using a OneWorld account: 

• Set estimated current and average rates at beginning of each accounting period 
so that reports run during accounting period are reasonable 

• Set current, average and historical rates during month-end close process to 
reflect and appropriate rates for financial statement preparation 

 

Walkthrough: Multi-Currency Customer 
 

 

Use Case:  Your Company is working with customers that transact in multiple 

currencies. Let’s look at defining this behavior on a customer record.  
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Multiple Currency Customers 
 
This functionality requires first enabling the Multiple Currencies feature: 

• Setup > Company > Enable Features > Company subtab, International 
section 

 
Set primary and additional currencies on the customer record: 
Go to a Customer record and Edit, go to the Financial subtab 

 

• On the Financial subtab, Account Information section, Primary Currency field 
select the currency to default for sales transactions, balance information and 
credit limits 

• Scroll down to the Currencies sublist and add / define each additional Currency 
to be used 

• Subcustomers are assigned the same currency as the parent company 

• Currency records are maintained in Lists > Accounting > Currencies 
 
Changing Primary Currency on Customer Record 
Edit a Customer record to reset the Primary Currency on transactions, credit limits 

and aggregate balance information as needed: 

• On the Financial subtab, Account Information section, Primary Currency field 
change to a different currency to default for sales transactions, balance 
information and credit limits 

• If primary currency is changed you must re-enter the Credit Limit 

• Cannot remove any currencies that have transactions against them 
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Walkthrough: Multiple Currency Vendors 
 

  

Use Case:  Your Company is also doing business with vendors that transact in multiple 

currencies. Let’s look at defining this behavior on the vendor record.  

 

Define Multiple Currencies on a Vendor Record 
 

Enable Multiple Currencies feature: Setup > Company > Enable Features > Company 

subtab, International section. 

Edit a Vendor record to set the Primary Currency and additional Currencies: 

• On the Financial subtab, Account Information section, Primary Currency field 
select the currency to default for purchase transactions, balance information and 
credit limits 

 

 

• Scroll down to the Currencies sublist and add / define each additional Currency 
to be used 
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Changing Primary Currency on Vendor Record 
 

Edit a Vendor record to reset the Primary Currency on transactions, credit limits and 

aggregate balance information as needed: 

• On the Financial subtab, Account Information section, Primary Currency field 
change to a different currency to default for purchase transactions, balance 
information and credit limits 

 

 
 

• If primary currency is changed you must re-enter the Credit Limit; credit limit is 
by subsidiary and tracked on the subsidiaries subtab 

 

Review Currencies in a Sales Report 
 
Currencies can be viewed in reports, e.g. Sales by Customer Report customized: 

• Go to Reports > Sales > Sales by Customer > Customize 

• Add the following fields (columns) 
o Sales: Amount (Foreign Currency) 
o Sales: Currency: Name 
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Accounting for Currency Exchange Rate Fluctuations 
 
Exchange rate variances between your base currencies and the foreign currencies can 

impact your General Ledger accounts: 

• Variance between the transactions’ initial value and the value upon closure or 
payment 

• Gains and losses post to separate GL accounts based on their source 
 

 

• Go to Transactions > Financial > Revalue Open Currency Balances 
o Select the Posting Period, Accounting Book (if Multi-Book feature 

enabled) and the Subsidiary 
o Select other optional fields, as required by your process 

 

 
 

Now It’s Your Turn 
 

 
Use Case/Scenario:  Chatham is using OneWorld functionality, multi-currency currency 

customers and vendors:  

• Confirm currency features and accounting preferences 

• Add Japan and Russia as subsidiaries with new currencies of Yen and Ruble as 
base currencies 

• Ensure that vendor and customer records have additional currencies available to 
them 

• Allow 15 – 20 minutes 
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Exercise 01: Confirm Features and Set Accounting Preferences 
Time: 1-2 minutes 

Scenario: The Chatham Company is using multiple currencies, for transactions with vendors and 

customers, and we need to confirm settings 

In these exercises: 

 Confirm feature 

 Set accounting preference 

 Go to Setup > Company > Enable Features 

a. On the Company subtab, International section, confirm that Currency Exchange Rate 

Integration is selected. 

b. Click Save. 

 Go to Setup > Accounting > Accounting Preferences 

a. On the General subtab, scroll down to the Exchange Rate Integration section and the 

Rate Provider field and choose Thomson Reuters (in production accounts, Xignite is no 

longer supported.  You may review the field help for this field. 

b. Review field help for the Use Triangulation Calculation by NetSuite field, but do not 

select it. 

c. Click Save. 

 End. 
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Independent Study Exercises 

Exercise 02: Create New Currencies/ New Subsidiaries and Update Time Zone 
Time: 5 minutes 

Scenario: In these exercises: 

 Create two new currencies  

 Create the new subsidiary for each currency 

 Update currency record for the Update Time Zone 

Create new currencies 

 Navigate to Lists > Accounting > Currencies > New. 

 Enter the following details for the new currency record: 

a. Name: Ruble 

b. Default Locale: Russian Federation (Russian) 

c. ISO Code: RUB 

d. Default Exchange Rate (to root subsidiary currency): 0.03 

e. Leave Automatic Update as checked 

 Click Save when you have finished. 

 View the Currencies List and note if Ruble is a Base Currency. 

 Now click New. 

 Repeat these steps to create a currency for Japan using the following details for the new record: 

a. Name: Yen 

b. Default Locale: Japan (Japanese) 

c. ISO Code: JPY 

d. Default Exchange Rate (to root subsidiary currency): 0.01 

e. Leave Automatic Update as checked 

 Click Save. 

Create new subsidiary for each currency 

 Navigate to Setup > Company > Subsidiaries > New. 

 Enter the following details for the new subsidiary record for Russia: 

a. Name: Russia 
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b. Subsubsidiary of: Parent Company 

c. Document Number Prefix: RU 

d. Currency: Ruble 

e. Country: Russian Federation 

 Click Save &New. 

 Repeat these steps to create a subsidiary for Japan using the following details for the new 

record: 

a. Name: Japan 

b. Subsubsidiary of: Parent Company 

c. Document Number Prefix: JP 

d. Currency: Yen 

e. Country: Japan 

f. What did the Edition field value default to, when you choose the Country as Japan? 

 Click Save.  

 Navigate to Lists > Accounting > Currencies. Are the Ruble and the Yen listed as a Base 

Currencies? If so, Why? 

 Click on Ruble to edit the currency Record and update time zone: 

a. In the Update Time Zone, select (GMT+01:00) Brussels, Copenhagen, Madrid, Paris 

b. This will align the update to a closer time zone. 

c. Click Save  

 Click on Yen to edit the currency Record 

a. In the Update Time Zone, select (GMT+09:00) Osaka, Sapporo, Tokyo 

b. This will align the update to a closer time zone. 

c. Click Save 

 End. 
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Exercise 03: Assign Currencies to a Customer 
Time: 3 minutes 

Scenario: You want to take advantage of the multi-currency customer feature, to transact sales with 

customers in various currencies. 

 Assign one (1) additional currency to a customer record. 

  Note: Since Customers can be created in multiple subsidiaries, the corresponding subsidiary 

currencies are automatically added to the customer record. 

 As the Administrator, navigate to List > Relationships > Customers.  

 Click Edit next to TEST ABC. 

 Go to the Financial subtab, then to the Currencies sublist.  Note: If you do not see the Currencies 

sublist, then the Multi-Currency Customers feature has not been enabled or it was turned off.  

a. In the currency field, click the dropdown arrow and select Canadian Dollar. 

b. Click Add. 

c. You do not need to do anything with the Currency Format column, but the capability 

exists to override the Currency format. 

d. Click Save. 

 End. 
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Exercise 04: Assign Currencies to a Vendor 
Time: 3 minutes 

Scenario: You want to also take advantage of the multi-currency vendor feature, to transact purchases 

with vendor in various currencies. 

 Assign one (1) additional currency to a vendor record. 

 Navigate to List > Relationships > Vendors.  

 Click Edit next to TEST Widget Works. 

 Go to the Financial subtab, then to the Currencies sublist.  Note: If you do not see the Currencies 

sublist, then the Multi-Currency Customers feature has not been enabled or it was turned off.  

a. In the currency field, click the dropdown arrow and select Canadian Dollar. 

b. Click Add. 

c. Click Save. 

 End. 
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Solution for Exercise 02: Create New Currencies/ New Subsidiaries and Update 

Time Zone 

 
What did the Edition field value default to, when you chose the Country as Japan? 

Answer: JP 

 

Navigate to List > Accounting > Currencies Are the Ruble and the Yen listed as a Base Currencies? If so, 

why? 

Answer: Now that we have created subsidiaries, all these currencies are base currencies. 
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Activity: Match Game 
 

After doing the exercises, match the term on the right with the description on the left 

 

 

Additional Resources 
 
NetSuite Help Center: 

• Accounting: General Accounting: Working with Currencies  
 
SuiteAnswers Learning Center:  

• New Feature Training 

• NetSuite OneWorld 
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NetSuite Tax Information 

 

About this Module 
 

Taxes! It is important to understand NetSuite tax concepts as you are implementing 

NetSuite: 

• NetSuite helps track, calculate and pay different types of taxes, based on the 
sale of products and services  

• The Advanced Taxes feature and NetSuite Editions drive tax functionality 
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NetSuite Editions and Advanced Taxes 
 
NetSuite provides tax functionality using the NetSuite Edition and the Advanced 

Taxes Feature, if enabled. 

 
NetSuite Editions support localized handling of taxes: 

• The country of business determines the edition 

• In a single-instance account, the edition manages the taxes for the account 

• In a OneWorld account the subsidiaries may use different NetSuite editions 
 

Advanced Taxes feature: 

• Manage and calculate taxes for different nexuses (tax jurisdictions) within the 
same NetSuite account 

• Utilize tax schedules to define the tax treatment of items, in each nexus, meeting 
local business requirements 

• OneWorld accounts, by default, utilize Advanced Taxes 
 

NetSuite and Taxes around the World 

The different editions handle country-specific taxes (sales & purchase): 

• NetSuite United States (US): 
o Pre-coded tax, State tax imports required 
o No separate tax reporting periods, No Foreign trade settling 

• NetSuite Canada (CA): 
o Pre-coded tax, GST/PST 
o No separate tax reporting periods, No foreign trade settling 

• NetSuite United Kingdom (UK): 
o Pre-coded tax, VAT 
o Separate tax reporting periods, Provides full EU reporting 
o Foreign trade settling 

• NetSuite Japan (JP): 
o Pre-coded tax, Consumption Tax 
o Separate tax reporting periods, Foreign trade settling 

• NetSuite Australia (AU): 
o Pre-coded tax, GST 
o Separate tax reporting periods, Foreign trade settling 

• NetSuite International (XX): 
o No pre-coded tax – install bundle to configure 
o Separate tax reporting periods 
o Foreign trade settling 
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Overview of NetSuite Tax Terminology 
 
Most of the following terminology is part of tax setup, across editions: 

• Tax Periods: Are expressly for tax reporting in all Non-US and Non-Canada 
editions and set up is similar to set up of accounting periods 

• Nexus: Defines jurisdictions in which you collect and pay sales and/or purchase 
taxes; required component of Advance Taxes functionality 

• Tax Control Account: Define tax types and contain GL postings of indirect taxes 
such as sales tax and VAT 

• Tax Types: Define where the paid or collected tax is tracked on the balance 
sheet and used to define tax codes 

• Tax Codes: Determine the amount of tax applied to each line item on your 
transaction  

• Tax Groups: Combine several tax codes that can then be applied to a 
transaction 

• Tax Schedules: Determine how NetSuite calculates taxes for items in each 
nexus 

• Tax Agency: Defines a vendor record as the taxing authority to which taxes are 
paid on behalf of customers 

 

Tax Periods for Reporting 
 
The use of Tax Periods: 

• Facilitates audits 

• Allows closing individual periods, 

• Enables running tax reports whether monthly, quarterly, or annually 
 
Go to Setup > Accounting > Manage Tax Periods to set up and manage your tax 
periods: 

• Track Tax Reporting periods separately from Accounting periods: 

• Available in all editions, except the US and Canada 

• Tax periods apply across all subsidiaries; close at subsidiary level 

• Set up is like the setup of accounting periods; includes the ability to tie a specific 
fiscal calendar to the tax period 

 
Why do you need Tax Reporting periods?  

• If you back dated a transaction and you have closed the transactions for that 
period, the tax cannot be applied into that previous month 

• Your A/P is closed, but you still want to report tax into the closed period, the Tax 
Report period is still open and this allows you to report the tax  
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Country – Specific Tax Reporting Available 
 
NetSuite supports country-specific sales tax/GST/VAT reports: 

• NetSuite releases bundles (SuiteApps) regularly with updated accounting 
functionality for international tax reporting (usually Fridays) 

• NetSuite software is certified, which indicates that your audits are based on 
generally accepted accounting and bookkeeping rules applicable in each country 

• Go to Setup > Company > Enable Features > Tax subtab, Tax & Compliance 
section:  

o Review the list of Related SuiteApps 
o Click on the available hyperlinks for: 

▪ International Tax Reports 
▪ Withholding Tax 
▪ Tax Audit Files  

 
Accounting functionality certified by the specific countries’ independent auditors: 

• NetSuite software is certified, which indicates that your audits are based on 
generally accepted accounting and bookkeeping rules applicable in each country 

o Certification does not mean that the product is fully market ready (i.e. has 
all the requirements that local users need such as online banking, payroll, 
shipping) but it means that it meets the accounting rules required of 
software in that country  

 

Tax Nexuses 
 

Nexus defines geographies in which you collect and pay sales and/or purchase taxes 

• NetSuite automatically creates one nexus per subsidiary in OneWorld 
o In the United States or Canada, creates one nexus for the state/province 

defined during creation of the subsidiary 
o In other countries, creates new nexus based on country selected 

• You can independently associate each subsidiary with additional tax nexuses 
 

Note: A nexus may also be manually set up, if you are using Advanced Taxes:   

• Use Case: U.S. company running the U.S. edition of NetSuite and they need to 
pay GST and HST Canadian taxes 

• Turn on advanced taxes and setup a Nexus for each Canadian Province that is 
required for the calculation of taxes 
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Tax Schedules 
 
Go to Setup > Accounting > Tax Schedule > New and enter the following: 

• Product field, enter the name of the tax schedule that you want to associate with 
a product or item 

• Enter a Description for this tax schedule 

 
 

• For nexuses in the U.S. click the US Nexuses subtab, and check the box in the 
Taxable column next to each state where these items are taxable 

• For Non-US nexuses click the Non US Nexuses subtab, select the sales and 
purchase tax codes to be used when charging customers with shipping 
addresses in those countries 

 
Tax schedules determine tax calculations (treatment) for an item, in each nexus: 

• Countries charge goods/services at the same tax rate across the country 

• US and Canada, taxation of goods and services is specific to the state or 
province, so in this case a tax schedule is useful 

o Graphic design services = taxable in New York, not taxable in Florida 
 

Edit Items to Assign Tax Schedules 
 

Edit an item or use Mass Update Items to apply Tax Schedules to those items: 

• Edit an item record, go to the Accounting subtab, Tax/Tariff section and Tax 
Schedule field 

 
• Or, go to Lists > Mass Updates > Mass Updates and expand the General 

Updates 
o Select Item type 
o Select Tax Schedule criteria and properly define it 
o Go to Mass Update Fields 
o Check the Apply Fields check box for the Tax Schedule and in the Value 

field, select the new Tax Schedule 
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Activity: True or False 
 

 

Now It’s Your Turn 
 

 

Use Case/Scenario:  Chatham is using Advanced Taxes features and as the 

administrator you can do some initial configuration 

• Set up current year tax periods 

• Define Tax Schedules for US, Germany and Italy 

• Allow 5-10 minutes 
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Independent Study Exercises 

Exercise 01: Manage Tax Periods  
Time:  3-5 minutes 

Scenario: Chatham’s need to adhere to International tax laws. In this exercise: 

 Set up a tax period for the current year 

 Navigate to Setup > Accounting > Manage Tax Periods and note which Tax Period already exists 

a. On the top, left-hand side of the page, click the Set Up Full Year button. The New 

Generate Tax Reporting Periods for Full Year page opens. 

b. In the Fiscal Year End field, enter the current year.  

c. Ensure Period Format = Calendar Months. 

 Click Save.  You may repeat these steps for any future years 

 Verify the period created is for the current year (or the next year) with four quarters. 

 End. 
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Exercise 02: Set Up a Tax Schedule 
Time: 3-5 minutes 

Scenario: Chatham Company utilizes Advanced Taxes. In this exercise: 

 Define a tax schedule for US 

 Also, define tax schedules for Germany and Italy 

 Note: The features in this exercise might be different from those in your purchased NetSuite 

account. 

Create new currencies 

 Navigate to Setup > Accounting > Tax Schedules > New. 

a. Note: You may need to scroll down through the menu items. 

 The Tax Schedule page displays. 

a. In the Product field, type S1. 

b. In the Description field, type S1. 

 On Non US Nexuses subtab, do the following: 

a. Germany:  

i. Sales Tax Code field, select UNDEF-DE from the dropdown list. 

ii. Purchase Tax Code field, select UNDEF-DE from the dropdown list. 

b. Italy:  

i. Sales Tax Code field, select UNDEF-IT from the dropdown list. 

ii. Purchase Tax Code field, select UNDEF-IT from the dropdown list. 

 Click US Nexuses subtab and confirm that CA is the defined nexus. 

 Check the Taxable checkbox, since we will be charging taxes in California. 

 Click Save. 

 End. 

 

  



71 

 

Additional Resources 
 
NetSuite Help Center: 

• Accounting: Taxation: Advanced Taxes 

• Account Setup: Account Setup: Getting Started with OneWorld 
 
SuiteAnswers Learning Center: Training Videos 

• New Feature Training 

• Financial Management 
 
NetSuite Essentials tab, in your Demo Account – view Videos: 

• Set Up US Tax 

• Set Up EU Tax 

• Set Up UK Tax 

• Set Up CAD Tax 
 

 

  



72 

 

 



73 

 

 

Set Up Items 

 

About this Module 
 

Your company needs to effectively manage goods and services that you buy and sell: 

How do you: 

• Match your business requirements to the NetSuite functionality 

• Obtain real-time information on quantities, prices, costs and asset value  

• Streamline stock levels, reduce costs and maximize revenue and profits 

• Items and Inventory Considerations 
 

 
 
  



74 

 

Items and Inventory Considerations 
 

What are each of your products and services?  

• How can you map to NetSuite’s item types and categories? 
o Do you have the need to assemble items as finished goods or sell items 

as a collection of other items? 

• How would you sell Software and Services, in groups or packages? 
o Do you need to track time against a service item? 
o How do you describe your items? Are these short descriptions or do you 

tend to provide detailed descriptions for your clients? 
 
How will you manage inventory distribution and fulfillment? 

• Do you track and distribute inventory to multiple locations? 

• What is your fulfillment process?  
 

OneWorld Considerations 
 
The following may be some things to think about with OneWorld: 

• Are your products and services offered in all subsidiaries? 

• In your current system, do subsidiaries share locations and warehouses?  

• Currently, how do you process transfers between locations and warehouses that 
may/may not be in same subsidiary? 

o Non-OneWorld accounts – Inventory Transfer Orders 
o OneWorld accounts – Intercompany Inventory Transfers 
o OneWorld account could also use a buy (purchase order)/sell (sales 

order) process between subsidiaries 
 

Ecommerce Items Considerations 
 

Ecommerce may have its own set of considerations: 

• Do you have a Web store and how do you want items displayed? 

• Do you plan to have one or more Web sites, and have sites share items for sale?  

• How are you planning to display out of stock inventory? 

• Are you planning to do personalized or custom items? 

• Are you planning to sell and process Gift Certificates/Promotions on your Web 
site? 

• Are you planning to charge up front or allow the customers to be invoiced? 
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Activity: Your Inventory and Items Considerations 

 

Which areas will you be using? Comments and concerns? 
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Walkthrough: Enable Features 
 

 

Use Case:  Configure the features to accommodate your strategy with managing and 

selling goods.  

 

Enable Items and Inventory Features 
 
Navigate to Setup > Company >Enable Features > Items & Inventory subtab 

• Review the available Items features; enable appropriate features per your 
requirements 

• Review the available Inventory features; enable appropriate features per your 
requirements: 

o Once Inventory is enabled, NetSuite automatically creates accounts for 
Cost of Goods Sold (COGS) and Inventory Assets. 

o Note: The Standard Costing feature must be enabled to make it an 
available accounting preference for Inventory Costing Method 

o Multi-Location Inventory (MLI): Once enabled, the warehouse becomes 
a mandatory field either at the header or line-level of any sales transaction 

▪ Important: Besides distribution, once a transaction is created in 
any MLI location, the MLI feature cannot be switched off  

o Landed Costs (Optional): 
▪ Landed Costs: track the true cost of shipping including shipping, 

duty fees and other fees that are involved in getting you your 
products.  

▪ Any landed cost associated with an item is added to the actual 
asset value of an inventory item, allowing you to accurately 
calculate profitability  

▪ For existing inventory items that have an associated landed cost, 
you can check the Track Landed Cost box on the item record. 
Then, you can enter the landed cost information on item receipts 
and bills that include these items 
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Enable Features for Ecommerce 

Go to Setup > Company >Enable Features: Web Presence subtab 

 

• Review the Web Site, Publishing, and Access sections and enable the features 
per your requirements 

 

Walkthrough: Accounting 
 

 

Use Case:  The necessary features have been enabled; now examine the related 

accounting configuration.  

 
Define Accounting Preferences: Default Accounts, Work Orders 

 
Define Items/Transactions preferences per your company needs: 

Go to Setup > Accounting > Accounting Preferences: 

• Items/Transactions subtab 
o In the Accounts section, define the various Default Accounts 

 
▪ Default Cost of Goods Sold (COGS) Account 
▪ Default Asset Account 
▪ OneWorld Note: Default accounts are set for the root (parent)  

o Go to the Inventory section and review preferences such as: Centralize 
Purchasing in a Single Warehouse 
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• Order Management subtab, Work Orders section is available if the Work 
Orders feature has been enabled  

 
o Check Allow Purchase of Assembly Items to add assembly 

items to purchase orders, vendor bills, checks, credit card 
transactions and vendor credits.  This is dependent upon 
Assembly and Work Order features being enabled. 

 

Costing Methods 
 

Go to Setup > Accounting > Accounting Preferences > Items/Transactions subtab; 

go to the Costing section and select the Inventory Costing Method to meet your 

business needs: 

• Choices that are available are dependent upon which Inventory features are 
enabled 

 
• Select from Average, FIFO, LIFO, or Average to define how you handle the costs 

associated with buying the same items at different purchase prices over a given 
period of time: 

▪ Average costing (weighted-average method): Total units available 
during a period divided by the beginning inventory cost plus the 
cost of additions to inventory. This the NetSuite Default 

▪ FIFO (First-in, first-out): First goods purchased are assumed to be 
the first goods sold so that the ending inventory consists of the 
most recently purchased goods 

▪ LIFO (Last-in, first-out): Last goods purchased are assumed to be 
the first goods sold so that the ending inventory consists of the first 
goods purchased. 
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o If you enabled Standard Costing at Setup > Company > Enable 
Features > Items & Inventory subtab, Inventory then you will also be 
specifying a Default Cost Category to classify the type of inventory item, 
for example Materials versus labor 

• Create at Setup > Accounting > Accounting Lists > New 
> Cost Category  

• If you use lot numbering or serial numbering to track inventory, you can now 
choose to use Average costing for these items- Refer to SuiteAnswers 

 

Walkthrough: Review an Item Record 
 

 
 
Use Case:  In preparation for entering goods and services, that you buy and sell, 
prepare by examining an item record  
 

Review an Item Record 
 
If you review various item records, most item records do have similar fields in the 

following sections: 

• Primary Information:  Name fields, item hierarchy – (UPC code is only visible if 
the Bar Coding feature is enabled) 

• Classification: OneWorld Subsidiary information, Department, Class, and 
Location 

 

 
 
The difference in the item records is evident when reviewing the different subtabs, 

which determine the item’s behavior: 

• Can a purchase price or selling price be entered? 

• Are we tracking Inventory? 

• Can we track against COGS, Asset, or Income Accounts? 

  



80 

 

Walkthrough: Inventory and Matrix Items 
 

 
 
Use Case:  Chatham Company will be selling inventory items. They also may consider 
matrix items, selling items with various options. Let’s look at these item records 
 

Inventory Items 
 

 

Inventory Items are goods purchased, stocked and sold, such as: 

• Goods sold to customers 

• Parts and raw materials purchased from vendors 

• Tracked individually or as groups, kits or assembles 

• Go to Lists > Accounting > Items > New > Inventory Item 

• Review available subtabs and enter in necessary information 
o If you are running a Web Store, go to the Web Store subtab: 

▪ Define how the item displays in the Web site 
▪ Describe the item 
▪ Set Stock and Pricing Behavior 
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Matrix Items 
 
Matrix Items allow you to define item properties such as size and color, e.g. t-shirts in 

different sizes and colors: 

 

• An item matrix consists of a parent item and sub items 

• Go to Lists > Accounting > Items > New > select the Matrix Item Assistant 
hyperlink for an item type 

o This easy-to-use feature lets you create an item and all the available 
options in single step-by-step interface 

• Alternatively, create manually by setting up custom lists and fields 

• Review available subtabs and enter in necessary information 
 

Non-Inventory Items 
 

 
 
Use Case:  Chatham Company also will be using non-inventory items and will 
investigate for purchase, for sale and for resale  
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Non-inventory Items 
 
Non-inventory Items: not kept in formal stock and are costs related to doing business: 

 

• Lists > Accounting > Items > New and select one of the following types of 
Non-inventory Item 

o For Purchase: items purchased that are not sold, e.g. office supplies 
o For Resale: items both bought and sold for a profit, e.g. case of soda 
o For Sale: items sold that are not purchased, e.g. dinner entrée 

 

Non-Inventory Conversion 
 
Convert items originally set up as a non-inventory type into a type of inventory item.  

• Go to Lists > Accounting > Items and click the View link of an item record 

• Click on Convert to one of the following, dependent upon enabled features: 
o Convert to Inventory 
o Convert to Serialized Inventory, 
o Convert to Lot Numbered Inventory 

 

• Keeps all records in one place: 
o Transaction history of item prior to conversion 
o All inventory data after conversion 
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Walkthrough: Service Items 

 
Use Case:  Chatham Company also will offer service on items that they sell. They will 
consider service items for investigate for purchase, for sale and for resale  
 

Service Items 
Service Items: allow tracking time and recording billable hours  

 

• Track time across subsidiaries using Intercompany time feature 

• Software companies commonly setup Support, Maintenance, Consulting and 
Installation as Service Items  

• Lists > Accounting > Items > New and select one of the following types of 
Service Items 

o For purchase: buy from vendors, but do not sell to customers 
o For resale: buy from vendors and then sell to customers 
o For sale: sell to customers 

• Go to the service Item Preferences subtab and select Can be 
fulfilled/Received; allows for item fulfillment / receipt 

 
Software items may be set up as service items (specifically for things such as 
professional services or training) for a fixed fee.  
 
Software companies commonly setup Support, Maintenance, Consulting and Installation 

as Service Items linked to: 

• Products/Licenses as tracked as non-inventory items 

• Choose the service item, when entering time, and bill to customer 

• You can bundle licenses and services into an item group 
o With both Advanced Billing and Advanced Shipping features, you can set 

a status on service item records that defines them to be fulfilled or 
received. Then, order processing is based on the fulfillable/receivable 
status of the item 

o Preferences: Can be fulfilled/Received and Offer support 
▪ Check to enable item to be received and fulfilled 
▪ Clearing item does not require being received and fulfilled 
▪ Once item has been added to transactions, this setting cannot be 

changed. 
▪ Advanced Billing and Advanced Shipping features are both enabled 
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Activity: True of False 
 

 

 

Walkthrough: Assembly, Item Group, Kit/Package 
 

 
 
Use Case: Chatham Company is also considering building items, as well as putting 
different components together 
 

Assembly Items 
 

Assembly items are available if the Assembly Items feature has been enable; Assembly 

Items are made up of several components, identified as a single item: 

• Go to Lists > Accounting > Items > New and depending upon features 
enabled, select from: 

o Assembly/Bill of Materials 
o Lot Numbered Assembly/Bill of Materials 
o Serialized Assembly/Bill of Materials 

 
• Manufactured by combining raw materials that you stock 

o The following can be added to Assemblies: 
o Inventory items and Non-Inventory items 
o Assemblies  
o Other charges and Service Items 
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Item Groups 
 
Go to Lists > Accounting > Items > New and select Item Group; create groups for 

items that you frequently sell together:  

• Entered as single unit, saving time creating sales transactions: 
o Displays as multiple line items when selected in a transaction; user adds 

or deletes items ad hoc   

• Price of group inherits prices of member items; there is no Sales/Pricing or 
Accounting subtab available 

• Go to the Purchasing/Inventory subtab, Components sublist and enter in the 
items 

o Purchasing and inventory information is tracked at the member level 

 
• The following can be added to item groups: 

o Inventory items 
o Assemblies and Kits 
o Service items 

 
Other Item Group attributes: 

o A group can be made up of taxable and non-taxable items, and tax is 
calculated only on the taxable items (components) 

o You can choose to print all the members of the group, with their quantities, 
descriptions and rates, on transactions, or you can print only the 
description and amount of the group item on the form. Details for each 
group component can be changed on transactions. 

o Software Items may be used as groups to sell a package of item, e.g. 
bundle license with support/maintenance  

o OneWorld Note: Members must be setup in the same subsidiary. 
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Kits and Package Items 
 
Go to Lists > Accounting > Items > New > Kit/Package: 

 
• Ability to create items that are collected from other items 

• Displays as a single line item when selected in transactions  

• Price is set at the kit level; the user cannot modify the kit contents 

• Add any of the following: 
o Description 
o Inventory or Non-Inventory 
o Other charge 
o Service 
o Kit / Package 
o Assembly items 

• OneWorld Note: Members must be setup in the same subsidiary. 
 
Other Kit/Package attributes: 

• You can choose to print all members of the kit, with their display names, 
quantities, descriptions and rates on the invoice or other forms. Or print only the 
description and amount of the kit or package on the form 

• Reporting Note: A kit has its own revenue GL/line account. Reporting on 
Sales/Revenue is by the kit NOT the members. 

 

Assembly vs. Kit vs. Group 
 
This is a useful chart to examine the different behavior of each of the listed item types. 
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Activity: Which Item Types Will You Need? 
 

 

Walkthrough: Inventory Adjustments 
 

 
Use Case:  The Administrator will work with the CFO and implementation team to 
determine options for adjusting inventory 
 

Adjust Inventory 
 

Change the quantity and value of your inventory with consideration to quantity on hand: 

• Go to Transactions > Inventory > Adjust Inventory and enter the following, 
required information: 

 
o Subsidiary 
o Adjustment Account 

• At the line level, in the Item field, select the item you want to adjust inventory for 
o Define all required column fields 

• If LIFO or FIFO are your costing methods, the costing method is preserved 

• Note: Lot numbered and serialized inventory items are visible 
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Adjust Inventory Worksheet 
Change inventory quantity / value exclusive of quantity on hand: 

• Go to Transactions > Inventory > Adjust Inventory Worksheet and enter the 
following, required information: 

 

o Subsidiary 
o Adjustment Account 
o Transaction Order: choose when you want this worksheet to post 
o First Transaction in Day: post at the beginning of the day and not 

include additional inventory transactions entered during that day for this 
worksheet. 

o Last Transaction in Day: post at the end of the day and do include all 
inventory transactions entered during that day for this worksheet. 

o Warehouse 

• If using LIFO or FIFO costing methods, the costing method is reset to average; 
costing history is lost 

o If you use the Worksheet and you have FIFO or LIFO costing methods, it 
will set your costing method to average. You will lose all your previous 
costing history information 

o To preserve LIFO or FIFO, use the Adjust Inventory form for any inventory 
adjustments. If you use the average costing method, you can make any 
changes you want on this worksheet 

• Note: Lot numbered and serialized inventory items will not be visible in the 
worksheet; use the Adjust Inventory transaction 

 

Other Inventory Adjustment information: 

• When you open an existing inventory adjustment to make changes, only items 
included in the original adjustment appear in the list. The list shows all items from 
the original adjustment and cannot be filtered to exclude any of these original 
items 

o Showing all items from the previously saved worksheet ensures that no 
lines are filtered out and deleted upon saving changes 
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Adjust Inventory vs. Adjust Inventory Worksheet 
 
Here are the primary differences between the inventory adjustment transactions: 

• Adjust Inventory 
o Is inclusive of the previous stock total 

▪ Once you have established your inventory, the Adjust Inventory 
transaction is more common; it preserves the adjustment history. 

o Adds or subtracts quantity to the previous inventory count 
o Lot numbered and serialized inventory items are visible in the Adjust 

Inventory transaction 
 

• Adjust Inventory Worksheet 
o Is exclusive of previous stock total 
o Resets the inventory count to the quantity entered on the date of the 

worksheet 
 

Best Practices: Items and Inventory 
 
Consider the following best practices for items and inventory: 
 

• If you are NOT using Inventory, then do NOT enable the feature. 

• Do not specify a location on an item record; this action limits the availability of 
that item 

• If Multi-Location Inventory is required, then it is recommended having the MLI 
feature enabled and then import items 

• If you enable the Multi-Location Inventory feature and distribute items, you 
cannot disable the feature without contacting Customer Support 
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Intercompany Inventory Transfer (OneWorld) 
 

Global product businesses need to move products between legal entities (subsidiaries): 

• NetSuite handles the operational and accounting details 

• End-to-end workflow, from PO/SO through fulfillment/receipt to invoice bill, is 
automated 

• Revalues period-end inventory and COGS 

• Detailed reporting provides a clear audit trail for internal and external auditors 
 
Please review Help Topics and New Feature Training in SuiteAnswers 

 
Inventory Workflow and Reporting 

 
NetSuite is an integrated system from procurement to sales, with reporting at the center: 

• Tracks quantity, value and commitment of items you purchase and sell 
o Committed: No longer available to sell, but inventory has not been 

relieved 

• Updates on-hand quantities for any transaction that affects inventory 
o On Hand: Quantity of the item in inventory, this includes available and 

committed 

• Defines item records with item’s cost, sales price, stock level and more 

• Tracks your cost of goods sold and assets 
 

Standard Financial and inventory Reports: 
Use the NetSuite Financial and Inventory reports: 

• Go to Reports > Financial to use the standard financial reports to streamline 
stock levels to reduce costs and maximize revenue and profits, e.g. 

o Income Statement 
o Balance Sheet 

• Go to Reports > Inventory/Items to use the inventory reports to make regular 
assessments of stock quantities and identify your replenishment needs, e.g. 

o Current Inventory Status 

o Inventory Back Order 

Review the Standard Reports topic in the Help Center and SuiteAnswers, for more 

information 
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Now It’s Your Turn 
 

 
 
Use Case/Scenario:  The administrator enters in a few items and inventory quantities 

• Allow 35-50 minutes 
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Exercise 01: Enabling Transactions and Inventory Features/Preferences 
Time: 2-3 minutes 

Scenario: Before setting up items and testing those items you must ensure that all required features are 

enabled. 

Chatham’s BRD defines item types and categories, transactions, and inventory management. They use 

inventory, non-inventory and service type items. 

In this exercise, enable the following features and define the Preferences 

 Transactions: Basic, Shipping & Receiving 

 Items & Inventory: Items and Inventory 

 Note: The features in this exercise might be different from those in your purchased NetSuite 

account. 

 Navigate to Setup > Company > Enable Features. The Company subtab displays. 

a. In the ERP General section, uncheck Multiple Units of Measure if checked. 

 Click the CRM subtab, go to the Support section and uncheck Issue Management, since 

Chatham will not be using. This removed a corresponding field on item records. 

 Click the Transactions subtab, ensure that the following features are checked, and only uncheck 

when directed, for each of the following sections; some of these features will be used in later 

modules: 

a. Basic Features 

i. Estimates 

ii. Sales Orders 

iii. Return Authorizations 

iv. Purchase Orders 

v. Vendor Return Authorizations 

b. Shipping & Receiving 

i. Advanced Shipping 

ii. Pick, Pack and Ship 

iii. Advanced Receiving 

c. Billing 

i. Bill Costs to Customers 
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ii. Uncheck Advanced Billing 

iii. Uncheck Charge Based Billing and any other Billing features listed. 

 Click the Items & Inventory subtab and ensure that the following features are checked for each 

of the following sections: 

a. Items 

i. Uncheck Matrix Items 

ii. Leave Multiple Vendors as checked. 

iii. Uncheck Bar Coding and Item Labels 

b. Inventory: 

i. Inventory 

ii. Multi-Location Inventory - If prompted, click OK to enable Multi-Location 

Inventory (for OneWorld accounts only). Then click OK two more times. 

iii. If checked you may leave Serialized Inventory and Lot Tracking as checked 

iv. No other Inventory features should be checked 

 Click Save when you are done. 

 Navigate to Setup > Accounting > Accounting Preferences. 

a. Select the Items/Transactions subtab. 

b. Go to Default COGS Account and choose Cost of Goods Sold or COGS. 

c. Confirm Default Asset Account is set to 1200 Inventory. 

d. Go to Default Receivables Account and choose or confirm 1100 Accounts Receivable. 

e. Ensure that Anyone Can Set Item Accounts is checked.  You may review field help for 

more information. 

f. Click Save when you are done. 

 End. 
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Exercise 02: Create Inventory Items  
Time: 3-5 minutes 

Scenario: The Chatham Company provides computer hardware and ink. In this exercise, you will set up 

two inventory items. 

 Navigate to Lists > Accounting > Items > New 

 Select Inventory Item from the list of available items. 

 Enter the following: 

a. Item Name/ Number: HP LJ 1320 Printer 

b. Subsidiary: Select Parent Company and check Include Children 

 On the Purchasing/Inventory subtab: 

a. Enter Purchase Price = 25.00 

 On the Purchasing subtab, click the Vendors sublist: 

a. Select Test Widget Works from the Vendor dropdown list 

b. Go to the Preferred column and check the box 

c. Go the Purchase Prices field, click the icon to set price by currency 

d. In the pop-up window, set the US Dollar or USA currency and Purchase Price at $25.00 

 

e. Click Add and then OK to close the pop-up window 

f. Click the Add button 

 Go to the Sales/Pricing subtab: 

a. Copy and paste HP LJ 1320 Printer into the Sales Description. 

b. Enter the Item Weight as 20 pounds. 

c. Go to the USA sublist and enter 50.00 in the Base Price field 

 Click the Accounting subtab and confirm accounts or select: 

a. Confirm COGS Account as Cost of Goods Sold 

b. Confirm Asset Account as 1200 Inventory 
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c. Confirm Income Account as 4000 Sales 

d. Select S1 from the *Tax Schedule dropdown In the Tax/Tariff section, 

 Click Save & New. 

 Enter the following: 

a. Item Name/ Number: Printer Ink Starter Pack 

b. Subsidiary: Select Parent Company and include Children 

 Purchasing/Inventory subtab: 

a. Item/Cost Detail section, enter Purchase Price = 15.00 

 Scroll down and click the Vendors sublist: 

a. Select Test Widget Works from the Vendor dropdown list 

b. Go to the Preferred column and check the box 

c. Go the Purchase Prices field, click the icon to set price by currency 

 

d. In the pop-up window, set the US Dollar or USA Currency and Purchase Price at $15.00 

e. Click Add and then OK to close the pop-up window. 

 Click Add 

 Go to the Sales/Pricing subtab: 

a. Copy and paste Printer Ink Starter Pack into the Sales Description. 

 Click the Accounting subtab and confirm accounts or select: 

a. Confirm COGS Account as Cost of Goods Sold 

b. Confirm Asset Account as 1200 Inventory 

c. Confirm Income Account as 4000 Sales 

d. Select S1 from the *Tax Schedule dropdown list 

 Click Save. 

 End. 
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Exercise 03: Create a Non-Inventory Item  
Time: 3-5 minutes 

Scenario: You regularly buy pens as an office supply, to have on hand in your supply rooms. In this 

exercise: 

 Create a non-inventory item resale, since you may also sell these items. 

 Navigate to Lists > Accounting > Items > New 

 From the New Item page, locate the Non-inventory Item section and click the For Resale link: 

a. Note: This makes the non-inventory item available on a PO to a vendor and a Sales 

Order for a customer 

 The Non-inventory Item for Resale page displays. 

a. Item Name/Number field, enter 12-Pack Ball Point Pens 

b. Subsidiary set to Parent Company and Include Children. 

 Go to the Purchasing subtab: 

a. Enter the Purchase Price = 1.99 

b. Enter Purchase Description = 12-pack regular ball point pens, blue ink 

 Scroll down to the Vendors sublist: 

a. Choose Test Widget Works. from the Vendor dropdown list 

b. Preferred = checked 

c. Go the Purchase Prices field, click the icon to set price by currency 

d. In the pop-up window, set the US Dollar or USA Currency and Purchase Price at $1.99 

e. Click Add and then OK to close the pop-up window 

f. Click Add 

 Click the Sales/Pricing subtab: 

a. Enter 12-Pack Ball Point Pen, blue ink into the Sales Description 

b. Scroll down and enter 10.00 for the Base Price 

 Click the Accounting subtab: 

a. Confirm Income Account as 4000 Revenue: Sales 

b. Confirm the Expense Account to 6150 Office Expense 

c. Tax Schedule = S1 
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 Click Save. 

 End. 
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Exercise 04: Create a Service Item 
Time: 3-5 minutes 

Scenario: Chatham sells service for the HP Printer. In this exercise: 

 Create a service item for Service for the HP LJ 1320 printer 

 Follow the same steps as the previous exercise to access the new item form, but create a 

Service Item For Sale this time. 

 The Service for Sale page displays.   

a. Item Name/Number field, enter Service for the HP LJ 1320 Printer 

b. Subsidiary set to Parent Company and Include Children. 

 Go to the Sales/Pricing subtab: 

a. Enter the Sales Description = Regular service for the HP LJ 1320 Printer 

b. Scroll down to the USA sublist and enter 25.00 on the Base Price line 

 Scroll up and click the Accounting subtab: 

a. Confirm the Income Account as 4000 Sales. 

b. Select Tax Schedule of S1. 

 Go to Preferences subtab and note the fields for Can be Fulfilled/Received and Offer Support. 

a. Do NOT check, but review the field help. 

 Click Save. 

 End. 
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Exercise 05: Create an Inventory Item for OneWorld  
Time: 3-5 minutes 

Scenario: One of the company’s requirements is to track its inventory by location. In this exercise: 

 Enter an item into the German subsidiary 

 Navigate to Lists > Accounting > Items. 

 Click on View next to the HP LJ 1320 Printer item. 

 Navigate to Actions > Make Copy. 

a. Enter HP Deskjet D2530 Printer (Germany only) into the Item Name/ Number field. 

b. Click on Parent Company: Germany in the Subsidiary field. 

c. Uncheck Include Children, if necessary. 

d. Navigate to the Sales/Pricing subtab and enter HP Deskjet D2530 Printer (Germany only) 

in the Sales Description field. 

e. Go to the Euro sublist and enter 65.00 in the Base Price field. 

 Click Save. 

 Navigate to Transactions > Sales > Enter Sales Orders. 

a. Make sure that you select Standard Sales Order in the Customer Form field. 

b. Note: We cover order management later in the course: this is to test the relationship 

between customers and items in OneWorld. 

 Select the Test German Customer. 

a. Click OK, if a pop-up window displays, to continue. 

 Navigate to the Items subtab and click the Item dropdown arrow.  

a. Is the HP Deskjet D2530 Printer item in the list? 

 Click Cancel and change the customer on your sales order to TEST ABC. 

 Go to the Items subtab and click the Item dropdown arrow.  

a. Is the HP Deskjet D2530 Printer item in the list? 

 Do not save the sales order. 

 End. 
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Exercise 06: Enter Inventory Quantities 
Time: 3-5 minutes 

Scenario: Chatham company wants to set the initial quantity for all inventory items, so they are going to 

use the Adjust Inventory Worksheet. In this exercise: 

 Enter quantities, for the newly-entered inventory items, in all warehouses. 

 Navigate to Transactions > Inventory > Adjust Inventory Worksheet. 

 For the Subsidiary dropdown list, select Parent Company from the dropdown list. 

 From the Adjustment Account dropdown list, select 5090 Inventory Variance. 

 In the Transaction Order field, select First transaction in day. The updated information will be 

available tomorrow.  

 For the Warehouse/Location value, select East Coast. 

a. All the inventory items should display in the Adjustments subtab. 

 Navigate to the Adjustments subtab and enter 100 in the New Quantity field for each item. 

a. There will be a pop-up warning window. Please ignore it as we are entering the opening 

balances.  

b. Note: If the New Value column displays zeroes, then a purchase price was not entered 

for the item record 

 Click Save. 

 Repeat for the German Subsidiary and the Berlin Warehouse. 

 End. 
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Solution for Exercise 05: Create an Inventory Item for OneWorld  

 
Click the Item dropdown arrow. Is the HP Deskjet D2530 Printer item in the list? 

Answer: Yes. The customer and item share the same subsidiary. 

 

Click the Item dropdown arrow. Is the HP Deskjet D2530 Printer item in the list? 

Answer: No. The customer and item do NOT share the same subsidiary.  
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Activity: Identify the Item Types 
 

After you do the exercise, write the item types next to these photos.  There may be 

multiple item types applicable to each picture 
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A Quick Note: Advanced Inventory Management v. Demand Planning 
 
Advanced Inventory Management 

• Calculates reorder points based on historical data 

• Assumes that demand is constant in most cases 

• Reordering is based on ‘reorder point’, which may create an excess in inventory 
o Examples:  Ordering Halloween candy based on current reorder point 

capability may create excess inventory around the shelf throughout the 
year 

 
Demand Planning 

• Order based on the expected demand  
o Demand can be calculated based on 

▪ Outstanding CRM data (i.e. opportunities, estimates, and sales 
orders) 

▪ Projection of historical demand mathematically 
▪ Provides ability to use the sales history of another item for 

calculations 
 

Need More Information 
 
NetSuite Help Center: 

• Items and Inventory Management: User Guide 
 

SuiteTraining: Manufacturing Course 
 

SuiteAnswers Learning Center 

• New Feature Training  

• Items/Fulfillment/Billing 

• Contract Renewals – Software Vertical 

• Items & Inventory 

• Ecommerce 
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Now It’s Your Turn – Various Feature Enhancements 
 
Please review the summarized information in your Student Workbook for enhancements 

as related to: 

• Inventory 

• Manufacturing 

• Costing 
 

Review information in SuiteAnswers, including New Feature Training videos.  

 

ERP - Supply Chain Management Enhancements 
 
The NetSuite Manufacturing and Supply Chain Management feature area is one of the 

most active product development areas in NetSuite; the goal is better production 

throughput and reverse logistics: 

• Improve demand planning visibility 

• Optimize work center productivity 

• Each NetSuite release brings more functionality 

• Please be sure to review the current New Release Notes. 
 
Plan your inventory levels more accurately and confidently, which can be challenging 

when dealing with unexpected demand changes: 

• Receive Planning Action Messages when using Demand Planning: 
o Planners can receive recommendations to take during each supply plan 

run to optimize productivity 
o Add Reminders to the Reminders portlet: 

• Use Planning Time Fence to allow NetSuite to make better suggestions for 
planning future item supply 

o Prevent disruption to planned production 

• Get deeper visibility into orders and assemblies using the Gross Requirements 
Inquiry, with the Show Details option: 

o Each line of the Gross Requirement Inquiry details the orders that create 
the demand 
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Optimize work center productivity with smarter work order management: 

• Schedule your manufacturing work centers using the Work Center Calendar 
o Use individual work center calendars to analyze scheduling capacities to 

optimize your work center processes 

• Use Work Order Validation to automatically validate work order operations 
sequences: 

o Set a preference to validate that routing operation sequences are always 
followed in accordance with the work order 

 
Utilize Warranty and Repairs management: facilitates registering item warranties and 

process warranty-related claims: 

• This is offered through a SuiteApp; please contact your sales rep to purchase 

• More information is available in the Help Center 
 

Distribution Resource Planning to plan inventory across locations and subsidiaries 

within a preset distribution networks: 

• Transfer item between locations to meet supply need 

• Have the option to increase inventory by transferring items 

• Enable the feature and define the Accounting Preferences 
 
Backward Scheduling for Manufacturing allows using a backward scheduling for 

supply planning, in addition to the forward scheduling method 

• Set the production end date to reflect the date you need to have the completed 
items 

• NetSuite determines the necessary production start date based on time, 
materials and resources needed to complete all necessary tasks 

 
Manufacturing Operations Overlap, Manufacturing Routing allows multiple work 

order to be processed in a staggered method throughout the production cycle; an 

improvement over one at a time 

 
Work Order Completion Validation Enhancements: completion validations will 

function when a work order is edited or deleted if you use the Check Completed 

Quantity in Prior Operations During Operation Completion preference 
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Set Up Pricing 

 

About this Module 

 

NetSuite provides multiple methods to capture your pricing strategy:   

• How do you sell your products?  

• What is your pricing strategy? 
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Pricing Considerations 

 

Before enabling any pricing features, document your pricing strategy and address these 

implementation questions: 

• Do you have a standard price book or do you use custom pricing? 

• Do you have tiered pricing levels? 

• Do you use volume-based pricing? 

• Are your transactions conducted in multiple currencies? 

• Do you maintain multiple price lists across your customer base? 
 

OneWorld: 

• Pricing is per currency, not per subsidiary! 

• Do multiple subsidiaries share a currency, but have different pricing?  

• How do you handle pricing for any intercompany purchases and sales?  

 
Activity: Pricing Considerations 

 

Comments and concerns? 
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Walkthrough: Review an Item Record 
 

 
Use Case:  To prepare for working with pricing, review an item record to see how 
pricing information is stored.  
 

Review an Item Record 
 

Go to Lists > Accounting > Items > New and select the item type, or Edit an existing 

item: 

 

• Go to the Sales/Pricing subtab where you may enter 
o Base Price 
o Quantity Pricing Schedules 
o Quantity breaks 
o Price Groups 

• If the Multiple Currencies feature has been enabled, then pricing is entered for 
each currency 

 
The rows and columns work together: 

• The columns are for your quantity breaks for pricing discounts 

• The number of pricing ‘buckets’ is an accounting preference 
 

Walkthrough: Define Pricing Features and Preferences 

 
Use Case:  If you have defined your pricing strategy, for your company, go ahead and 

configure NetSuite to match your needs.  

  



110 

 

Enable Pricing Features 
 
Go to Setup > Company > Enable Features > Transactions subtab, Sales section 

and select the options appropriate for your requirements: 

 

• Multiple Prices: Offers various prices, Price Levels, for the same items 
o Use Case: A company wants to sell an item at wholesale and retail prices 

at different times: Solution: Create price level for wholesale customers 
and price level for retail customers. Assign the price to each price level 

• Quantity Pricing or volume pricing: Item pricing is dependent upon the quantity 
purchased: 

o Quantity Pricing automatically applies different sales prices to items based 
on the quantity being sold, offering discounts to customers who buy in bulk 

o Quantity pricing schedules are templates applied to items to generate 
purchase and sale prices 

o Define the maximum number of quantity price levels in accounting 
preferences 

 

Walkthrough: Define Accounting Preferences 
 

Go to Setup > Accounting > Accounting Preferences > Item/Transactions subtab: 

 

• Review the Sales & Pricing section: 
o Maximum # of Quantity-based Price Levels:  

▪ Assign a value between 2 and 50 for the quantity price “buckets” 
o Allow Quantity Discounts per Price Levels on Schedules:  

▪ Check this box if you want to enter different quantity discounts for 
each price level on quantity pricing schedules. 
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Walkthrough: Use Pricing Features 
 

 
Use Case:  Features have been enabled, to accommodate different pricing types, now 
you can look using pricing.  
 

Set Up Price Levels 
 

Price levels allow you to setup multiple prices for each item you sell: 

• Go to Setup > Accounting > Accounting Lists > New > Price Level and enter 
the following: 

 
o Price Level:  enter a name 
o Markup/Discount %: may be a markup or discount that is applied to the 

base price 
o Update Existing Prices: Check this box to make this price level available 

on all item records that you sell 
o Online Price Level: Check this box to allow customers to use this in the 

Web store. 

• There is no "system” limit to the number of price levels; there may be a practical 
level 

• You may also define the out-of-the box price levels 
o Setup > Accounting > Accounting Lists and set the Type filter to Price 

Level 
o Edit one of the provided lists to define a markup or discount, and save 
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Quantity Pricing Schedule Overview 
 
Quantity Pricing Schedules are templates to apply to items to generate purchase and 

sale prices: 

• When you apply a quantity pricing schedule to an item, the prices for all price 
levels are created dynamically 

• You can apply a schedule to any number of items 
 
Quantity pricing schedules can be used to apply prices negotiated with vendors: 

• Edit the vendor record, and click the Financial subtab 
o On the Pricing Schedules sublist, click New Pricing Schedule 
o Only one vendor may be associated with each quantity pricing schedule 

 

Define a Quantity Pricing Schedule 
 
Go to Lists > Accounting > Quantity Pricing Schedules > New 

 
Enter the following: 

o Name 
o Use Marginal Rates: Check if you want the quantity discounts in the 

schedule to be applied to each pricing bracket separately. 
o Calculate Quantity Discounts: 

▪ By Line Quantity - pricing is applied according to the quantity 
included in the line item. 

▪ By Overall Item Quantity - pricing is applied for all line items for 
the same item on a transaction. 

▪ By Overall Parent Quantity - pricing is applied for all items with 
the same parent item on the transaction. This can be useful for 
applying quantity pricing to matrix items. 

▪ By Overall Schedule Quantity - pricing is applied to all items that 
use the same pricing schedule that are included in the transaction. 

• Quantity pricing schedules can be used to apply prices negotiated with vendors 
o To associate a pricing schedule with a vendor, edit the vendor record, 

click the Financial subtab. On the Pricing Schedules subtab, click New 
Pricing Schedule and add the schedule 

• On the Item record’s Sales/Pricing subtab, you can select the quantity pricing 
schedule you want to use to generate prices for the items 
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Define a Pricing Group 
Pricing Groups facilitate customer-specific price levels for groups of items: 

• Identify the items to be included by selecting the pricing group on the item record. 
E.g. Create a pricing group called “Laptops” and associate the pricing group with 
all your laptop items. 

• Define the pricing group and assign a price level on the customer record 
 
Go to Setup > Accounting > Accounting Lists > New > Pricing Group and enter in 

the following: 

 

 Pricing Group: enter the name for this group 

 
Walkthrough: Set Up Item Pricing 

 

 
Use Case:  Apply pricing on an item record.  
 

Sales/Pricing on Item Record 
 
Go to the item record and the Sales/Pricing subtab: 

 

• Enter in Base Price 

• Select optional Quantity Pricing Schedule or define Qty (Quantity breaks) 
o Choosing a Quantity Pricing Schedule automatically defines the 

Quantity break at a % discount, for example 8%: 
▪ Applied to the base price ($10 less 8% = $9.20) 
▪ Applied also to other price levels 

• Select optional Pricing Group 
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Walkthrough: Pricing on the Customer Record 
 

 
Use Case:  Pricing can also be applied on a customer record  
 

Pricing on a Customer Record 
 

On the Customer record, Financial subtab, define customer’s available pricing: 

 

• Go to the Account Information section 
o Price Level: sell items at a specific price level, select one from the list 

• Scroll down to the sublists 
o Group Pricing sublist: select a Pricing Group and apply a price level  
o Item Pricing sublist: define an absolute (contract) price for items 

▪ Enter custom item prices in any of a customer’s transaction 
currencies 

 

! 

Important: If either Group Pricing and/or Item Pricing are 
defined, those override the Price Level  

 
o For example, a customer is assigned a Price Level with an 8% discount. 

However, on the Item Pricing the price for a printer is defined with a Price 
Level of custom and the unit price of $25.  When this customer purchases 
items, they will receive the 8% discount on most products and pay $25 if 
they buy a printer 
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Walkthrough: Mass Update for Pricing 
 

 
Use Case:  Administrators can use a mass update to update prices for items, but there 
are some considerations  
 

Update Prices 
 
Mass update allows you to update prices and run per a defined schedule, but be sure 

that you adequately define the update. 

Go to Lists > Mass Update > Update Prices 

• Enter a Name for the update 

• Enter the change amount (-/+) or percentage 

• Choose the affected Price Levels 
o The “update” is uniform for all specified price levels and items 

• Define the appropriate criteria 

 

If items do not increment by a uniform amount, then use CSV import function to update 

your pricing 

Now It’s Your Turn 
 

 
 
Use Case/Scenario:  Let’s see how pricing works, starting out with enabling features, 

through a sales transaction, and then look at price lists. 

▪ Allow 35-45 minutes 
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Exercise 01: Enable Pricing Features 
Time: 2-3 minutes 

Scenario: Our company’s BRD requires that all products have prices. Price levels are established by 

products. Quantity pricing is also used. And in some situations, prices and price lists are established at 

the customer level.  

Further, prices are defined in the currency of the subsidiary where the transaction occurs.  

In this exercise: 

 Enable Pricing features 

 Note: The features in this exercise might be different from those in your purchased NetSuite 

account. 

 Go to Setup > Company > Enable Features and go to the Transactions subtab 

a. In the Sales section, confirm or select Multiple Prices and Quantity Pricing 

b. Scroll down to the Billing section and confirm or uncheck Advanced Billing  

c. Click Save 

 End 
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Exercise 02: Create a Price Level 
Time: 2-3 minutes 

Scenario: We have enabled multiple pricing, allowing price levels for items.  As the Administrator 

complete the following in this exercise: 

 Create a discounted price level. 

 Navigate to Setup > Accounting > Accounting Lists > New. 

 The Add to Accounting Lists page displays, select Price Level from the available list. 

 Enter the following information: 

a. Price Level as Test Price Level. 

b. Enter the Markup/Discount % as “-8”.  After you tab out, the field should display “-

8.00%” 

c. Check Update Existing Prices. Note: If you check Update Existing Prices, all items are 

updated using this price level. 

 Click Save. 

 Click the List hyperlink, top-right, to view the list of Price Levels 

 Confirm that your Test Price Level is displays.  

 End. 
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Exercise 03: Add Price Level to Items 
Time:  2-3 minute 

Scenario: In this exercise: 

 Add Base Price to item and see discounted price. 

 Navigate to Lists > Accounting > Items. 

 Click View next to Printer Ink Starter Pack. 

 Click Edit and go to the Sales/Pricing subtab > USA sublist. 

a. Confirm that Test Price Level displays in the list of price levels. 

b. Enter 30.00 as the Base Price, in the column under Qty 0, and tab out of the field. 

c. Notice that when you do this, the Test Price Level auto fills with the Base Price less the 

8% discount or 27.60. 

 Click Save. 

 End. 
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Exercise 04: Set Up Quantity Based Pricing  
Time: 3-5 minutes 

Scenario: In some situations, the Chatham Company uses quantity based pricing. In this exercise: 

 Define Quantity Based Pricing on Item record 

 Navigate to Lists > Accounting > Items. 

 Click View next to HP LJ 1320 Printer. 

 Click Edit and go to the Sales/Pricing subtab > USA sublist. 

a. The base price of 50.00 is already entered in the first column. 

b. For the quantities and their respective prices, enter in columns: 

Quantity 5 10 15 

Base Price 48 45 40 

c. Note that Test Price Level for each Quantity 

Test Price Level 44.16 41.40 36.80 

 

 Click Save. 

 End. 
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Exercise 05: Set Up Item Pricing on a Customer Record 
Time: 2-3 minutes 

Scenario: In this exercise, we will associate a pricing on Customer Record, TEST ABC: 

 Select Price Level 

 Use (Global) Search to find the TEST ABC customer record. 

 Click the Edit link next to the customer record. 

 Click the Financial subtab. 

 From the Price Level dropdown list, select Test Price Level. 

 Click Save. 

 End. 
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Exercise 06: Use Sales Transactions to Demonstrate Pricing Schemes 
Time: 3-5 minutes 

Scenario: Test customer's assigned price level in a transaction. In this exercise: 

 Enter a sales transaction to enter a cash sale. 

 In the Administrator role, go to Transactions > Sales > Enter Cash Sales 

a. Customer: TEST ABC 

b. Memo: Testing Pricing 

c. Warehouse: East Coast Warehouse 

d. The Date field defaults to today’s date. 

 Go to the Items subtab > Items column. 

a. Select Service for HP LJ 1320 Printer from the Item dropdown list and click Add. 

b. Notice that the Quantity defaults to 1. Price Level, Rate and Amount field automatically 

populate. Test Price Level populates from the customer record. 

 Go to the Billing subtab, scroll down to the Payment sublist and from the Payment Method list 

of value select Cash as the Payment Method. 

a. Click OK if any pop-up windows display. 

 Click Save 

 End.  
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Exercise 07: Generate Price Lists 
Time: 3-5 minutes 

Scenario: Price lists for customers are a defined requirement in the BRD. 

In this exercise: 

 Generate price lists for multiple customers and/or for an individual customer. 

 Note: The price list also reflects those items with a basic price, adjusted by the customer's 

price level and currency.  The base price is used if no price level is specified.   

 Navigate to Transactions > Customers > Generate Price Lists. 

a. In the Currency field, select Primary Currency; we only want to print the price list in the 

customer’s primary currency. 

b. Check Assigned Price Levels Only box, top right-hand side.  

c. In the Form field, select Standard Price List 

 On the Customers subtab select: 

a. TEST ABC 

b. Check the Print box. 

 On the Items subtab choose All in the Type box.  

 Click Print.  

 The Price List opens in a new tab; it displays in the prices list is dependent upon base price and 

pricing information on the customer record.  We are seeing the adjusted Unit Price, based on 

the Price Level on this customer’s record. 

 After reviewing, close the tab that is displaying the price list. 

 End.  
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Activity: Match Game 
 

Match the terms on the left, to the descriptions on the right. 

 

Additional Resources 
 
NetSuite Help Center: 

• Items and Inventory Management: User Guide 
 
SuiteTraining: Manufacturing Course 
 
SuiteAnswers Learning Center:  

• New Feature Training  

• Items/Fulfillment/Billing  

• Contract Renewals – Software Vertical 

• Items & Inventory 

• Ecommerce 
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Order Management 

 

About this Module 
 

Using order management streamlines the fulfillment processes: 

• Manage warehouse activities 

• Ship orders in a timely manner 
This module explores: 

• The considerations for enabling order management 

• The tasks for setting up order management 

• The step-by-step process for fulfilling a sales order 
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Order Management Workflow 
 
Example: 

This is a representation of Customers interacting with Sales; from the initiation of the 

quote, through order creation, approval then fulfillment with the shipping department. 

 
 
Note: The Accounts Receivable process is covered in the Account Receivable module. 
 

Order Management Transactions 
 
NetSuite can convert estimates (quotes) into orders, easily and efficiently, allowing for 
less data entry.  The following will also be looked at in the Sales Force Automation 
module: 

• Convert a quote to an order 

• Approve the order 

• Enter an order 

• Fulfill an order  
o Usually involves inventory items and a pick/pack/ship process 

• Bill the customer (send an invoice to the customer) via email, fax or hardcopy 
 

Quote-to-Invoice Process 
 
The following is the available quote-to-invoice process in NetSuite; you may choose to 

omit and alter some step: 

Create and save a Quote: Quote status = Open 

• Provides the customer with items and pricing information and may be the starting 
point for placing an order 
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Convert a quote by creating a sales order: Order status = Pending Approval 

• Rather than entering all new data for a sales order, quickly move the customer 
through the sales cycle.   

Approve a sales order: Order status is Pending Fulfillment 

• Maintain integrity over your selling processes.  For example: Sales managers 
can assure that sales policies are being followed. 

Fulfill the sales order: Order status is Pending Billing 

• Utilize the Item Fulfillment transaction, through the shipping or warehouse 
department, for tangible goods.  Note: Service Items can also be fulfilled if the 
service item has been set up correctly and the appropriate features have been 
enabled (Advanced Shipping and Advanced Billing).   

Invoice the sales order: Invoice status is Open 

• Billing is done by your accounting department.  Customers that pay on terms can 
receive an invoice.  A customer that paid cash, results in billing of the sales order 
turning the final transaction into a cash sale. 

 

NetSuite’s Order Management 
 
NetSuite can support simple to complex order management processes.   

 

Default Sales Order Status = Pending Fulfillment and order actions: 

• Enter sales order 

• Fulfill sales order 
 
Default Sales Order Status = Pending Approval and order actions: 

• Enter sales order 

• Approve sales order 

• Fulfill sales order  
 
Add Advanced Shipping and order actions: 

• Enter sales Order 

• Approve sales Order 

• Fulfill sales order and invoice sales order – actions taken by different 
departments 
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The focus of this class looks at adding Pick/Pack/Ship and the order actions: 

• Enter sales Order 

• Approve sales Order 

• Pick/Pack/ship 

• Fulfill sales order /invoice sales order – actions taken by different departments 

• Invoice the sales order 
 

Warehouse Actions 
 

Warehouse works with all sales orders with Pending Fulfillment status.  At this point 

inventory on this Sales order is “Committed.” These items are now available for this 

customer only on this sales order:  

• Fulfill all items on the order 
o Order status is Pending Billing  

• Partially fulfill order 
o Order status is Partially Fulfilled / Pending Billing 

 

Reminders and Order Management 
 
The Reminders portlet, on the dashboard, allows users to track orders through the 

order-to-billing cycle: 

 

• Sales Manager tracking orders to approve, e.g. Sales Orders to Approve 

• Warehouse staff monitoring the shipping queue, e.g. Orders to Fulfill 

• Account Receivable reminded when there are orders available to bill, e.g. Sales 
Orders to Invoice 

• Available reminders are based on permissions 

• User goes to the Reminders portlet and clicks on the relevant reminder to start 
the process 
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Sales Order Overview 
 
Sales orders are the transactions recording the sale of your goods and services:  

• There is no accounting impact until the items are shipped or services have been 
completed 

• Can be generated in different ways: 
o Order is entered upon receipt of a purchase order 
o Order is entered as a Web store purchase 
o Online order is entered in the Customer Center 

▪ The Customer center can also be an outlet for your distributors or 
resellers to create their own orders 

 

Types of Forms 
 

Sales Order forms can be customized to match your business requirements.  The 

following order forms may be accessed from Transactions > Sales > Enter Sales 

Orders, and then choosing from a dropdown list: 

• Standard Sales Order: Automatically creates the appropriate billing transaction 
based on whether you enter a payment method or select payment terms on the 
sales order 

• Standard Sales Order – Cash Sale: The sales order becomes a cash sale 
when it is fully billed. As it is a cash sale, full payment is assumed to be received 
at the point of transaction 

• Standard Sales Order – Invoice: This is the most commonly used sales order 
entry form; upon billing, this sales order becomes an invoice. No payments are 
recorded on this type of sales order; therefore, terms of payment need to be 
entered 

• Standard Sales Order – Progress Billing: This sales order is not commonly 
used; it works best when the Advanced Shipping feature is disabled (with no 
fulfillment). Many service businesses use Progress Billing to bill for portions of 
jobs as they are completed 

 

 

To make a sales order form preferred for all users, navigate to: 
Customization > Forms > Transaction Forms and select the preferred 
check box next to the sales order entry form commonly used by users 
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Order Management Considerations 

Quote-to-cash process: 

• What are the key steps in your quote-to-cash process? 

• Do you need approvals and if so what is the approval criteria? 

• What are your different order types? 

• How do you handle fulfilling orders?  
 
Return material authorization and Returns: 

• What are the critical decisions in the process? 

• Do you have different types of return codes/reasons? 
 
OneWorld: 

• If using special or drop ship orders, the vendor and customer must share the 
same subsidiary 

• The fulfillment location and customer must share the same subsidiary 
 

Activity: Your Order Management Considerations 

Take a look at some of the areas. Do you have comments or concerns?   
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Walkthrough: Set Up Order Management  
 

 
 
Use Case:  The administrator, finance, sales, and order management have discussed 
some requirements, not it is time to configure NetSuite.  
 

Enable Shipping & Receiving Features 
 
Go to Setup > Company > Enable Features > Transactions subtab to enable those 
features that support order management:  

 
 

• Review the Shipping & Receiving section 
o Advanced Shipping: Separates the fulfillment and billing steps; allows 

separate transactions to fulfill a sales order and bill a sales order 
o Allows users to invoice customers for an entire order, even if not all items 

were shipped; this will work in tandem with the Accounting Preference – 
Invoice in Advance of Fulfillment 

o Useful for companies where warehouse staff that fulfills orders is not 
responsible for generating sales invoices 

o There are also accounting impacts you need to consider. When do you 
want these actions to post, together at the same time or separately at 
different times? 

• Pick, Pack, Ship: Separates the fulfillment step into three separate steps 
(picking, packing and shipping), if three different people or departments are 
responsible for these functions 

o Use separate transactions for each step, which can feed information into 
Reminders portlet 

▪ Pick items from inventory 
▪ Pack items to be shipped 
▪ Ship the items 

 
Please be sure to review SuiteAnswers and Help Topics on the other features such as: 

Shipping Label Integration and Multiple Shipping Routes 

Advanced Receiving will be discussed in a later module. 

  



132 

 

Setup Defaults and Define Preferences Overview 
 
Go to Setup > Accounting > Accounting Preferences > Order Management subtab 
to define defaults and behavior to meet your business needs.  The available 
preferences are determined by the features enabled. 
 

 
• Review the following sections and review field help and help topics for available 

options: 
o Sales Orders: for example, Defaults Sales Order Status, Default 

Warehouse for Sales Orders 
o Picking/Packing: for example, the Name for each status 
o Fulfillment 

• The available preferences are dependent upon the features enabled for example: 
o The Name for Picked Status, Packed Status, Shipped Status fields are 

only visible if the Pick, Pack and Ship feature has been enabled 
 

Sales Order Defaults 
 
Select the Default Sales Order values to meet your requirements: 

• Default Sales Order Status 
o Pending Approval - you need a sales order approval process 
o Pending Fulfillment if an approval process is not needed 
o The status can be switched on the transaction 

• Require Re-Approval on Edit of Order 
o Someone edits an order that was approved previously 
o Partially fulfilled orders are not affected; the status cannot be changed 

back to pending approval 

• Send Email Confirmation when Sales order Cancelled 

• Default Location Sales Orders 
o Select a warehouse to default into an order 

• Item commitment options 
  



133 

 

Picking/Packing Defaults 
 

Select the Picking/Packing values to meet your requirements: 

 

• Picking ticket attributes 

• Printed forms 

• Status labels 

• Packing Slip attributes 
 

Fulfillment Defaults 
 

Select the Fulfillment values to meet your requirements: 

 

• Fulfill Based on Commitment: 
o Limit to Committed – cannot fulfill a quantity greater than commitment 

quantity 
o Allow Uncommitted – allows fulfillment of a quantity that is greater than the 

commitment quantity 
o Ignore Commitment – no restrictions, no regard to commitments 

• Default Items to Zero Received/Fulfilled 

• Filter Bulk Fulfillment Page by Warehouse 

• Allow Overage on Item Fulfillments – may work in tandem with commitment 
setting 

• Email settings 
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Walkthrough: Order-to-Invoice Process 
 

 
 
Use Case:  Start using the forms and move through the various transactions.  Finish by 
printing forms.  
 

Enter Sales Order 
 

Go to Transactions > Sales > Enter Sales Orders and on the New Sales Order page 

choose the appropriate form: 

• Changing the form after entering data results in losing your data 
o Alternatively, save the form and then edit to choose the correct form – this 

preserves the data 

• If multi-location inventory has been enabled, then the location (warehouse) is a 
mandatory field 

• Enter in all required information 

 
 
Select the appropriate Customer Form: 

• Standard Sales order: You can either accept a payment method or terms 

• Standard Sales order – Cash Sale: You need upfront payment from the customer 

• Standard Sales Order – Invoice: Has only terms; no payment method is available 
 

! 
Important: Recommended number of line items should be under 
the maximum of 500, when entering orders in NetSuite 
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Approve Orders 
 

Approval of orders is available in different locations: reminders, menu, or in the order:  

• Approve sales orders in bulk at Transactions > Sales > Approve Order: 

 
o This may also be accessed through Reminders 
o Results of this page can be filtered by date or by Supervisor if required 
o Select the first check box or check each order’s Approve check box 
o Click Submit 

• Individual orders can be approved from the Sales Order page: 

 
o View an individual sales order 
o Click the Approve button 

▪ Requires appropriate permissions 
 

Fulfill Orders 
 

Once approved, order fulfillment is available in different locations: 

• Fulfill orders in bulk processing at Transactions > Sales > Fulfill Orders or may 
also be accessed through Reminders: 

 
 

o Set the filters for Shipment Status, Location, etc. 
o Set Fields available to update some fields on the order 
o Select the Mark All or check each order’s Fulfill check box 
o Click Submit 
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• Individual orders can be fulfilled, picked, packed and shipped from the Sales 
Order page 

 
o View an individual sales order 
o Click the button being displayed, will be one of the following: 

▪ Fulfill, pick, pack and ship 
▪ Requires appropriate permissions 

 

Invoice Sales Orders 
 

With Advanced Shipping once orders are fulfilled, order billing is available in different 

locations: 

 

• Bill orders in bulk processing at Transactions > Sales > Invoice Sales Orders 
or may also be accessed through Reminders (Sales Orders to Invoice): 

o A filter may be set on Customer 
o Set Fields available to update some fields on the order 
o Select the Mark All or check each order’s Invoice check box 
o Click Submit 

• Individual orders can be invoiced from the Order page after they are approved 
and fulfilled 

 
o View an individual sales order 
o Click the Bill button 
o Requires appropriate permissions 

 

• Note: Marking the bills “To Be Printed” queues the invoices for a bulk print.  
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Print Order Form 
 

Orders, Picking Tickets, and Packing Slips can be printed individually or in bulk: 

• Go to Transactions > Management > Print Checks and Forms: 
o Select each form that you want to print 

• Does not require using separate Pick/Pack/Ship steps 

• Picking Tickets and Packing Slips can be printed any time during the fulfillment 
cycle 

• Invoices can also be printed once Orders are invoiced 

• TIP: You may want to add the various print pages as Shortcuts on your 
Home Dashboard. Also, explore the available Reminders. 

 

Walkthrough: View Sales Order History 
 

 

Use Case:  NetSuite gathers information on the sales order, related records, so let’s 

look.  

View Sales Order History 
 

View Sales Order status and history from the order record: 

• Go to Transactions > Sales > Enters Sales Orders > List and select an order 

• Status is displayed at the top of the form 
o If the order is not fulfilled, the status reflects Pending Approval or Pending 

Fulfillment and nothing displays on the Fulfillments and Invoices subtabs.  

• Go to the Related Records subtab to view Invoice and Fulfillment data: 
o If the order was split across more than one fulfillment (items were back 

ordered), the individual fulfillment transactions display. Similarly, if the 
invoicing was split, then more than one invoice displays 
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Drop Shipments & Special Orders 

 
Go to Setup > Company > Enable Features > Items & Inventory subtab to enable the 

Drop Shipments & Special Order feature, if required: 

• Drop Shipment sent directly from vendor to the customer 
o Item is not processed in your inventory; does not impact your inventory 

asset accounts or affect your stock count 
o Streamlines your inventory by reducing order-to-delivery cycle time 

• Special Orders (a.k.a. just-in-time" or customized orders) 
o Not fulfilled with regular stock, but is fulfilled only when the linked order for 

the special item is received from the vendor 
o Special orders are received into inventory and impact assets and COGS  

 

OneWorld Note: Vendor must be assigned to the correct subsidiary and you CAN have 
a preferred vendor for each subsidiary.  
 

NetSuite Terminology and Impact on Reports 
 

NetSuite has specific definitions that may not be consistent with your terminology. 

However, the application is designed for you to customize (rename) certain values.  

An Order is a transaction that records commitment to sell items or services to customer: 

• No accounting impact until items are shipped or services are completed 

• Order report shows what the original order is 

• Sales Report includes posted transactions, invoices, cash sales 

• Invoice reflects only what is invoiced at that time  
o May or may not correspond to what has been shipped, depending on use 

of Advanced Billing and Invoice in Advance of Fulfillment 
 

Standard Sales Order Reports 
 
Go to Reports > Order Management to view reports that help you analyze the order 
fulfillment process by: 

• Listing open customer orders with information about specific items 

• Showing items that are back ordered 

• Showing all open transaction lines for items committed and ready to be fulfilled 
on orders 
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Some of the key reports include: 

 

• Open Sales Orders: Lists only open customer orders with information about 
specific items, including the description, quantity ordered, quantity shipped and 
the quantity that still needs to be fulfilled 

• Sales Back Order: Shows items that are back ordered grouped by transaction 

• Sales Order Register: Lists all orders for a customer, gives the status and 
amount of those orders and reports only open sales orders if you check the Open 
check box 

• Sales Orders Pending Fulfillment: Shows all open transaction lines for items 
committed and ready to be fulfilled on sales orders, grouped by sales order 

• Shipping Report: Lists each order to be shipped in the period or dates defined 
in the report footer. For each transaction, the address, total item and shipping 
weight, and reference number are included 

 
Review the Standard Reports topic in the Help Center and SuiteAnswers, for more 
information 
 

Now It’s Your Turn 
 

 

Use Case/Scenario:  Set up NetSuite, for order management, and then create and 

complete transactions. 

• Allow 30-40 minutes 
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Exercise 01: Define Order Management Preferences 
Time: 5-8 minutes 

Scenario: Chatham is ready to configure the system to meet their requirements for processing sales 

orders through to delivery.   

In the Items Module, when setting up items, we enabled features that facilitate order management: 

 Advanced Shipping 

 Pick, Pack and Ship 

In this exercise: 

 Define Accounting Preferences for Order Management 

 Navigate to Setup > Accounting > Accounting Preferences. 

 Click the Order Management subtab. 

a. Ensure the Default Sales Order Status is set to Pending Approval.  

b. Set the Default Warehouse for Sales Orders to East Coast.  

c. Do NOT change the other available default fields. 

 Click Save. 

 End. 
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Exercise 02: Enter a Sales Order 
Time: 5-8 minutes 

Scenario: As the NetSuite administrator, it is important that you understand the Sales Order process so 

you can support your user community.  

In this exercise: 

 Enter a sales order using the Standard Sales Order – Invoice form. 

 Navigate to Transactions > Sales > Enter Sales Orders. 

 In the Custom Form field, select Standard Sales Order – Invoice.  

a. The form you select determines the type of Sales transaction to be processed. 

 In the Form field, Primary Information: 

a. Leave the default values for Date and Order#.  

b. From the Customer field, select Test ABC. 

c. Leave the default values for Date and Order#. 

i. Notice that the default Status is Pending Approval. This ensures that the sales 

order is approved before it is shipped. Setting the status to Pending Fulfillment 

marks the sales order as approved 

d. In the PO# field, enter 12345 

e. In the Warehouse field, confirm that East Coast is displayed. 

f. In the Memo field, enter TEST Order. 

 Go to the Items subtab, select HP LJ 1320 Printer from the Item dropdown list. 

a. Tab to the Quantity field and enter 10. 

b. Note that the Price Level defaulted to Test Price Level, per the customer record. 

c. Click Add to add the item to the order. 

 Select Printer Ink Starter Pack to add the item to the order. 

a. Tab to the Quantity field and enter 5. 

b. Change the Price Level value to Custom 

c. Enter 20.00 in the Unit Price (or Rate) field. 

d. Click Add to add the item to the order. 

 Click the Shipping subtab to verify the shipping address. 
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 Click the Billing subtab, enter the payment Terms as Net 30 and confirm that a billing address 

has been added to the record. 

 Click Save. 

 The Sales Order status is Pending Approval. 

 End. 
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Exercise 03: Enter a Sales Order OneWorld 
Time: 5-8 minutes 

Scenario: In this exercise: 

 Enter a Standard Sales Order – Invoice form for a customer with a Purchase Order with 

payment terms 

 Navigate to Transactions > Sales > Enter Sales Orders. 

a. In the Custom Form field, select Standard Sales Order – Invoice.  

i. The form you select determines the type of Sales transaction to be processed. 

b. From the Customer field, select Test German Customer.  If a pop-up window opens, 

then click OK in the popup window, to ensure the correct tax nexus is used. 

c. Leave the default values for Date and Order #.  

d. Notice that the default Status is Pending Approval. 

i. This ensures that the sales order is approved before it is shipped. Setting the 

status to Pending Fulfillment marks the sales order as approved. 

e. In the PO# field, type 543201 (the customer’s Purchase Order number) and enter OM-

03 in Memo field. 

 In the Warehouse field, select Berlin from the dropdown list. 

 Go to the Items subtab, select HP Deskjet D2530 Printer (Germany Only) from the Item 

dropdown list. 

a. Note: A warning message may display regarding inventory level.  

b. Click OK 

c. Tab to the Quantity field and enter 10. 

i. Note: There may be only 3 available. You will receive a message, but the order 

will continue to be processed. 

d. Change the Price Level value to Custom. 

e. Enter 35.00 in the Unit Price (or Rate) field. 

f. Click Add to add the item to the order. 

 Click the Billing subtab, enter the payment Terms as Net 30 and confirm that a billing address 

has been added to the record. 

 Click Save. The Sales Order status is Pending Approval. 
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 End. 
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Exercise 04: Approve Sales Orders 
Time: 5-8 minutes 

Scenario: In the Administrator role, practices approving an order into the system.  In this exercise: 

 Use your Reminders Portlet to access Orders to Approve. 

 Navigate to Transactions > Sales > Approve Sales Orders. 

a.  To approve all the sales orders, click the very top check box; all subsequent check boxes 

should then automatically be checked. 

b.  If you wanted to approve a single sales order, then you would check the Approve box 

next to the order. 

c. Note: To view the details for any of the sales orders, click the appropriate Date link. 

 Click Submit. 

a. The Sales Orders are approved. 

  Use the Recent Records portlet, click on one of the Sales Orders, and note that the Status is 

Pending fulfillment 

a. You could also go to Transactions > Sales > Enter Sales Orders > List to view the status of 

all sales orders in the system, Pending Fulfillment 

 End. 
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Exercise 05: Fulfill Sales Orders 
Time: 5-8 minutes 

Scenario: The warehouse staff can view the fulfillment queue and fulfill orders 

In this exercise: 

 Fulfill the approved sales orders. 

 Navigate to Transactions > Sales > Fulfill Orders. 

a. If necessary, change Filter by field to Ignore Item Availability. 

b. Set the Bulk Fulfill From Warehouse to East Coast, to view each sales order you just 

created.  

c. Click the Date link to view the sales order for TEST ABC (Memo column should show Test 

Order).  

d. Click Fulfill. 

 The Item Fulfillment page displays. 

a. Ensure that the Fulfill boxes are checked for the Printers and the Ink. 

b. Enter a memo – Test Order Fulfillment. 

c. Click Save. 

 Go Home and click the dropdown arrow > Set Up in the Reminders portlet. 

a. Click Add Standard Reminders and select the following: 

i. Orders to Fulfill 

ii. Orders to Pack 

iii. Orders to Ship 

iv. Sales Orders to Invoice 

b. Click Save. 

 In the Reminders portlet click the # Order to Pack. We want to find the order that has the Item 

fulfillment done in a previous step. 

 The Mark Orders Packed page displays.  

a. Bulk Fulfill From Warehouse:  defaults to Unchanged. Leave that. 

b. Check the Pack box for the order(s) to process and click Submit. 

c. Process Status page displays.  You can click Refresh to see final status. 
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 Go Home and refresh the Reminders portlet.  This may take a few seconds. 

a. If necessary, log out, log back in and refresh reminders portlet.   

 The Reminders portlet now reflects #Orders to Fulfill and # Order to ship.  Click # Order to Ship 

link.  

a. The Mark Orders Shipped page displays.  

b. Check the Mark Shipped box for the order(s) to process and click Submit. 

c. Process Status page displays.  The Submission Status needs to read Complete.  You can 

click Refresh to see the final status 

 Go Home and Refresh the Reminders portlet.  This may take a few seconds. You may need to 

refresh more than once. 

a. If necessary, log out, log back in and refresh reminders portlet.   

 You now have a link for # Sales Order to Invoice. We will invoice sales orders in the next module. 

 Note: Because you set the option to Pick, Pack, & Ship (Set Up > Company > Enable Features > 

Transactions > Shipping and Receiving) in an earlier exercise, you must step through each stage 

of the Fulfillment process to see that transaction in the Invoice Sales Order list 

 End. 
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Activity: Order Management 
 

Answer these questions 

 

 

Grid Order Entry SuiteApp 
 

Grid Order Entry SuiteApp is a managed SuiteApp feature that enables users to enter 

sales orders for inventory items in a grid entry form. The SuiteApp supports the 

following item types: 

• Inventory Item 

• Lot Numbered Inventory Item 

• Serialized Inventory Item 

• Assembly Item 

• Lot Numbered Assembly Item 

• Serialized Assembly Item 

• Matrix Items (for Inventory, Lot Numbered Inventory, and Serialized Inventory 
Items 

 

Review SuiteAnswers for more information 
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Order Management Enhancements 
 
Fulfilling orders across multiple accounting periods: 

• If the Pick, Pack and Ship feature has been enabled, you can pick items in one 
accounting period and ship in another accounting period 

 

 
• Go to Setup > Accounting > Accounting Preferences > Order Management 

subtab, Fulfillment section, select Update Transaction Date Upon Fulfillment 
Status Change 

 
Please refer to SuiteAnswers for more information 
 

Additional Resources 
 
NetSuite Help Center: 

• Shipping: User Guide 
 
SuiteAnswers Learning Center: 

• New Feature Training 

• Items/Fulfillment/Billing 

• Order Management 
 

ERP Part 1 is done, next… ERP Part 2 
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ERP Part 1: Recap and Review 

 

Review Day 3: ERP Part 1 
 

Let’s review and recap some key points from yesterday’s topics:  

• Accounting Management 

• Multiple Currencies 

• NetSuite Tax Information 

• Items 

• Pricing 

• Order Management 
 

Enterprise Resource Planning (ERP) Overview 
 

Enterprise Resource Planning (ERP) unifies operations into a single data source; 

increase efficiencies and better manage the bottom line. 

 

• Set up account: enable Features and define Preferences 

• Work with Chart of Accounts 

• Use the General Ledger 

• Consider Financial Segmentation (Classifications) 

• Use and manage Accounting Periods 
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Consider Classifications 
 

Consider classifications to facilitate financial reporting: 

• Use any or all classifications: Department, Location, Class 

• Combine with general ledger accounts to simplify your chart of accounts 

 

Define General Ledger Preferences 
 

Navigate to Setup > Accounting > Accounting Preferences > General subtab, 

General Ledger Section: 

 

• Use Account Number: Display both account number and names; NetSuite does 
NOT require account numbers  

• Use Legal Name in Account: Check this box to add the Legal Name 
field to the general ledger account record. This field is useful in countries where 
the legal name of an entity is required by law. 

• Show All Transaction Types In Reconciliation: Check this box to display all 
transactions in the reconciliation pages, including positive or negative amounts of 
certain transaction types. 

• Expand Account Lists Restrict user, or not, to most appropriate accounts 

• Cash Basis Reporting: check or leave blank 
to use accrual-basis accounting 
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• Work with Journals: Void Transactions Using Reversing Journals, Require 
Approvals on Journal Entries  

• Enable Accounting Period Window: maintain a few unlocked current and 
future accounting periods 

• Minimum Period Window Size:  define the number of periods for the Window, 1 
is the default 

• Allow Transaction Date Outside of Posting Period: set preference for 
handling mismatched transaction entry, date to period 

 

Multiple Currencies 
 

Uses for multiple currencies: 

• Sell to customers and purchase from vendors in different currencies 

• Allow each subsidiary to have a base currency; the currency used to keep the 
books 

• Transact in currencies other than the base currency of your company 

• Base currency is the currency used for your company’s, subsidiaries’, books 

• Assign multiple currencies to customer and vendor records 
 

NetSuite Editions and Advanced Taxes  

 
NetSuite provides tax functionality using the NetSuite Edition and the Advanced 

Taxes feature, if enabled: 

 
NetSuite Editions support localized handling of taxes: 
 

• The country of business determines the edition 

• In a single-instance account, the edition manages the taxes for the account 

• In a OneWorld account the subsidiaries may use different NetSuite editions 
 

Advanced Taxes Feature: 

• Manage and calculate taxes for different nexuses (tax jurisdictions) within the 
same NetSuite account 

• Utilize tax schedules to define the tax treatment of items, in each nexus, meeting 
local business requirements 

• OneWorld accounts, by default, utilize Advanced Taxes 

 

Tip!  Always review Release Notes for new tax functionality provided through 
SuiteApps 
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Item Types 
 

Different item types will have different behavior in NetSuite.  Set up Items at Lists > 

Accounting > Items > New: 

• Inventory Items: Items your purchase, stock and sell 

• Matrix Items: define item properties such as size and color, e.g. t-shirts in 
different sizes and colors 

• Non-Inventory items: not kept in formal stock and are costs related to doing 
business 

• Service items: track time and record billable hours  

• Assemblies:  inventory items made up of several components, identified as a 
single item  

• Item group: entered as single unit; displays as multiple line items when selected 
in a transaction; user adds or deletes items ad hoc   

•  Kit/Package: create items that are collected from other items; displays as a 
single line item when selected in transactions  

 

Pricing to Match Your Business Needs 
 

• Enable pricing features:  
o Multiple Prices: sell items at different prices  
o Quantity Pricing: price is based on quantity purchased  

• Define Accounting Preferences: Maximum # of Quantity-based Price Levels 
and Allow Quantity Discounts per Price Levels on Schedules  

• Use Price Levels: can be a discount or a markup  

• Define a Quantity Pricing Schedule: templates to apply to items to generate 
purchase and sale prices 

• Set up a Pricing Group:  allows you to assign customer-specific price levels for 
groups of items  

• Pricing on an item record: price levels, pricing schedules, pricing group, price by 
currency 

• Pricing customer record: price level, group pricing, item pricing  

• Update item prices: utilize mass updates or a csv import 
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Order Management 
 
Order management, in NetSuite, can be tailored to meet your needs: 

• Enable the required features and define the preferences 

• Use the Quote-to-Invoice process: 
o Create and save a Quote: Quote status = Open 
o Convert a quote by creating a sales order: Order status = Pending 

Approval 
o Approve a sales order: Order status is Pending Fulfillment 
o Fulfill the sales order: Order status is Pending Billing 
o Utilize Item Fulfillment 
o Bill the sales order: Invoice status is Open 

• Work with different order forms, such as the following, and customize if 
necessary: 

o Standard Sales Order – Invoice 
o Standard Sales Order – Cash Sale 
o Standard Sales Order 
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Review Questions 
 

See if you can answer the following questions; fill in the bank or use true/false values: 

1. Name the three NetSuite classifications available for reporting and the GL: 
______________      _______________      _________________ 
 

2. True or False: Combine the use of classifications with the general ledger account 
to simplify your chart of accounts. 
 

3. True or False: Account numbers are mandatory in NetSuite 
 

 
4. Which feature allows transacting business with vendors and customers in 

different currencies?  ___________ _____________ 
 

5. What is a base currency? __________________________________ 
 

6. The NetSuite _______________ supports localized handling of taxes 
 

7. True or False: Assemblies, Kits and Item Groups all act the same way in 
NetSuite 
 

 
8. If I want to sell an item at different prices, I use _________  ____________ 

 
9. What type of pricing considers the number of items bought?  

________   __________ 
 

10. Can you name some of the different types of sales orders? 
______________         ____________________      _____________________ 

 

ERP Part 1 is done, next … ERP Part 2 
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Accounts Receivable Overview 

 
About this Module 

 

Gain full financial visibility into your receivables with real-time access to outstanding 

customer invoices and payments:  

• Track money that customers owe and monitor customer that take a long time to 
pay 
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Accounts Receivable Overview 
 
Accounts receivable tracks unpaid goods or services: 

• Initiated by the sales process when your customer owes money in exchange for 
goods and services your provided 

 
Billing is typically handled by creating an invoice: 

• The Invoice is a record of sale to your customer and is mailed, faxed or emailed 

• An invoice lists credit or payment period and payment terms 
 

Overview of A/R Workflow 
 
This diagram illustrates the standard accounts receivable workflow the department/clerk 
follows to complete the sales process: 

• After the customer receives the goods or services, an invoice is created  

• When the payment is received, it is processed by AR 
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Accounts Receivable – Billing and Payment Process 
 
Here is a high-level look at a standard billing and payment processes, for a customer 
that has paid on terms: 
 
Billing process: 

• A Sales Order is Pending Billing 

• AR staff bill the sales order to create an Invoice 

• Print, fax, or email the invoice to the customer 

• The invoice reflects in the A/R aging report and on the customer record 

• The invoice remains Open until receipt of customer payment 
 
Payment process: 

• Review open Invoices 

• Accept payments from customers 
 

Implementation Considerations 
 

Start thinking about how you will need to work with A/R functionality in NetSuite. Here 

are a few considerations: 

• What are the key steps in your A/R and collections processes? 

• Which forms of payment do you take? 
o Credit Card processing and Electronic Funds Transfer (EFT)? 

• Invoicing and payments: 
o Do you accept prepayments and deposits? 
o How do your customers establish credit with you? 
o Is payment accepted in a parent/child relationship at both levels? 

• OneWorld:  
o How do you currently post transactions? In NetSuite, the posting is 

determined by the entity associated with the transaction. 
o Are receivables segregated by countries?  
o How is intercompany accounting tracked?  
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Activity: Your Order A/R Considerations 

Let’s look at some of the areas. Do you have comments or concerns?   

 
 

Walkthrough: Set Up Accounts Receivable 
 

 
 
Use Case: The administrator and the A/R staff have discussed some requirements, 
now it is time to configure NetSuite.  
 

  



 

11 

 
 

Enable Accounts Receivable Features 
 

Go to Setup > Company > Enable Features > Accounting subtab: 

 

• Select from Basic Features: 
o AR: invoice customers for delivered goods or services and provide 

payment terms  

• Review and select Advanced Features to meet your needs: 
o Important: The Consolidated Payments feature is NOT compatible with 

the Multi Subsidiary Customer feature:  
▪ allow customer payments from the customer or subcustomer record 

and provide consolidated customer statements 
▪ Make payments on invoices, apply credit memos and deposits at 

both levels and allows Consolidated Statement option 
▪ Allows Consolidated KPI’s  
▪ Multi-Currency Customers and Consolidated Payments 

• It is no longer a requirement that all customers and 
subcustomers in a hierarchy use the same primary currency. 

• When you accept payments through a top-level customer, 
select the currency of the invoices you want to accept 
payment toward. The list of invoices, credits, and deposits is 
filtered to the show only those transactions in the selected 
currency  

• Review other features and utilize the field definitions to help you determine if 
the setting meets your business requirements. 
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Enable A/R-Related Features (Optional) 
 

• Go to Setup > Company > Enable Features > Transactions subtab; review the 
features in the Shipping & Receiving section: 

 
 

• Enable the Advanced Shipping feature to have separate transactions for 
fulfilling sales orders and billing sales orders: 

o Invoice customers for an entire sales order even if not all items have 
shipped. 

▪ Note: Once Advanced Shipping is enabled, you cannot disable until 
all fulfilled sales orders have been billed.  

o This feature will then facilitate an Accounting Preference to Invoice in 
Advance of Fulfillment 
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Define Accounting Preferences: General 
 

Setup > Accounting > Accounting Preferences > General subtab, review and select 

the available preferences in the Accounts Receivable section per your business 

requirements, for example: 

 

• Show Only Open Transactions on Statements: select to include only open 
transactions on customer statements  

• Open Transactions on Statements:  select handing method for generating 
statements 

o Open Transactions by Today 
o Open Transactions by Statement Date 

• Customer Credit Limit Handling: select Ignore or Warn Only as the preferred 
way to handle a customer exceeding their allowed credit limit  

• Customer Credit Limit Includes Order:  select to include orders not yet billed, 
when performing credit limit calculations, to ensure customers not placing orders 
over their credit limit; this will include unapproved orders  
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Define Accounting Preferences: Items/Transactions 
 

Navigate to the Items/Transactions subtab and review the Accounts section: 

 

• Create or select default accounts to display in transactions 

• Default Payment Account 
o Leaving this blank, the payments go into the Undeposited Funds account  

• Default Receivables Account and Default Intercompany Receivables 
Account: 

o The Default Receivables Account field, select the A/R account you want 
selected by default on receivables transactions 

o To set a default A/R account for a customer, edit the record, Financial 
subtab, the account you want to use. Select Use System Preference to 
use the company default account 

• OneWorld Note: Default accounts are for all subsidiaries. The default account 
refers to the account that already exists in NetSuite. There are limitations for 
members from any given subsidiary to see their default account: 

o If the default account is being used for consolidated reporting, then not 
everyone will need to view it 

o If the default account is used for ALL subsidiaries, then make that account 
available to the Parent and Children. Ensure the roles and permissions 
are set up correctly, to allow each person who needs access can view it 
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Define Accounting Preferences: Order Management 
Navigate to the Order Management subtab and review the Invoicing section: 

 

• Show Unfulfilled Items on Invoices: 
o Select for invoices to show items yet to be fulfilled 

• Invoice in Advance of Fulfillment: 
o Select to invoice customers for the full amount in advance of fulfilling the 

order, even a partially fulfilled order 

• Convert Absolute Discounts to Percentage: 
o Select to convert a currency-based discount into percentage-based 

discounts spread across several invoices; the discount is applied evenly to 
all bills for that order instead of the entire discount being applied to the first 
bill 

 

Walkthrough: Sales Order to Payment Process 

 
 
Use Case: Now that features and preferences have been defined, let’s look at the 
order-to-payment transactions.  
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Enter a Sales Order 
 
Navigate to Transactions > Sales > Enter Sales Orders choose the appropriate form:  

 
• Standard Sales Order - Invoice:  

o Customer may be using a purchase order 
o Customer has payment terms (i.e. Net 30) and they pay within a certain 

period for the delivery of the product or service 
▪ Terms may be manually entered or default from customer record 
▪ A preferred term may populate for sales transactions 

• Setup > Accounting > Accounting Lists > Term 
 
Navigate to Transactions > Sales > Enter Cash Sale  

• Enter Cash Sale: payment received at time of delivery of goods/services 
o Example: If an order is generated from the web or a customer provides 

payment in full, then it’s a ‘Sales Order – Cash Sale’. The only 
requirement is that payment information is captured on the Payment 
subtab when creating the sales order. This is assuming there are no 
partial payments 

 

Note: In some situations, a customer may require a deposit up front 

• We will look at this later in the module and how to create a customer deposit 

• We can process the Sales Order Invoice as you normally would process a term 
sales order.  

• When accepting the customer payment, you will offset the amount owed by 
applying the deposit that was recorded earlier.  
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Invoice Sales Order 
 

Navigate to Transactions > Sales > Invoice Sales Orders: 

• Whether you create an invoice or cash sale from the sales order depends on the 
form used and information entered: 

• Entering terms, i.e. Net 30, converts the order to an invoice upon billing 

• Entering in a payment method, i.e. check, converts the order to a cash sale upon 
billing 

• The default A/R process suggests billing sales orders after any partial or 
complete fulfillment, unless you have selected the Accounting Preference - 
Invoice in Advance of Fulfillment 

o Allows invoicing the full amount prior to complete fulfillment of an order - 
Common with orders partially shipped 

 

Review Customer Invoice 
 

Review invoices at Transactions > Sales > Create Invoices > List: 

 

• Set your desired View 

• Optionally use the list Filters 

• Click on Edit to edit an invoice 

• Click on View to view an invoice 
o In the Summary section, view the following: 

 
▪ Subtotal 
▪ Discount Item 
▪ Tax 
▪ Total 
▪ Amount due 

• References the Created From Sales Order number 
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Accept Customer Payments 
 

Navigate to Transactions > Customers > Accept Customer Payments and select the 

Customer 

 

• Accepting customer payments allows for different handling options for the 
payments received: 

o Undeposited Funds: payments that will be deposited to bank account 
o Deposit to Bank Account: payments that have been deposited to a 

specified, bank account 

• Consider the Apply payment checkbox 
o When entering customer payments, credit memos or vendor credits you 

can check the Auto Apply box to automatically apply the payment or credit 
to the oldest open receivable or payable. 

o Only the payment you enter on the transaction is applied. Other existing 
credits and deposits are not automatically applied against open 
receivables.  

o If you do NOT check the Auto Apply box, the transaction amount is 
unapplied; you must apply the payment or credit amount to an open 
receivable or payable.  

• Specify Payment Method 

• Review Summary  

• Save 

• Status is Not Deposited  
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Make Deposits 
The banking process allows users to deposit payments received which are credits to 

bank accounts: 

 

• Includes checks, EFTs, credit card transactions and other sources 

• Go to Transactions > Bank > Make Deposits  
o Select Account 
o Verify Date and Posting Period, fill in optional Memo 
o Go to the Deposits subtab and select items from the following sublists  

▪ Payments: payments from sales activity  
▪ Other Deposits: non-sales cash deposits 

• Cash sources can be employees, customers or vendors 
▪ Cash Back: record amount not to be part of the deposit, for 

example:  

• Scrap sale. 

• Refund a customer that had a customer deposit on file, but 
never transacted a sale with you. Since there is no 
process/transaction interface to refund customer deposits 
not linked to any sales, cash back is used instead as a 
workaround. 

• Credit Card payments: Even though your credit card processing company 
(merchant account provider) deposits straight to your bank account, most all of 
them will bundle the deposit and net out their fees. 

o For example: A company receiving 20,000 credit card payments in a 
single day come through the CC processor separately, but show up in the 
bank as a lump sum.  

o The Make Deposit screen helps to note this properly so your bank 
deposits match with NetSuite bank entries for later reconciliation. 
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Walkthrough: Additional Accounts Receivable Tasks 
 

 

Use Case:  There are other tasks that AR staff can complete, so let’s look.  

Create Invoices 
 

Go to Transactions > Sales > Create Invoices to enter an invoice for a transaction 

with immediate and payment on terms: 

 

• Use Case: Customer walks into store, buys and takes Home Theater package, 
will pay on Net 15 terms 

• Choose appropriate form 

• Complete all required information 

• Invoices track balances due to be received from customers 

• NetSuite tracks outstanding invoices in Accounts Receivable 
 

! 
Important!  The total number of liner, per transaction, cannot exceed 
200 
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Generate Statements 
 

Various menu paths are available: 

Go to Transactions > Customers > Generate Statements to execute for all 

customers:  

 

• Review and complete all fields: 
o Statement Date 
o Start Date 
o Include Zero Balances 
o Show Only Open Transactions 
o Form 
o Select Customers 
o Print 

• Suggested frequency is to send statements once-a-month 

• Company sends statements to remind customers to pay their invoices 
o Print, email or fax statements in HTML or PDF format  

 
Go to Transactions > Customers > Individual Statement to execute for a specific 

customer 

This account also has statement types are specific to Japanese business and are 

present due to having created a Japanese subsidiary: 

o Generate Item Detail Statements 
o Individual Item Detail Statements 
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Record Customer Deposits 
 

Go to Transactions > Customers > Record Customer Deposits: 

 

• Complete Primary Information and Classification sections 

• Define and complete fields on the Payment Method subtab  
 
Use cases: 

• Cannot readily be assigned to an existing transaction  

• Customer pays in advance for an order or a project 

• Payments are a liability in the General Ledger until applied to an invoice 
 
Note: The key difference between the Record Customer Deposit and an Unapplied 

Customer Payment is that the Customer Deposit posts to a liability account, whereas 

the Unapplied Customer Payment reduces Accounts Receivable. 

 

Create a Deposit on a Sales Order 
 

Use the Create Deposit button on Standard Sales Order – Invoice: 

 

• Must have one of the following statuses 
o Pending Approval 
o Pending Billing 
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• View the Sales order and then click the Create Deposit button: 
o The Create Deposit button that allows sales people to record a deposit 

immediately upon saving a new sales order. 
▪ This deposit is reserved for the originating sales order and cannot 

be applied to other invoices. 
▪ A read-only Sales Order field on the deposit shows this linked 

transaction. When you invoice the sales order, the reserved deposit 
is automatically applied. 

▪ You can apply multiple deposits to a single order.  

• If the deposit total exceeds the order amount, the excess 
deposit amount is not linked to the original order and can be 
applied to any invoice 

o Complete the Primary Information and Classification sections 
o Define and complete fields on the Payment Method subtab 

 
Create Deposit is also available on saved orders that use other forms, but do not have 

terms or a payment method specified  

Issue Credit Memos 
 

Credit Memos decrease the amount a customer owes, deduct the credit from the total 

amount due; go to Transactions > Customers > Issue Credit Memos:  

 

• Complete the Primary Information, Sales and Classification sections 

• On the Items subtab consider the Auto Apply setting and enter in Items  

• Review other subtabs 

• Save 

• This has no link to a previously-entered sales order 
 

Use Case: Customer received two widgets, bought for $100/each, they were ruined in 

transit and cannot be returned 

• Credit memo issued for $200 

• Later, customer purchases five widgets and the invoice total is $500, $200 credit 
memo is applied, total now owed equals $300  
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Process a Return Authorization 
 
Process a return authorization for return of merchandise, if the Return Authorizations 

feature has been enabled; the following steps each involve specific permissions:  

• View an invoice, click the Authorize Return button  

• In the Return Authorization page: 
o Select the correct Custom Form and then click Save 
o Return Authorization status is Pending Approval  

• View the Return Authorization and click Approve Return 
o Return Authorization status is Pending Receipt 
o Click Receive  

• The Item Receipt page opens and you review, edit as necessary and click Save 

• Go back to the Return Authorization, you can use the hyperlink in the Item 
Receipt or Recent Records  

o Status is Pending Refund  

• Click Refund 
o Either a credit or refund is created based upon the payment method 

• Complete the Credit Memo 
o Complete the Primary Information, Sales and Classification sections 
o On the Items subtab consider the Auto Apply setting and enter in Items  
o Review other subtabs 
o Save 

• This has now linked to a previously-entered sales order 
 

Issue Customer Refund 
 

Use Case: A customer returns a widget purchased for $50.00 cash sale:  

• Rather than issue credit memo, company refunds cash to Joe  
 

Use the Issue Cash Refund transaction to return money to customers who paid for 

goods or services using cash, check or credit card: 
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Go to Transactions > Customers > Issue Customer Refund 

 

o Complete the Primary Information, Sales and Classification sections 
o On the Apply subtab select available Credits or Deposits 
o Complete the fields on the Refund Method subtab 
o Save 

• This records the refund to the customer 
o Payment is generally in form of currency or printed check  

 

Nuanced Differences between Credit and Refund 
 

Here are some possible guidelines to help evaluate the original transaction determining 

the subsequent transaction: 

• Cash Sale = Transactions > Customer > Refund Cash Sale 

• Paid Invoice = Transactions > Customer > Issue Credit Memo 

• Sales Order fulfilled/billed/payment accepted = Return Authorization process 
 

Walkthrough: Analytics for Accounts Receivable 
 

 

Use Case:  The A/R and finance staff can keep up-to-date on receivables through KPIs 

and Reports. Let’s look 
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Key Performance Indicators (KPIs) for A/R 
 

Click the Personalize link for the dashboard: 

• Select Key Performance Indicators 

• Close the Personalize Dashboard pane 
 
Find the Key Performance Indicators portlet 

• Click Set up and select KPIs to be included 

• Define highlighting for a headline - IMPORTANT: Headlines only work when the 
Highlight if value is set to Always. 

• Save 

 

Standard A/R Reports 
 

Go to Reports > Customer/Receivables  
 

 
• Use the standard A/R reports to analyze your accounts receivables and focus 

your collection efforts, for example: 
o A/R Aging 
o A/R Register 
o A/R Payment History by Invoice 
o A/R Payment History by Payment 

• OneWorld accounts Subsidiary Context filter available when viewing report 
results 

• Review the Help Topic: Standard Reports for more information on each report 
 

A/R Payment History by Payment Report 

• Provides a view of your customer's payment history  

• Organized by payment 

• Shows how payments were applied to invoices 
See Standard Reports topic in the Help Center and SuiteAnswers. 
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Now It’s Your Turn 
 

 
 
Use Case/Scenario: Run through A/R transactions, including creating invoices, 
accepting payments, processing a return, and recording a bank deposit. 

• Allow 20-30 minutes 
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Exercise 01: Invoice All Sales Orders 
Time: 2-3 minutes 

Scenario: Billing a sales order creates a record of debt owed to you by your customer. When you invoice 

a sales order, your Accounts Receivable ledger increases by the amount of that bill. 

Usually, customers are billed for a sale when the items on the order are shipped. Once you ship the 

items, you bill the customer.  In this exercise: 

 Invoice Sales order to create Invoices 

 Go to Transactions > Sales > Invoice Sales Orders. 

 The Invoice Sales Orders page opens. 

a. Set the Customer field to Test ABC, to see all sales order for that customer. 

b. The transaction Date defaults to today’s date. 

c. In the To Be Printed field, choose Yes. 

d. Click the Mark All button. 

e. Click Submit. 

 You may get a Notice window.  You do NOT need to go away from this page. 

 The Process Status page displays showing the invoices being processed. Click the Refresh 

button.  

a. When processing is complete, the Submission Status will change to Complete. 

b. Review if there were any errors.   

i. If we had had zero errors, then when you go to Transactions > Sales > Invoice 

Sales Orders and filter by TEST ABC there are no sales orders pending billing. 

 Click the Complete link  

 Click an Invoice link to review the invoice; the Invoice has a status of Open; this will remain open 

until payment is received from the customer.  

 Click Home. 

 End. 
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Exercise 02: Create a Cash Sale 
Time: 2-3 minutes 

Scenario: In this exercise, 

 Create a cash sale for a walk-in customer buying an item with cash. 

 Navigate to Transaction > Sales > Enter Cash Sales; the Cash Sale page opens. 

a. From the Customer dropdown list, select Test ABC. 

i. Note: The Date field defaults to today’s date but this can be changed if needed. 

b. From the Warehouse dropdown list, select East Coast. 

c. Go to the Items subtab > Items sublist and select HP LJ 1320 Printer from the Item 

dropdown list. Put in a Quantity of 5. 

i. Details such as Quantity, Description and Price Level are automatically 

populated upon selecting the item. You can change these values as necessary. 

d. Click the Add button to add the line item. 

e. Click the Billing subtab, Payment section and select Cash from the Payment Method 

dropdown list. 

f. Click the Save button to save the Cash Sale. 

 The Cash Sale page displays with the status of NOT DEPOSITED. 

 End. 
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Exercise 03: Create an Invoice 
Time: 2-3 minutes 

Scenario: A customer comes into the business, purchases goods and wants to be billed. 

In this exercise: 

 Create an invoice for a walk-in customer to be billed later  

 Navigate to Transactions > Sales > Create Invoices; the Invoice page displays.  

a. From the Custom Form dropdown list, select Standard Product Invoice.  

b. The Date field defaults to today’s date and can be changed if needed. 

c. From the Customer dropdown list, select Test ABC. 

d. From the Warehouse dropdown list, select East Coast. 

e. Go to the Items subtab > Items sublist and select HP LJ 1320 Printer from the Item 

dropdown list.  

i. Quantity, Description and Price Level are automatically populated for the item. 

ii. Change the Quantity to 5. 

iii. Click the Add button to add the line item. 

f. Click the Billing subtab, Billing Information section and select Net 30 as Terms. 

g. Click the Save button to save the Invoice. 

 The Invoice page displays with the status of OPEN. 

 End. 
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Exercise 04: Accept Customer Payments 

Scenario: Sales transactions with payment terms will remain open until customer payments are 
received. It is time to accept the payment. 

In this exercise: 

 Accept a customer payment 

 Go to Transactions > Customers > Accept Customer Payments. 

 The Payment page opens in a new browser tab. 

a. From the Customer dropdown list, select Test ABC.  

i. Notice: The form automatically populates with a list of open invoices for this 

customer and the Date field defaults to today’s date. It can be changed if 

needed. 

b. In the center column Undep. Fund selected as the default. 

c. Go to the Apply subtab > Invoices sublist. 

d. Check the Apply check box for one of the invoices you created in the previous exercise, 

in the amount of $220.80.  Note that the Payment Amount will auto-populate. 

e. Go the Payment Method subtab.  In the Payment Method field, select Check and enter 

Check # as 987. 

f. Click Save. 

 The Payment page displays with the status as NOT DEPOSITED.  

 End. 
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Exercise 05: Issue a Return Authorization  
Time: 3-5 minutes 

Scenario: In this exercise, you will use test the following functionality: 

 Authorize the return of merchandise from our customer TEST ABC. 

 Approve the return authorization. 

 Use Global Search, type in CUS: TEST. 

 View the Customer record for TEST ABC; go to the Sales subtab and the Transactions sublist. 

a. Click the Date hyperlink for their Invoice Paid in Full - (this was for the printers 

b. Review the Invoice and note that the customer purchased the HP LJ 1320 Printers  

 Click the Authorize Return button 

 The Return Authorization page opens. 

a. Change the items from 5 printers to 2 and click OK. 

b. Click Save.  The Return Authorization is PENDING APPROVAL. 

  Click Approve Return.  The Return Authorization is PENDING RECEIPT. 

a. Click Receive. 

 The Item Receipt page displays: 

a. Confirm Qty 2 Printers and add memo -Receiving 2 printers 

b. Click Save 

c. On the Item Receipt page click the link for the Return Authorization #. 

 The Return Authorization is PENDING REFUND.  Click Refund. 

 The Credit Memo page opens.  

a. Go to the Items subtab and confirm that 2 printers are listed. 

b. On the Items subtab, right-hand side, the Auto Apply checkbox may be checked.  If we 

leave this as checked then this credit will be applied to the oldest open receivable.  Clear 

this box, so that we can later apply the credit to an open receivable. 

 Click Save.  The Credit Memo status is OPEN until applied to a receivable. 

a. Note: The credit memo has been saved. You could click refund to issue a check or leave 

the credit memo open, which could then be applied once the customer has a new and 

unpaid invoice. 
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 End. 
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Exercise 06: Make a Bank Deposit 
Time: 3-5 minutes 

Scenario: Payments have been received and accepted from customers.  The Chatham Company has 

multiple banking accounts; this exercise only uses one checking account. 

In this exercise: 

 Deposit payments to the 1000 – Checking account 

 Navigate to Transactions > Bank > Make Deposits.  

 Select 1010 Checking: Checking – Germany from the Account dropdown list. Review if there is 

anything to deposit. 

 Now select 1000 Checking bank account from the Account dropdown list.  The Amount column 

should display properly. 

a. The Date field defaults to today’s date and may be changed if needed.  

b. Verify the Posting Period; you may need to change it to a new posting period to be 

appropriate for the posting date.  

 Go to the Deposits subtab > Payments sublist.  

a. Select the checkboxes for all payments to deposit into the checking account.  

 Click Save.  Review the Confirmation message. 

 Ensure that you are on the saved deposit page and then click the Printer icon and Print Summary 

to view the deposit summary. 

 Click Home. 

 End. 

 

  



 

35 

 
 

 

Activity: Match Game 
 
Try matching the terms on the left, with the descriptions on the right. 

 
Dunning Letters 

 
The Dunning feature allows the set up an automated dunning process to help manage 

the collection process of accounts receivables: 

• Dunning is a systematic method of tracking overdue invoices and persistently 
sending letters to customers to demand payment.  

• With this feature, also send reminder letters before payment is due 

• Create dunning procedures and assign them to customers or invoices. 
o Dunning procedures define the escalation points or dunning levels, and 

the time that must elapse before a dunning letter is sent to a customer.  
o Dunning levels define the thresholds for overdue amounts and days 

overdue, as well as the letter templates to use for each level 

• Speak to your implementation consultant regarding the related SuiteApps 

• Review Help and SuiteAnswers: Dunning Overview 
 

Other Billing and AR Enhancements 
 
Billing Operations that provide automation tools:  

• Go to Setup > Company > Enable Features > Transactions subtab, Billing 
section, select Billing Operations 

o Create and manage bill runs, bill run schedules, billing groups and invoice 
approvals 
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Invoice Approvals provide the ability to create a customized approval workflow for 

specific business needs 

• Go to Setup > Accounting > Accounting Preferences > Approval Routing 
subtab, and select the Invoices check box 

o SuiteFlow must be enabled in the account at Setup > Company > Enable 
Features > SuiteCloud subtab, SuiteScript section 

 
Please refer to SuiteAnswers for more information 
 

Global Invoicing Preferences 
 

Most appropriate for use with projects. 

Use the Invoicing Preferences page to determine the way billable lines appear on 

invoices: 

• To set invoicing preferences, go to Setup > Accounting > Preferences > Invoicing 
Preferences (Administrator). 

As you select options in various combinations, a preview at the bottom of the page 

reflects how invoices appear using the settings: 

• You can select and deselect options until the Preview section reflects the way 
you prefer for invoices to show. 

When the Preview section accurately reflects your preference for the appearance of 

invoices, click Save. 

Invoicing Preferences for Individual Forms: In addition to the company-level settings for 

invoicing preferences, you can set preferences for invoicing options on customized 

forms.  

Please refer to SuiteAnswers for more information 
 

Additional Resources 
 

NetSuite Help Center: 

• Order Management: Billing and Invoices 
 
SuiteAnswers Learning Center: 

• New Feature Training 

• Items/Fulfillment/Billing 

• Accounts Receivable 
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Set Up Purchasing  

About this Module 
 

With NetSuite, you can keep inventory at optimum levels by tracking purchases, for both 

inventory items and supplies/furniture etc...  

In this module, we examine: 

• Considerations for setting up purchasing; satisfying your requirements 

• Tasks for setting up purchasing 

• The complete purchase-request to purchase-order process  
 

 

  



 

38 

 
 

Purchasing Workflow 
 
The diagram illustrates the standard business process to complete the tasks of entering 
a purchase request, approving a purchase request, entering a purchase order, and 
receiving a purchase request.  
 

 
 

Purchase Requests and Orders 
 
Purchase Requests are optional and are entered in the Employee Center, by an 

employee: 

• A request to purchase goods and services, but not an authorization to purchase 

• Once approved, a purchase request converts to a purchase order 

• This is a non-posting transaction 
 

Purchase Orders authorize vendors to provide items, materials or services to your 

company: 

• Track items that you have received 

• Track items that have yet to be received 
 

  



 

39 

 
 

Purchasing Considerations 
 
Consider the processes and who is involved: 

• What are the key steps in your ordering/receiving process and who are the key 
players involved in these processes? 

• What is your procedure for employees to enter purchase requests? 

• What information do you track regarding your vendors? 

• Do you receive the vendor bills at the time of receipt of goods or after? 

• Do you receive partial shipments? 

• OneWorld: Do you require selling relationships between your vendors and 
customers of another subsidiary? 

• OneWorld: Do you need to inter-subsidiary inventory transfers? 
 

Activity: Your Purchasing Considerations 
 
Which areas will you be using? Comments and concerns? 

 

 
Walkthrough: Enable Features 

 

 

Use Case:  The administrator and the purchasing staff have discussed some 

requirements, now it is time to configure NetSuite.  
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Enable Features: Accounting and Transactions 
 

Enable required features at Setup > Company > Enable Features:  

• > Accounting subtab > Basic Features section: 

 
o Select Accounting to enable NetSuite for your business accounting 
o Select A/P to allow users to maintain accounts payable records and track 

purchases, bills, vendors and payee records 

• > Transactions subtab > Shipping & Receiving section: 

 
o Select Advanced Receiving to separate item receipt and vendor billing 

▪ Separates physical steps for warehouse to receive orders 
▪ Gives billing department flexibility for posting vendor bill  
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Enable Features: Purchase Requests and Approval 
 

Go to the Employees subtab > Time & Expenses section and enable optional features 

as required: 

 

• Approval Routing: route both purchase requests and expense reports to 
appropriate approvers, based on approval limit 

o If your company does not use Approval Routing, request automatically 
becomes a purchase order as soon as immediate supervisor approves it 

• Purchase Requests: allow employees to create purchase requests that are 
routed to supervisors for approval 

o With Approval Routing, route purchase requests to the purchase approver 
based on approval limits set on an employee record  
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Walkthrough: Accounting Preferences 
 

 
Use Case:  Now that features, review accounting preferences.  

Define Accounting Preferences 
 

Go to Setup > Accounting > Accounting Preferences: 

Define aging report preferences: 

•  > General subtab, General Ledger section 

 
o Aging Reports use: 

▪ Transaction Date: age by the date of the bill or invoice,  
no matter when it is due 

▪ Due Date: use whatever due date you assign  
for aging bills and invoices 

 
Set purchase order preferences: 

• > Order Management subtab, Purchasing section 

 
o Allow Expenses: ability to add expenses to purchase order, e.g. rental 

fees  
o  Default Warehouse for Purchase Orders: default location for purchase 

orders 
 
Review approval routing preferences: 

• > Approval Routing subtab, select Approval routing 

 
o Allows for the setup of a custom approval processes, using workflow 

(SuiteFlow), for the listed transactions 
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Walkthrough: Set Up Purchase Approver 
 

 
 
Use Case: To use approval processes, the employee record must be edited to identify 
approvers.  
 

Set Up Purchase Approver 
 

The purchase approver is the person who approves or denies purchase requests; not 

necessarily the employee’s supervisor: 

• Edit an Employee record and go to the Human Resources subtab 

• Complete the necessary fields in the Expense and Purchasing section 

 
o Expense Limit: maximum amount expensed without approval  
o Expense Approver: person that approves the employee’s expense 

reports  
o Expense Approval Limit: maximum amount this employee can approve  
o Purchase Limit: maximum purchase amount without approval  
o Purchase Approver: person that approves the employee’s purchase 

requests  
o Purchase Approval Limit: maximum amount this employee can approve 

• If the Expense and/or Purchase Approver is not defined, then expenses and 
purchases are routed to the defined supervisor 

 

Walkthrough: Processing Purchase Requests 
 

 
 
Use Case:  Let’s look at the transactions and flow of transactions.  
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Enter a Purchase Request 
 

Employees use their Employee Center role to enter Purchase Requests:  

• The Employee Center Role may be added to an employee’s access, without 
adding another NetSuite license 

 
• This is can be an optional first step in your purchasing process 

• Switch roles > Employee Center – Purchases portlet > Enter Purchase 
Requests 

o Complete required fields in Primary Information and Classification 
sections 

o Enter Items 
o Save – If the total is over the purchase limit, the status is Pending 

Supervisor Approval 
o A purchase request is only a request; it is not an authorization 

• Once approved, a purchase request converts to a purchase order 
 

Approve Purchase Request 
 

NetSuite routes the request to the appropriate Purchase Approver: 

• Setup Reminders, on the dashboard, to display the Standard Reminder – 
Purchase Requests to Approve 

• Click on the hyperlink to view the Approve Purchase Request page 

• Approve from this page or view the transaction 
o Click on the Date hyperlink 
o The page opens as a Purchase Order and do one of the following: 

▪ Edit to make changes before approving, OR 
▪ Approve as is, OR 
▪ Reject as is  
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Walkthrough: Processing a Purchase Order 
 

 

Use Case:  Let’s look at how the transactions flow through different roles.  

Enter a Purchase Order 
 

NetSuite does not require using purchase requests to initiate the purchasing process; 

A/P clerks may enter New Purchase Orders 

 

• Navigate to Transactions > Purchases > Enter Purchase Orders 
o Complete required fields in Primary Information and Classification 

sections 
o Select the Employee to associate that employee requestor with the 

purchase order 
o Enter Items 
o Save – If the total is over the purchase limit, the status is Pending 

Receipt 
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Custom Purchase Order Approval 
 

Using SuiteFlow adds more control over approval of Purchase Orders: 

 

• Requires the following: 
o Setup > Company > Enable Features > SuiteCloud subtab and enable 

SuiteScript features  
o Setup > Accounting > Accounting Preferences > Approval Routing 

subtab and select Purchase Orders 
o Once the above have been enabled both Purchase Requests and 

Purchase Orders will also display a Next Approver field 

• Edit the Purchase Order, update Approved Status 

• Complete the Next Approver field, to route for additional approval rejection 
bases on workflow requirements 

• Once approved, the Purchase Order status is Pending Receipt 
 

Receive a Purchase Order 
 

Navigate to Transactions > Purchases > Receive Orders to fully receive a purchase 

order: 

• The Receive Orders page may be filtered by Vendor 

 
• Review Posting Period and Date, use Filters if necessary 

• Click the Receive checkbox for Purchase Orders to be received and click 
Submit and submit to process the purchase order(s) without review the item 
receipts OR 
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• Click on the Receive hyperlink to view the New Item Receipt and review before 
receiving 

 
• If all items are received, the Purchase Order status is Pending billing 

 

Receive some items on a Purchase Order 
 

Partially receive a purchase order: 

• Click on the Receive hyperlink and review the New Item Receipt  

• Select the items to receive and update the quantities as required 

• The Purchase Order status is Pending Billing/Partially Received 
 

! 
Important!  If the vendor has shipped everything they can and no 
more items expected; Bill the PO for items received, then close the PO  

 

Standard Purchasing Reports 
 
Go to Reports > Purchases and view your purchasing data for specific dates or time 

periods, using the purchasing reports to identify: 

 

• Use the standard Purchases reports to monitor purchase order status, activity 
with vendors, price changes: 

o Purchase by Vendor 
o Purchase by Item 
o Purchase Order Register 
o Open Purchase Orders 
o Purchase Order History 

• OneWorld accounts will have a Subsidiary Context filter available when viewing 
report results 

• Review the Standard Reports topic in the Help Center or SuiteAnswers, for 
more information 
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Now It’s Your Turn 
 

 
 
Use Case/Scenario: Enter a purchase order and then receive all items. 

▪ Allow 5-10 minutes 
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Exercise 01: Enter a Purchase Order 
Time: 3-5 minutes 

Scenario: Now you follow the NetSuite’s purchase order process from the creation of the purchase 

order to the receipt of the purchased goods.  In this exercise: 

 Enter a Purchase Order for Printer Ink Starter Packs  

 Email the saved P.O. to the vendor 

 Navigate to Transactions > Purchases > Enter Purchase Orders. 

a. Leave Standard Purchase Order selected in the Custom Form field. 

b. Select TEST Widget Works from the Vendor dropdown list. 

i. Note: The Vendor #, our account number with that vendor, is populated from 

the Vendor record only if it has been entered on the Vendor record.  

c. In the Receive By field, enter a date that is two weeks from today. (Click the Calendar 

icon) 

d. From the Warehouse drop down list choose East Coast. 

 Go to the Items subtab, Items sublist, the Item field, select Printer Ink Starter Pack. 

a. In the Quantity field, enter 100. 

b. Click Add 

 Review the Billing, Relationships and Communication subtabs 

a. Go back to the Billing subtab, select Net 30 for Terms 

b. Which subtab enables you to indicate how you want to send the Purchase Order to your 

vendor and where does the email address come from  

c. Click Save 

 The Purchase Order page displays. The Purchase Order has been created and is Pending Receipt.  

 Go to Actions and select Email 

a. Review the New Email Message pop-up window and note the email address has 

populated from the vendor record 

i. If you do not see a pop-up window, then you neglected an exercise during the 

Getting Started topics.  Navigate to Setup > Company > Email Preferences. On 

the Transactions subtab, In the Transactions section, check Use Popup For Main 

Transaction Email Button. 
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b. Go to Copy Others and select TEST Widget Works: John Brown TEST on the email and 

note his email address. 

c. Click Cancel to close the window 

 End. 
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Exercise 02: Receive All Items on a Purchase Order 
Time: 3-5 minutes 

The warehouse can review the receiving queue. In this exercise: 

 Receive all the Printer Ink Starter Packs 

 Navigate to Transactions > Purchases > Receive Orders. 

 The Receive Orders page displays: 

a. Locate the Purchase Order for the Printer Ink Starter Packs and click the Receive link. 

 The Item Receipt page opens: 

a. Review the item receipt 

b. Click Save. 

c. All items have been received on this Purchase Order. 

 Find the purchase order, under Recent Records. 

 View the Purchase order and note that the status is Pending Bill. 

 End. 
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Solution for Exercise 01: Enter a Purchase Order 
 

View information in the Billing, Relationships and Communication subtabs. 

Which subtab enables you to indicate how you want to send the Purchase Order to your vendor 

and where does the email address come from? 

Answer: The Communications subtab enables you to indicate how you want to send the 

Purchase Order to your vendor.  The email address populates from the vendor record, which 

was set up earlier in the week. 

 

The Purchase Order page displays. The Purchase Order has been created successfully.  

What is the status of the Purchase Order? 

Answer: The status of the Purchase Order is PENDING RECEIPT. 

Note: When Advanced Receiving is enabled, the status of the Purchase Order is Pending Receipt. 

(Advanced Receiving was enabled earlier). If Advanced Receiving is not enabled, the status is 

Pending Bill. 
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Activity: True or False 
 

Review after the exercises: 

 

Purchasing Enhancements 
 

Go to Setup > Company > Enable Features > Transactions > Basic Features 
section to select: 

• Request for Quote, Purchase Contracts must be enabled: 
o A request sent to one or more vendors asking for specifics about their 

pricing, terms and conditions regarding a purchase contract for a product 
that they will provide  

• Requisitions lets you company make a purchase and track pertinent 
information, such as the following: 

o Who needs the item, what exactly is the item that is needed, when is the 
item needed, how much do we expect to spend for the item, and who has 
approved the expenditure for the item? 

• Requisitions serve a different purpose than purchase requests and may be 
easier to enter 

o The following table compares requisitions to purchase requests: 
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• Purchase Contracts let purchasing managers and buyers use contracted terms, 
pricing, and delivery schedules when purchasing materials  

o Instead of having terms and pricing based only on a specific purchase 
order being placed, buyers can automatically take advantage of quantity-
based terms and discounts based on an annual volume of goods or 
services purchased 

• Blanket Purchase Orders maintain fixed pricing for a preset quantity of items 
o Deliveries can be scheduled at the time the blanket purchase order is 

created or items can be released as needed during the set effectivity 
range 

o Purchase orders created using information from blanket purchase orders 
reference the source documents for easy cross-reference. 

 
The most recent enhancements include the following enhancements to vendors, 

purchasing, and receiving features: 

• Billing Address on Purchasing Transactions 

• Purchases/Vendors Dropdown Menu Changes 

• Deleting Subrecords on Purchase Contracts and Blanket Purchase Orders 

• Order Requisition Enhancements 

• Shared Vendor Saved Searches Display Secondary Subsidiaries 

• Procurement Dashboard 
 

Please refer to SuiteAnswers and New Feature Training for more information 

Additional Resources 
 
NetSuite Help Center: 

• Vendors, Purchasing, and Receiving Topics 
 

SuiteAnswers Learning Center: Training Videos 

• New Feature Training  

• Purchasing/Accounts Payable 
 
From the NetSuite Essentials tab, in your demo account, view the following video:  

• Set Up Purchasing 
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Accounts Payable Overview 

 

About this Module 

 

Accounts Payables reflect debts resulting from purchasing assets or receiving services 

on credit or on an open account:  

• Manage the Accounts Payable process through entering bills, use approvals and 
pay bills from the payables list as they become due  
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Accounts Payable Workflow 

This diagram illustrates the standard Accounts Payable process. Received items are 
logged into NetSuite. Once a receipt and a matching purchase order are identified, 
NetSuite notifies the Accounts Payable department that a payment should be made. 
 

 

 

Payables Considerations 
 
Time to think some of your considerations: 

• What are key steps in your A/P process and who is involved? 

• Do you have current processes that need improvement? 

• What are critical decisions in this process, especially around approvals? 

• Do you have credit limits / different payment terms with your vendors? 

• What payment methods do you use to pay bills? 

• What is your return to vendor process? 

• Do you receive credits unrelated to goods? 

• OneWorld: Do you need to send or receive payments within the country of 
operation? 

• OneWorld: Do you need to send or receive payments across different countries? 
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Walkthrough: Set Up Features and Preferences 
 

 
Use Case: The administrator and the A/P staff have discussed some requirements, now 
it is time to configure NetSuite.  
 

Confirm Accounting and Transactions Features 
 

Go to Setup > Company > Enable Features and confirm that the Accounting and 

Transaction features have been enabled: 

• Accounting subtab, Basic Features: 

 
o Accounting: use NetSuite for your company’s accounting 
o A/P: track bills from vendors 

 

• Transactions subtab, Shipping & Receiving: 

 
o Advanced Receiving: provide separate processes for your shipping and 

accounting departments, which accommodate the fulfilling and billing of 
sales orders 
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Define Accounting Preferences 
 

Navigate to Setup > Accounting > Accounting Preferences to define accounting 

preferences to best meet your company needs: 

• General subtab, Accounts Payable section 

 
o Define Vendor Payments to be Printed: defaults the To be Printed as 

checked and enables a print queue or check run 
o Vendor Credit Limit Warning:  check to receive a warning when you 

exceed your credit limit with a vendor 
o Vendor Credit Limit Includes Orders:   

▪ If checked includes purchase orders entered, not yet billed, whether 
approved or not 

▪ If unchecked, then only billed orders are used in the credit limit 
evaluation 

• Order Management subtab, Receiving section: 

 
o Bill in Advance of Receipt:  Bill a purchase order before receiving goods 

▪ Works in conjunction with the Advanced Receiving feature 
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Walkthrough: Managing Vendor bills 
 

 

Use Case:  Vendor bills can be managed through different approval processes.  

Consider Default Bill Status and Custom Approval Routing 
 

Select Accounting Preferences to effectively manage your payables; navigate to 

Setup > Accounting > Accounting Preferences:  

• > Order Management subtab, Vendor Bills section  

 
o Default Vendor Bill Status, select one of the following: 

▪ Pending Approval: a reviewer must approve the bill before 
payment can be made  

▪ Approved: no further review is required  

• > Approval Routing subtab and select the check boxes, per your needs, to 
enable a specific workflow:  
 

 
 

o If you enable this preference and use SuiteFlow, you can create your own 
custom workflow to process purchase approvals; non-sequential approval 
process or conditional routing 

o Enable Custom Purchase Order Approval Routing 
o Enable Custom Vendor Bill Approval Routing 

▪ Prior to enabling this preference, it is recommended that all bills 
with a Pending Approval status must be set to Rejected or 
Approved. It is not recommended to have bills in a Pending 
Approval status when you begin using SuiteFlow workflows for 
vendor bill approval routing.  
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Compare Standard versus Custom Approval Routing 
 

Standard approval routing enforces a strong AP approval processes: 

• Ensure Bills match their Purchase orders 

• Useful for companies with straightforward AP processes 

• Bills that are pending or rejected cannot be paid 
 

The custom approval routing preferences allow you to use a more flexible process for 

approvals, using SuiteFlow workflow manager, define a non-sequential approval 

process facilitated by rules such as: 

 

Walkthrough: Processing Bills 
 

 
Use Case:  We can move through transactions and steps in processing bills.  
 

Bill Purchase Orders 
 
Create a bill in NetSuite after receiving an invoice from a vendor; navigate to 
Transactions > Payables > Bill Purchase Orders or add a Standard Reminder to 
your Reminders portlet for Purchase Order to Bill 

 
 

• Filter on a specific Vendor and consider Use Bill-to Address from Vendor 
o Determine whether to use the default billing address of the vendor by 

default in the vendor field on the Billing subtab on the Bill created. 

• Select the Bill checkbox and click Submit to view the New Bill page; this will 
create a separate bill for each vendor.  

o Review the bill and if ready, select Approval Status of Approved  
o Converts the purchase order into a bill; status is Fully Billed: 
o Once a bill is created, an additional bill cannot be entered against the 

same PO items; the first bill must be processed or cancelled 

• Once a bill is approved, the status cannot be changed  
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Enter Bills 
Enter bills directly and pay them as they become due; go to Transactions > Payables 

> Enter Bills: 

 

• Enter the following information: 
o Select the Vendor 
o Add your Expenses or Items 

▪ The Amount field in the header will update as you add or edit lines  
o Review Approval Status 
o Enter other information such as Terms, Due Date, Reference No., etc.  

▪ Note: Entering a bill using the same reference number, results in a 
warning message  

o Click Save 

• This is common for services where no inventory is received and therefore, no 
purchase order exists to generate a bill 

• Bills can move through an approval process 
 

Approve Bills 
 

Saved Bills may be approved by users with the appropriate permissions: 

• Bulk approvals: Transactions > Payables > Approve Bills 

 
o The Approve Bill page may be filtered by Vendor 
o A Date range may be specified 
o The Reminders portlet may be set up to take you to the above page 

• Individual bill approval:  
o Go to the bill and Edit the bill  
o Update the Approval Status 
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Walkthrough: Vendor Credits 
 

 

Use Case:  As part of payables activity, you may need to return goods to vendors and 

process credits 

Vendor Credits Overview 
 

A vendor credit is an offset to your payables which may either: 

• Affect inventory, follow Vendor Return Authorization process  

• Or, account for price adjustments: 
o Create Price Adjustment item in “Other Charge” category, which does not 

affect inventory count 

• You may enter a Vendor Credit at Transactions > Payables > Enter Vendor 
Credits to access the Bill Credit 

• Enter in required Primary Information, Classification 
o Enter in Items 
o This is a stand-alone transaction and is not tied to any previous 

transaction 
o Issue Vendor Credits: Inventory 

 

Issue Vendor Credits: Inventory 
 

The following Vendor Return Authorization steps each involve specific permissions: 

• View a Bill, click Authorize Return 

• In the New Vendor Return Authorization review, update if necessary and Save 
the return authorization 

• In the Vendor Return Authorization, click Approve Return 

• Go back to the Vendor Return Authorization and click Return 

• Review and Save New Item Fulfillment 

• From the Item Fulfillment, click Credit 

• In the New Bill Credit, review it and Save it  

• On the bill, the related records subtab shows the bill credit 

• The vendor authorization has related records of item fulfillment and bill credit 
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Walkthrough: Processing Payments 
 

 
Use Case:  Pay your bills and provide remittance to the vendor  
 

Pay Bills 
 

Go to Transactions > Payables > Pay Bills to access the Bill Payments page and 

enter the following: 

 

• Account: bank account to be used to pay bills 
o In OneWorld accounts select the Account, which then populates the 

correct Subsidiary  

• Confirm Date, Posting Period and Subsidiary  

• To be Printed must be checked if you plan on doing a check run 
o Review Accounting Preferences – Default Vendor Payment to be Printed 

• Check the top check box to pay all bills, or click individual check boxes to pay 
specific bills 

• Click Save 

• Review and Refresh the Processed Bill Payments until you see Status 
Complete  

 
Available SuiteApp for NetSuite Electronic Payments for Global Payment Processing 

Management  

• NetSuite Electronic Payments is globalized to support international bank formats 
and routing,  

• Please refer to SuiteAnswers for more information 
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Print Checks – Process payments in check runs or individual checks 
 

Process payments in check runs or individually to accommodate physical, printed 

checks: 

• Navigate to Transactions > Management > Print Checks & Forms and then 
click Checks 

 
• Select the Account, confirm the Check Type 

o Check style is normally set in Setup > Company > Printing & Fax > 
Check Printing section, Default Check Type field: 

▪ Standard check is three checks on a form 
▪ Voucher check is one check at the top and two vouchers 

underneath 

• A voucher check is different than printing a voucher on the 
actual bill itself 

▪ No variation from these styles is possible. If you do not have this 
format, you need to change your format 

• Type in the First Check Number and the Check Number field will auto-populate 
based on the number of checks being printed  

• Click Print 
o The check displays, in Acrobat (PDF) format, on a new internet tab 
o Use the appropriate browser tool to print the page 
o Print checks on pre-printed check stock available from NetSuite’s supplier 

of imprinted forms, NetSuite Checks & Forms http://netsuiteforms.com/  
▪ Note: When setting up a new account at this site, you may not be 

able to select the country that you need. Contact the customer 
service numbers provided on the http://netsuiteforms.com/ website. 

• Review SuiteAnswers for electronic payments through Automated Clearing 
House (ACH) payments  

  

http://netsuiteforms.com/
http://netsuiteforms.com/


 

67 

 
 

Electronic Payments 
 

NetSuite includes a standard Electronic Fund Transfer (EFT): 

• Allows your customers to authorize the transfer of funds (EFT) from their bank 
accounts to your bank accounts to pay their invoices 

• Provides ACH Vendor Payments that lets you send vendor payments 
electronically to their bank 

 
The NetSuite Electronic Payment SuiteApps extends the processing capabilities of EFT 

and ACH Vendor Payments features:  

• Pay your vendor bills, employee expenses 

• Take payments from customers across the globe directly from NetSuite 
 
Please refer to SuiteAnswers for more information 
 

Standard Accounts Payable Reports 

 
Use Accounts Payable reports to determine: 

• How many unpaid bills are in your Accounts Payable  

• How many transactions are liabilities representing amounts owed to vendors for 
the purchase of inventory, goods or services 

• How many outstanding bills need to be paid 

• Review Report > Purchases 

• Also, review Reports > Vendors/Payables 

• OneWorld accounts will have a Subsidiary Context filter available when viewing 
report results 

• Review the Help Topic: Standard Reports for more information on each report 
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Activity: Match Game 
 
After you do the exercises, match the terms on the left with the descriptions on the right 

 
 

Now It’s Your Turn 
 

 
 
Use Case/Scenario: Set up Reminders and then through steps to process bills 

• Allow 25-35 minutes 
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Exercise 01: View Purchase Orders to Bill in Reminders Portlet 
Time:1-2 minutes 

Scenario: The Chatham Company requirements, as defined in the BRD, follow NetSuite’s standard 

process with minimal changes. We continue completing Accounts Payable tasks: processing purchase 

orders, creating and paying bills, and printing checks. 

Using Reminders is a best practice. In this first exercise: 

 Set Reminders portlet to view open purchase orders 

 Click on HOME and navigate to the Reminders portlet and click Set Up. 

 On the left-hand side, review list under Click or Drag to Add. 

 Select Purchase Orders to Bill and click Save. 

 Click Save. Do you see any purchase orders? 

a. NOTE: The listing of purchase orders is subsidiary driven.  

b. If you do not see an expected purchase order you may need to go to Home > Set 

Preferences > Restrict View. 

i. The Restrict View page enables you to set restrictions by Subsidiary, 

Department (Division), Location (Warehouse), and Class (Sales Channel) 

ii. These restrictions apply to your current session and will revert upon your next 

login. 

 End. 
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Exercise 02: Define Accounting Preferences 
Time:1-2 minutes 

Scenario: Keeping tighter control over Bills and Purchase orders is enabled by defining the appropriate 

accounting preferences. In this exercise: 

 Define Vendor Bill Status and Review Approval Routing 

 Navigate to Setup > Accounting > Accounting Preferences > Order Management subtab. 

a. Scroll down the page to Vendor Bills and set the Default Vendor Bill Status to Pending 

Approval. 

 Go the Approval Routing subtab and review the settings and field help for Expense Reports, 

Purchase Orders and Vendor Bills. Do NOT check anything. 

 Navigate to the General subtab and scroll down to the Accounts Payable section. 

a. Ensure that Default Vendor Payments To Be Printed is checked; enables doing a check 

run at the time of processing vendor payments. 

 Click Save. 

 End. 
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Exercise 03: Bill a Purchase Order 
Time:1-2 minutes 

Scenario: Now you must bill open Purchase Orders. You cannot bill purchase orders from different 

vendors at the same time. In this exercise: 

 Bill a purchase order from either the Reminders portlet or the menu path - Transactions > 

Payables > Bill Purchase Orders 

 Go to the Home dashboard, Reminders portlet and click on the Purchase Order to Bill link. 

 The Bill Purchase Orders page opens 

a. Review the Vendor and Use Bill-to Address From Vendor field help. 

b. Check the Bill box for the Test Widget Works purchase order. 

c. Click the Submit button. 

 The Bill: Test Widget Works page opens. 

a. Review the Primary Information and the Expenses and Items subtab, Items sublist.  Do 

not make any changes. 

b. Click Save.  Review the Confirmation message. 

 Navigate to Transactions > Purchases > Enter Purchase Orders > List to view all purchase orders 

and their status.  This purchase order shows a Status of Fully Billed. 

 End. 
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Exercise 04: Enter and Approve a Bill 
Time: 2-3 minutes 

Scenario: Bills are entered when no inventory is received and no Purchase Order exists to generate a 

bill. An example of this is a telephone bill.  In this exercise: 

 Enter a utility bill from a vendor and approve it 

 Navigate to Transactions > Payables > Enter Bills: 

 The Bill page opens 

a. In the Reference No. field, enter 123456 (the Vendor’s Invoice Number) to identify this 

transaction 

b. Select Test Widget Works 

c. In the Memo field, enter Current month’s bill to describe this bill.  Replace information 

that is pulled from the Vendor record, Financial subtab, Account field 

 Go to Expenses and Items subtab > Expenses sublist and enter the following information: 

a. Account: 6260 Telephone Expenses 

b. Tab to Amount: 50.00 

c. Click Add. This total should also be reflected in the Amount field in the header of the 

transaction 

 Go to the Billing subtab; confirm the address 

a. Note: If you set up terms on the Vendor record, discount terms auto-populate. This also 

determines the values for the Due Date, Discount Date, and Discount Amount fields. 

 Click Save. 

 The Bill is saved and the status is PENDING APPROVAL. 

 Approve Bills by first going Home and click Setup in the Reminders portlet: 

a. Under Click or Drag to Add, select Bills to Approve 

b. click Save 

 In the Reminders Portlet, click the hyperlink Bills to Approve: 

a. On the Approve Bills page, click the Mark All button 

b. Click Submit 

 Use Recent Records to view the Bill: 
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a. Approval Status is Approved 

b. The Bill Status is OPEN 

 End. 
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Exercise 05: Pay a Bill 
Time: 2-3 minutes  

Scenario: Once you have recorded vendor bills, you pay them when they are due. Several vendors may 

be paid at once, if required.  In this exercise: 

 Pay vendor bills 

 Navigate to Transactions > Payables > Pay Bills. 

 The Bill Payments page opens: 

a. From the Account field, you can select the account to be used to pay these bills. Use the 

default value: 1000 Checking 

b. The Date field automatically populates with today’s date 

c. In the center columns the To Be Printed check box should be checked 

 Review the lower portion of the page: 

a. Displays the outstanding bills of the parent company 

b. Lists any credits or refunds the parent company has received from vendors 

c. Also, includes expenses due to be paid to employees 

d. Can be sorted, in different ways, by clicking on column headings  

e. (OneWorld: As the NetSuite administrator, you may want to pay bills for all subsidiaries. 

Navigate to Home > Set Preferences > Restrict View and select the subsidiary you want 

to make payments for). 

 Check the top checkbox.  All the other checkboxes should now be checked.  Pay all outstanding 

bills.  

a. To view the details about a specific transaction, click the Date link next to a bill or credit. 

 Click Save.  Review the Confirmation message. 

 Click Refresh until the Status is Complete.  The bill payment has been processed. You print 

checks in the next exercise. 

 End. 
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Exercise 06: Print a Check 
Time: 2-3 minutes 

Scenario: Once you have selected bills and processed the bill payments you need to print the checks.  In 

this exercise: 

 Issue check to a vendor 

 Navigate to Transactions > Management > Print Checks and Forms. 

a. Note: Alternatively, you could add a Reminder - Checks to Print – This may not be set up 

in the account 

 Click the Checks link: 

a. In the Account field, select 1000: Checking. 

b. In the First Check Number field, the next available check number is automatically 

inserted 

c. Ensure that Voucher is selected in the Check Type field: 

i. Standard option prints three checks to an 8.5-by-11-inch sheet without any 

voucher/Stubs 

ii. Voucher option prints a single check per page with voucher information at the 

bottom 

d. Check the Print box for the Test Widget Works payee 

e. Click the Print button 

 The check is displayed in a new browser tab, in Adobe Acrobat PDF format: 

a. To print the check, you need to click the PDF printer button. Do not click the PDF printer 

button if you are in a classroom. 

b. Close the Check tab or window.  

 The check has been printed and will no longer display in the list on the Print Checks page. 

 Click Home. 
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Additional Resources 
 

NetSuite Help Center: 

• Accounting: General Accounting 

• Vendors, Purchasing, and Receiving Topics 
 

SuiteAnswers Learning Center: 

• New Feature Training  

• Purchasing/Account Payable 

• Accounts Payable 
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Banking and General Ledger 

 
About this Module 

 

In this module, we explore how to use NetSuite to manage Banking and General Ledger 

tasks.  We also introduce some of the considerations to think about as you prepare for 

your NetSuite implementation.  
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Financial Considerations 
 
Define your banking and accounting processes: 

• Consider Roles and Permissions; controlling who enters journal entries 

• Do you require approvals on your journal entries? 

• Do you have recurring journal entries? NetSuite journals must balance 

• Create a “clearing” account, a holding account for journal entries 

• Do you need to memorize transactions? Will it need to be reversed?  
 
OneWorld Considerations: 

• Each bank account belongs to exactly one subsidiary (the same can be said for 
each credit card and/or PayPal account) 

• Cash receipts from one subsidiary cannot be deposited into an account 
belonging to another subsidiary 

• Transactions from one subsidiary cannot be processed through a different 
subsidiary; Vendor bills, customer payments, etc. 

 

NetSuite GL Overview 
 
The general ledger, with subledgers, is the core of your company’s financial records:  

 

• Entries post to the subledgers and transact through the GL as debits and credits 

• View the GL Impact from a transaction and drill into the register, e.g. an Item 
Fulfillment 

o View an Item Fulfillment 
o Go to Actions > GL Impact 
o GL Impact page displays showing all debits and credits by account 

▪ On the GL Impact page, non-posting transactions display debits to 
the related non-posting register.  

▪ The non-posting account register lists transactions that do not 
directly affect the balance of what the company is worth. E.g. 
Purchase Order transactions do not actually incur debt the way bills 
do. Nevertheless, it's important to know how these transactions 
affect the balance of your accounts 

o Click the Account name, e.g. Cost of Goods Sold  
o View the Cost of Goods Sold Register 
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Walkthrough: General Ledger Functions 
 

 
Use Case:  Recurring transactions can be memorized.  Use journal entries to make GL 
adjustments. Let’s look at both.  

 

Memorize Transactions 
 
Save time by creating a memorized transaction, setting up the transaction to recur over 

time, for common recurring transactions such as: 

• Payable monthly bills such as utilities and rent 

• Receivable monthly invoices for apartment rental business 
 
Use Case: monthly bill for 12-month cell phone contract: 

• Go Transactions > Payables > Enter Bills 

 
• Complete the Primary Information and Classification sections 

• Enter Expense> Account > Telephone Expense: Cellular 

• Enter in the monthly Amount 

• Save the bill to post the first month of our 12-month contract 
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Define the memorized transaction: 

 

• Edit the bill, go to Actions and select Memorize 

• Enter a Name, e.g. 12-month Cell Phone Contract 

• Select Remind Me to maintain control the posting of memorized transactions 

• Define the Frequency, e.g. Monthly 

• Enter related information, e.g. Next Date one month from today 

• For our use case, we now select Number Remaining 
o We have a 12-month contract, we have posted the first month 
o Enter 11  

• Save 

• Set up your Reminders portlet, adding Memorized Transactions 
 
Review the list of memorized transactions: 

 
• Go to Transactions > Management > Enter Memorized Transactions > List 

o Click Edit to edit the memorized transaction 
o Click View to edit the memorized transaction 
o Click Enter to edit the source transaction record 
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Make Journal Entries 
 
Journal entries adjust balances in your ledger accounts; you can manually enter or 

import, but must balance and can be set to reverse:  

• Transactions > Financial > Make Journal Entries: 
o OneWorld accounts: select the Subsidiary, this will default in Currency 

and Exchange Rate 
▪ Exchange Rate only displays if the Multiple Currency feature has 

been enabled 
o Add in the Debit and Credit lines, Out of Balance by must be blank 

before saving 
o Consider the Reversal Date if you want this journal automatically 

reversed; e.g. account for a 6-month loan of equipment 
▪ Select Defer Entry to make the reversal a memorized transaction  

o Save the journal; must be in balance 
 

 

Best Practice: Journal Entries 
Use an approval process for journal entries, set in Accounting 
Preferences: Require Approvals on Journal Entries.  Entries can be 
recorded but not posted prior to approval. 

 

Walkthrough: OneWorld GL Transactions 
 

 
 
Use Case: In a OneWorld account intercompany transactions and adjustments, as well 
as eliminating journals, help preserve the accuracy of consolidated reporting.  Please 
note that one of the features and related Accounting preferences are not 
compatible, and are unnecessary, if the with Multi Subsidiary Customer feature 
enabled. 
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Enable Intercompany Features 
 

Go to Setup > Company > Enable Features > Accounting subtab, Advanced 

Features: 

 

• Intercompany Time and Expenses: enter intercompany time and expenses and 
transfer these from one subsidiary to another: 

o When time and expenses are entered, their impact on employee 
subsidiary accounts is recorded.  

o For customers that have a subsidiary different from employees, create 
adjusting journal entries to reverse the impact on employee subsidiary 
accounts and register the impact on customer subsidiary accounts.  

o If the Multi Subsidiary Customer feature is enabled, then this feature 
is unnecessary and cannot be enabled 

• Automated Intercompany Management: Manage intercompany transactions 
and automatically generate elimination journal entries 

o Reduce the manual steps required to manage and report intercompany 
activity 

o NOTE:  To use this feature, an Elimination subsidiary must exist. 
o Create intercompany purchase orders per subsidiary as needed. 
o Generate intercompany sales orders from intercompany purchase orders.  
o Manage intercompany inventory transfers.  
o Enter intercompany journal entries for other intercompany transactions. 
o Reconcile intercompany transactions.  
o Run Intercompany Elimination from the Period Close Checklist.  
o View the Intercompany Elimination report.  
o Manual intercompany journals are also available 

• Automated Intercompany Drop Ship: manage intercompany drop ship 
workflow and automatically generate elimination journal entries  

 

Refer to SuiteAnswers for information on all the available features and then your 

Accounting team can decide what they need 
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Define OneWorld Accounting Preferences 
 

Go to Setup > Accounting > Accounting Preferences > General subtab: 

• Define the OneWorld accounting preferences for situations where the employee 
and the customer are in different subsidiaries: 

o Requires that Intercompany Time and Expenses feature was enabled  

• Go to One World section: 

 
o If the Multi Subsidiary Customer feature is enabled, then this section 

is unnecessary and it is not displayed 
o Intercompany Time: how will you handle time entries when the employee 

and customer are in different subsidiaries?  
▪ Allow 
▪ Disallow 

o Intercompany Expenses: how will you handle expense entries when the 
employee and customer are in different subsidiaries?  

▪ Allow 
▪ Allow and Auto Adjust – this is the default setting and enables 

automated intercompany adjustments  
▪ Disallow  

 

Create Intercompany Adjustments for Time and Expenses 
 

These adjustments are possible in your account if: 

• If the Multi Subsidiary Customer feature is NOT enabled 

• The Intercompany Time and Expense feature IS enabled 
o If the Multi Subsidiary Customer feature is enabled, then this feature 

is unnecessary and cannot be enabled 

•  The Intercompany Expenses preference set to Allow and Adjust  

• Requires the Intercompany Adjustments permission, and access to all 
subsidiaries; users can quickly generate required adjustments for a selected 
posting period 

• This is task can be completed as part of the period close process 

• It is also available outside of the period close process 
o Transactions > Financial > Create Intercompany Adjustments 
o If the Multi Subsidiary Customer feature is enabled, then this 

transaction is unnecessary and is not available  
 
Refer to Help topic: Creating Intercompany Adjustments for Time and Expenses 
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Elimination Subsidiaries 
 

Set up elimination subsidiaries to log journal entries to balance consolidated books; 

NetSuite does not auto-create elimination subsidiaries: 

• Must use the same currency as parent 

• Usually have siblings (otherwise when the data is rolled up, there would be no 
data that needs eliminating) 

• Only journal entries post to elimination subsidiary (no other transactions) 

• Go to Setup > Company > Subsidiaries > New 

 
o Enter subsidiary information 
o Consider using the word “Elimination” in the name of the subsidiary 
o Set the Currency first and then  
o Check the Elimination checkbox 

 
Use cases for elimination subsidiaries: 

• An Indian company keeps “local books” per separate local Indian GAAP and they 
do their separate reporting in rupees 

• Then they create an elimination subsidiary of that company that is a subsidiary 
(reports in rupees) to hold adjustments between the local Indian accounting 
practices and the GAAP accounting principles that are used for the consolidating 
reporting in total 
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Elimination Journal Entries 
 

Use the standard journal entry process; go to Transactions > Financial > Make 

Journal Entries: 

 

• Complete all information, but be sure to select an Elimination Subsidiary  

• Preserve the accuracy of consolidated reporting 
o Intercompany transactions can lead to incorrect reporting results for a 

parent subsidiary, elimination journal entries correct this 
o Intercompany transaction balances may need to be eliminated for:  

▪ Sales between subsidiaries 
▪ Inventory transfers between subsidiaries 
▪ Loans between subsidiaries 
▪ Investment into a subsidiary 

 

Make Intercompany Journal Entries (ICJE) 
 

Intercompany journal entries are specifically for OneWorld:  

• References separate subsidiaries and books 

• References more than one subsidiary: 

• Currency can only be expressed in currency of one of the two subsidiaries, select 
either currency:  

o Line items amount is expressed in currency of ICJE 

• Navigate to Transactions > Financial > Make Intercompany Journal Entries 

 
o Select both the Subsidiary and the To Subsidiary 
o Select the Currency, which will we the currency of one of the subsidiaries 
o Continue entering information 

▪ Accounts are associated with subsidiaries chosen  
▪ Debits and Credits must balance by subsidiary 
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Now It’s Your Turn 

  

Use Case/Scenario: Use some basic transactions 

• Regular journal entry for the parent company 

• Elimination journal to eliminate profit between subsidiaries 

• Memorize recurring rent expense 

• Allow 10 – 20 minutes 
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Exercise 01: Make Journal Entries 
Time: 2-5 minutes 

Scenario: In this exercise: 

 Create a regular journal entry for the parent company. 

 Navigate to Transactions > Financial > Make Journal Entries. The Journal page opens.  

a. From the Subsidiary dropdown list, select Parent Company. 

b. Currency defaults from the Subsidiary field. 

 Go to the Lines subtab.  

a. Click the Account dropdown and select 1300 Prepaid Expense. 

b. Enter 100.00 in the Debit field.  

c. Notes:  

i. You can enter a description in the Memo field to help you recognize this entry in 

a register for this account. An example might be ‘Rent Prepayment Journal 

August’. 

ii.  You can also use the Name field to enter a person or company to associate with 

the entry. Perhaps using TEST ABC as the entry. This step is optional but 

associating a person or company with this transaction helps identify this 

transaction in Search results.  

d. Click Add.  

 On the next line, select 6200 Rent Expense from the Account drop down list.  

a. Tab to the Credit field. The field should automatically populate with 100.00. 

b. Click Add. 

i. Note: The Out of Balance By Debit and Credit fields at the top of the page 

should be blank. If either field contains an amount, your line items are out of 

balance. If your line items do not balance, you cannot save this entry.  

 Click Save.  Review the Confirmation message. 

 End. 
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Exercise 02: Make Journal Entries with Elimination Subsidiaries 

Time: 2-5 minutes 

Scenario: An intercompany sale has been previously recorded and the profit must be eliminated. We 
recognize the profit at the subsidiary level, but we do not want to see this in the consolidated reports. 
This elimination can be done with two separate journal entries as this exercise illustrates.  

We eliminate both the net effect and the entire transaction. In this example, the net effect and the 
entire transaction are the same as there is only one transaction to clear. 

 

In this exercise 

 Eliminate the profit realized in the sales between two subsidiaries 

 Navigate to Transactions > Financial > Make Journal Entries. The Journal page opens.  

a. Subsidiary: *Elimination Parent Company. 

b. Currency defaults from the Subsidiary field. 

c. Verify the Posting Period value. 

 Go to the Lines subtab.  

 Click the Accounts dropdown, select the accounts; click Add after each entry. 

Accent Debit Credit 

4000 Sales 200.00  

1100 Accounts Receivable  200.00 

1200 Inventory 150.00  

5000 Purchases  150.00 

a. Notes:  

i. Enter an optional description in the Memo field to help you recognize this entry 

in a register for this account. Use the Name field to optionally enter a person or 

company to associate with the entry. Associating a person or company with a 

transaction helps identify this transaction in Search results. Perhaps you want to 

use TEST as a value to help identify the entry. 

ii. The Out of Balance By Debit and Credit fields must be blank. An out-of-balance 

journal cannot be saved. 

 Click Save.  Review the Confirmation message. 

 Now repeat for *Elimination Germany. 

a. Hint: Actions > New 

b. Click the Subsidiary dropdown and select *Elimination Germany. 
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 Click the Accounts dropdown, select the accounts; click Add after each entry. 

Accent Debit Credit 

2000 Accounts Payable 200.00  

1200 Inventory  200.00 

a. Note: To reflect the inventory transfer in your group reports, you may need to use a 

suspense inventory account.  SUSPENSE ACCOUNT: temporarily used for receipts, 

disbursements, or discrepancies until and they can be properly classified. 

 Save.  This treatment eliminates the impact of the intercompany transactions (between Parent 

Company and Germany Subsidiary) from the consolidated reports. It reflects the profit as well as 

Balance Sheet items impact at the Subsidiary level. 

 End. 
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Exercise 03: Memorize a Transaction 

Time: 2-5 minutes 

Scenario: Using memorized transactions are useful for recurring transactions, cutting down on data 

entry time. In this exercise: 

 Memorize the journal entry #1, created in Exercise 01. 

 Hover over Recent Records clock and select Journal #1.   This should be for the Prepaid 

Expense/Rent Expense adjustment 

 The Journal page opens. 

a. Click the Edit button. 

b. Click Actions > Memorize. 

c. In the Name field, enter One Year Lease. 

d. As a precaution, you can leave the Remind Me radio button selected. 

e. Select Monthly from the Frequency dropdown list. 

f. Select One Month from today for Next Date. 

g. Select the Number Remaining radio button and enter 11 in the field. 

i. This is a 12-month lease and we already posted the first month. 

h. Select the Update Addresses check box to ensure that we have the vendor’s current 

address. 

i. Click Save.  

 The Memorized Transactions page opens.  This is a listing of all memorized transactions.  We can 

see our One Year Lease. 

a. The Edit link allows us to edit the Memorized Transactions attributes 

b. The View link allows us to view the Memorized Transactions attributes. 

c. The Enter link takes us to the transaction, such as the journal. 

 End. 
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Walkthrough: Banking Transactions 
 

 
Use Case:  Let’s look at recording basic banking transactions.  NetSuite is NOT doing 
the banking, but you are entering information into NetSuite to reflect banking activity.  
 

Write Checks – “Spend Money” 
 

Issue a check to pay an expense or record a non-check transaction: 

• Record cash transactions 

• Pay vendors if you do NOT use Accounts Payable 

• Reimburse employees for expenses if NOT using Direct Deposit or AP 

• Write a check instead of using petty cash  

• Go to Transactions > Bank > Write Checks 

 
o Complete Primary Information and Classification sections 
o Go to Expenses & Items and complete required line items 

• Please refer to the Help Topic: Writing Checks 
 

Other information: 

• Checks written in this way do not display in Accounts Payable 
o Note: In the payee field, you can select anyone to write this check to, but it 

will not go against the accounts payable. 

• If you use Expense Reports (ER), employees are synonymous with vendors and 
are paid via Pay Bills. If you are not using ER, Write Checks is a preferred 
method for reimbursement; it records the liability and the payment in one screen.  

• Note: This function is not limited to physical ‘Checks’. If you pay with petty cash 
or credit card, you can still use this function to record disbursements. 
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Record Transfer of Funds 
 

Record the movement of funds from one bank account to another bank account: 

• NetSuite records fund transfers, but does not execute fund transfers  

• Go to Transactions > Bank > Transfer Funds  

 
• Select the From Account and To Account, and corresponding Amounts 

• Complete all other fields 

• Save  
 
Other information: Transfers between bank accounts and non-bank accounts are 
typically done with checks or deposits.  

• Example, pay off a loan with a check, instead of doing a transfer from the 
checking account to the loan payable account, you write a check and choose the 
loan payable account for the expense 

• Transfers between two non-bank accounts are rare and should be done with a 
general journal entry. You may want to consult your accountant 

 

Import Online Banking Data 
 

You must first download banking data from your bank and then import into NetSuite: 

• Supported file types to import bank statements: 
o OFX (Open Financial Exchange) is a file format sponsored by Intuit, 

Microsoft, and Checkfree. It is commonly used with Microsoft Money 
o QFX (Quicken Financial Exchange) is a file format developed by Intuit and 

is used with their Quicken software. It is a variant of the OFX file format 
o QIF (Quicken Interchange Format) is a file format developed, but no 

longer supported, by Intuit. Some banks still use this format 
o If your financial institution provides banking data in another format, such 

as MT940 or CSV, use a third-party conversion tool to convert the data file 
to OFX format and then import 

• File contains a list of all transactions cleared for a range of dates 
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• Go to Transactions Bank > Import Online Banking Data  

 
 

Reconcile Bank Statement 
 

Reconcile the NetSuite bank account register to your bank statement; go to 

Transactions > Bank > Reconcile Bank Statement: 

 

• Use the following subtabs appropriately:  
o Deposits and Credits: includes payments from customers 
o Checks and Payments: payments to vendors 
o New Charges: bank and credit card fees 
o New Deposits: record interest on an account.  

• Choose the appropriate action: 
o Save:  if the reconciliation is out of balance, NetSuite automatically places 

the reconciliation on Hold 
o Hold: save what you have done and return later to finish reconciliation 

• Please refer to Help Topics: Bank Account Reconciliation and Reporting 

 

 
Best Practice: Clear transactions in the register through the month, 
then reconcile account with monthly statement. The Reconciliation page 
includes cleared transactions and identifies that they have cleared. 
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Walkthrough: Manage Accounting Periods 
 

 
Use Case:  You may be defining your fiscal year with accounting periods.  By default, 
OneWorld accounts use Accounting Periods.  Let’s examine some of the functionality 
associated with accounting periods.  
 

General Ledger Preferences 
Go to Setup > Accounting > Accounting Preferences > General subtab, General 

Ledger section:  

 

Define Accounting Period Window: Maintain a window of unlocked current and future 

accounting periods that best suits your business needs and month-end process: 

• Ability to lock all other future periods to transaction posting 

• Daily verification that the correct number of accounting periods are unlocked and 
available for posting transactions 

• Define accounting preferences at Setup > Accounting > Accounting 
Preferences > General subtab, General Ledger section:  

o Enable Accounting Period Window: maintain a few unlocked current 
and future accounting periods 

o Minimum Period Window Size:  define the number of periods for the 
Window, 1 is the default 

o Allow Transaction Date Outside of Posting Period: set preference for 
handling mismatched transaction entry, date to period 

o Default Posting Period When Transaction Date in Closed Period: 
choose the period in which the system should post a backdated 
transaction from a closed period  
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Quick Close of Accounting Periods: Enables you to close one or more accounting 
periods with a single click; useful if you have reopened one or more closed 
accounting periods to make a change: 

o The Quick Close preference enables you to close one or more accounting 
periods with a single click and is useful when you have reopened one or 
more closed accounting periods to make a change.  

o NetSuite marks complete all tasks in all reopened accounting periods, 
eliminating the requirement to close them one-by-one.  

o Warning! The Period Close Checklist helps you with your financial closing 
workflow. Quick Close does not run period closing tasks. It only marks the 
tasks as completed. Use Quick Close only when you are certain that there 
is no requirement to run period closing tasks. 

 

Manage Accounting Periods 
 

Go to Setup > Accounting > Manage Account Periods to view a list of all accounting 

periods set up in your NetSuite Account: 

 

• You can Expand All/Collapse All 

• Use the Checklist for period close activities 

• View the status of period, AP, AR, All G/L, and Allow Non G/L Changes 
o Open/Unlocked: Transactions can be posted by any user, restricted only 

by role 
o Locked: Lock A/R, A/P, Payroll. Do each task separately 
o Override Period Restrictions permission required to make GL changes to 

locked (but not closed) periods 
o Lock All is pre-requisite to other tasks 
o Closed means no one can make G/L changes, not even Administrators, or 

people with Override Period Restrictions permission  

• If Multiple Fiscal Calendars enabled, then review the Fiscal Calendar filter 
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Use the Period Close Checklist 
 

The checklist assists in completing steps for a Period Close and is available for regular 

and adjustment periods, not quarter or year: 

• Click the Checklist icon, on the Manage Accounting Periods page, for the first 
open periods  

 
• Checklist tasks display based on Accounting features enabled 

• Shows dependencies between tasks  

• Periods can be Open/Unlocked, Locked or Closed 

• Audit trail tracks who locked, closed or reopened each period and when 
 
General Information: The period close checklist gives you better control of, and 
visibility into, the accounting period close process.  

• Lock your periods before finally closing them to avoid accounting errors while you 
are still entering adjustments and performing other closing tasks  

• Certify that you've completed critical closing tasks like NetSuite OneWorld 
currency revaluation and intercompany adjustments 

• Check for Cost and quantity inconsistencies 

• Reconcile transactions that are not dated within the correct financial period and 
set a preference on how to handle those discrepancies 

• Manage your negative inventory 

• Closed periods must be explicitly reopened before any user can post transaction 
changes and a full audit trail keeps track of who locked, closed, or re-opened 
each period and when. 
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Locking Accounting Periods by Subsidiary 
 
This is the number one enhancement requested by NetSuite OneWorld customers:  

• Enables locking of accounting modules independently per subsidiary, based on 
the business needs and schedule of each subsidiary 

• Easier to manage periods and close periods across the globe 

• Click on a checklist task, e.g. Lock A/R, Lock A/P, Lock All 
o Simply check Close on individual subsidiaries  

 

Accounting for Currency Exchange Rate Fluctuations 
 
Exchange rate variances between your base currencies and the foreign currencies can 

impact your General Ledger accounts: 

• Variance between the initial value of the transaction and the value upon closure 
or payment 

 
Revaluation Engine on historical transactions  

• Gains and losses post to separate GL accounts based upon their source 
 

 
 

• Impacts both standard and OneWorld customers 

• Customers that do not have to have accounting periods enabled. Account 
periods are optional, but recommended. 

• If multiple currencies have been turned enabled, then the customers need to be 
able to account for variances due to currency exchange rate fluctuations 

 
NetSuite processes currency revaluation for transaction lines in groups of 500 
lines. 

• It creates one currency revaluation transaction for every 500 lines. The total 
variance amount for each currency revaluation transaction created posts to the 
Unrealized Gain/Loss account 
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Closing a Period End – General Information 
 
The close task is the final task that is dependent upon all other tasks having been 

completed: 

• Periods must be lock, before closing them 

• Closed periods must be explicitly reopened before any user can post any 
transaction changes 

o Once closed, no one can make GL changes without re-opening the period 
▪ Administrators cannot post 
▪ Override Period Restrictions permission does not matter 

• Periods are closed in chronological order 
o If you re-open a period, all closed periods after it will also be re-opened, 

and you must close them individually  
 

General Information: Period Close gives you the ability to prevent other users from 

posting to the GL while making adjustments: 

• Ensure critical processes (intercompany, revaluation) are performed or signed-off 
on prior to closing 

• Prevents GL changes to closed periods 

• Ability to audit who closes/re-opens periods and when 

• Important for large (public) companies, small companies may also use this  
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Review Financial Reports 
 
Go to Reports > Financial reports: 

 
• Not all roles have access 

• Reports are date driven 

• May be customized: 
o Reports > New Financial Report and access the Financial Report 

Builder 

• OneWorld accounts will have a Subsidiary Context filter available when viewing 
report results 

• Review the Help Topic: Standard Reports for more information on each report 
 

Now It’s Your Turn 
 

 
 
Use Case/Scenario: Test out the period close checklist, going through the tasks. 

• Allow 5-10 minutes 
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Optional Exercise 

Exercise 04: Close Accounting Periods (Optional) 

Time: 2-5 minutes 

Scenario: Period closing is an accounting procedure done at the end of the month, closing the current 
posting period.  

Once your accounting department has completed its month-end closing operations, the period closing 
procedure begins. 

In NetSuite closing an accounting period means changing its status from Open to Closed. This status 
prevents posting for any dates included in the period. 

Functionality includes locking components at the subsidiary level. 

 Navigate to Setup > Accounting > Manage Accounting Periods. The Manage Accounting Periods 

page opens. 

a. Open the oldest Fiscal Year, for example FY2014 

b. Click the Checklist Icon for the first (oldest) January listed. 

 The Period Close Checklist: Jan 20XX page opens. Note: the available tasks are dependent upon 

the features enabled: 

a. In the Go To Task column, click on the first green arrow icon to Lock A/R.  

b. In the Subsidiaries subtab Task: Lock Accounting Period (A/R), click Mark All on the 

subsidiaries sublist 

c. Click Submit. 

d. Repeat for A/P. 

e. (Alternatively, you could select Lock All. This depends on your company’s month end 

policies.) 

f. Once the period is locked, posting is prohibited unless a user with the Override Period 

Restrictions permission un-locks the period. 

 

 Click the Go To Task for Resolve Date/Period Mismatches. 
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a. In the page Task: Resolve Date/Period Mismatches, click Resolve Date/Period 

Mismatches, then Back to Period Close, and then Mark Task Complete.   

i. If any records were to show up, you could click edit and change the posting 

period to match the date.  Click Save.  You would then go back to period close 

checklist. 

 Repeat for Review Negative Inventory, click Review Negative Inventory, then Back to Period 

Close, and then Mark Task Complete. 

 Repeat for Review Inventory Cost Accounting, click Review Inventory Cost Accounting, then 

Back to Period Close, and then Mark Task Complete. 

 Repeat for Review Inventory Activity if it displays in your account. Click Review Inventory 

Activity and view the report.  Then go back to Setup > Accounting > Manage Accounting 

Periods and return to the checklist you were working on.  Go to the Review Inventory Activity 

and Mark Task Complete. 

 As of the printing of this workbook, this feature may not be behaving as expected.  That is why 

we are following slightly odd steps 

Continue with OneWorld Tasks: During this course, there were no transactions completed in a foreign 

currency that require you to Revalue Open Foreign Currency Balances. But, to view the task’s 

functionality, follow the directions below. 

 Now, the Create Intercompany Adjustment task and click the green arrow.  Click Create 

Intercompany Adjustments for Expenses, then Back to Period Close, and then Mark Task 

Complete. 

a. Note: If the Multi Subsidiary Customer feature is enabled, then this step is unnecessary 

and is not available 

 Repeat for Revalue Open Foreign Currency Balances.  Click Currency Revaluation, then Back to 

Period Close, and then Mark Task Complete. 

a. Click Currency Revaluation button. 

 In the Go to Task column click the green arrow icon to Calculate Consolidated Exchange Rates, 

click the Calculate Consolidated Exchange Rates button. 

a. On the Consolidated Exchange Rate page, click the Calculate button. 

i. Notice on this page, that you can determine between which subsidiaries you 

want to consolidate the exchange rates. 

b. Next, click Back to Period End Close button and then click Mark Task Complete. 
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 Repeat for Eliminate Intercompany Transactions.  Click Run Intercompany Elimination. You 

may get a pop-up window, click OK and then Back to Period Close, and then Mark Task 

Complete. 

 Note that the icon next to Task: Close, is now changed to green arrow. 

a. You are now ready to close the period. 

b. In the Go to Task column, click on the green arrow icon to Close the period. 

c. In the page Task: Close Accounting Period click Close Period. 

 Go to Setup > Accounting > Manage Accounting Periods to verify that the period is closed. 

 

 End. 
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Activity: Match Game 
 

Match the term on the left, with the description on the right 

 

 

Introducing SuiteGL - Please Refer to SuiteAnswers 

 
SuiteGL features allow you to customize your general ledger processes to 

accommodate operational and financial requirements: 

• Adaptation of accounting practices to the complex and widely varied standards of 
different nations 

• Strengthening of regulatory compliance, satisfaction of industry-specific and 
company-specific needs 

• Modifying line-level general ledger impact of transactions 

• Designing specialized transaction types with unique GL capabilities 

• Creation of customized classifications (segments) that improve reporting and 
analytics 

 

Go to Setup > Company > Enable Features > SuiteCloud subtab  
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Need More Information 
 
NetSuite Help Center: 

• Accounting 
 
SuiteAnswers Learning Center:  

• New Feature Training  

• Financial Management 

• Accounting  

• Closing Accounting Periods 

• SuiteGL 
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Reports and Searches 

 
About this Module 

 

Does NetSuite provide analytical tools, like what you used previously? 

• Does the NetSuite application include reports that have the same content that I 
use in my work now? 

• Can I change a NetSuite standard report? 

• Will NetSuite’s Search functionality make my job easier?  
 

We will look multiple approaches to extracting data for use within your business.  
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Reports and Searches Overview 
 

Which will serve you better, a report or a search? 

• How can users get to critical information?  

• What are some of the existing reports that your users need on a regular basis? 

• What are some of the situations that arise when your users want lists of records 
or data? 
 

As you plan your implementation, think about the data that you want to report or 
search on: 

• The way that you enter/put in the data will dictate how you will be able to pull the 
data out of the record 

 
Reports and Searches Comparison 
There are differences between a report and a search.  

Reports  Searches 

 

 

 

• Point-in-time analysis  • Dynamic list of results 

• Natural, hierarchical 
grouping 

 • May be easier to navigate 

• Totals and subtotals  • Flexibility with formulas 

• More polished appearance  • Highlighting capability 

• Natural, hierarchical grouping 

• May include calculated fields 
and dimensions not available 
in a search 

 • Can be reused in many place, providing 
different displays of the results  
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Walkthrough: User Needs and NetSuite Reports 
 

 

Use Case: The administrator is often the go-to person for reporting.  It is time to look at 

a reporting use case presented by a manager and then investigate reports in NetSuite. 

Examine the Use Case 

 
Use Case: Customer Report and Credit Limits 
A manager needs a NetSuite report that replicates a spreadsheet, helping assess 

customer credit limits: 

• Information grouped by Customer 

• Open balance 

• Overdue balance 

• Credit limit 

• Customer Liability=X-Y:  X is the credit limit and Y is the open balance 
 

 

As the administrator, you will need to identify which report might help with the 

manager’s requirements 
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Investigate the Reports Dashboard 
 

Navigate to Reports > Reports Overview, the reports dashboard: 

 

• Reports are grouped around functional areas, e.g. Purchases, Sales, Customer 
Service 

• Available reports dependent upon features in your account 

• User access to reports is controlled by their role and permissions 

• Use the Expand All, Collapse All to impact all report groupings 

• Or, expand one grouping 

• As the administrator, investigate reports that may meet the requirements of the 
use case – customer balance information with credit limits: 

• Review Help topic on Standard Reports 

• Open Customer/Receivables, view the A/R Aging Report 

  



 

109 

 
 

Walkthrough: Gap Analysis 

 

Use Case: The report needs to look at the customer record, so you need to review the 

record to identify available fields to expose in a report.  Test run the standard report to 

assess how well it meets your needs.  

Before you customize a standard report, do a gap analysis 

Review the Underlying Record 
 

Review the customer record to familiarize yourself available fields: 

 

• Go to the Financial subtab and peruse the available fields for our use case, such 
as:  Credit Limit, Balance, Overdue Balance 
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Test Run the Report 
 
 

 
 

The A/R Aging Report as a good starting point; test run the report: 

• Review the report filters at the bottom of the page 

• Identify what can be added or removed from the report: 
o We probably do not need the Aging buckets 
o We do need columns for Overdue Balance, Credit Limit and the calculated 

Customer Liability 
 

Walkthrough: Using the NetSuite Report Builder  
 

 
Use Case: Customize the A/R Aging Summary to show 

• Customize the A/R Aging Summary to show: 

• Customer Name, 

• Open Balance  

• Overdue Balance 

• Credit Limit 

• Customer Liability 
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Report Builder Overview 
 

The Report Builder allows users to customize a standard report: 

 

• Go to Reports > Customers/Receivables > A/R Aging > Summary 

• Click Customize, the Report Builder displays 

• Enter the report Name; develop a naming convention 
 

Edit Columns 
 

 

 
 

Edit columns to delete, move, or add columns and define formatting: 

• Remove Current column, we do not need aging buckets 

• Add columns so that we have: 
o Customer Name 
o Open Balance  
o Overdue Balance 
o Credit Limit 
o Customer Liability:  Use a formula and define as x-y-customer liability 

Credit Limit-Open Balance = Customer Liability 
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Filter Data, Sorting and More Options 

 

Click on Filters, to use filters to narrow down the results: 

• Select fields to filter on and define the criteria 

• Select Show in Footer to add report footers 
 
Sorting and More Options 

• Click Sorting to define how the report is sorted: 
o Add additional sorting options through the Add Fields panel 
o Sorting options are applied in the order listed 
o Use [Move Up] and [Move Down] buttons or drag and drop lines 

representing columns to determine the sort order 
 

• Click More Options to define: 
o Additional Formatting 
o Allow Web Query 
o Choose your Audience  

 

View the Report Results 
 

 

Save and view the results and pay attention to viewing and sharing options: 

• You may have navigation “bubbles” on the right-hand side 

• Filters and other settings at the bottom 
 
Success: the spreadsheet is now replicated by our custom A/R Aging Summary report: 
 

• Grouped by Customer 

• Columns showing: Open Balance, Over Due Balance, and Credit Limit 
o This information pulled directly from the customer record 

• Formula column, Customer Liability 
Credit Limit-Open Balance = Customer Liability 
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Sharing the Report Results 
 
View report results, and look at the sharing options at the bottom of the page: 

 

• Export: CSV, Microsoft Word, Excel, or PDF 

• Print 

• Email the report, once, to recipient (s) 

• Schedule a report 
o Allows for specifying a time of day, indicates whether or during peak hours 

 

Tips: Customizing Reports 
 
Review your company’s existing reporting needs 

• Identify a comparable NetSuite standard report 

• Test run a standard report 

• Use the Save As feature to create new versions of the information 

• SAVE! 
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Walkthrough: Creating a New Saved Search 
 

 

Use Case: You are helping a sales rep display a list of customers to visit on their Home 
Dashboard. 
 

Access a Saved Search and Select the Record 
 

Saved searches are available both standard and custom record types; available records 

depend upon your role’s access. 

• If you personalized the Create New bar to include Saved Search, then click on 
its link 

• Go to Lists > Search > Saved Searches > New 

• Go to Reports > Saved Searches > All Saved Searches > New  
o Choose the record type, e.g. Customer  

• The Saved Customer Search page opens 
o Enter in a Search Title, e.g. Customers to Visit  
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Saved Search Views and Locations 
 

In the Saved Customer Search page, define the availability: 

 

• Available as List View: the search may be accessed from the view filter 

• Available as Dashboard View: display the search in the list portlet 

• Available for Reminders: can be added as a custom reminder in the reminders 
portlet 

 

Define the Saved Search 
 

• Criteria subtab, Standard: What are you looking for? For example: 
o Add State/Province, any of, United Sates –Alaska, California, Hawaii, 

New Jersey 

 
 

• Results subtab: Which columns and how do you want it displayed? For example: 
o Add State/Province 
o Remove Office Phone, Fax, Alt. Email, Industry, Year Established 
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• Highlighting subtab, Highlight if: highlight critical information and build a 
legend 

o Add Filter, State/Province, any of United States – Hawaii 
▪ Define Image, Text Color, Background Color, Bold, and 

Description  
o Add Filter, State/Province, any of United States – Alaska 
o Define Image, Text Color, Background Color, Bold, and Description 

 
 

Use Joins in Results 
 

Joined fields give access to data stored in different tables; they connect, or join tables, 

by means of the values common between the tables: 

• Review available sublists on a record 

• I want to see if any messages have gone out to my customers: 
o Messages From Fields 

▪ Messages From: Date 
▪ Messages From: Subject 

 

 
 
  



 

117 

 
 

Execute the Search and View the Results 
 

Save and Run your saved search to view the results; each time you run the saved 

search, the results are refreshed with the latest records that match the criteria. 

 

• When only one result returns, you cannot navigate back to the search criteria; 
change how single record results are displayed:  

o Go to Home > Set Preferences > Analytics and check the Show List 
When Only One Result box 

 
 

Share the Search: Export or Email the Results 
 

Export, print, or email the saved search results to transfer NetSuite data to other 

applications or users; click on the options at the top: 

 

• Export - CSV icon to export results to a .csv file; e.g. prepare data for import into 
another application 

• Export - Microsoft Excel icon to export results to an .xls file; e.g. manipulate the 
data or provide in Excel format for non-NetSuite users 

• Export – PDF icon to export results as a PDF file 

• Print to local printer 

• Email to recipient  
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Publish to the Home Dashboard 
 

Go to Home Dashboard and click Personalize Dashboard: 

 

• Select Custom Search portlet 

• Define the Custom Search portlet: 
o Click Setup link 
o Select saved search 
o Click Save  
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Best Practices: Searches and Reports 
 

• Create and follow a standard title naming convention 

• Test your search before making it available 

• Save search criteria OFTEN as you are developing the search 

• Use Save and Run function to preview results 

• Use the Audit Trail (Administrators) for searches and reports to view: 
o All changes made to a saved search/report definition.  
o Latest execution and the number of times it has been executed.  

• Manage All Saved Reports and All Saved Searches with inline editing; begin at 
the Reports Overview page  
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Activity: True or False 
 

 

Now It’s Your Turn 
 

 

Time to start investigation how to extract and display business data: 

• Examine reports 

• Customize reports 

• Work with searches 

• Allow 30-40 minutes 
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Exercise 01: Identify a Pre-Built Report 
Time: 3-5 minutes 

Scenario: The purchasing manager has asked for a list of purchases by vendor. The purchasing manager 

wants to know what is being spent with each vendor to negotiate better prices. 

In this exercise: 

 Find a pre-built NetSuite report to satisfy specific requirements.  

Note: There will not be any data in the report, but you can still review its construction 

Review Existing Documentation 

 Go to the Reports > Reports Overview. 

a. Click Help link, top of the page, to view Reporting Overview topic in the Help Center. 

i. NOTE:  If Help displays in a foreign language, use the dropdown list at the-top 

right to reset your language. 

 

 Confirm you are on or navigate to Reporting Overview. 

 

 Click on the second bullet hyperlink Standard Reports. 

 Scroll down the page to Purchases and click to display available reports. 

Test Report 

 From the report descriptions, select the report that seems to include most of the criteria that 

you need to see in your report. (e.g. Purchase by Vendor Summary Report) 

 Close the Help Center. 

 Execute a test run of this report. Go to Reports > Purchases > Purchase by Vendor. 

 Review the footer options. Is Subsidiary Context an available filter? If so, which subsidiaries are 

available? 
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a. Answer:  

 Click Customize to view the columns that are included in the report. Does it include vendor and 

total columns? 

a. Answer: 

 End. 
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Exercise 02: Restrict Data included in Pre-Built Report (OneWorld) 

Time: 2-5 minutes 

Scenario: Suppose you only want to see information for a specific subsidiary. You can restrict access to 
data.  

In this example: 

 Review data associated with a single subsidiary. 

 Note: There will not be any data in the report, but you can still review its construction and 

report footers options. 

 Navigate to Home > Set Preferences > Restrict View subtab. 

a. From the Subsidiary dropdown list, choose: Germany. 

b. Click Save. 

 NetSuite may change your language. If so, do the following. 

a. Click on the tab to the right of the star 

 

b. Click on the bottom menu item 

c. In the new page, go to the second section, first field and change the language back to 

your preferred language. 

d.  Click the Save button at the top-left to save to save. 
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 Go to Reports > Purchases and run the Purchase by Vendor Report. 

 The Purchase by Vendor Summary page displays.  

a. Is Subsidiary Context an available filter? No, since we restricted our view to a specific 

subsidiary. 

Remove your restrictions to continue with the exercises. (One World only) 

 Navigate to Home > Set Preferences > Restrict View subtab.  

a. Choose Parent Company from the Subsidiary dropdown list and check include Sub-

subsidiaries. 

b. Click Save. 

 End. 
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Exercise 03: Add Data to Customer Record 

Time: 2-5 minutes 

Scenario: Chatham company tracks Industry type on the customer record, for reporting needs. In this 

exercise: 

 Add industry to domestic customer records 

 OneWorld: Add industry to German Customer 

 Navigate to Lists > Relationships > Customers. 

 Click Edit next to Customer: TEST ABC 

a. Go to the Company Profile subtab. 

b. From the Industry dropdown list, select Computer Hardware. 

c. Click Save.  

 Click Edit next to Customer: TEST German Customer 

a. Go to the Company Profile subtab. 

b. From the Industry dropdown list, select Computer Software. 

c. Click Save. 

 NetSuite may display a duplicate record warning.  Continue through that pop-up message. 

 End. 
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Exercise 04: Add Custom Field to NetSuite Standard Report 

Time: 3-5 minutes 

Scenario: The Chatham Company wants a sales report grouping customers by industry. In this exercise: 

 Modify a standard report with this information. 

 Navigate to Reports > Reports Overview. 

a. Click the plus ‘+’ sign next to Sales.   

b. Click the Sales by Customer Detail hyperlink.  

 You are looking at the Sales by Customer Detail report.  

a. Verify that the Subsidiary Context is set to Parent Company (Consolidated) 

b. Click the Customize (button at bottom of page).  

Add Custom Field to Report 

 In the Add Fields column on the left, click the plus + sign next to the Customer/Job folder. 

a. Scroll down to Industry (Custom). 

b. Click on the Industry (Customer) field.  This adds Industry (Custom) as a column on the 

right.  

c. Click on the Customer: Job 1 column (the pencil) and deselect Group. 

 

  Click the Industry column and then the Move button to move the Industry column to the left-

most position. 

 Select Group for this column, to group the results by Industry. 
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 Return to the Customer: Job column and select Group with Previous Column. 

 

 Give the report a unique name XX Customer Sales by Customer Detail by Industry. 

 Click Save.  You may need to change the Date filter, to get results.  The report displays showing 

customers grouped by Industry such as: Computer Hardware.  The Journal is listed which was 

the elimination of a purchase between subsidiaries. 

 

 End. 
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Exercise 05: Create Search to Identify Customers in Price Level 

Time: 3-5 minutes 

Scenario: One of the primary tasks of the Sales Manager is to monitor which customers are assigned to 
each price level. In this exercise: 

 Create a saved search to spot changed or added Price Levels. 

 Reminder: Save your searches as you create them so you do not accidentally lose your 

search criteria if you need to navigate to a different area of the application. 

 Navigate to Lists > Search > Saved Searches > New. 

 In the New Saved Search page, for the Search Type, click Customer. 

a. In the Search Title field, enter XXX Customers - Alt Price Level 1.  Tip: XXX enter your 

initials. 

 Go to the Criteria subtab > Standard sublist and set the following Filters: 

a. Price level = any of Alternate Price 1 (Click Set) 

b. Status = any of Customer- Closed Won (Click Set) 

c. Inactive = No (false) (Click Set) 

 Click the Results subtab; add, remove, and sort the columns to display as follows: 

a. Name 

b. Price Level 

i. Note: To remove, select the line, click the Remove button. To add, click the Add 

button, select the field you want. Custom fields are appended by (Custom) to 

identify them.  

 Click Save & Run when you are done to view the results.  

a. Hint: Click the dropdown arrow to the right of the Save button. If necessary, click Edit 

the Search to refine your search criteria. 

 Click the Home tab.  

 Find the Custom Search portlet.  

a. Click the Set Up link within the Down Arrow icon in the top right for the Custom Search 

portlet and select XXX Customers - Alt Price Level 1 from the Search dropdown list. 

b. Enter Alternate Price Level 1 Customers in the Custom Portlet Title field. 

c. In the Results Size field, enter 10. 
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d. Click Save.  Your saved search is now on the Dashboard. You can directly edit some of 

the information in this list. You can change or add values to any of the fields in columns 

with a pencil icon.  

 For future ease, go to your Home Dashboard and to the Create New dropdown. 

a. Click on Personalize. 

b. Find Saved Search and select it. 

c. Click Save.  Now you have a menu option for saved searches in Create New dropdown. 

 End 
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Exercise 06: Restrict Data included in the Search (OneWorld) 

Time: 3-5 minutes 

Scenario: You can restrict access to data. In this exercise: 

 Look for data associated with a single subsidiary. 

 Navigate to Home > Set Preferences > Restrict View subtab. 

a. From the Subsidiary dropdown list, choose: Germany. 

b. Click Save. 

 On the Home dashboard, look at the custom search portlet Alternate Price Level 1 Customers. 

a. Note that there are NO results.  Most likely we do not yet have any customers in the 

German subsidiary at Alternate Price Level 1. 

Remove your restrictions to continue with the exercises. 

 Navigate to Home > Set Preferences > Restrict View subtab. 

a. Choose Parent Company from the Subsidiary dropdown list and check mark to Include 

Sub-subsidiaries. 

b. Click Save. 

 On the Home dashboard, look at the custom search portlet Alternate Price Level 1 Customers. 

a. Note that there we now see a list of customers, since they are set up in Parent company. 

 Navigate to Home > Set Preferences > Restrict View  

a. Remove any subsidiary context, by going to a blank line.   

b. Click Save. 

 End 
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Solution for Exercise 01: Identify a Pre-Built Report 

Does the report output meet the requirements? If so, what is the name of this report? If not, repeat 
steps 4 and 5. 

Answer:  Purchase by Vendor Summary Report 

Click Customize to view the columns that are included in the report. Does it include vendor and total 

columns? 

Answer: Yes. 
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Pivot Reports: SuiteApp 
 

Pivot Reports (Beta):  
 

• Combines the power and flexibility of saved searches with more polished look of 
standard reports 

• Available for all searchable records 

• Access the drag and drop functionality of the new Pivot Report page from the 
saved search definition page 

 
This is provided as a SuiteApp; go to Customization > SuiteBundler > Search & 
Install Bundles: 

• Enter the following criteria in a Basic Search: 
▪ Keywords = Pivot Reports BETA 
▪ Click Search 
▪ Click the link for Pivot Reports BETA (Bundle ID 17447). 
▪ Click Install 

 
 

Additional Resources 
 
NetSuite Help Center: 

• SuiteAnalytics (Dashboards, Searches, & Reports) 
 

SuiteTraining: SuiteAnalytics courses 
 
SuiteAnswers Learning Center:  

• New Feature Training 

• Saved Searches/Reports 
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Design Dashboards 

 
About this Module 

 

Empower Users with individually-tailored, role-specific dashboards: 

• How do you know what the user/role needs? 

• What are some considerations for creating good dashboards? 
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Dashboards Overview 
 
Tabbed pages have related dashboards, facilitating access to critical information: 

 

• Provides a visual workspace containing real-time data and analyses relevant to 
each user’s Role 

• Chart types, as pictured below, give you the right view of your data 

 
Introduction to the Dashboard Design Process 

 

 
Identify User/Role Requirements 

 

Identify the top five tasks and metrics for every user or role, the specific needs around:  

• Data management: 
o Activities users perform, such as updating records, completing calls, or 

scheduling appointments 

• Data analysis: 
o Activities users perform to extract intelligence from information and 

measure performance 

• Data distribution: 
o Activities users perform to view data in NetSuite or another application 
o Activities users perform to share NetSuite data with other employees or 

colleagues who do not have access to NetSuite 
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Map Requirements to Dashboard 
Evaluate user needs before creating any dashboards: 

• Default dashboards are available for each Role, for example: 
o A/P or A/R Clerk 
o CFO, CEO 
o Sales Manager, Sales Person 
o Support Person 
o Warehouse Manager 

 

 
• Default dashboards are available for each tabbed page, not just the Home page 
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Identify Needed Content 
 

• Based on the user, determine which portlets to include; go to Personalize to add 
content 

 

• The Home Dashboard has defined limitations, for optimized performance, which 
may include: 

o 6 custom search portlets, 1 quick search portlet 
o 1 KPI portlet, 1 KPI scorecard portlet 
o 1 list portlet  

• To display and provide access to more information: 
o Use shortcuts, list portlets, and KPIs 
o Use dashboards on other tabbed pages 
o Create a custom tab to display an “unlimited” number of portlets 

▪ If you create a custom tab, you can display many custom search 
portlets, KPI scorecards, etc., all on one dashboard. However, each 
portlet (especially KPI and scorecard portlets) take time to load and 
could degrade performance. 

 

Home Dashboard Layout Considerations 
 
 
 
Click the Layout dropdown and select one of the three layouts. 

 
Portlet placement: 

• Place portlets with multiple columns in center of the dashboard 
o For example: Saved search lists and KPI scorecards  

• Place portlets with one column links on sides of dashboard 
o For example: The calendar, settings, reminders, and shortcuts portlets  

 
Monitor size:  

• Mobile devices: Two columns may be optimal  

• Small monitors: Two (2) columns are suggested 

• Wide monitors: Three (3) columns are suggested 
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Now It’s Your Turn 
 

 
Think about the following: 

• What are some of the roles that exist in your company?   

• What functions do you want these Roles to have?  

• What data do you want them to be able to review? Or to enter? 

• Allow 5-10 minutes 
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Exercise 01: Design a Dashboard for a Specific User (Optional) 
Time: 3-5 minutes 

Scenario: You have been asked by the Sales Manager to help them tailor their dashboard. The Sales 

Manager and you have discussed the content to be added and the layout of the portlets. 

In this exercise: 

 Plan the content of a dashboard  

 Personalize the home dashboard of the role 

Step 1: Assign Cathy Cadigan, or whichever login name at top-right of page specifies, to the new 

custom role (created in previous exercise). 

 Navigate to Lists > Employees > Employees. 

a. Confirm that the View is set to Basic. 

b. Click Edit next to your name. 

c. Click the Access subtab and confirm that CC: Sales Manager is there. 

d. If necessary- from the Role dropdown list, select the CC: Sales Manager and add it to the 

record. 

e. Click the Save button to save the record changes. 

Step 2: Change your role to the CC: Sales Manager role 

 Go to Change Role.  

 Click the CC: Sales Manager role you created in a previous exercise. 

 Go to Personalize Dashboard (in upper-right hand corner of home page). Click on it. 

 When the Personalize Dashboard portlet opens, click the following (some of these may already 

be on the dashboard): 

a. Calendar 

b. Calendar – yes, we are going to have two, each set up differently 

c. Custom Search 

d. Key Performance Indicators 

e. List 

f. My Login Audit 

g. Phone Calls 
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h. Tasks 

i. Reminders 

j. Settings 

k. Shortcuts 

l. Close the Personalize Dashboard portlet. 

Step 3: Organizing information on the Dashboard. Note: You may close the New Release portlet if it is 

displayed. 

 Drag and drop the portlets to where you want them.  

 Set up one of the Calendar portlets to view Agenda and the other to View Day.  

a. The Agenda view may not have any results, meaning that you have no agenda items 

(Events, Phone Calls, Tasks 

b. The Weekly view provides a listing of the work week. 

 Set up the portlets by clicking on the Set Up in each portlet, define the display and save:  

a. Explore the various setup parameters 

b. Make changes as you wish 

c. Save your changes 

 Setup the KPI portlet by adding the following Standard KPIs: 

a. Authorized Commission 

b. New Opportunities 

c. New Leads 

d. New Customers 

e. Click Done and then Save 

 Setup the List portlet to display customers. 

 Remove the New Release Portlet 

 Review the Layout options and select one of the layouts. 

 This could now be the dashboard prototype for your Sales Managers. 

 End. 
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Activity: Dashboards Questions 
 
After you do the exercises, answer these questions 

 

Need More Information 
 
NetSuite Help Center: 

• SuiteAnalytics: Dashboards 
 
Suite Training: SuiteAnalytics Course 
 
SuiteAnswers Learning Center:  

• New Feature Training  

• Getting Started 
 

ERP Part 2 is done, next CRM and Next Steps 

 
This is the end of the topics and exercises; the appendix follows. 
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Workbook Appendices 

 The following section is for you reference. The exercise covers common 

standard tasks that administrators perform. 

 

Revalue Open Currency Balances 
Time: 3-5 minutes 

Scenario: NetSuite automatically calculates and posts exchange rate variance amounts for 

transactions that are closed in each accounting period.  However, additional work is required 

to calculate and post variance amounts for: 

▪ Any transactions that remain open and  

▪ Balances in foreign currency accounts.  

Complete this revaluation of open currency balances for each period before it is closed as part of the 

regular month end tasks. 

 In the Administrator role, navigate to Transactions > Financial >Revalue Open Currency 

Balances, in the Classic or Administrator view. 

a. The Month End Currency Revaluation page opens. 

b. Select Germany from the Subsidiary dropdown list. 

c. Click Save. 

 The Foreign Currency Revaluation: Status page opens. 

a. Click Refresh until the Status is COMPLETE and the Percent Complete is 100% 

 Repeat these steps for each Subsidiary as required 
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ERP Part 2: Recap and Review 

 

Review Day 4: ERP Part 2 
Let’s review and recap key points from yesterday’s topics:  

• Accounts Receivable 

• Purchasing 

• Accounts Payable 

• Banking and GL 

• Reports and Searches 

• Dashboards for Users  
 

Accounts Receivables – Invoicing and Payment Process 
 

Accounts receivable tracks unpaid goods or services: 

• Initiated by the sales process when customer owes money in exchange for goods 
and services provided 

 
Invoicing process: 

• A Sales Order is Pending Billing 

• AR staff bill the sales order to create an Invoice 

• Print, fax, or email the invoice to the customer 

• The invoice reflects in the A/R aging report and on the customer record 

• The invoice remains Open until receipt of customer payment 
 
Payment process: 

• Review open Invoices 

• Accept payments from customers 
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Additional Accounts Receivables Tasks 
 
A/R staff also has access to the following:  

• Go to Transactions > Sales > Create Invoices to enter an invoice for a 
transaction with immediate and payment on terms; invoice remains open until 
paid 

• Go to Transactions > Customers > Generate Statements to generate 
statements for customers  

• Go to Transactions > Customers > Record Customer Deposits for a payment 
that cannot readily be assigned to an existing transaction or customer pays in 
advance for an order or a project 

• Use the Create Deposit button on a Sales Order 

• Go to Transactions > Customers > Issue Credit Memos to decrease the 
amount a customer owes, deduct the credit from the total amount due 

• Use Return Authorizations and Customer Refunds  

 
Purchasing 

 
Manage purchasing in NetSuite through features and preferences: 

• Use purchase requests and/or purchase orders to replenish inventory and 
supplies 

• Set up purchasing approvals, if required 

• Purchase Orders: Authorize vendors to provide items, materials or services to 
your company  

 

Purchase Requests and Approval 
 
Purchase Requests are optional; they are requests to purchase goods and services, but 

not authorization to purchase: 

• Switch roles > Employee Center – Purchases portlet > Enter Purchase 
Requests  

• Saved with a status of Pending Supervisor Approval  

• NetSuite routes the request to the appropriate Purchase Approver: 
o Setup Reminders, on the dashboard, to display the Standard Reminder – 

Purchase Requests to Approve  
 
Purchase Orders authorize vendors to provide items, materials or services to your 

company: 

• Track items that you have received and have yet to be received 

• Navigate to Transactions > Purchases/Vendors > Enter Purchase Orders  
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Receive Purchase Orders 
 
Navigate to Transactions > Purchases/Vendors > Receive Orders to fully or partially 

receive a purchase order: 

• The Receive Orders page may be filtered by Vendor 

• Review Posting Period and Date, use Filters if necessary 

• Click the Receive checkbox for Purchase Orders to be received and click 
Submit and submit to process the purchase order(s) without review the item 
receipts OR 

• Click on the Receive hyperlink to view the New Item Receipt and review before 
receiving 

 

! 

Important!  the vendor has shipped everything they can and no 
more items expected; Bill the PO for items received, then close 
the PO  

 

Accounts Payable 
 
Effectively manage payables (debts) and payment activities with your vendors: 

 

• Enter and approve bills 

• Bill purchase orders 
o Receiving an invoice from a vendor for items purchased creates a bill in 

Accounts Payable using the Bill purchase order page 

• Pay Bills 
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Default Status and Custom Approval Routing 
 

Select Accounting Preferences to effectively manage your payables; navigate to Setup 

> Accounting > Accounting Preferences: 

• > Order Management subtab, scroll down to the Vendor Bill section: 
o Set Default Vendor Bill Status to either Pending Approval or Approved 
o Standard approval routing enforces strong AP approval processes 

and is useful for companies with straightforward AP processes 

 
 

• >Approval Routing subtab to use custom, more flexible approval process: 
o Use in conjunction with SuiteFlow, Workflow Manager 
o Useful for companies with more complicated approval processes 
o Select Approval Routing for any or all the following: 

▪ Expense Reports, Purchase Orders, Vendor Bills, Invoices 
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Banking and General Ledger Tasks 
 

Work with and manage the following: 

• Memorized transactions: 
o Save time by creating a memorized transaction, setting up the transaction 

to recur over time 

• Journal Entries, both standard and inter-company: 
o Adjust balances in your ledger accounts and across companies 
o Enter manually or use the import function 

• Banking activities: 
o Write checks or “spend money” 
o Record deposits, transfer of funds 
o Import banking data and reconcile accounts 

• Accounting periods: 
o Maintain open/closed periods and accounting period window 
o Use the period close checklist to complete all required, closing tasks 

 

Reports: Point-in-Time Analysis 
 
Take advantage of standard reports, then customize if necessary: 

 

• Familiarize yourself with records and fields 

• Work the Report Builder to: 
o Edit columns 
o Filter the data 
o Sort the information 
o Set report options and audience 
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Searches – Actionable List of Results 
 

 

Saved searches provide another way to expose data and get a dynamic list of results: 

• Create saved searches for both standard and custom record types 

• Expose standard and custom fields  

• Access to records is dictated by your role 

• Make saved searches available throughout NetSuite 

• Work with criteria, results and highlighting 

• View the refreshed results each time you run the saved search  
 

Best Practices: Reports and Searches 
 

• Create and follow a standard title naming convention  

• Test your report and search before making available 

• Include search criteria in search results to confirm that results are what you need 

• Save report customization and search criteria OFTEN  

• Use Save and Run function to preview search results 
o Use the Audit Trail (Administrators) for searches and reports to view: 
o All changes made to a saved search/report definition.  

• Manage All Saved Reports and All Saved Searches with inline editing; begin at 
the Reports Overview page 
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Review Questions  
 

Answer the following questions: 

1. A _______    ___________ decreases the amount a customer owes. 
 

2. True or False: An Invoice is open until paid. 
 

3. Can I accept money from a customer, in advance of an order in the system?  
If so, how? _______________________________ 
 

4. I received a partial quantity of P.O. line item; the vendor will never ship the 
remaining quantity.  How should I handle the PO and billing the PO? 
____________________________________________ 
 

5. I need more control of purchase orders approvals. What can I do in NetSuite? 
_____________________________________________ 
 

6. How can I maintain more control over Vendor Bills and the payment of those 
bills? 
____________________________________ 
 

7. I want to save data entry time on a transaction that occurs monthly. What type of 
action can I take on a transaction? _____________________________ 
 

8. I need to start closing accounting periods. What do I do?   
____________________________ 
 

9. True or False: Reports cannot be customized 
 

10. True or False: Saved searches only expose standard NetSuite fields 
 

ERP Part 1 is done, next CRM and Next Steps 
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Sales Force Automation (SFA) 

 
About this Module 

 

Time is money! Empower your sales force with information and tools they need to close 

more deals in timely fashion. You may be wondering:  

• Which features and preferences need to be considered?  

• Is there a way to automate lead assignment?  

• Can we capture lead information, in NetSuite, through a landing page or web 
form?  
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Terminology: Stages of an Entity 
 
Lead: An unqualified potential Customer that is in the first stage of the sales cycle and 
might progress to the Prospect stage 

• Can be created manually, through an online web form or through mass import  

• Do not have any quotes/estimates, Opportunities or transactions associated 
with them 

Prospect: A qualified Lead who shows interest in your company or products 

• Do not have any sales orders, invoices, cash sales or other sales transactions 
associated with them 

Customer: An individual or company that has purchased items from you 

• Has an existing invoice or sales order 
 

Terminology: Sales Transactions 
 
Opportunity: Puts a monetary value on a deal 

• Creation of an Opportunity moves record from Lead to Prospect 
 

Estimate or Quote: Estimate or quote of the price or scope of work for items or 

services 

• When the Customer accepts, estimates are converted into sales orders, 
invoices or cash sales 

 

Sales Orders: Commitment to sell items or services to a Customer 

• Can be created from Opportunity or estimate records 

• Have no accounting impact until items are shipped or services are completed 
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Lead-to-Customer Life Cycle 

Manages the entire sales process from lead to sale and post-sales: 

• Complete customer-purchase histories enable sales reps to serve customers 
better and increase profitability 

• Create a unique Lead-to-Customer workflow for each sales team 
 
General Process: 

• Sales reps qualify Leads to determine their commitment to buy 

• A qualified lead is converted to a Prospect 

• The Prospect purchases and is converted to a Customer 
 

 
 

Status and Probability Values 

 
Use several statuses, with probabilities, per stage for accurate tracking of Lead-to-

Prospect and Prospect-to-Customer conversions: 

• Create these values to support your unique sales process 

• Use the percentages to track how likely the deal is to close 
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Lead-to-Customer Process 
 
 
This graphic represents the Administrator working with the Sales Manager to: 

• Understand how leads are generated 

• Identify required criteria for sales rules 

• Design the sales rule 

• Build the territory, assign the rule and sale rep 

• A new lead comes in and is routed to the appropriate rep to: 
o Qualify the lead, create an opportunity and save it 
o Lead converts to a prospect and the sales rep can send them an Estimate 
o Estimate is converted to a sales order and the prospect converts to a 

customer 

• Pipeline reports can include opportunities and estimate 

• Forecasts can include opportunities, estimates, and order 
 

 

 
Leads that are not qualified can be: 1) left in the system as unqualified, 2) inactivated 
through a mass update, or 3) identified as archived (change the lead status to 
“archived” or “unqualified” by customizing the Customer status list) 

• Lead Tips 

• A company attending a trade-show collects a lot of new leads. The sales 
representative working the trade show can enter leads directly into NetSuite if 
they have access or they can enter the list of new leads to an Excel 
spreadsheet and import the file later via .CSV 

• Do a data scrub before importing your leads so you only bring qualified leads 
into NetSuite 

• Note: Return an opportunity to the lead stage at any time by changing its 
status.  
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Sales Considerations 
 

What will be important to you? 

• Lead generation, routing and assignment 

• Opportunity management 

• Forecasting 

• Up-selling and cross-selling 

• Communications 

• Incentive management 

• Partner management 

• Reporting: which metrics do you need to manage your sales business? 

• OneWorld: You can choose to set a sales rule based on a subsidiary 
 

Walkthrough: Set Up Sales Force Automation 
 

 
Use Case: The Sales Manager has mapped out the sales processes and now the 

Administrator begins to configure NetSuite to accommodate these processes.  

Enable Features 
 

Setup > Company > Enable Features > CRM subtab for the CRM features that 

facilitate sales activities: 

 

• Basic Features: 
o Customer Relationship Management: Access lists of the  

companies and contacts you do business with. Create 
 tasks and keep a calendar 

o Sales Force Automation:  Set up and manage sales territories, and 
automatically prioritize and assign Leads within those territories. 
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o Marketing Automation: To facilitate multi-channel campaigns and 
tracking effectiveness. 

• Sales: 
o Opportunities:  Allow you to track sales Opportunities 

 
o Not all sales organizations will take advantage of the opportunities 

feature 
o The opportunities feature has an impact on the automated process of 

converting a Lead to a Prospect however; if your company does not 
use opportunities, you can still manually progress the Lead to a 
Prospect by changing the customer record status. 

• Marketing: 

 
o Online Forms: We want to enable this to facilitate capturing new lead 

information. 
o Mail Merge: We want to enable this to allow adding attachments to 

emails. 
 

Set Up Employees as Sale Reps 
 

Employees must be selected as Sales Reps to include them on sales order forms or 

sales territory assignments; navigate to Lists > Employees > Employees and Edit the 

employee record 
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• Navigate to Lists > Employees > Employees and Edit the employee record 

• Go to the Human Resources subtab 
o Select the Sales Rep check box 

 
• Go to the Access subtab, Roles sublist 

o Assign a Sales role 

 
• Save 

 

Set Sales Preferences 
 

How do you plan to use the Sales Force Automation feature? The defined General and 

Forecast preferences are companywide.  Navigate to Setup > Sales > Sales 

Preferences:  

• General subtab: 
o Define the various Statuses 
o Select restrictions 
o Define Quote Expiration date 
o And other settings 

 

 
• Forecasts subtab: 

o Name or labels for forecast levels 
o Define what forecast includes 
o Define when forecast runs 
o Select editing options 
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Walkthrough: Statuses, Rules and Territories 
 

 
Use Case: As new leads come into the NetSuite account, lead automation will be 

utilized to assign those new leads.  This function will be facilitated by some initial sales 

set up, including rules and territories.  Also, consider of the territory stacking and the 

round robin sales territory.  

 

Create Customer Statuses 
Go to Setup > Sales > Customer Status > New to create and use several statuses, 

with varying probabilities, for the prospect stage:  

 

• Enter a name for the Status 

• Select the appropriate Stage  

• Set the Probability; use the following as guidelines for the different stages: 
o Leads have a 0% probability 
o Prospects have 1 – 99% probabilities 
o Current Customers have 100% probability, Lost Customer set at 0% 

 
Statuses help you track Leads, Prospects, and Customers through the sales cycle 
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Create Sales Rules 
Use Case:  Sales rule to be defined by the city a customer does business in; limit to 

cities in the San Francisco Bay Area 

 

• Go to Setup > Sales > Sales Rules > New to use standard and custom fields on 
the customer (lead, prospect, or customer) record, e.g. City 

• Enter a Name and provide an optional description 

• Specify the Criteria, e.g. equal to and enter in the first City – San Francisco 

• Go down to Sub-Criteria to enter other cities such as: 
o equal to – San Mateo 
o equal to – Redwood city…etcetera 

• Review the radio buttons Match All Conditions or Match Any Condition 
o This use case needs Match Any Condition 

 

Create Sales Territories 
 

Sales territories use sales rules to distribute assign potential Customers; information in 

Lead, Prospect, or Customer’s record must match criteria of the sales rule to be 

assigned to that territory 

 

• Go to Setup > Sales > Sales Territories > New 
o Enter a Name and an optional Description 
o Select either Match All Rules or Match Any Rule 
o Configure Rule Definitions subtab, and add a value for Apply Rule 
o Lead Assignment subtab, add Sales Reps 
o Save  
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• Default Round-Robin Territory: 
o Automatically distributes Leads evenly among sales reps 
o Net Suite provides a Default Round-Robin territory: 
o Customers not matching a sales rule are unassigned; they are then 

assigned manually or distributed by the Round Robin sales territory 
o If Round Robin is your only necessary territory requirement, then you must 

edit the territory and add the sales reps 
 

Manage Sales Territories 
 

Review the sales territory stacking to further optimize sales force automation: 

 

• Go to Setup > Sales > Sales Territories and view the Manage Sales 
Territories page 

• Adjust order of territories, Move to Top or Move to Bottom or drag and drop, to 
adjust assignment 

o Default Round–Robin should probably remain last 
o Click on Default Round-Robin to Edit and add Sales Reps 

▪ Potential Customers not matching sales rules are unassigned; they 
can be assigned manually or distributed by the Round Robin sales 
territory 

▪ Automatically distributes Leads evenly among sales reps 
 

Activity: True or False 
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Walkthrough: Capture Lead Information 
 

  

Use Case:  The Company would like to have a web page or web form to allow site 

visitors to enter their own contact information.  This information needs to automatically 

populate a lead record in NetSuite.  

Create Online Customer Form 
 

Go to Setup > Marketing > Online Customer Forms > New to create a form that 

captures new lead information and creates new records: 

• Select Type: with the Marketing Automation feature enabled, you can choose 
the Default Form Template  

 
• Title: Displays at the top of the form and the Web tab 

 
• Message: Introduction to the form, use rich text editing 

• Enable Online: Makes form accessible online  

• Select Fields to add fields needed for your requirements: 
o Select the field, mark as mandatory any field that will feed into your sales 

rule, such as city 
o Label may be changed 
o Width may be changed 
o Mark mandatory any field that is important to your sales rules 
o Search for potential duplicates 
o For each selected field on the Select Fields subtab, you can check the 

boxes in the Update Customer and Update Contact columns to define 
which record type is updated when the form is submitted.  

▪ The new columns only apply to online customer forms that create 
customers as companies. The Update Contact column is not used 
for customers that are created as individuals.  
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Detail Message 
 

Go to the Detail Message subtab to enter a Detail Message to display at the bottom of 

the form: 

• Considering setting expectations for the submitter 
o Perhaps providing the customer a message such as: “Thank you for 

providing some information.  A sales rep will be in touch within two 
business days.” 

• Use rich text editing, or toggle to html 

 
Set Up Workflow 

 

On the Setup Workflow Subtab, set the following per your needs: 

 

• Preferences, for example: 
o Consider the Create Customers as Companies setting 
o Review Status and Update settings for Lead and Lead Source  
o Redirect to Form or Redirect to URL 
o Define Handle Duplicate Records and User Duplicate Detection 

Criteria  

• Customer Notification: 
o Send Auto-Reply Email: select a template to use when generating an 

automatic reply to the customer  

• Sales Rep Notification: 
o Select Send Notification Email check box; the customer’s sales rep can 

receive a notification regarding the lead 
o Select Template for New Leads and Template for Existing Customer 
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Set Up Appearance and Save the Form 
 

Go to the Set Up Appearance subtab to define the appearance of your form, 

considering your company’s branding and requirements: 

 

• Select your preference for Number of Columns Shown 

• Select a Color Theme 

• Select a Font for the displayed field names 

• Recommend leaving Unlayered Sections as checked to avoid form displaying 
with tabbed sections 

• Define the Button Alignment 

• Select a Form Logo, the image may already be residing in your file cabinet or 
can be added to your file cabinet 

 
Save the form  

• Once the form is submitted, online form submission information is available on 
the contact record (person entering the form), the marketing subtab. 

 

Publishable Form URL 
 

View a saved online form at Setup > Marketing > Online Customer Forms and test 

the form:  

 

• Go to the External subtab to view/access the following information 
o Number of Requests: number of times the form was accessed  
o Number of Submits:  number of times the form was submitted  
o Internal Form URL: use this to URL to publish the form on a tab inside 

your NetSuite account; requires user access to your NetSuite account  
o Publishable Form URL 

▪ Use this URL to access the form outside of NetSuite application  
▪ The Enable Online check box must be checked 
▪ As the administrator, you will use this URL to test the form 
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Best Practices: Setting Up SFA 
 

• Create a storyboard of your qualification process: 
o Break it down into important stages, events, decision points, and so forth 
o Draw lines between each point to show relationships and flow 

• Change standard statuses and stages to match familiar terminology 

• Decide between using individual sales reps or sales teams 
o Impact of turning on and turning off team selling 

▪ If you start with team selling and set up rules and territories, then 
move away from team selling, there are impacts to be aware of: 

• Minimal effect on rules and territories 

• If there are transactions referencing multiple people on the 
Team Selling tab, you will lose all team selling data.  
Essentially the subtab gets replaced with a single Sales 
Representative field 

• This will also affect commissions 
▪ Note: turn off team selling and then make use of the territory 

reassignment 

• Identify sales reps for territories before you build your territories 

• Track online form submissions on the Contact record, Marketing subtab 
 

Now It’s Your Turn 
 

 
 
Use Case: Configure NetSuite for Sales Force Automation  

• Enable features, define preferences, set up sales reps, define rules, and 
assign territories 

• Create an online form to capture lead information 

• Allow 35 – 45 minutes 
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Exercise 01: Enable Sales Force Automation 
Time: 1-2 minutes 

Scenario: The Chatham Company intends to implement Sales Force Automation as part of Phase 1 of its 

implementation process. In this exercise: 

 Enable Sales Force Automation (SFA) features 

 Switch back to Administrator role if necessary. 

 Navigate to Setup > Company > Enable Features. 

 The Enable Features page displays; click the CRM subtab. 

a. Ensure that the boxes for the following features are checked. 

b. In the Basic Features section: 

i. Customer Relationship Management 

ii. Sales Force Automation 

iii. Marketing Automation 

iv. Note: Marketing Automation should be enabled so you can select between the 

Default Form Template and the Custom HTML Template in a later exercise. To 

enable Marketing Automation, you must agree to the Terms of Service first. 

c. In the Sales section: 

i. Opportunities 

d. In the Marketing section: 

i. Online Forms 

ii. Mail Merge (this allows adding attachments, and other functionality, to emails) 

iii. Note: If other options are currently checked, leave them as is! 

 Click Save. 

 End. 
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Exercise 02: Set Up an Employee as Sales Representative 

Time: 1-2 minutes 

Scenario: Employees must be referenced as a Sales Rep for assignment to a sales territory. In 

this exercise: 

 Set up an employee as a sales representative Switch back to Administrator role if necessary. 

 Navigate to Lists > Employees > Employees.  

a. Ensure that the View filter, top of the page, is set to All. 

 In the Name column, locate your login or whichever login name at top-right of page specifies, 

and click the Edit link. 

a. Note: Make sure that you are using the Standard Employee form. 

b. In the Primary Information section: 

i. In the Job Title field, enter Sales Representative. 

c. Click the Human Resources subtab. 

i. Check the Sales Rep box. 

 Click Save. 

 End. 

  



 

25 
 

Exercise 03: Set Sales Preferences 
Time: 1-2 minutes 

Scenario: Administrators set default statuses for Lead, Prospect, and Customer records to define 

workflow automation when new records are added. In this exercise: 

 Set the SFA preferences for your company 

 Navigate to Setup > Sales > Sales Preferences. 

 In the General subtab, ensure that the fields are completed as follows. 

a. These fields tell NetSuite what status to use for the potential customer in each situation: 

b. Lead Status: Unqualified 

c. Prospect Status New - Qualified Prospect 

d. Prospect Status - Opportunity: In Discussion 

e. Prospect Status – Quote: Proposal 

f. Customer Status: Closed Won 

g. Standard Sales Roles: Unrestricted 

i. Note: This will allow viewing and editing any records or transactions that the 

role has permission to work with. 

h. Default Quote Expiration (in days): 30 

i. Click Save. 

 End. 
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Exercise 04: Create Customer Statuses 
Time: 1-2 minutes 

Scenario: Chatham Company’s BRD requirements outline the need for users to track customers at all 

stages of the sale. 

In this exercise: 

 Create customer statuses 

 Navigate to Setup > Sales > Customer Statuses > New.  

a. In the Status field, enter Reviewing Quote.  

b. In the Stage field, select Prospect. 

c. In the Probability field, enter 65. 

d. In the Description field, enter: 

i. The prospect is reviewing the proposed quote. 

e. Select or leave Include in Lead Reports as checked so that records with this status will 

display in lead reports. 

f. Click Save. 

g. Note: If you get the message “This record already exists", then click Go Back. 

h. Set the Stage to Prospect again, if necessary, and click Save again. Click OK in the pop-up 

window. 

Test the Customer Status 

 Navigate to Lists > Relationships > Prospects > New. 

a. In the Status field, click the dropdown arrow and select the PROSPECT-Reviewing-Quote. 

This is the customer status that you just created. 

b. Notice that the Probability value changed to 65.0%, allowing you to track the progress of 

this prospect. 

 Click the Home tab. Do not save the prospect record. 

 End. 
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Exercise 05: Create a Sales Rule 
Time: 1-2 minutes 

Scenario: Rules and territories can automate lead assignment.  Rules can be defined on standard and 

custom fields.  

When a new lead is added, the lead is evaluated against a sales rule and territory.  The lead is then 

routed to the appropriate sales rep. 

In this exercise: 

 Create a sales rule based on the State field 

 Navigate to Setup > Sales > Sales Rules > New.  

 On the Select a Customer Rule Field page: 

a. Scroll down and click the State link. The new rule will apply to this field. 

b. In the Name field, enter Eastern Sales Region Rule. 

c. In the Description field, enter Eastern Sales Region. 

d. Notice that this sales rule is based on the State field. 

e. In the Criteria field, select any of. 

f. From the list of states, select 

i. Connecticut 

ii. Massachusetts 

iii. New Jersey, 

iv. New York 

v. Once selected, these four values will be listed in the Current Selections pane on 

the right side of the window. 

vi. Note: Because this is a OneWorld account, states from a variety of countries are 

listed in the Choose State window. 

 Click Done  

 Click Save. 

 End. 
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Exercise 06: Create a Sales Territory 
Time: 1-2 minutes 

Scenario: The territory is defined by a sales rule (s) and assigned sales reps. In this exercise: 

 Create a territory with a selected rule and sales rep 

 Navigate to Setup > Sales > Sales Territories > New.  

a. In the Name field, enter Eastern Sales Team. 

b. Leave Match all Rules selected. 

c. From the Configure Rule Definitions subtab, choose the Eastern Sales Region Rule from 

the Apply Rule drop-down and click Add. 

d. Click the Lead Assignment subtab. Select Amy Nguyen from the Sales Rep dropdown list 

so all leads that match this rule will be assigned to her. 

i. Don’t forget to click Add. 

1. Note: Additional sales reps can be added to a territory. If more than one 

sales rep is assigned to a territory, NetSuite will round-robin the lead 

assignment between the sales reps on this subtab! 

 Click Save. 

 End. 
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Exercise 07: Create an Online Form 
Time: 5-10 minutes 

Scenario: Chatham wants to use an online form to gather new leads  

In this exercise 

 Create an online lead generation form  

 Test it by adding a new lead through the external form 

 Verify that the sales rules and territories assigned the correct sales rep to the new lead 

 Navigate to Setup > Marketing > Online Customer Forms > New. 

 Select Type Default Form Template. 

a. In the Title field, enter Welcome to Chatham Company. 

b. In the Message field, enter some text and format as desired. 

c. Ensure that the Enable Online box is checked. 

Select the Fields for the Online Form 

 Go to the Select Fields subtab. 

a. Note: Subsidiary field is used to search for duplicate records in OneWorld accounts, it 

has been added automatically.  

b. To prevent a field being displayed on a form, mark Hide as Yes. 

 From the Field dropdown list, add the following fields: 

a. First Name (check the mandatory column) 

b. Last Name (check the mandatory column) 

c. Email  

d. Company Name (check the mandatory column) 

e. Phone Number 

f. Address line 1 (Re-name to: “Street Address” using the Label field) 

g. City 

h. State (check the mandatory column for proper territory routing 

i. Zip/Postal Code 

j. Increase the Width of the Company Name and Street Address fields to 50. 
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Enter a Message to display on the Form 

 Click the Detail Message subtab and enter some text and format as desired.  The Detail Message 

will display at the bottom of the form; below the fields, and the Submit and Reset buttons. 

Set Up the New Lead Workflow 

 Set Up Workflow subtab to control how NetSuite will handle the incoming leads. 

a. Ensure that the Create Customers as Companies box is checked.  

b. From the Set Lead Status field, ensure that Lead-Unqualified is selected as the default 

and uncheck the allow update box. 

c. From the Set Lead Source dropdown list, select Web and uncheck the Allow Update on 

Customer Record and Allow Update on Contact Record boxes. 

d. In the Redirect to URL field, leave the default website address or change it to a website 

of your choice but be sure to preface the address with http://www. 

i. Note: When the lead form is submitted, NetSuite will automatically take the 

user to this website. Commonly, this field defaults to your NetSuite e-commerce 

website. 

e. Leave Handle duplicate records with default value and check Use Duplicate Detection 

Criteria 

f. Scroll down to the Sales Rep Notification and check the Send Notification Email box to 

notify sales reps when new leads derived from this online form are added to NetSuite 

i. Select Template for New Leads – Standard Notification for New Leads  

ii. Select Template for Existing Customers – Standard Notification for Existing 

Customers 

iii. Please note that if you see forms with 2.0 as part of the names relate to 

scriptable templates, which is not part of this course.  Scriptable templates 

provide more functionality and customization. 

Set Up the Appearance of the Online Form 

 Click the Set Up Appearance subtab and select the following: 

a. Number of Columns Shown: 2 

b. Color Theme: Your choice 

c. Font: Verdana (This field controls the font to use for field names, where formatting the 

font wasn’t an option.) 

d. Unlayered Sections: Checked 
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e. Button Alignment: Center 

f. Note: Use the Form Logo field to add a company logo if an image is available. 

i. Please refer to SuiteAnswers or Help Center for more information. 

 Save 

View the Online Form 

 Click the External subtab. 

a. Or, if you were navigated way from the form then go to Setup > Marketing > Online 

Customer Forms. 

i. Click the Edit to view your online form and click the External subtab. 

b.  Click the Publishable Form URL link. 

 The Website Leads Online Form displays in a new window. This is how customers will view the 

form. 

a. Note: If it does not display, you may have a browser pop-up blocker. 

Test the Online Form 

 Enter a new lead through the online form. Be creative, but don’t forget the customer’s name!  

a. Set the state to New York for your new lead. 

b. Click Submit when you have completed the form. Once the form is submitted, you will 

be re-directed to the URL specified in setup! You can close that browser tab. 

 In NetSuite, use (Global) Search to find the Company you just entered. 

 Locate the Lead Record.  

a. A Contact should have been added to the Lead record, if you entered information in the 

first and last name fields. 

b. Click the View link for the lead record. Confirm that the lead information entered from 

the online form has populated all the correct fields. 

c. If you selected New York as the state on the form, the assigned Sales Rep should be Amy 

Nguyen, based on the sales rules and territories. 

 End. 
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Activity: Sales Force Automation 
 
After you do the exercises, answer these questions 

 

Additional Resources 
 

NetSuite Help Center: 

• Sales Concepts and Setup Guide: User Guide 
 
SuiteAnswers Learning Center:  

• New Feature Training 

• Sales Force Automation 

• Implementing Sales Forecasting in NetSuite 
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Lead-to-Customer Management 

 

About this Module 
 

With Sales Force Automation (SFA) enabled, and set up, how can it help sales to:  

• Better serve customers 

• Manage leads through the sales process  

• Drive higher close rates 
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Lead-To-Prospect  
 
Creation of an opportunity and associating it with a Lead record converts the Lead to a 

Prospect 

• The CRM feature, Opportunities, must be enabled 
o If not using the Opportunities feature, you can manually convert Leads to 

Prospects  

• An opportunity details the sales representatives’ negotiations with prospects 
o Multiple opportunities can be created for a single lead/prospect  

• Opportunities are ‘internal documents’, whereas Estimates are ‘external 
documents’ presented to customers 
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Prospect 
 

Use Opportunities and Quotes with the Prospect record: 

• An Estimate/Quote defines the proposed services or products for purchase 
before a sale order is generated and is a customer-facing document 

• Estimate/Quotes can be associated with a Prospect record 
o The Estimate/Quote record is a modified version of the details entered into 

the opportunity record, however an Estimate/Quote record can be 
independently created from the Opportunity record 

o Multiple versions of an Estimate/Quote can be created, as customers 
typically request modifications after their initial review 

o Set an expiration date for the Estimate/Quote and NetSuite will remind you 
to follow up on the estimate shortly before it expires 

• An Estimate/Quote has no accounting impact until it is converted to a Sales 
Order / Cash Sale / Invoice 

• You can print, email or fax an Estimate/Quote to your customer 
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Prospect-To-Customer Conversion 
 

When a sales order is created, Prospects automatically convert to a Customer record: 

• Accepted quotes are converted to a cash sale, invoice, or sales order 
o A sales order is the commitment to purchase specific goods and/or 

services 
Note: If a Prospect is associated with an opportunity record and the opportunity is 
later closed as ‘won’, the Prospect record is automatically converted into a 
Customer record 
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Lead-to-Customer Management 
 
Follow the Lead-to-Customer management process: 
 

• Leads come into the system and either get qualified or marked dead 
o On online form is submitted 
o An unqualified lead record is created in NetSuite  
o Sales is notified to follow-up with the lead 

• A lead transforms to a prospect with a saved Opportunity 

• Sales negotiates with the prospect on quotes, reviews of quotes and 
eventually placing an order 

o Negotiations are happening 
o CRM activities may include phone calls, meetings or tasks 
o Sales can convert the opportunity to the Quote/Estimate record (several 

quotes may be created) 

• The Sales Order is created, the prospect is transformed to a customer 
o The Quote/Estimate record is converted to a Sale Order record  
o The Prospect automatically converts to a Customer 

 

Key Sales Tools – Refer to SuiteAnswers 
 
Quick View on Key Records available in all accounts: 

• QuickViews are now customizable, based on actions by the administrator: 

• Especially useful to review lead, prospect and customer records 
 
Last Sales Activity 

• A last Sales Activity field is added to all lead, prospect, customer, contact and 
opportunity records 

• Tracks last date a sales activity was performed 

• Can be designed as a Dashboard reminder and is configurable  
 
Replying and Forwarding Email from Records and Transactions: 

• Useful when communicating with your lead, prospect and customer 

• When you view an existing email message, there are three new buttons at the 
top of the message record: Reply, Reply to All, and Forward 

 

The Enhanced Sales Center SuiteApp  
• Provides user interface enhancements to the standard NetSuite Sales Center. 
• The new Sales Center is designed to make information that is relevant to sales 

users easily available to them through better organized tabs, forms, links, and 
dashboards. 
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Walkthrough: Lead-to-Qualified Lead 

 

Use Case: Sale Force Automation has been set up.  You start investigating the use of 

the lead record and how it transforms in NetSuite.  

View a Lead Record 
 

Drill into the lead record from the lists of leads: 

 

• Go to Lists > Relationships > Leads and View a lead record 

• Review the record noting the: 
o Sales rep assignment 
o Contact information 
o Other relevant information. 
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Enter a New Lead  
 

Navigate to Lists > Relationships > Leads > New to access the New Lead form; enter 

a lead directly into the system: 

 

• Enter in the Primary Information and Classification section fields: 
o Note that the Type defaults to the setting from Setup > Company > 

General Preferences > Default Lead Type: 
▪ The user can change it manually, for example change it from 

Company to Individual 
▪ Type Individual tracks the customer record by the person’s name 

 

Qualify a Lead  
A Lead’s status can be manually changed: 

 

• Edit a Lead record 

• In the Primary Information section > Status field, use the dropdown to set the 
new status: 

o Status changes should be determined by your sales qualification process 
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Lead Conversion Overview 
 
Commonly used in business-to-business; companies with more than one contact: 

• Facilitates better management of the lead process, in the case when the lead is 
Type Individual with future requirements for additional contacts 

• Lead record is converted into two records: 
o A prospect record tracking information on the company who eventually 

becomes a customer 
o A contact record tracking information on the individual 

 
Use Case:  Your Sales Rep is working with Joe Smith as an individual, who owns Smith 

Securities.  Initially, your sales rep does not anticipate needing other contacts. However, 

that scenario changes when the sales rep discovers how big Smith Securities is. How 

can this be accommodated? 

• New Lead, Type Individual, Customer Name = Joe Smith, Company Name = 
Smith Securities 

• Enable Lead Conversion 

• Lead transform to Type Company, Customer Name = Smith Securities, 
Primary Contact = Joe Smith: 

o Now you can add additional contacts 
 

Walkthrough: Lead Conversion 
 

 
Use Case: The Company may be working with both individuals and companies that 
represent potential customers.  Being able to convert a potential customer, initially 
represented as an individual, and converting them to a company with a contact will be 
important.  
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Enable Lead Conversion 
 

The Lead Conversion feature may be enabled to allow converting from an Individual 
type of customer record, to Company type: 

 

• Go to Setup > Company > Enable Features > CRM subtab > Sales section 

• This feature allows the conversion of leads into prospects, customers, with 
contacts, opportunities and tasks. 

 

Revisit Sales Preferences 
 

A new preference is available, with the Lead Conversion feature enabled: 

 

• Go to Setup > Sales > Sales Preferences  

• Consider “Starts With” Matched in Lead Conversion  
o If checked, then NetSuite checks contacts and lead, prospect, or customer 

records to be considered possible duplicates upon lead conversion 
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View, Save and Convert the Lead 
 

Go to Lists > Relationships > Leads and View the lead record: 

 

• Click the Convert button to view the Convert Lead page: 
o Review Primary Information, Email | Phone | Address and 

Classification 
o Go to Create Prospect and assign a Sales Rep 
o Go to Create Contact, confirm the name and select the Role, e.g. 

Primary Contact 
o Continue to Create Opportunity – Optional  

▪ Check Create Opportunity and complete required fields  
o Continue to Create Task – Optional: 

▪ Check Create Task and complete required fields 

 
o Click Submit 
o The lead record is converted into two records:  

 
▪ A prospect record, type company  
▪ A contact record tracking information on the individual  
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Walkthrough: Opportunity to Quote Process 
 

 
 
Use Case:  Let’s now look at working with transactions that may be part of the sales 
process.  
 

Create an Opportunity 
 

This is an internal document; the customer does not see it. Creating an opportunity from 

the lead record will populate all the pertinent information: 

• In a customer (lead, prospect or customer) record, View or Edit mode 

• Go to the Sales subtab and click on the New Opportunity button 

 
• Review information populated from the Lead record, add and update if 

necessary: 
o Go to the Items subtab, Items sublist to add items 
o Review other subtabs, adding information as necessary 

• Click Save, the Opportunity status is In Progress 

 
• This opportunity is now part of the entity’s record, Sales subtab 
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Manage the Opportunity 
 

The Opportunity Status may be manually changed to reflect how likely you are to 

continue through the sales process: 

 

• Edit the opportunity 

• In Primary Information go to the Status field and select from the dropdown list: 
o These statuses have been defined under Setup > Sales > Customer 

Statuses 
o Each status is related to a stage of the customer record, e.g. lead | 

prospect | customer 
o Describes the progression through the sales cycle 

 

Generate a Quote 
 

Use the Opportunity as the basis for the quote: 

• Populate the quote from the opportunity and edit if necessary 

• View the opportunity 

• Go to the Sales subtab, click Quotes sublist and click New Quote: 

 
o Review the populated information; add and update if necessary 

 
o Add, remove, edit items 
o Review other subtabs, adding information as necessary 
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• Click Save, the Quote is saved with a status of Open: 
o We have a link back to the Opportunity, which now has a status of Issued 

Quote 

 
• This opportunity is now part of the entity’s record, Sales subtab, Transactions 

sublist 

 
 

Walkthrough: Quote-to-Sales Order Process 
 

 
Use Case:  Once negotiations have been finalized, move on to the customer’s 
commitment to purchase.  
 

Review the Quote and Convert to a Sales Order 
 

Use the Quote as the basis for an order: 

• Populate the order from the quote and edit if necessary 

• View the Quote 

• Review the information: 
o If necessary Edit the quote, to add and update, then Save  

• Click the Sales Order, Cash Sale, or Invoice button: 
o The corresponding sales transaction opens and may be edited. 
o Save the transaction 
o We have a link back to the following: 

▪ The Customer with a status of Closed – Won 
▪ The Quote with a status of Processed 

• This Sales Transaction is now part of the entity’s record, Sales subtab, 
Transactions sublist 
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Best Practices and Considerations 
 
Lead-to-Customer: 

• Track contacts, activities (including tasks, events, and phone calls), and 
messages on the Lead record 

• Mark leads as qualified when they show interest in purchasing your 
company’s goods or services 

• Identify leads as Dead-Leads when they do not have any interest in 
purchasing your company’s goods or services 

 
OneWorld Considerations - Do you share customers globally? 

• Review the Multi Subsidiary Customer feature 

• Customers are separate entities and separate accounts 

• To see a global view across subsidiaries, create parent/child relationships 
between customer records 

 

Standard Pipeline and Forecast Reports 
 
Pipeline reports help monitor the health of your sales pipeline: 

• Identify the projected and weighted totals of open opportunities and estimates 
for each sales rep, with expected close dates, and totaled by customer  

• Open Deals > X% that you want to track 

• Reports > Pipeline Analysis 
 
Forecast reports gauge how well the sales reps are doing: 

• Identify each sales rep's forecast and quota for a defined period, view each 
sales rep's calculated and override forecasts for a defined period, and 
Determine how close each sales team’s saved forecast is to actual amount of 
sales for a period  

• Forecast = Open Deals + Closed Deals - Forecast = (Opportunities + 
Proposals) + (Sales Orders + Invoices)  

• Reports > Forecast 
 

Now It’s Your Turn 
 

 
 

Use Case: Check the customer status and answer these questions: 

• Locate your lead and work with your lead  

• Allow 10-15 minutes  
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Exercise 01: Work a Lead 
Time: 3-5 minutes 

Scenario: Sales reps need to effectively work their leads. We look at editing lead records, as well as 

converting leads. 

In this exercise: 

 Edit the lead you created through the online lead form and change the lead status and add 

an opportunity. 

 Enable Lead Conversion and enter a new lead 

Locate the Lead (without Lead Conversion enabled) 

 Navigate to Lists > Relationships > Leads, the Leads list page displays. 

a. Locate the New York Lead that you just entered. (Create and Online Form Exercise) 

b. Verify that it was assigned to the correct sales rep based on the rules and territories that 

set up in the previous module. 

Change the Lead Status 

 Click Edit to update the lead record.  

a. In the Status field, change the status to LEAD-Qualified Lead.  

b. In the Sales Rep field, verify that a Sale Rep has been chosen. 

c. Click the Address subtab, scroll down the page to verify that you have the correct 

address information (State of New York). 

d. Click the Company Profile subtab and select an Industry. 

e. Click Save. 

Add an Opportunity 

 If you are no longer on the lead, find the record under Recent Records, click the record name, 

and then click the Sales subtab 

 From the Sales subtab, go to the Opportunities sublist and click New Opportunity. 

 The Opportunity page opens. 

a. In the Title field, enter TEST Opportunity. 

b. Select a Warehouse in the U.S. 

 From the Items subtab, click the Add Multiple button and add the following items: 
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a. (Quantity) 1   HP LJ 1320 Printer  

b. (Quantity) 1   Service for the HP LJ 1320 

c. Click Done and then click Save to save your changes. 

d. Notice the Opportunity has a status of IN PROGRESS 

Create a Lead (with lead conversion enabled) 

 Setup > Company > Enable Features > CRM subtab 

a. Under the Sales section, check Lead Conversion. 

b. Click Save. 

 Navigate to Lists > Relationships > Leads > New, the Leads entry form displays. 

 Use the Standard Customer Form and enter the following information: 

a. Type: Select Individual 

b. First Name: Betty 

c. Last Name: Smyth 

d. Company Name: TEST DEF 

e. Primary Subsidiary: Parent Company 

 Click the Company Profile subtab and select an Industry. 

 Click Save. 

Change the Lead Status and Convert the Lead to a Prospect 

 Click Edit to update the lead record.  

a. In the Status field, change the status to LEAD-Qualified Lead.  

b. Click Save & Convert.  

i. Note: If prompted select the radio button to Create Prospect TEST DEF. 

 In Create Prospect: TEST DEF choose Amy Nguyen from the Sales Rep dropdown list. 

 In Create Contact: Betty Smyth choose Primary Contact from the Role dropdown. 

 Under Create Opportunity – Optional, check Create Opportunity.  

a. Enter Test Lead Conversion in the Title field. 

b. Enter 1000 in Projected total field. 
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 Under Create Task – Optional, check Create Task.  

a. Enter Title: Call Betty/TEST DEF initial call. 

b. Start Date is today, Due date is one week from today. 

c. Change Priority to High. 

 Click Submit and view the Prospect record. 

a. TEST DEF is now the customer of Type Company and Betty is the contact. 

 End. 
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Exercise 02: Generate a Quote from an Opportunity 
Time: 1-2 minutes 

Scenario: In this exercise: 

 Convert the opportunity to a quote; populating the information from the opportunity into 

the quote. 

 Navigate to Transactions > Sales > Create Opportunities > List.  

a. Click View for the TEST Lead Conversion. 

 The opportunity displays and the Status should be In Discussion. 

a. Under the Sales subtab, go to the Quotes sublist and click New Quote to verify that the 

status is Proposal with a probability of 50%. 

 A Quote form displays: 

a. In the Classification section, enter a Warehouse 

b. Go to the Items sublist, select HP LJ 1320 Printer from the item dropdown list. 

c. Enter Qty 10 of HP LJ 1320 Printer. 

d. Click Add. 

e. Click Save. 

f. The quote is saved and is an open status. 

 End. 
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Exercise 03: Generate a Sales Order from a Quote 
Time: 1-2 minutes 

Scenario: In this exercise: 

 Convert the estimate/quote into a sales order; populating the information from the quote 

into the sales order. 

 Navigate to Transactions > Sales > Prepare Quotes > List.  

 Locate the Quote you just created and click the View link next to it. 

a. Click the Sales Order button.  

b. Change the Custom Form to Standard Sales Order, if necessary. 

i. Note that in the Sales Information section the Create From references our 

Quote. Review all the information, including the line item. 

c. Click Save. 

 Navigate to Lists > Relationships > Prospects: 

a. Is the Prospect in this list? 

b. Answer: 

 Navigate to Lists > Relationships > Customers: 

a. Is our Prospect in this list?  

b. Answer:  

c. Why? What caused it to convert to a customer? 

d. Answer: 

 End. 
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Solution for Exercise 03: Generate a Sales Order from a Quote 

 
Navigate to Lists > Relationships > Prospects. 

Is the Prospect in this list? 

Answer: No. 

 

Navigate to Lists > Relationships > Customer. 

Is our Prospect in this list?  

Answer: Yes 

Why? What caused it to convert to a customer? 

Answer: Creation of a Sales Order. 
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Activity: Lead-to-Customer Management 
 

After completing the exercises, answer these questions 

 

 

Need More Information 
 
NetSuite Help Center: 

• Sales Concepts and Setup Guide: User Guide 
 
SuiteAnswers Learning Center:  

• New Feature Training 

• Sales Force Automation 

• Implementing Sales Forecasting in NetSuite 
 
View the following video, from the NetSuite Essentials tab in the demo account:  

• Lead to Customer Management 
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Customer Support and Case Management 
 

About this Module 
 

Providing excellent customer service and increasing customer satisfaction is critical to 

the success of your business. You may be wondering: 

• How do we create and manage cases? 

• As with lead assignment, can we have automated case assignment? 

• Are there other considerations?  
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Customer Service and Support Overview 
 
Overview: 
Handle issues quickly and improve customer relationships: 

 

• Set up required values for rules and territories, support preferences, and define 
support reps and support groups  

• Case values include:  Origin, Type, Status, and Priority 

• Define Rules and Territories that facilitate case Automated Assignment 
o Alternatively, work with manual case assignment 

• Consider Escalation routing to get support help from another rep or support 
group 

• Work and Close cases  
 

Implementation Considerations 
 

Customer support overview and support channels: 

• How do you currently track and resolve support cases? 

• Do you need to create an online Case form? 

• How do your customers communicate support issues to you and how do you 
communicate with customers when you update a case? 

• Do you need a support email alias, such as support@companyx.com  
 

Support teams:  

• Do you assign to teams or individuals & can they view each other’s cases? 
 

OneWorld: 

• How do you handle support procedures across subsidiaries? 

• Are there differences depending upon the subsidiary, such as: using logos or the 
wordings and policies among the different subsidiaries?  
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Additional Options: OneWorld 
 

Options are available for managing customer support in OneWorld: 

• Enter main support “From” email addresses for each subsidiary 

• Maintain notification templates for each subsidiary 

• Use different inbound email addresses for each subsidiary with the Email Case 
Capture feature 

• Configure and brand online case forms 

• Track cases by subsidiary 

• Restrict support rep visibility to cases based on subsidiary 
 

Activity: Your Support and Service Considerations 
 
Which areas will you be using? Comment and concerns? 

 

Walkthrough: Initial Setup 
 

 
Use Case: This Company has decided to use NetSuite for customer support and 
services.  Time to start configuring and doing initial set up tasks.  
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Enable Features 
Navigate to Setup > Company > Enable Features to define the CRM and Employee 

features to facilitate support: 

• > CRM subtab > Basic and Support sections: 

 
o Customer Support and Service: route cases  

 
o Email Case Capture: case creation from received emails  
o Automated Case Escalation: work with escalation rules, for automatic 

escalation of cases  
o Consider Issue Management and Help Desk – see the Help Topics 

• > Employees subtab > Time & Expenses section: 

 
o Time Tracking to track employee time using singe day time records. 
o Time Tracking for CRM: track and bill time associated with cases, tasks, 

and events directly from these records  
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Define Support Reps 
 

Employees must be selected as Support Reps to assign them in case records: 

• Navigate to Lists > Employees > Employees and Edit the employee record 

• Go to the Human Resources subtab 

 
o Select the Support Rep check box 

• Go to the Access subtab, Roles sublist 
o Assign a Support role 

 
• Save 

• Displays in the Support Rep or Assigned To fields on Case records, support 
Territories and Escalation assignments 

 
• Are included on customer support reports and report snapshots 

 

Set Up Support Groups 
You may also use support groups to facilitate the resolution of cases: 

• Go to Lists > Relationships > Groups > New 

 
• Select the kind of group to create, e.g. Static 

• Select the Members, e.g. Employee 
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• Click Continue 

 
o Enter the Name, Owner, and other general information as necessary 
o Check the Support Group box to make this group available for 

assignment on a support case 
o Add in the Group Members on the Members subtab 

• Save the group; this group can now be assigned to cases and the group 
calendar is available on activities 

 
 

Walkthrough: Set Up Support Values 
 

 
Use Case: Similar to sales force automation, the administrator can set up values that 
help tracking and can be used with case rules.  
 

Create Case Statuses 
 

Navigate to Setup > Support > Cases Statuses > New; case status indicates phase of 

Case resolution: 

 

• Enter a name for the Case Status 

• Define its location in a dropdown list with Insert Before 
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• Select the appropriate Stage  

• A case status can be indicated as “On Hold” to stop the clock 
o A key support metric is turnaround time; there are situations where you do 

need to stop the clock.  
▪ For example, waiting on a customer to take some sort of action and 

report back to you. 

• Enter an optional Description 

• Check “Show Awaiting Support Reply” to track cases needing a reply; display 
in reports and saved searches 

• Save 
 

Case Priorities, Types and Origins 
 

Go to Setup > Support > Case Priorities > New; priorities determine order of 

resolution 

 

• Enter a name for the Case Priority, select Insert Before, enter optional 
Description 

 
Go to Setup > Support > Case Types > New; case types identify what the customer 

might be reporting to you: 

 

• Enter a name for the Case Type, select Insert Before, enter optional Description 
 
Go to Setup > Support > Case Origins Types > New; case origin  type indicates how 

the case came to you 

 

• Enter a name for the Case Origin, select Insert Before, enter optional 
Description 
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Walkthrough: Rules and Territories 
 

 
Use Case:  To facilitate automated case assignment and automated case escalation, 
define rules, assign to territories.  
 

Create Case Rules 
 

Create Case Rules before creating Case Territories; rules can be grouped on territories: 

Use Case: Case rule to be defined by the priority 

• Go to Setup >Support > Case Rules > New to use standard and custom Case 
and Customer fields; e.g. Case field - Priority 

• Enter a Name and provide an optional description 

• Specify the Criteria, e.g. any of  

• Select values for Priority, e.g. Urgent Red and High  

• Save 
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Define Case Territories 
 

• Automatically assign cases to support reps or support groups: 

• Configure Rule Definitions and Support Assignments 

• Go to Setup > Support > Case Territories > New 

 
o Enter a Name and an optional Description 
o Select either Match All Rules or Match Any Rule 
o Configure Rule Definitions subtab, and add a value for Apply Rule 
o Support Assignment subtab, add Support Reps / Support Groups 
o Save  

• Default Round-Robin Territory: 
o Automatically distributes Leads evenly among sales reps 

 

Manage Case Territories 
 

Review the support territory stacking to further optimize customer support and service 

functionality: 

• Go to Setup >Support > Case Territories and view the Manage Case 
Territories page 

 
• Adjust order of territories, Move to Top or Move to Bottom or drag and drop, to 

adjust assignment 
o Default Round–Robin should probably remain last 
o Click on Default Round-Robin to Edit and add Support Reps 

▪ Cases not matching case rules are unassigned; they can be 
assigned manually or distributed by the Round Robin sales 
territory. 

▪ Automatically distributes cases evenly among support reps 
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Create Case Escalation Rules 
 

To use the following functionality, the Automated Case Escalation feature must be 

enabled at Setup > Company > Enable Features > CRM subtab > Support section. 

Escalation Rules can be applied to cases and then assigned to an escalation territory: 

Use Case: Escalate cases coming in during non-work hours, weekend. Capture any 

case that has been in the queue for 8 hours or 480 minutes. 

• Go to Setup > Support > Escalation Rules > New; use case and customer 
records, standard and custom fields, e.g. Duration since Case Creation (minutes) 

o Enter the Name, optional Description 
o Select Criteria, e.g. greater than or equal to  
o Enter Duration Since Case Creation (Minutes) as 480 
o Save 

 

Manage Escalation Assignments 
 

Automatically escalate cases to support reps or support groups: 

• Configure Rule Definitions and Support Assignments 

• Go to Setup > Support > Manage Escalation Assignments > New 

 
 

o Enter a Name and an optional Description 
o Configure Rule Definitions subtab, and add a value for Apply Rule – 

e.g. Off Hours Cases, Duration since Case Creation (minutes)  
o Escalation Assignment subtab, add Support Reps 
o Save  
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Walkthrough: Online Form and Preferences 
 

 
Use Case:  Give your customers the option to enter their own support needs, using a 
form.  Consider the support preferences and set up accordingly.  
 

Create and Publish an Online Case Form 
 

Go to Setup > Support > Online Case Forms > New to create a form that captures 

new case information and creates case records: 

 

• Select Type: Default Form Template  

• Title: Displays at the top of the form and the Web tab 

• Message: Introduction to the form, use rich text editing 

• Enable Online: Makes form accessible online  

• Select Fields to add fields needed for your requirements: 
o Also, define the behavior for each field 
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Setup Workflow 
 

On the Setup Workflow Subtab, set the following per your needs: 

 

• Preferences, for example: 
o Consider the Create Customers as Companies setting 
o Default Subsidiary 
o Default Case Profile: determines from name and email address, and 

templates for notifications  
o Set Case Origin 
o Redirect to URL 
o Define Handle Duplicate Records and User Duplicate Detection 

Criteria 

• Customer Notification: 
o Send Auto-Reply Email: select a template to use when generating an 

automatic reply to the customer  

• Additional Notification: 
o Notification Template and Email Address of Recipients  
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Publish Form URL 
 

View a saved online form at Setup > Support > Online Case Forms: 

 
• Go to the External subtab to view/access the following information 

o Number of Requests: number of times the form was accessed  
o Number of Submits:  number of times the form was submitted  
o Internal Form URL: use this to URL to publish the form on a tab inside 

your NetSuite account; requires user access to your NetSuite account  
o Publishable Form URL 

▪ Use this URL to access the form outside of NetSuite application  
▪ The Enable Online check box must be checked 
▪ As the administrator, you will use this URL to test the form 

 

Set Support Preferences 
 

Go to Setup > Support > Support Preferences and set default support preferences 

workflow, notifications, and ordering on various subtabs: 

 
• General: Case Email Setup, Preferences, Defaults, Case Lockout 

o Under Case Email Setup, check Default Case form to Internal Only as 
a best practice. You may need to uncheck Default Case form to Customer, 
Save your changes, and then go back in to select Default Case form to 
Internal Only 

• Notification: Creation, Inbound Email Case Capture, Assignment, Update, 
Escalation, Closure 

• External: External Case Form Redirect URL, Default Customer Case Form, 
Create New Lead on No Match 

• Inbound Email: Inbound Email 

• Ordering: Case Statuses, Case Priorities, Case Types, Case Origins, Case 
Issues 

 

Please refer to Help and SuiteAnswers for detailed information on all the above 
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Introduction: Support Case Profiles 
 

 
Use Case:  Further tailor your usage of support cases 
 

Support Case Profiles 
 

Create case profiles that enable you to apply different configurations to sets of support 

cases: 

• Provides better control over the branding of your support communication 

• Case profiles include the following settings: 

• Support From name and email address 

• Anonymous customers for inbound email and online forms 

• Customer and employee case notification templates 

• To create new case profiles, go to Setup > Support > Case Management > 
Case Profiles > New 

 
• Case Profile is a required field on the case form 

 
• OneWorld accounts can set up case profiles by subsidiary 

 

Please refer to Help and SuiteAnswers for detailed information 
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Now It’s Your Turn 
 

 
 

Use Case: Investigate the customer service and support set up tasks.  

• Allow 20 – 30 minutes  
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Exercise 01: Enable Customer Service and Support Features 
Time: 1-2 minutes 

Scenario: Chatham company has decided to work with Customer Support and Service in NetSuite. 

In this exercise: 

 Enable Customer Service and Support 

 Navigate to: Setup > Company > Enable Features and click the CRM subtab. 

a. In the Basic Features section, the following should be checked: 

i. Customer Relationship Management 

ii. Customer Support and Service 

b. In the Support section the following should be checked: 

i. Email Case Capture 

ii. Automated Case Escalation 

iii. Deselect Issue Management if checked. 

c. Click Save. 

 End. 
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Exercise 02: Set Up an Employee as a Support Representative 
Time: 1-2 minutes 

Scenario: In this exercise: 

 Setup a current employee as a Support Representative 

 Navigate to Lists > Employees > Employees.  

 Locate Amy Nguyen and click the Edit link next to the left of record name.  

a. Verify that you are on the Standard Employee Form. 

b. In the Email | Phone | Address section, enter the Email address: 

anguyen@chatham.com  

c. Click the Access subtab 

i. Select the Access checkbox. 

ii. Assign the Support Person role and click Add. 

iii. Do NOT click any other boxes. 

d. Click the Human Resources subtab and ensure that the Support Rep box is checked. 

e. Click Save. 

i. If you get a pop-up message, click OK. 

 End. 

 

  

mailto:anguyen@chatham.com
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Exercise 03: Create a Case Status 
Time: 1-2 minutes 

Scenario: Case Statuses indicate where the case is in the resolution process. 

 Create new case status to indicate that the Support Representative has responded to a 

customer and is now waiting for a response from that customer 

 Navigate to Setup > Support > Case Statuses > New. 

a. In the Case Status field, enter Waiting for Customer Reply. 

b. In the Insert Before field, select 3-Escalated. 

c. In the Stage field, ensure that Open is selected. 

d. Check the On Hold checkbox to “stop the clock” on the case, avoiding excessive 

resolution time being shown for the case on reports. 

e. Check Show Awaiting Support Reply to have this case status show on searches and 

reports that track cases needing a response from support reps 

f. In the Description field, enter: Use this status when waiting for a response from the 

customer. 

g. Click Save. 

  End. 
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Exercise 04: Create a Case Priority 
Time: 1-2 minutes 

Scenario: Case priorities help prioritized which cases should be worked on first. Users will then be able 

to more easily identify cases needing immediate attention. 

In this exercise: 

 Create a new case priority called, Urgent – Red 

 Navigate to Setup > Support > Case Priorities > New and enter the following details: 

a. Case Priority: Urgent-Red 

b. Insert Before: 1-High 

c. Description: Use this case priority to identify cases that have been submitted from large 

customers that have expressed an urgent need for a resolution. 

d. Click Save. 

 End. 

 

Exercise 05: Create a Case Type 
Time: 1-2 minutes 

Scenario: Case type helps define what is being reported by the customer and help support reps track the 

different types. 

In this exercise: 

 Create a new case type called, Critical Error. 

 Navigate to Setup > Support > Case Types > New and enter the following information: 

a. Case Type: Critical Error 

b. Insert Before: 3-Problem 

c. Description: Use this case type when customers report receiving a critical error 

message. 

d. Click Save. 

 End. 
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Exercise 06: Create a Case Rule 
Time: 1-2 minutes 

Scenario: Case rules are part of automating case assignment. Rules are part of a case territory. Rules 

may be based on standard and custom fields. 

In this exercise: 

 Create a case rule to track support cases  

 Navigate to Setup > Support > Case Rules > New. 

a. Click the Priority link. 

b. Enter or select the following information: 

i. Name: Red 

ii. Criteria: any of 

iii. Priority: Urgent-Red and High 

c. Click Save. 

 End. 
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Exercise 07: Create a Case Territory 
Time: 3-5 minutes 

Scenario: Case territories are defined by rules. If the rule evaluates to true, then the case is 

automatically assigned to a representative on the territory. 

In this exercise: 

 Create a case territory and assign the previously created rule 

 Assign a support Rep 

 Navigate to Setup > Support > Case Territories > New and enter the following information: 

a. Name: Urgent Red Responders 

b. Ensure that the Match all rules is selected. 

 Go to the Configure Rule Definitions subtab: 

a. From the Apply Rule dropdown, select Case Rule –Red. 

b. Click the Add button. 

 Click the Support Assignment subtab. 

a. From the Support Rep dropdown, select Amy Nguyen. 

b. Click the Add button. 

 Click Save. 

Test the New Case Territory 

 Navigate to List > Support > Cases > New and enter the following information: 

a. Subject: Web Server Down 

b. Company: TEST ABC 

c. Profile: Parent Company 

d. Contact: Amy Andrews 

e. Priority: Urgent –Red 

f. Type: Critical Error 

i. Notice that Type, Status, and Priority values that created are available in the 

dropdown lists for each of those fields. 

ii. Notice that the Assign to field is blank. 
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 Click Save. 

a. Notice that the Assign to field is now set to Amy Nguyen. 

i. The case was automatically assigned based on the case rule and case territory 

you created. 

 End. 
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Activity: Set Up Customer Support 
 

Answer these questions 
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Case-to-Close Business Process 
 
Customer enters a problem as a Case. Support rep works to resolve the Case. The 

Case closes when problem or issue is resolved. 

 

 
 
The diagram the workflow of the support group/manager and the standard business 

process that a support representative or support person should follow to complete the 

tasks of: 

• Creating a Case 

• Viewing the Case list 

• Assigning a Case using automatic assignment and manual assignment 

• Grabbing a Case 

• Responding to a Case 

• Escalating a Case 

• Closing a Case 
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Walkthrough: Working a Case 
 

 
 
Use Case: Examine case entry and end-user tasks associated with working a case.  
 

Case Entry Overview 
 
Cases can be entered in four (4) ways:  

• Support rep creates Case record in NetSuite for customer who calls in 

• Customer completes an online Case form 

• Customer sends an email to your support address 

• Customer clicks Contact Support link in the Customer Center of your web site 
and submits an external Case record  

 

Manual Case Entry 
 

Go to Lists > Support > Cases > New to manually enter a case into NetSuite: 

 

• Complete the Primary Information and Incident Information section fields 

• Go to the Communication subtab to enter Incoming from Customer Message: the 
details of their problem 

o You can also enter an outgoing message to be sent in response to the 
case. 

o Go to the File sublist to add Attachments 
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o For better customer service, NetSuite provides the ability to attach files 
such as screenshots, logs, and recordings to the case; ensuring that your 
support team has access to the information they need to understand and 
diagnose issues 

• Save the case 

• NetSuite generates Case number when record is saved 
o Can use Case number to search  

 

View the Case List 
 

Monitor cases awaiting assignment and status of assigned cases: 

 

• Go to Lists > Support > Cases  

• Select the appropriate View 
o Use filters to get the view that best fits your needs 

▪ The Cases list displays all open Cases by default and can be 
filtered to show only the Cases you want to work with 

• Use filters to refine the list display 

• Click Grab to take the case and assign it to yourself  
 

Assign a Case Automatically or Manually: 
 

Cases may be assigned, automatically, using rules and territories: 

• Use Case Rules and Territories: A Case assignment rule is a set of parameters 
for how support Cases are distributed to support representatives: 

o Rules are based on fields found in the Case record 
o Rules are grouped together as Case Territories 
o Territories are assigned to your support representatives so that new 

support Cases are distributed automatically 

• If you have assigned support reps to the round-robin territory, then the cases will 
be distributed round-robin style  
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The Support Manager or designated employee can assign Cases manually: 

• In either a new or existing case record he Assigned To dropdown lists displays 
employee, marked as support reps, or a support group  

 

Respond to a Case 
 

Edit the Case record, go to the Communication subtab: 

 

• Left-hand side is the customer’s message, either entered by a support rep or 
populated from a form 

• Go to the right-hand side Outgoing from Support Rep; enter a message to the 
customer, e.g. maybe a request for more details 

o Send to Customer is checked 
o Copy Employee if required 

• Save the case: An email is sent to the customer and is captured as part of the 
communication history on the case record 

 

Escalate a Case 
 

Escalate Case to another support rep or other employee: 

• The escalation message is NOT visible to the customer 

• Edit the Case record, go to the Escalations subtab 

 
o Enter in an Escalation Message 
o Go to the Escalate To sublist and add the Escalatee (s)  

• Save the case  
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Track Time on a Case 
 

Go to the Case record, Time Tracking subtab to track time spent working on Case to 

charge customer: 

 

• Fill in all the necessary information: 

• Save; this time is now part of the case record 
 

Replying to and Forwarding Case Replies 
 

View the case record; go to the Communication subtab and the Messages sublist 

 

• Click the View line for the message that you want to reply to or forward 

• Select the action in the Email Message pop-up window by clicking on one of the 
following: 

o Reply 
o Reply to All 
o Forward  
o Cancel 
o Preview 

• A new pop-up window opens and you will need to define the Recipients, 
Message, and provide Attachments (optional) 

• Messages to which you reply are recorded in the message history 
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Standard Support and Service Reports 
 
Go to Reports > Cases to use the Support and Service reports to analyze your levels of 

service:  

 

• Monitor Case handling times 

• Measure support rep efficiency 

• Analyze Case workload and distribution 

• Determine Case turnaround time 
 
Refer to Help: Standard Reports  

Activity: True or False 
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Current Support Enhancements 
 
Link Support Cases to Transactions from the Related Records subtab, Support 

Cases sublist: 

 

• Seven (7) transactions are supported including sales orders, invoices, and 
purchase orders; for example, create an invoice for a customer’s repair service 
and the invoice with the support case that originated the service request 

 

Enhancements to Notifications for Online Form Submission: 

▪ Go to Setup > Support > Online Case Forms > New > Workflow subtab, 
Additional Notification section 
 

 
 

▪ Set up online case forms to send email notification to a specific list of recipients 
upon case submission; this is in addition to the customer notification 

 
Please refer to SuiteAnswers for more information 
 

Additional Resources 
 
NetSuite Help Center: 

• Support Management 
 
SuiteAnswers Learning Center:  

• New Feature Training 

• Support 
  



 

86 
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Incorporate Marketing and SuiteCommerce  

 
About this Module 

 

What are other ways to “connect” with the public and extend your NetSuite 

Functionality? We will introduce how NetSuite can: 

• Accommodate multi-channel marketing campaigns 

• Help with delivering consistent, engaging and personalized shopping and service 
experiences from various devices 
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Introducing Marketing Automation? 
 
Marketing Automation works across many areas of your NetSuite Account, including 

CRM and SFA:  

• Set up Marketing Automation and use the associated tools to meet your 
requirements  

• Work with Lead Management 

• Reach your customers effectively; create targeted and customizable Templates 
for email marketing 

• Consider your Audience 

• Use different marketing Events 

• Drive your Sales and get real-time ROI numbers 
Streamline and automate your marketing processes: 

• Use multi-channel campaigns 

• Obtain real-time visibility into the lead-generation to sales-execution processes 

• Prime your sales pipeline 

• Track the effectiveness of your marketing efforts 

 
Setting Up Marketing Automation 

 

Framing Campaign Automation 

• Configure your NetSuite Account, enabling features and defining preferences 
facilitating marketing automation 

• Define marketing preferences and work with different lists of value to manage 
your campaign data 

 
Building Campaign Components 

• Maximize communication avenues using templates and promotional URLs 
o Templates: over and over, a standard look and feel for your marketing  
o Promotional URLs: create short and descriptive Web site URLs (Universal 

Resource Locator) that link to online forms, and other marketing tools 

• Develop leads and sales opportunities: 
o Customer Imports 
o Use an on-line form to get a new lead directly into NetSuite for use by 

marketing and sales 
o Get more data mining capability through Upsell Manager 

• Who is your target audience for your marketing efforts? 
o How about a dynamic group of customers? 

  



 

89 
 

Launching Campaigns 

• Use various campaign events or channels 
o Email campaigns for targeted and effective marketing communications to 

your audiences 

• What about leveraging from the Web, using Keyword Campaigns?  

• Incorporate Lead Nurturing 

• Get insight how well you marketing efforts are working 

 

Introducing NetSuite SuiteCommerce 
 
NetSuite’s SuiteCommerce lets you provide experiences for B2C and B2B businesses 

by connecting with order management, customer service, inventory, merchandising, 

marketing, and financials: 

• Build and deploy a simple website or a full functionality Ecommerce; set up the 
appropriate Web Site 

• Organize and maintain your web presence with content that is always current 
and easy to navigate  

• Manage your Web presence with current Content and easy Navigation 

• Synchronize and improve visibility across your business to facilitate 
Shopping, Selling, Accounting and Customer Service 

• Capture Lead information  

• Report on your web activities, along with other reporting functions 
 

Use Case: Web Order to Payment Process 
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SuiteCommerce Overview 
 

In a single cloud platform, deliver true omnichannel shopping and service experiences 

combining ecommerce, in-store POS and order management with your back-office 

systems: 

• 360° CUSTOMER VIEW: A single view of all customer interactions and 
transactions across all touch points and channels. 

• INTELLIGENT ORDER ORCHESTRATION: Customers can buy, fulfill and 
return anywhere; your company maximizes profitability with centralized order 
management and a single view of inventory  

• INNOVATIVE EXPERIENCES: Rapidly create unique, personalized and 
compelling mobile, web and in-store experiences that differentiate your brand 
and exceed your customer expectations  

• UNLIMITED EXPANSION: Quickly deploy sites for multiple business models, 
channels, brands, countries, currencies and languages all on the same platform. 

 

SuiteCommerce Products 
 

SuiteCommerce Advanced Web Sites:  

▪ Implement a web store that includes the full shopping, cart and checkout, and my 

account experiences for B2C and B2B businesses 

Site Management Tools: 

▪ Manage content, add landing pages, and enhance existing pages on your 

SuiteCommerce Advanced website through a user interface  

SuiteCommerce Site Builder Sites: 

▪ Legacy e-commerce solution by NetSuite; includes access to SSP application 

platform and free access to SuiteApps to add functionality to your e-commerce 

site and checkout.  

NetSuite Point of Sale:  

▪ The in-store register component of the SuiteCommerce product line 

SuiteCommerce InStore: 

• Web-based point-of-sale application available for the U.S. market 
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Review of SuiteCommerce Features 
 

Determine whether to use Site Builder or SuiteCommerce Advanced: 

▪ This table compares different Site Builder web sites with SuiteCommerce 

Advanced 

 

Additional Resources 
 
NetSuite Help Center Topics and User Guides: 

▪ Marketing 

▪ SuiteCommerce 

▪ Marketing and SuiteCommerce Guides 

SuiteAnswers:  

▪ Marketing 

▪ SuiteCommerce 

SuiteCommerce Web Resources: 

▪ Overview: http://www.netsuite.com/portal/products/suitecommerce.shtml 

SuiteTraining: Review course offerings for Marketing and SuiteCommerce 

 

http://www.netsuite.com/portal/products/suitecommerce.shtml
http://www.netsuite.com/portal/products/suitecommerce.shtml
http://www.netsuite.com/portal/products/suitecommerce.shtml
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NetSuite on the Go! 

 

About this Module 
 

NetSuite provides different solutions for mobile access to your NetSuite Account to: 

• Drive business performance 

• Give users real-time access to needed information with the ability to log in 
anytime, anywhere 

• Gives sales employees access to NetSuite records while traveling 
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CRM Access for Mobile Devices 
 

Accounts with CRM+ can give users anytime / anywhere mobile access: 

• Supports iPhone, Blackberry or Android 
o Support provided by both NetSuite and NetSuite SuiteCloud partners 

• Provides sales users with real-time access to key, business information: 
o Access the latest business reports and business metrics 
o Manage calendar information and accept/decline meetings 
o See customer and opportunity details 

• Integrates with social and productivity tools using SuiteSocial platform: 
o Supports cross-departmental collaboration for opportunities, orders and 

other transactions 

• Outlook Integration supports calendar and contact synchronization 

• Google Apps (via Celigo) supports calendar and contact synchronization for 
Gmail 

• The OpenID Single Sign-on feature supports inbound single sign-on to 
NetSuite from Google Apps 

• A registered Google Apps domain is required to use the OpenID Single Sign-
on feature 

• NetSuite Account administrator completes the steps for Setting Up Google 
OpenID Access to NetSuite, 

• Users complete the steps for Adding the NetSuite Gadget to the Gmail 
Sidebar 

• Users log in to NetSuite from Gmail by clicking the Login to NetSuite button. 
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NetSuite for iPhone 
 

The NetSuite for iPhone app; access to your key business information so you can 

monitor business activities anytime and from anywhere: 

• Free to use for all NetSuite customers; requires no set up or special 

• View your NetSuite dashboard including KPIs, scorecard, trend graphs, report 
snapshots, recent records, and reminders 

• View calendar activities, accept or decline events, and mark tasks as complete 

• Search, view and edit records including contacts, customers, employees, cases, 
issues, leads, opportunities, prospects, estimates, and sales orders 

• Work remotely, placing calls, sending emails, finding locations with Google Maps, 
and opening Web pages 

• Review release notes and SuiteAnswers for recent enhancements  
 

NetSuite for Android 
 

NetSuite for Android allows mobile access:  

• Manage expenses and attach copies of receipts. See Tracking Expenses in 
NetSuite for Android. 

• Create and submit expense reports for accounting approval. See Creating and 
Editing Expense Reports in NetSuite for Android. 

• Log and manage billable time effectively. See Tracking Time in NetSuite for 
Android. 

• Manage your NetSuite calendar. See Using the Calendar Feature in NetSuite for 
Android 

• Keep abreast of key business information with complete support for Home and 
Employee center dashboard portlets. See Dashboard Portlets. 

• Log inbound and outbound business calls from your device and assign them to 
companies and customers. See Logging Calls in NetSuite for Android 

• View, edit and attach files to records 

• Review release notes and SuiteAnswers for recent enhancements 
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Outlook Integration 
 
Windows-based application that allows you to save email messages from Outlook into 

NetSuite and to synchronize your events, tasks, phone calls, and contacts: 

• Access the managed Outlook Integration SuiteApp from Setup > 
Company > Enable Features > SuiteCloud subtab 

• Control the following to allow you to configure the application to work 
seamlessly with your current business processes: 

o How frequently you sync 
o Which records from your account are synced 
o How conflicts between NetSuite and Outlook are resolved 

• Use controls that allow administrators to pre-configure the application to make 
the setup process easier for users and control how users synchronize their 
data 

• Works with specific operating systems and internet browsers – Review help 
topics for supported browsers 

 

SuiteSocial – Social Collaboration Tool  
 
More tightly connect social interactions of NetSuite data and track important changes to 

that data: 

• Interactive newsfeeds: Posts and updates by you and colleagues you follow: 
o Real-time posts when relevant NetSuite records are created or edited 
o Easily access records you are following 

• Integrate with 3rd party social networking applications, such as Yammer 

• Get social collaboration features natively in NetSuite 

• SuiteSocial is a SuiteApp built on the SuiteCloud platform: 
o Made up primarily of custom records and client/server SuiteScripts 
o Setup > Company > Enable Features > Company subtab, Social 

section 
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Additional Resources 
 
NetSuite Help Center Topics: 

▪ NetSuite for Outlook 
▪ NetSuite Mobile 
▪ SuiteApps 
▪ SuiteSocial 

 
SuiteAnswers Learning Center:  

• New Feature Training 

• Search the above topics for Support Articles, Training Videos, Help Topics and 
Best Practices 
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Go Live and Maintain NetSuite 

 

About this Module 
 

Your implementation may be coming up or it may already be in progress. You may be 

curious about:  

• How will the implementation be structured? 

• What are key tasks, as the Administrator, which I need to take care of? 

• Where do I get information? 
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Stages of an Implementation Project 
 
The implementation project is managed through a business process-driven approach 

and milestone-based approach: 

• View the Web Page, outside of your NetSuite account, at: 
http://www.netsuite.com/portal/services/consulting/methodology.shtml  

  

 
 
  

http://www.netsuite.com/portal/services/consulting/methodology.shtml
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Implementation Project Plan 
 
Develop and follow a project plan to communicate the schedule, duration, and 

ownership of project activities: 

 

• A project plan is an essential part of a successful implementation 

• Use a tool of your choice, such as “MS Project”  

 
Walkthrough: User Adoption 

 

 

Use Case: Drive successful user adoption through repeating a cycle of: 

• Alignment – Ensure your objectives, benefits, management team and end users 
are strategically positioned around the change initiative. 

• Communication – Create a strong communication plan to promote awareness 
and minimize surprises. 

• Training – Educate users on fully tested technology using a role-based, day-in-
the-life approach to drive appropriate system usage. 

• Support – Create a support plan to promote user proficiency and continuing 
education. 

• Measurement – Motivate users through incentives and predetermined 
performance 

 

When introducing a new technology to your users you can use: 

• Guidelines 

• Tools 

• Change management activities 
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User Adoption in SuiteAnswers 
 

 
  



 

103 
 

 

Now it’s Your Turn 

 

Time: 1-2 minutes 

Scenario: Familiarize yourself with tools; in this exercise, you: 

 Access the NetSuite User Adoption Toolkit from SuiteAnswers and confirm that you can 

open it 

 Go to your Support tab, SuiteAnswers portlet and Go to SuiteAnswers 

 In SuiteAnswers, click on Training Videos 

 In the left-hand list, scroll down and click User Adoption 

 Select NetSuite User Adoption Toolkit: 

a. Scroll down to File Attachments and download the NetSuite User Adoption Toolkit 
b. Open the zip file to view the PDFs, Excel worksheets and PPT. 
c. Try accessing the NetSuite User Adoption Quick Guide 

 Confirm your success with the instructor  

 End. 

 

Our adoption toolkit provides templates and easy- to- follow steps that infuse your 

project with practical change awareness activities that promote user adoption, and allow 

you to realize a quicker return on your NetSuite investment. 

• Adoption Workbook: Step-by-step guide to help you plan and execute an 
adoption strategy. 

• Adoption Checklist: Checklist to keep track of your progress. 

• Adoption Templates: Rich library of change management templates to support 
your adoption activities. 

• Note: Education Services Consulting Available. 
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Go Live Checklist 
 
Before your go live, review the project plan to ensure all action items are complete and 

validate that:  

• All forms and layouts have been configured  

• Check have been ordered  

• A cycle count of all inventory has been completed 

• All opening balances have been entered for accounts and inventories  

• All test data has been deleted and real data has been entered/imported 

• You have reviewed and ensured that all users have the appropriate Roles and 
Permissions 

• A training strategy has been defined and is ready to begin (if it has not already) 

• User acceptance testing has been completed and approved  
 

Go Live Date and Cutover Event 
 
When determining the go live date: 

• Schedule the cutover to provide sufficient time for any last-minute changes 

• Assume an increased level of support will be needed during the days and weeks 
around the cutover period: 

o The NetSuite standard implementation includes two weeks of cutover 
support 

▪ You can choose to extend this period if necessary 
o Onsite cutover support is also available 

▪ You have access to real-time Support to issue resolution 
 

After Rollout 
 
Often the entire NetSuite application is not installed in the initial project, for example: 

• Phase 1: CRM and SFA 

• Phase 2: Financials 

• Phase 3: Customer Support 
 
When implementing different areas, at different times, it is important to: 

• Review the successes and challenges of the NetSuite implementation to improve 
future projects 

• Plan for on-going support of the application 

• Identify and address unresolved issues and items 
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Administrator's Typical On-going Tasks 
 
What are some of the key administration, on-going responsibilities? 

• Maintenance and daily management of the NetSuite account 

• Technical and system administration, including data integration with multiple 
systems: e-mail marketing solution, member data mart, Web site and inventory 
management system 

• Planning, reviewing and customizing NetSuite as needed to meet needs of staff; 
update roles, permissions, dashboards, etc. as your business requirements 
change 

• Stay informed about new enhancements and features and utilize as they become 
available in new releases: 

o Use the New Release portlet in the account 
o In SuiteAnswers, review: Webinar: Preparing for NetSuite's Major 

Release 
▪ This Webinar addresses a previous release, but also speaks to the 

general process of preparing for a NetSuite Release 

• Providing front line support with regards to all aspects of NetSuite and data 
maintenance and primary point of contact to NetSuite Support  

 

Review Roles, Permissions and Centers 
 

Implementation projects can be working up against tight deadlines.  Sometimes roles 

and permissions may not have received the proper attention.  Now might be a good 

time to review this area.  

Users must have the correct role, permissions, and center: 

• Check before go-live and validate when adding new users after go-live or as 
people’s jobs change 

o Review your custom roles; review all the tasks users tackle and match to 
required permissions 

o Remember that using Standard roles is NOT recommended 

• Review the permissions of each custom role created: 
o Reference the Standards Roles Permission Table in Help 
o Compare roles: Go to Setup > Users/Roles > Show Role Differences 

• Evaluate any potential need for a custom center 

• Educate users, with multiple roles, the need for switching roles to match the 
tasks being attempted: 

o Using the appropriate role, with the defined access to records, is another 
way to protect the data and conform with the requirement to have a 
segregation of responsibilities 
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Revisit Password Management 
 
Administrators may need to revisit password management, which was discussed in the 
Navigation module – in your Getting Started Workbook: 
 
Administrator, go to Setup > Company > General Preferences: 

• Password Policy: enforces specific requirements 
o Strong: minimum length of 10 characters, at least 3 of these four 

character types —uppercase letters, lowercase letters, numbers, non-
alphanumeric characters – this is the default setting 

o Medium: minimum length of 8 characters, at least 2 of these four 
character types: uppercase letters, lowercase letters, numbers, non-
alphanumeric characters 

o Weak (Not Recommended): minimum length of 6 characters 
o All three password policies continue to enforce validation against these 

basic criteria: significant difference from previous password, use of only 
legal characters. 

• Maximum Password Length:  dictated by the password policy defined 
o The default value for this field is determined by the selected password 

policy. 
o You can, if desired, make the minimum password length value longer than 

the minimum required by the policy. You cannot make this value shorter. 
o Passwords for new users logging in with the Customer Center role, and for 

web site shoppers, require a minimum of six (6) characters. Passwords for 
Customer Center users and web site shoppers who existed before that 
release were not affected by this change. 

• Password Expiration: number of days a login password can be used before a 
user is prompted to change it 

o Days are calculated from the date that each user last changed their 
password, not from the date that the company preference is changed. 

o It is strongly recommended that administrators set this value to a minimum 
of 180 days. 

▪ The maximum number of days will take a very large number, which 
should accommodate most companies. 

o To comply with Payment Card Industry (PCI) standards, employees with 
access to view unencrypted credit card numbers are automatically 
required to reset passwords every 90 days, unless the limit set here is 
shorter. 
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NetSuite Account Security 
 
We provide enterprise-class data management, security & availability: 

Application security: 

• Role-level access and idle disconnect 

• Strong 128-bit encryption 

• Access only to the NetSuite application, not the underlying database 

• IP address restrictions 

• Strong password policies 
Operational security: 

• Comprehensive security certifications  

• Continuous security monitoring 

• Managed physical access 

• Fully guarded premises 

• Continuous data center performance audits 
Data Management: 

• Multiple levels of redundancy to guard against failure  

• Disaster Recovery protocols 

• “Hot Backups” to restore your data rapidly and reliably 

• Offsite backups 

• Scalability to address increased volume and transactions 
Availability: 

• Multiple data centers 

• Completely redundant internet connections and backup power systems  

• HVAC systems, Fire suppression and Seismic engineering 
Energy efficiency using cost-effective and sustainable practice 

 
Please refer to our SuiteCloud Infrastructure Web page for more information: 

http://www.netsuite.com/portal/platform/infrastructure.shtml 

  

http://www.netsuite.com/portal/platform/infrastructure.shtml
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Access Enhancement Voting 
 
Customers, who have purchased NetSuite Support and have the Support Center role, 

can vote on enhancement requests:  

• Go to Support tab, click the Go to SuiteIdeas in the SuiteIdeas portlet  
o If not visible, contact your administrator to add the permission to your 

role 

• Click one of the following links within the SuiteIdeas site: 
o Search to see if your idea has been requested by others. 
o Browse for ideas by categories. 
o View new ideas, the most recently updated ideas, and ideas that have 

received the most votes. 
o View the ideas you have voted for. 
o Clicking an idea opens it in a new window. 

• If you find the idea you are looking for, click Vote for this Idea. 

• Rate the idea, and click Submit Vote. 

 

NetSuite Resources 
 
NetSuite provides various resources to you: 

• Help Center 

• SuiteAnswers provides: 
o Announcements, Release Information, Trending Now, New Answers 
o Help topics, Support Articles, Training Videos and recorded Webinars 
o Phone Support 

▪ You can get your NetSuite Account number when you choose to 
contact support by phone 

o Additional Resources 
▪ E.g. Contact NetSuite Training 

• Join the User Group from your Support tab, User Group portlet: 
o Communicate with other customers and Certified Consultants to ask 

questions and trade tips 
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SuiteSupport 
 

Contact Support if you need a “How do I_______?” question answered 

You have the various support options; complemented by an extensive library of detailed 

online help and other resources such as: 

• FAQs, online user guides, sneak peeks at upcoming releases, and tips that will 
help you get the most from your NetSuite application  

 

 

 

• View more information at: SuiteSupport or 
http://www.netsuite.com/portal/services/support.shtml  

 

Note: Work with Professional Services for the “How SHOULD I” type of question 

  

http://www.netsuite.com/portal/services/support.shtml
http://www.netsuite.com/portal/services/support.shtml
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Authorized Contacts for Support 
 

To improve NetSuite Support response times and develop a scalable Customer 

Support, NetSuite has adapted the Authorized Contacts process in line with your Terms 

of Support Service: 

• NetSuite Terms of Support Service: 
http://www.netsuite.com/portal/resource/terms-of-support-services.shtml  

• The number of Authorized Contacts will be based on the Support Type 

• Review the Supplemental Support Terms and Support Offering Comparison 
Chart 

 
o Also, found in this link http://www.netsuite.com/portal/resource/terms-

of-support-services.shtml  
▪ Manage Authorized Contacts via NetSuite Account Center 
▪ Administrators are not automatically set up as authorized contacts 

o Authorized users are people specified by their company and can have 
any role, including the Administrator role. 

o To ensure continued world-class customer support, please make sure 
that you are set up as one of the Authorized Contacts in your NetSuite 
account before calling and/or submitting a case online. 

 

In SuiteAnswers: Search on “Authorized Contacts” and review the support article and 

FAQs  

  

http://www.netsuite.com/portal/resource/terms-of-support-services.shtml
http://www.netsuite.com/portal/resource/terms-of-support-services.shtml
http://www.netsuite.com/portal/resource/terms-of-support-services.shtml
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Revisit Best Practices 
 

Access a list of Best Practices, developed by NetSuite Professional Services and other 

subject matter experts: 

• Go to the SuiteAnswers type in “Best Practices” in the search box 

• The Results Overview will list various types of results: 
o Support Articles 
o Training Videos 
o Help Topics 
o SuiteWorld Presentations 

 

NetSuite Evaluation 
 
Your feedback is important to us, so please take a few minutes to complete an online 

evaluation: 

• Course Name: Essentials 

• Start Date: 

• Location: Virtual 

• Instructor 
 

CRM and Next Steps is done, next the Course Summary 
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Summary and Wrap Up 

 

The Path You Have Travelled 
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Use the resources… 
 

The following resources are all available online: 

NetSuite Help Center: 

• Help Guides, Tips and More 
 
SuiteAnswers: 

▪ Support Articles, Training Videos, Recorded Webinars, Help Topics, Best 
Practices, and SuiteWorld Presentations 

 
NetSuite User Group: 

• Share ideas/questions with other users, NetSuite Partners and NetSuite 
Employees 

 
SuiteSupport 
 

Activity: What Did You Find Exciting 

 

Think about a key concept or idea that you will use and share with your coworkers 
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Training is the Most Critical Factor 
 
Why should you develop a training plan? 

• Untrained users cost five times more to support than trained users* 

• Two-thirds of enterprises will pay informal training costs (out of the support 
budget) that are at least 20 times higher than would have been required for up-
front formal training. * 

• 70% of companies cite the most critical factor for new software implementation 
success and ROI is effective training and user adoption* 

 
*Source: Gartner Research Publications:    Business Intelligence Applications Benefit 

from Interactive Visualization; To Train or Not to Train Remote Users: Is There a 

Question? Intersection of IT Support and End-User Training; Untrained Users Cost 

More to Support than Trained Users 

SuiteTraining 
 
Interested which SuiteTraining courses available? 

• Review course Catalog 
http://www.netsuite.com/portal/services/training/catalog.shtml or, 

• Find a course 
http://www.netsuite.com/portal/services/training/course-finder.shtml  

 

 
  

http://www.netsuite.com/portal/services/training/catalog.shtml
http://www.netsuite.com/portal/services/training/course-finder.shtml
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NetSuite Certification 
 

NetSuite ERP Consultant Certification Program: 

• Become a certified in various areas of NetSuite 

• Complete and pass two exams; certification fees may be applicable for each 
exam 

• Please refer to the Certification Program page: 
http://www.netsuite.com/portal/services/training/certification.shtml for more 
information 

o You can also navigate from the NetSuite Visitor page, under the Services 
menu 

 

You are DONE! 
 

Thank you for your participation: 

• If you have not already done so, please complete the online evaluation 

• Have a successful implementation 
 
This is the end of the topics and exercises; the appendix follows. 

  

http://www.netsuite.com/portal/services/training/certification.shtml
http://www.netsuite.com/portal/services/training/certification.shtml
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Workbook Appendices 

The following section is for you reference. 

Register for the NetSuite User Group 
Do not complete these steps during class 

Time: 1-2 minutes 

Scenario: The NetSuite User Group can be another resource for finding and sharing information. Use the 

following steps to submit a request to join. 

Within 24 to 48 hours, the NetSuite User Group Administrator will notify you through Email that your 

User Group account has been setup. 

 If you are the administrator, go to Setup > Company > Company Information 

a. On the right-hand side, copy your Account ID 

 If you are not an Administrator, then navigate to the Support tab: 

a.  In the SuiteAnswers portlet, click on the Go to SuiteAnswers  

 The SuiteAnswers home page, opens in a new browser tab: 

a. On the right-had side of the page, click Contact Support by Phone 

b. The Contact Us By Phone page displays your NetSuite Account Number. Make note of 

this. 

c. Close the pop-up window. 
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 Go back to the NetSuite Support tab and click on the NetSuite User Group link. 

a. The User Group page opens 

 

b. Click the Register Now button. 

c. Complete all fields 

d. Agree to the site’s terms and rules 

e. Click Complete Signup 

 It will take some time for your registration to be approved.  
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